Author Topic: Networking eCS & Win 7 new article !  (Read 4996 times)

Greggory Shaw

  • Global Moderator
  • Sr. Member
  • *****
  • Thank You
  • -Given: 39
  • -Receive: 19
  • Posts: 420
  • Karma: +0/-0
    • View Profile
Networking eCS & Win 7 new article !
« on: August 21, 2015, 11:46:59 am »
I need some help and comments for this !

I got the eCS to Win7 almost done and starting on the Samba server or Win 7 to eCS now.

http://os2notes.duckdns.org/os2win.html


Cheers,

Greggory

Neil Waldhauer

  • Hero Member
  • *****
  • Thank You
  • -Given: 11
  • -Receive: 50
  • Posts: 630
  • Karma: +1/-0
    • View Profile
    • Blonde Guy
Re: Networking eCS & Win 7 new article !
« Reply #1 on: August 22, 2015, 08:50:03 pm »
I can't get the eCS EVFS-based SAMBA to connect at boot time. It will connect later, but I can't connect automatically. Any idea how to do this?
Expert consulting for ArcaOS, OS/2 and eComStation
http://www.blondeguy.com

Greggory Shaw

  • Global Moderator
  • Sr. Member
  • *****
  • Thank You
  • -Given: 39
  • -Receive: 19
  • Posts: 420
  • Karma: +0/-0
    • View Profile
Re: Networking eCS & Win 7 new article !
« Reply #2 on: August 23, 2015, 12:42:47 pm »
I can't get the eCS EVFS-based SAMBA to connect at boot time. It will connect later, but I can't connect automatically. Any idea how to do this?

I had something like that, then I installed the Samba server 12.wpi and then could see other computers in client EVFS.

There are so many different problems - also sometimes it's take minutes for changes to take affect.

After more testing this upgrade seems to be a hit or miss over all :( and really pissing me off ! On a new eCs install it worked, my production install failed, another new install failed, then work, SMH. However, installing Samba server below seem to fix everything.

Samba server:

ftp://os2user@os2notes.duckdns.org/

Password: os2

After installing Samba 1.2.wpi server install updates:

1) ftp://ftp.netlabs.org/pub/samba/server/test/samba-3.5.21-1.2.0-20130911.zip
2) ftp://ftp.netlabs.org/pub/samba/server/guitools/smbmon-25RC8-20150113-test.zip

After updating smbmon-25RC8-20150113-test.zip or Samba Status Monitor check the tab TDB files to see if all for correct and the server is working correctly (see attached pic).

And finally I messed things up so bad I had to uninstall everything and use the three wpi from the DVD to re-install everything. So you can start over too, use this way if you don't have backups of your system drive. You may get an error starting the EVFS client after a re-install, just update the client to evfsgui-25RC7-20141213.zip to fix that (evfsgui-25RC7 may overwrite your lmhosts file).

NOTE: if your tmp directories are on a RAM drive the install for Samba server will fail.

Could everyone post want their setup is for everyone please !


Greggory
« Last Edit: August 23, 2015, 04:02:18 pm by Greggory Shaw »

Neil Waldhauer

  • Hero Member
  • *****
  • Thank You
  • -Given: 11
  • -Receive: 50
  • Posts: 630
  • Karma: +1/-0
    • View Profile
    • Blonde Guy
Re: Networking eCS & Win 7 new article !
« Reply #3 on: August 23, 2015, 03:52:56 pm »
So it looks like you are installing the older 3.5 server rather than the newer 3.3 server.

On either, I think it's a good idea to check on how attributes and timestamps work before committing to a production environment. The 3.3 server has been tweaked to where I can use it. I know there has been work on KLibC to try to make permissions, timestamps, ownership and groups work. But OS/2 is not the same as Linux, so be careful.

On my production server, I have scripts to restore a lot of key files from backup after an bad client connects.

Installation of 3.3 always crashes at the end when creating the admin user. Users and Groups always crashes in the same place. I use some rexx scripts in the \samba directory to add users. Windows 7 can use my server. I'm very inexperienced on Windows, so more of a cookbook is needed. I wonder if my Win 7 Enterprise is different from others for networking.

How do you automatically connect after a reboot?

Expert consulting for ArcaOS, OS/2 and eComStation
http://www.blondeguy.com

Greggory Shaw

  • Global Moderator
  • Sr. Member
  • *****
  • Thank You
  • -Given: 39
  • -Receive: 19
  • Posts: 420
  • Karma: +0/-0
    • View Profile
Re: Networking eCS & Win 7 new article !
« Reply #4 on: August 23, 2015, 04:10:44 pm »

How do you automatically connect after a reboot?

In the Samba client I use the auto start under 'File' dropdown menu that puts a icon in the startup folder.

or in Startup.cmd  use something like:

--
evfscli attach h:

evfscli mount smbfs h:\ ;WORKGROUP=HOME;SERVER=SHAW;SHARE=AA;USER=XXXXX;PAS
SWORD=XXXX;EASUPPORTED=1 W

--
something like that not sure if thoses are correct.

Ok, I see 3.3 is dated 10/13 and Samba 1.2 (3.5.21) is dated 7/2013 what are the differences (the TDB files look good in 3.5.21 too) ? All the programs in Samba 1.2 work and had it running for 5 months without problems, do you know what the known problems are with 3.5 ? You may want to check out the updated 3.5.21 server.
« Last Edit: August 24, 2015, 12:05:42 am by Greggory Shaw »

Greggory Shaw

  • Global Moderator
  • Sr. Member
  • *****
  • Thank You
  • -Given: 39
  • -Receive: 19
  • Posts: 420
  • Karma: +0/-0
    • View Profile
Re: Networking eCS & Win 7 new article !
« Reply #5 on: August 23, 2015, 04:19:04 pm »

On my production server, I have scripts to restore a lot of key files from backup after an bad client connects.


How does that work and what files (TDB files ?) - Linux clients ? Trying to get Win10 to work, messed up Samba and had to reboot, but I never had to re-install anything. What files should I backup just in case ?

On the attributes and timestamps copying files from the Samba server to Win7/10 shows the correct timestamps. How do you check for the attributes (oh, well I guess just copy it back, LOL), you're talking about the EAs.

I just use Win7 or Win10 to Samba for media files.
« Last Edit: August 23, 2015, 05:40:16 pm by Greggory Shaw »

Neil Waldhauer

  • Hero Member
  • *****
  • Thank You
  • -Given: 11
  • -Receive: 50
  • Posts: 630
  • Karma: +1/-0
    • View Profile
    • Blonde Guy
Re: Networking eCS & Win 7 new article !
« Reply #6 on: September 09, 2015, 09:18:31 pm »
I've got the evfscli, but I didn't get the mount command to work. Some part of the syntax must be wrong, because it gives SYS0123.

When I have the server up and the wrong npdspb.dll in the browsing machine, any file that is read by the client gets its timestamp updated. So I need to replace a bunch of files with wrong timestamps, but no other problem. This problem was fixed by the Oct 2013 update to ndpsmb.dll, which is not found on the eCS 2.2 beta II installation DVD. I always update after installation from a thumb drive before connecting to my server.

Edit: I've got it working now. The command line I used was:

Code: [Select]
evfscli attach r:

evfscli mount smbfs R:\ \\BEACH2:SERBOPEEP\JFS@$username;WORKGROUP=BEACH2;SERVRBOPEEP;SHARE=JFS;USER=$username;PASSWORD=;SPASSWORD=6666666666664D6F726E696E6TET=WORKGROUP;MASTERTYPE=1;CTO=10;CLD=32;EASUPPORT=1 W

« Last Edit: September 11, 2015, 10:52:00 pm by Neil Waldhauer »
Expert consulting for ArcaOS, OS/2 and eComStation
http://www.blondeguy.com

Greggory Shaw

  • Global Moderator
  • Sr. Member
  • *****
  • Thank You
  • -Given: 39
  • -Receive: 19
  • Posts: 420
  • Karma: +0/-0
    • View Profile
Re: Networking eCS & Win 7 new article !
« Reply #7 on: September 12, 2015, 02:17:20 pm »
I got the eCS to Win7 done and OS/2 Samba server setup.

http://os2notes.duckdns.org/

Guess I should have add the command line syntax too.

Any corrections or recommendations please leave comments !


Cheers,

Greggory
« Last Edit: September 12, 2015, 02:19:50 pm by Greggory Shaw »