OS/2, eCS & ArcaOS - Technical > Utilities

Redirect LPT1 port


Hi everybody,

I'm new on that forum so first let me introduce myself shortly: I'm an IT technician in a french industrial company, more than newbie on OS/2 system, and I'm facing today with a little problem:

We've bought another company last year which the whole production system runs with OS/2 environment, on old PCs with old printers connected on parallel port (Epson LX-300)... And all those machines are networked with an old Novell server within Netware protocol. To be honest, it's a great premiere for me because I didn't know all those systems before, so you can imagine I'm not familiar at all with that!!

As we wanted to secure all that system before expected crash, I succeded in installing OS/2 Warp 4 on VirtualPC machines and make our application running well. But now I would like to find a solution to plug off the physical printers and make my application print in a file. An output on LPT1 is needed by our application indeed (or it doesn't work at all) and our old printers begin to be very tired so I would find a solution to redirect LPT1 outputs to a file on disk or simulate a printer on LPT1.

I found several DOS utils to do that but the application runs within a OS/2 session, so it doesn't work... And I tried some PDF printer utilities found on os2site.com archive, like pmpdf, ePDF or eredman, but I don't succed in installing/using them (because I'm not very at ease with this systme for sure...).

And for your information I already had a discussion with Ian Manners who guided me to this forum (because he knows there's a solution but don't remember what he made 17 years ago ! Shame on him  ;D...)

Would you have any solution for me?

Thanks by advance!

Martin Iturbide:
Hi Martin, welcome to OS2World.

I'm not understanding if the OS/2 application you have is printing directly to LPT1, or does it asks for a printer installed in OS/2.


That sounds very similar to a setup one of my clients has.  In fact I upgraded them about a year ago with all new computers - the only requirement was that each computer had a serial port to drive the machinery.

In your case are you trying to run everything using VMs in which case I would advise against it especially if the VM is a guest on windows.

Depending on your exact setup it might be better if you looked at network printers which can be driven from OS/2 without too many problems.

Other than that, if you want to take this to a private discussion, not put company business out for all to see, then feel free to e-mail me at ivanjt at free dot fr

@Martin I.: honestly I'm not very sure but I think that the application is printing directly to LPT1. That's why I'm looking for a utility that directly redirects LPT1 to a file. I already tried to tick the "Print to file" box in installed Epson LX-300 driver's properties or use the IBM NULL printer but when I type the command "print /D:LPT1 testfile.txt", I obtain a wondeful error message that indicates me that the printer must be out of paper!!

Why am I using the print command to test and not directly from business applicaton? Because a little thing that you have to know and doesn't help me at all in that task is that I can't test my installation in real conditions because I'm 350 kms from our other production site and the application needs a connection to Novell server by netware protocol to launch....

So if you're also having another test procedure to advise me, I'm interesting!

@ivan: Yes I'm using a VirtualPC VM on a Windows XP host. Why would you advice me against that configuration?

Concerning networked printer, it will be very complicate for me to set up because:

* the idea is to make without any physical printer in the future
* the only network for this installation in on netware protocol that I don't master at all
* I have no access to the Novell server administrationI'll send you an email today Ivan, I will be probably clearer in french (judging by your email address) !  :P

Thank you very much for your reactivity!!



[0] Message Index

Go to full version