Author Topic: Thinkpad X250 & eCS  (Read 7258 times)

Mike Kölling

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 2
  • Posts: 42
    • View Profile
Re: Thinkpad X250 & eCS
« Reply #15 on: February 29, 2016, 05:27:28 pm »
Sorry, uvcscope.exe does not work for me as well.
Regards, Mike

Wim Brul

  • Full Member
  • ***
  • Thank You
  • -Given: 3
  • -Receive: 31
  • Posts: 146
    • View Profile
    • Wim's home page
Re: Thinkpad X250 & eCS
« Reply #16 on: March 01, 2016, 12:06:14 pm »
Sorry, uvcscope.exe does not work for me as well.


Perhaps your webcam is not recognized at all anymore. In that case it is also not shown by usbres.exe and USB Dock. It seems to me that you need to revert your system back to the point where you were able to run uvcview.exe for about 3 minutes.

Mike Kölling

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 2
  • Posts: 42
    • View Profile
Re: Thinkpad X250 & eCS
« Reply #17 on: March 01, 2016, 04:55:25 pm »
Hi Wim,
I have now tested both programs uvcscope & uvcview with the latest USB drivers from Lars (v10.202) and from AN (v11.13).
In both environments both programs starts but  the video freezes after some seconds with the already posted error message.
I couldn't repeat the three minutes run time for uvcview.
I guess I shall try a clean environment, but that is a little bit tricky for the X250 because I have to clone the OS using DFSee.
If I have time I will give it another try and will stop for now testing the camera.
Hartelijk dank voor uw hulp.
Greetings form Potsdam/Germany,
Mike

Wim Brul

  • Full Member
  • ***
  • Thank You
  • -Given: 3
  • -Receive: 31
  • Posts: 146
    • View Profile
    • Wim's home page
Re: Thinkpad X250 & eCS
« Reply #18 on: March 01, 2016, 06:14:17 pm »
Hi Mike,

Quote
I have now tested both programs uvcscope & uvcview with the latest USB drivers from Lars (v10.202) and from AN (v11.13). In both environments both programs starts but  the video freezes after some seconds with the already posted error message. I couldn't repeat the three minutes run time for uvcview.

Thank you for your testing and reporting. It clearly shows that these webcam programs cannot run reliably in a multicore environment. Other people have run into the same problem with their webcams in such an environment. Unfortunately I cannot recreate that problem because I have only single cpu hardware to test with.

Quote
I guess I shall try a clean environment, but that is a little bit tricky for the X250 because I have to clone the OS using DFSee. If I have time I will give it another try and will stop for now testing the camera.

Don't spend more time on it since I really don't know how to solve the problem.

Best regards,
Wim.



Mike Kölling

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 2
  • Posts: 42
    • View Profile
Re: Thinkpad X250 & eCS
« Reply #19 on: March 08, 2016, 06:26:56 pm »
With the new Mulitmac package (Multimac-20160201.exe) from Arca Noae comes an e1000b.os2 driver for my LAN chip. So my patch of the older e1000b.os2 is no longer needed to use the LAN function of the X250.
Thanks to AN for the great support.
Greetings from Potsdam/Germany,
Mike

Neil Waldhauer

  • Sr. Member
  • ****
  • Thank You
  • -Given: 8
  • -Receive: 31
  • Posts: 460
    • View Profile
    • Blonde Guy
Re: Thinkpad X250 & eCS
« Reply #20 on: March 10, 2016, 01:52:12 am »
The X250 has a VGA port. Does that work for an external monitor?
Expert consulting for ArcaOS, OS/2 and eComStation
http://www.blondeguy.com

Mike Kölling

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 2
  • Posts: 42
    • View Profile
Re: Thinkpad X250 & eCS
« Reply #21 on: March 10, 2016, 09:13:35 am »
I use the VGA port on the docking station. I have the  Lenovo ThinkPad Pro Dock - 90W, EU (FRU: 40A10090EU).
Just tested now the VGA port on the device. It is working there as well.
I haven't tested the Mini-Display port, because of now hardware with such an interface.
Greetings,
Mike

Mike Kölling

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 2
  • Posts: 42
    • View Profile
Re: Thinkpad X250 & eCS
« Reply #22 on: March 17, 2016, 12:44:21 am »
Dear All,

Status-Update: Thanks to Wim Brul the built-in camera is now working! He does a great job.

Greetings, Mike

Greggory Shaw

  • Global Moderator
  • Sr. Member
  • *****
  • Thank You
  • -Given: 39
  • -Receive: 19
  • Posts: 420
    • View Profile
Re: Thinkpad X250 & eCS
« Reply #23 on: March 17, 2016, 06:18:27 am »
Dear All,

Status-Update: Thanks to Wim Brul the built-in camera is now working! He does a great job.

Greetings, Mike


Hi Wim, thanks for all the hard work that you done for OS/2 !

I was wonder about 'Hello' in Firefox - web video ? - https://webrtc.org/  - it supports every browser & included in over 700+ apps !

Ever think about partnering with VOICE (is looking for projects) or Blue Lion to get 'Hello' in Firefox working ? With your awesome programming skills (did you do the cam work in assembly?)


The video quality on eCS is even better then Windows version (Logitech), thx !

Greggory


« Last Edit: March 18, 2016, 10:54:46 pm by Greggory Shaw »

Neil Waldhauer

  • Sr. Member
  • ****
  • Thank You
  • -Given: 8
  • -Receive: 31
  • Posts: 460
    • View Profile
    • Blonde Guy
Re: Thinkpad X250 & eCS
« Reply #24 on: March 23, 2016, 02:42:21 pm »
Thinking about this thread, I headed over to the Lenovo website. The x250 is already gone. The x260 eliminates VGA support.

I had hoped that the pace of new introductions would slow with the decline of the PC market.
Expert consulting for ArcaOS, OS/2 and eComStation
http://www.blondeguy.com