Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Ibrahim Hakeem

Pages: [1]
1
Continuance from this thread. This new thread is for consistency's sake as the topic of the discussion had changed.

There has been some discussion for development of a new version of QEMU for OS/2 and a bounty for it being made. Here is the quote from my post proposing the bounty:

Quote
If anybody may be interested, I am willing to start a bounty for a well-rounded release of QEMU under the following conditions:
>Stable enough for everyday use
>Smooth Windows 95/98 emulation
>Audio, preferably SB16 compatible emulation
>Semi-decent video support (I.E, can run something like Flight Simulator 98 at low-mid settings with at least 30 to 40fps)
>A reliable GUI for configuring and launching VMs

Effectively, something that's going to be solid for low-mid range Win9x gaming.

I have a hunch this will most likely be 2.4.x or earlier. Once again like others have said, there's no need to build a newer version that's going to have more compilation related headaches - especially when modern Linux distros are still going off 2.4.x code without any complaint. I understand this will require more effort than a simple compile n' go situation especially with the desired specifications listed, but I believe there to be very viable use-case for a new and reasonably stable release of Qemu for our platform

The goal wouldn't be to replace Virtualbox, but to get up to speed for one ArcaOS's aims of being a good platform for DOS and early Windows emulation, especially in lieu of ArcaOS 5.1 hopefully being on the horizon. It would be really cool to have more usable and up-to-date software for 90's era x86 emulation. Plus I'm sure many of us still wish that this wasn't a hoax  :P

If there is enough interest for this idea, I sincerely hope we can make something of it for our platform's sake.

To get things started, I am willing to contribute 100USD to the pool which I will additionally match as a donation to Bitwise Works.

Thank you for your consideration  :)

2
Hardware / Thinkpad T450S trackpoint scroll button, can it be mapped?
« on: March 11, 2021, 06:57:00 am »
Hi all

For as long as I've been using my T450S with ArcaOS, I haven't been able to get the trackpoint's scroll button working as intended - whenever I press it, the cursor just jerks around the screen in a random direction. It's not that big a deal as much, rather a QOL thing that I'd love to wrangle.

I wasn't able to find a solution to potentially remap it and was hoping to see if anyone has experienced anything similar and might have a solution.

If it helps at all,  I tried an external mouse as well, finding that while scrolling itself worked fine, there was no response when I clicked the on scroll wheel. It did function perfectly and as intended when using my M93P however (using Firefox to test).

Thanks in advance as always  ;D

3
Applications / USB sound effects - Any methods?
« on: March 01, 2021, 09:18:25 pm »
Hi all. I know it's a bit frivolous and pointless but it's come across in my recent obsession with desktop customization... Is there any viable way to replace the PC beeps for a USB drive being inserted/removed to be replaced with a Wave sound like in other OSes? The idea of having a play.cmd script execute did come to mind but I'm not sure what the best way to go about it would be.

4
Storage / Regarding the Netlabs FAT32 driver
« on: December 27, 2020, 10:50:02 am »
After seeing Dariusz's recent thread, I'm now using the Netlabs FAT32 driver instead of the AN one and life is already so much more convenient.

All is not well in paradise however... Does anyone get any stability/access issues with this driver and if so, are there any good tricks on avoiding those problems (Namely the SYS0266 error)? I'm finding I have to reinstall the driver and reboot a few times afterward in order to get it to read/write FAT32 partitions (all formatted with DFSEE) which otherwise run fine on my other non OS/2 environments.

Thanks in advanced as always  :)

5
Hardware / Restoring T450S backup to M93P Tiny - USB HID woes
« on: December 24, 2020, 09:00:10 am »
Hi all.

As the title summarizes, I recently got my hands on a Lenovo Thinkcentre M93P Tiny - mainly to have something a bit more practical to run at my desk rather than my T450S. I initially ran a fresh install of ArcaOS 5.0.6 which mainly worked... save for the keyboard input which was repeating keystrokes if you typed at any reasonable speed.

After running into this roadblock, I figured restoring a backup of my Thinkpad T450S to the computer (using the setup USB and DFSEE) might yield better results but I'm now in the situation where I'm no longer able to use any USB mouse or keyboard post-boot. The computer will still recognize my USB disks but no HID devices. The USB stack I'm currently using is the Arca Noae 12.07 driver package.

I'd much rather work from this state rather than a fresh install as the environment is already perfectly configured and ready to go (save for the USB HID situation).

Does anyone have any advice or pointers on where to go from here?

Thanks in advance  :)

6
Hi all.

After installing a fresh copy of OpenOffice (version 417), I'm no longer able to get past the splash screen, it pretty much flashes and exits straight away without any kind of error or .TRP output. Even the older version (416) which used to work is now also presenting the same crash.

PMDLL shows that all required DLLs are available, I've tried the "Enable High Mem code loading" script, resetting the user folder and everything else in my environment (i.e, Virtualbox, VLC, Firefox, Java, etc) is running perfectly fine; it only seems to be OpenOffice which is suddenly presenting this issue.

I wish I had more details than that but I'm totally baffled. Is there any advice that I could possibly follow on how to approach this?

Thanks in advance  ;D

EDIT: I'm not sure how relevant this might be, but I just realized this may have started after updating to the latest version of CUPS, npth, poppler and libassuan. I'm unable to add new printers (log says: A non-recoverable error has occurred, very informative :P) but the printers I already had installed are working fine. There's probably no correlation but due to the closeness of both incidents I felt like it might be worth including just in case.

7
Applications / Windows 95 in DOSBox/2
« on: October 20, 2020, 10:15:17 am »
Hi all, I hope we're doing well today  :)

Recently I've been trying to get Windows 95 running under DOSBox/2 upon seeing that it's been done before, if the screenshots in the eCSoft2 page are correct. I was hoping to find out if anyone here has actually managed it before and if so, any comments about how they got it up and running. I've only gotten as far as mounting the image and booting it with a generic "Error Loading Operating System" so far.

Cheers  ;D

8
I've decided to give Arca OS a shot on a Yoga S1 which I was recently given and while most of it's been a breeze so far, I've inevitably ran into a few issues which I can't quite get past... In order to avoid going into a ramble I'll list them out as plainly as I can.

>Whilst trying to get the touch screen to function, I've been getting an error during boot stating that amouse.sys is not installed and therefore the line in CONFIG.SYS has been ignored. I am currently using the latest version of the Arca Noae driver. The hardware manager also tells me the driver has been installed however and appears to refer to amouse.sys for AUX_0 PS/2 and MOUSE_0 IBM

>When trying to run UVCVIEW, I am getting the 0000FF14 Obtain Thread error. The webcam light turns on but I receive no picture.

>Audio is working which is a relief, but it seem be playing both through the 3.5mm jack and the speakers. I've used the /A:1 switch as the wiki recommends but the recommended startup.cmd script simply errors out and doesn't seem to do anything useful.

As always, thank you all kindly for your advice.

I'm also currently searching for any solutions that might already exist and will update as I go if I find anything in order to help future users who may run into the same problems.

9
Hi all, I finished an installation + configuration of Arca OS on one of my computers and decided to use the zip program to make a backup in the hopes of it being a bit lighter/quicker than DFSEE. Using the following command found on Blondeguy: zip -qryS cdrive.zip c:\* -x WP?ROOT.?SF

The backup does start but inevitably after a bit of progress I get an Access Denied error. Zip and Unzip have been updated as required through YUM and I am a bit stumped on what could possibly be the source of the issue. I doubt it's anything too grave as it's a brand new installation but I haven't found any possible causes yet...

10
Hardware / Looking for suggestions a new laptop for Arca OS
« on: April 15, 2020, 07:22:35 pm »
Hey all, as the title says, I'm looking for a new addition to my stable for my next dailyable Arca OS laptop. I've seen quite a few examples and have a fairly solid idea on what I'm after (T450, Yoga 12, X250), but I was hoping to get the opinion of the more experienced folks here. Especially after seeing the 25th anniversary OS/2 Warp by Sigurd Fastenrath, I've come to the realization that virtually most concerns (and issues) I've had with hardware friendliness in the past are likely far less relevant than they might have been previously.

Before I ramble on too much I'll outline my question: does anyone have any recommendations from experience on a relatively modern laptop (2015+) that could fit the bill as a low/no-fuss, on-the-go, reliable and stable device?

Thanks in advance  :)

11
Applications / WINOS2 functionality on the Thinkpad X220 or X201i
« on: June 15, 2019, 01:01:08 pm »
Hi all, back at you with yet another question.

Lately I've been curious about trying to get DOS/WINOS2 to work on my Arca OS setups. Unfortunately with my X220 (intel i5) I've never really been able to get WINOS2 to properly work, I was hoping to find out if anyone's had any better luck on an X201 or even an X220. If so, was there any special steps you had to take and is it possible to install it after a completed installation of Arca OS?

Once again, thank you in advance  :)

12
Storage / Near-constant data loss and corruption, system is unusable.
« on: June 09, 2019, 02:09:03 pm »
Please move if I've posted in the wrong board...

Hey all, I'm running into a pretty serious data loss situation with my X220 and was hoping to see if anyone could give me some input.
If I had to describe it, I'd say data is simply not persisting across reboots more times than not, it seems to be simply dropping any changed configuration settings instead of saving them whilst shutting down. There are also incidents where my data will corrupt, including system files at times. Additionally, I'll occasionally have incidents in which my desktop environment will freeze up and I'll have to kill and reload the workplace shell after which point visual corruption of the interface starts to occur. It's happened multiple times with different drives, both on fresh and heavily configured setups - I'm at the point where I feel I must be missing something extremely vital or basic as this can't be the status quo.

Sincerest thanks in advance

13
Networking / Looking for driver for Intel 5100 8086:4232
« on: April 09, 2019, 04:26:06 pm »
Hey all, as the title states, I currently have an Intel 5100 8086:4232 card that is compatible but I've failed to locate the necessary GenMU driver (save for OS2Voice which I do not have credentials to) to go with it. Is there any location that might have this driver available?

Many thanks.

14
Hardware / Ways to make Arca OS wait until shutdown sound plays?
« on: July 03, 2018, 07:32:24 pm »
As the title states, my current Thinkpad goes through the shutdown sequence too quickly to even start playing a shutdown sound. I was hoping to see if there's any way to force a delay that would allow the sound to play or a similar remedy.

The Thinkpad I'm running is an X220i with the UniAud driver.

Thank you

Pages: [1]