Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Ibrahim Hakeem

Pages: 1 [2] 3 4 ... 6
16
Not really, the build requirements don't currently exist on our platform, namely Ninja, which works sorta like make.
It's also 1.4 GB's of source.

Ah shucks, it did seem too good to be easily possible honestly. Thanks for looking into it anyway, perhaps we'll get a new native x86 emulator in the future... 'til then it's back to Virtualbox  :P

17
Sorry to bump the thread, I just wanted to find out if there have been any potential updates on this front?

18
Agreeing to the sentiment shared here. QEMU is much less clunky as opposed to VirtualBox, if we could have a build with working audio (and maybe even networking), it would unlock a whole world of potential for many of us who run ArcaOS as a daily driver on one or more of our main machines.

19
Programming / Re: VSLICK - OS/2 Toolkit Support Package
« on: April 12, 2021, 02:31:03 pm »
Sorry to hijack this thread, but could you point us to where we can find a copy of VSLICK? I've been looking for a good OS/2 based IDE that's no VIM for a while now

20
Applications / Re: OS/4 (technical details only)
« on: April 07, 2021, 04:23:09 am »
I thought AN isn't providing support for anything involving the OS/4 kernel.

21
Applications / Re: OS/4 (technical details only)
« on: March 28, 2021, 02:28:45 pm »
On my M93P, I've managed to get the latest OS4 kernel to boot, but I get stuck on a loading cursor in the middle of the screen pre XWP starting.

Assuming you have gone through the enclosed HowTo  -  try to reboot a few times, PM Shell or WPS  have some bug which  brings this behavior. I have met it many times on the original kernel too.

That turned out to be the solution. I'm aware of this problem but thought there was something else at play after a few reboots didn't do the trick. After a total of 9 reboots, it's finally running properly and is starting every time without troubles now.

22
Applications / Re: OS/4 (technical details only)
« on: March 28, 2021, 11:36:28 am »
On my M93P, I've managed to get the latest OS4 kernel to boot, but I get stuck on a loading cursor in the middle of the screen pre XWP starting.

23
Hi

I think the issue may be that there are several brands of trackpoint, one may think that all should be from Lenovo, but indeed there are three brands of trackpoints that came bundle with Thinkpads.... I can not remember all ELAN, Synaptics...and I can not remember the third one.

Regards

Hi Martin

By the looks of it, the T450S's trackpoint relies on Synaptics hardware. I think most of the ELAN ones are used in the X-Series, I also can't seem to remember the name of the third manufacturer but I believe their ones are used in the mid-low range Thinkpads and Ideapads.

24
Apologies for the belated update. Unfortunately the IBM driver yielded no results - I was assuming as much so it comes as no surprise to me, but it was definitely worth the try  ;D

25
Search Plus would be a good program to replaced the old Search program in ArcaOS.

If I'm not mistaken? Isn't 5.1 already slated to have a built in search utility that mostly matches Searchplus?

26
What is the Trackpoint scroll button? Is it the blue trapezoid shaped button? What is it supposed to do?

Yes, the trapezoid shaped button with the row of blue dots. It's intended to work exactly like pressing down on the scroll wheel with a regular USB mouse - pressing it once or hold it down whilst also moving your cursor to scroll up and down with (predominantly modern) programs that have a page/document scrolling function, i.e Firefox or OpenOffice.


Did you try with the IBM USB mouse driver? Unluckily it doesn't seem to ship with ArcaOS and I'm not sure whether it'll work with the ArcaOS USB stack or what else it needs.

I'll definitely need to try that when I'm back at my laptop. I'm not too confident on how it'll turn out as I believe ArcaOS's USB stack is quite different - but it's definitely worth a shot.

27
For my T42, using the IBM mouse driver rather then the Amouse driver allows the scroll button to work. You do lose the ability to use a scroll wheel on a regular mouse though.
Not sure whether the T450S works the same as the T42 is old enough that IBM supported OS/2 on it and IIRC, it is wired as a PS2 mouse.

That was my first approach but unfortunately my T450S recognizes the trackpad + trackpoint as a USB HID device rather than a PS2 device.

28
Hardware / Thinkpad T450S trackpoint scroll button, can it be mapped?
« on: March 11, 2021, 06:57:00 am »
Hi all

For as long as I've been using my T450S with ArcaOS, I haven't been able to get the trackpoint's scroll button working as intended - whenever I press it, the cursor just jerks around the screen in a random direction. It's not that big a deal as much, rather a QOL thing that I'd love to wrangle.

I wasn't able to find a solution to potentially remap it and was hoping to see if anyone has experienced anything similar and might have a solution.

If it helps at all,  I tried an external mouse as well, finding that while scrolling itself worked fine, there was no response when I clicked the on scroll wheel. It did function perfectly and as intended when using my M93P however (using Firefox to test).

Thanks in advance as always  ;D

29
Applications / Re: USB sound effects - Any methods?
« on: March 03, 2021, 01:16:18 am »
Hi

Wim has a useful tool, usbwarn, that opens the Drives folder when a USB drive is attached.
This tool includes a cmd file that I think could be modified to also play a sound. See https://home.hccnet.nl/w.m.brul/usbstick/index.html


Regards

Pete

Sweet, that's actually pretty useful just for the fact that it automatically opens the drives folder... Now, to modify the script and write another daemon for ejection  ;D

30
Applications / USB sound effects - Any methods?
« on: March 01, 2021, 09:18:25 pm »
Hi all. I know it's a bit frivolous and pointless but it's come across in my recent obsession with desktop customization... Is there any viable way to replace the PC beeps for a USB drive being inserted/removed to be replaced with a Wave sound like in other OSes? The idea of having a play.cmd script execute did come to mind but I'm not sure what the best way to go about it would be.

Pages: 1 [2] 3 4 ... 6