Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Andi B.

Pages: [1] 2 3
1
Internet / Problems with our browsers (SM & FF) with bitbucket.org
« on: July 11, 2021, 12:36:41 pm »
Is bitbucket.org now unusable with our browsers too?

It worked when I tested some weeks/months ago. But this was on another OS/2 system. Now pages are left blank. I can log in and some direct links from my history work. But navigating to root projects or workspaces don't work anymore :-(

2
Applications / Unofficial xwp XWorkplace 1.0.13
« on: June 22, 2021, 11:19:59 am »
I've uploaded my own version of xwp here - ftp://ftp.netlabs.org/pub/xworkplace/

This version is very similar to the ones Rich released a while ago. Differences are described in the included .txt file
Quote
1) Power off/shutdown delay (apm.c) is set to 250ms in official builds. This
time is known to be too short for some systems. One of my system sporadically
does not fully switch off with this setting. 500ms works most of the time but it
needs 700ms to shut down reliable. My XWP builds defaults to 700ms. But you can
configure your own value by setting XWP_SHUTDOWN_DELAY environment variable.
F.i. adding 'SET XWP_SHUTDOWN_DELAY=1500' in config.sys increases the delay to
1500ms. Values from 250 to 3100 are allowed. Check setting 'Write XSHUTDWN.LOG
file' (Desktop - Properties - XShutdown) and an entry will be created for that
in this file in your %LOG% directory.

2) My XWP builds still uses the standard shutdown dialog with configurable names
for reboot options.

Maybe 1) is of interest for Doug.

Unfortunately I'm not a trac/xwp admin. So I can't add a proper ticket category. When you create a ticket at netlabs please specify exactly which build you're using.

3
Programming / human readable config file handling - libs we have
« on: February 06, 2021, 11:18:20 am »
OS/2 software usually stores application data in os2.ini or some application.ini. But nowadays I prefer human readable config files. We have such for a lot of ported software like smb.conf or http.conf or ...

Someone knows which libraries are used for (simple) config file processing? I want to store some application settings of my own program in a human readable form. For sure I don't need to reinvent all these text parsing stuff again. Which sources should I look for? Thanks.

4
Internet / Seamonkey and PGP
« on: January 08, 2021, 01:26:56 pm »
Can we handle PGP signed emails with our Seamonkey? Are there any addons?

5
Currently I write on a document on Win and OS/2. Started on Win it uses Times New Roman. When reading on OS/2 I don't see the Greek Ohm symbol. Our Times New Roman WT J does have a lot of Greek symbols but don't know if Win has this font. Moreover that Ohm symbol looks not very nice. I tried Calibri which looks fine but very different to Times...

Nimbus Roman No 9 doesn't have Ohm symbol or I didn't find it. Garamond No8 does have a very ugly (for the eyes of a technician) looking Ohm. Didn't try other Greek symbols.

Anyone here experienced with document exchange between Win and OS/2 and fonts? Best with technical/electronic symbols.

6
Occasionally I use AOO writer for some documents. When I open a document and try to save it with a new file name the whole system hangs. No CAD screen only a reboot when doing CAD two times. Ping from another system still works but f.i. ftpd does not. Wonder if it is only on my system or if this is a bug of our OS/2 version.

I've installed current libraries from netlabs standard repository. I can't remember if older versions behave the same way. I don't use AOO very much. But wonder if no one else sees this.

I usually have auto save enabled every 10 minutes and enabled make backup copy (translated, options menu, Load/Save settings). Wonder if it makes a difference.

Before I open a ticket I wanted to ask here if someone can replicate this.

7
As messages to this group are censored and silently deleted don't use this group (apache2@googlegroups.com).

Anyone knows a serious place where to discuss Apache for OS/2 topics without censorship?

8
A few days ago I though I give the newest SM version a try. But it behaves not very stable on my system. Every now and then it crashes without any .trp file or popuplog.os2 entry.

Before I heavy used SeaMonkey/2.42.9esr Build-Identifikator: 20190520220003 which is much more stable. But as I now do much wiki (confluence) editing it sooner or later eats up all higher shared memory. At that time it becomes very unresponsive. So I though I try the newest version.

First thing I noticed with the new version is, it uses more of the rpm dlls and does not provide the same in it's own directory. That's good IMO. But I had to update nss... packages from netlabs exp repository. Otherwise sites which needs TLS1.2 did not work. Okay I've no big problem using the exp repository. But I can't get this version as near as stable than the older one.

I tried a new profile without much success. Although startup is now way faster cause with my standard profile I usually automatically load email and calendar too. But the new profile without any extensions did not help either.

What makes me wonder is that SM does not create .trp files anymore. The older version did.  Anyone else seeing such problems? Dave here ;-)

9
Hardware / Someone tried OS/2 with 3840x2160 Display?
« on: April 03, 2020, 08:25:04 pm »
Until a few months ago I though my two 24" 1920x1200 monitors give me the maximum display size I can use with OS/2. And this only when I can use a graphic card which SNAP can drive in multi-head mode. Then I bought a used Thinkpad T540p with a 2880x1620 panel. Surprisingly this resolution works with panorama. But of course the display is much to small. Notebooks are only toys for me. For real work I need more than 24".

Now I've the opportunity to lend a 27" Eizo with 2560x1440 resolution. As the motherboard on one of my systems does have a DisplayPort I tested this monitor with OS/2 and it works. Now as I know that Intel processor integrated graphic chip can drive more than 1920x1200 via DP I wonder if it would be possible to drive even bigger displays. The motherboard specification says max. resolution 4096 x 2160 @ 24 Hz / 3840 x 2160 @ 60 Hz. Now I wonder if something like the DELL P4317Q Ultra HD IPS 42,5" which can do 3840x2160 will work with this board. Anyone tested such high resolutions with any motherboard?

10
Yesterday I updated on one of my systems the old VBox 1.6 installation to the latest 5.0.51. I also created a new virtual machine called 'WinXP_Banzai' with already working disk files (*.vdi) from another system. It worked yesterday. But I found out that this VBOX version needs a lot of lower shared RAM. 130MB - 170MB which pushes this system to the limits. Had to close some apps and reboot often but it worked yesterday. I tried to load high code segments of all vbox dlls but that does not help very much. VBox 1.6 seems to need less as it worked on this system for years.

Today when I try to start a virtual machine I get a error box with the message see subject. I got the same yesterday some times too but after a few tries it started. I've LIBCX_HIGHMEM=2 set. Attached the log.

I got this error when I start the machine with an object set to 'VBoxManage.exe startvm "WinXP_Banzai"'. Interestingly I could start the machine once from the VirtualBox.exe Manager Start button. But before I could see the log it crashed :-(

Log unsuccessful start -
Code: [Select]
VirtualBox XPCOM Server 5.0.51_OSE r159 os2.x86 (Mar 22 2018 02:52:37) release log
00:00:00.008000 main     Log opened 2020-01-06T10:06:40.327000000Z
00:00:00.008000 main     Build Type: release
00:00:00.008000 main     OS Product: OS/2
00:00:00.008000 main     OS Release: 1
00:00:00.008000 main     OS Version: 2.45
00:00:00.008000 main     Host RAM: 3327MB total, 2453MB available
00:00:00.008000 main     Executable: P:\VIRTUALBOX5.0.51\BIN\VBOXSVC.EXE
00:00:00.008000 main     Process ID: 1345
00:00:00.008000 main     Package type: OS2_32BITS_GENERIC (OSE)
00:00:00.152000          Home directory: 'e:\HOME\DEFAULT/.VirtualBox'
00:00:00.162000          Loading settings file "e:\HOME\DEFAULT/.VirtualBox\VirtualBox.xml" with version "1.7-os2"
00:00:00.233000          HostDnsMonitor: old information
00:00:00.233000            no server entries
00:00:00.233000            no search string entries
00:00:00.233000            no domain set
00:00:00.233000          HostDnsMonitor: new information
00:00:00.233000            server 1: 195.3.96.67
00:00:00.233000            server 2: 213.33.98.136
00:00:00.233000            no search string entries
00:00:00.233000            domain: domain
00:00:00.233000          HostDnsMonitorProxy::notify
00:00:00.266000          VD: VDInit finished
00:00:00.279000          ERROR [COM]: aRC=NS_ERROR_FAILURE (0x80004005) aIID={0eb668d2-495e-5a36-8890-29999b5f030c} aComponent={SystemPropertiesWrap} aText={Cannot determine default Guest Additions ISO location. Most likely they are not available}, preserve=false aResultDetail=0
00:00:00.344000          Loading settings file "r:\W2k\W2k.xml" with version "1.3-os2"
00:00:00.416000          Loading settings file "r:\eCS2.0\eCS2.0.xml" with version "1.3-os2"
00:00:00.418000          Loading settings file "r:\WinXP_Banzai\WinXP_Banzai.vbox" with version "1.15-os2"
00:01:10.690000 Watcher  ERROR [COM]: aRC=NS_ERROR_FAILURE (0x80004005) aIID={f30138d4-e5ea-4b3a-8858-a059de4c93fd} aComponent={MachineWrap} aText={The virtual machine 'WinXP_Banzai' has terminated unexpectedly during startup with exit code 1 (0x1)}, preserve=false aResultDetail=0
00:01:15.789000 main     ERROR [COM]: aRC=VBOX_E_OBJECT_IN_USE (0x80bb000c) aIID={4afe423b-43e0-e9d0-82e8-ceb307940dda} aComponent={MediumWrap} aText={Medium 'r:\WinXP_Banzai\Snapshots/{d80d3bc7-9227-4ccf-8345-84cfeacfceb4}.vdi' cannot be closed because it is still attached to 1 virtual machines}, preserve=false aResultDetail=0
00:01:15.789000 main     ERROR [COM]: aRC=VBOX_E_OBJECT_IN_USE (0x80bb000c) aIID={4afe423b-43e0-e9d0-82e8-ceb307940dda} aComponent={MediumWrap} aText={Medium 'R:\WinXP\WinXP_Boot.vdi' cannot be closed because it is still attached to 1 virtual machines}, preserve=false aResultDetail=0
00:01:15.789000 main     ERROR [COM]: aRC=VBOX_E_OBJECT_IN_USE (0x80bb000c) aIID={4afe423b-43e0-e9d0-82e8-ceb307940dda} aComponent={MediumWrap} aText={Medium 'r:\WinXP_Banzai\Snapshots/{46b8216e-e107-429a-a4c5-2be610d29b83}.vdi' cannot be closed because it is still attached to 1 virtual machines}, preserve=false aResultDetail=0
00:01:15.789000 main     ERROR [COM]: aRC=VBOX_E_OBJECT_IN_USE (0x80bb000c) aIID={4afe423b-43e0-e9d0-82e8-ceb307940dda} aComponent={MediumWrap} aText={Medium 'R:\WinXP\WinXP_HD2.vdi' cannot be closed because it is still attached to 1 virtual machines}, preserve=false aResultDetail=0
00:01:15.789000 main     ERROR [COM]: aRC=VBOX_E_OBJECT_IN_USE (0x80bb000c) aIID={4afe423b-43e0-e9d0-82e8-ceb307940dda} aComponent={MediumWrap} aText={Medium 'r:\WinXP_Banzai\Snapshots/{4ac5ebdf-82ff-4800-8758-989971aacb20}.vdi' cannot be closed because it is still attached to 1 virtual machines}, preserve=false aResultDetail=0
00:01:15.789000 main     ERROR [COM]: aRC=VBOX_E_OBJECT_IN_USE (0x80bb000c) aIID={4afe423b-43e0-e9d0-82e8-ceb307940dda} aComponent={MediumWrap} aText={Medium 'R:\WinXP\WinXP_HD3.vdi' cannot be closed because it is still attached to 1 virtual machines}, preserve=false aResultDetail=0
00:01:15.799000 Watcher  ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={0169423f-46b4-cde9-91af-1e9d5b6cd945} aComponent={VirtualBoxWrap} aText={The object is not ready}, preserve=false aResultDetail=0

Log successful start. When I copied this text from OS/2 editor (MED) to clipboard the VM crashed -
Code: [Select]
VirtualBox XPCOM Server 5.0.51_OSE r159 os2.x86 (Mar 22 2018 02:52:37) release log
00:00:00.009000 main     Log opened 2020-01-06T10:14:22.412000000Z
00:00:00.009000 main     Build Type: release
00:00:00.009000 main     OS Product: OS/2
00:00:00.009000 main     OS Release: 1
00:00:00.009000 main     OS Version: 2.45
00:00:00.009000 main     Host RAM: 3327MB total, 2437MB available
00:00:00.009000 main     Executable: P:\VIRTUALBOX5.0.51\BIN\VBOXSVC.EXE
00:00:00.009000 main     Process ID: 2273
00:00:00.009000 main     Package type: OS2_32BITS_GENERIC (OSE)
00:00:00.150000          Home directory: 'e:\HOME\DEFAULT/.VirtualBox'
00:00:00.160000          Loading settings file "e:\HOME\DEFAULT/.VirtualBox\VirtualBox.xml" with version "1.7-os2"
00:00:00.226000          HostDnsMonitor: old information
00:00:00.226000            no server entries
00:00:00.226000            no search string entries
00:00:00.226000            no domain set
00:00:00.226000          HostDnsMonitor: new information
00:00:00.226000            server 1: 195.3.96.67
00:00:00.226000            server 2: 213.33.98.136
00:00:00.226000            no search string entries
00:00:00.226000            domain: domain
00:00:00.228000          HostDnsMonitorProxy::notify
00:00:00.259000          VD: VDInit finished
00:00:00.273000          ERROR [COM]: aRC=NS_ERROR_FAILURE (0x80004005) aIID={0eb668d2-495e-5a36-8890-29999b5f030c} aComponent={SystemPropertiesWrap} aText={Cannot determine default Guest Additions ISO location. Most likely they are not available}, preserve=false aResultDetail=0
00:00:00.337000          Loading settings file "r:\W2k\W2k.xml" with version "1.3-os2"
00:00:00.410000          Loading settings file "r:\eCS2.0\eCS2.0.xml" with version "1.3-os2"
00:00:00.412000          Loading settings file "r:\WinXP_Banzai\WinXP_Banzai.vbox" with version "1.15-os2"
00:06:30.244000 Watcher  ERROR [COM]: aRC=NS_ERROR_FAILURE (0x80004005) aIID={f30138d4-e5ea-4b3a-8858-a059de4c93fd} aComponent={MachineWrap} aText={The virtual machine 'WinXP_Banzai' has terminated unexpectedly during startup with exit code 1 (0x1)}, preserve=false aResultDetail=0
00:06:34.109000          ERROR [COM]: aRC=VBOX_E_OBJECT_NOT_FOUND (0x80bb0001) aIID={edba9d10-45d8-b440-1712-46ac0c9bc4c5} aComponent={ExtPackManagerWrap} aText={No extension pack by the name 'Oracle VM VirtualBox Extension Pack' was found}, preserve=false aResultDetail=0
00:10:45.748000          ERROR [COM]: aRC=VBOX_E_OBJECT_NOT_FOUND (0x80bb0001) aIID={edba9d10-45d8-b440-1712-46ac0c9bc4c5} aComponent={ExtPackManagerWrap} aText={No extension pack by the name 'Oracle VM VirtualBox Extension Pack' was found}, preserve=false aResultDetail=0
00:13:09.705000 Watcher  ERROR [COM]: aRC=NS_ERROR_FAILURE (0x80004005) aIID={f30138d4-e5ea-4b3a-8858-a059de4c93fd} aComponent={MachineWrap} aText={The virtual machine 'WinXP_Banzai' has terminated unexpectedly during startup with exit code 1 (0x1)}, preserve=false aResultDetail=0
00:13:24.318000          ERROR [COM]: aRC=VBOX_E_OBJECT_NOT_FOUND (0x80bb0001) aIID={edba9d10-45d8-b440-1712-46ac0c9bc4c5} aComponent={ExtPackManagerWrap} aText={No extension pack by the name 'Oracle VM VirtualBox Extension Pack' was found}, preserve=false aResultDetail=0
00:13:24.560000          ERROR [COM]: aRC=VBOX_E_IPRT_ERROR (0x80bb0005) aIID={f30138d4-e5ea-4b3a-8858-a059de4c93fd} aComponent={SessionMachine} aText={Saved screenshot data is not available (VERR_NOT_SUPPORTED)}, preserve=false aResultDetail=0

Rest of log after crash -
Code: [Select]
00:14:54.126000 main     ERROR [COM]: aRC=VBOX_E_OBJECT_IN_USE (0x80bb000c) aIID={4afe423b-43e0-e9d0-82e8-ceb307940dda} aComponent={MediumWrap} aText={Medium 'r:\WinXP_Banzai\Snapshots/{d80d3bc7-9227-4ccf-8345-84cfeacfceb4}.vdi' cannot be closed because it is still attached to 1 virtual machines}, preserve=false aResultDetail=0
00:14:54.126000 main     ERROR [COM]: aRC=VBOX_E_OBJECT_IN_USE (0x80bb000c) aIID={4afe423b-43e0-e9d0-82e8-ceb307940dda} aComponent={MediumWrap} aText={Medium 'R:\WinXP\WinXP_Boot.vdi' cannot be closed because it is still attached to 1 virtual machines}, preserve=false aResultDetail=0
00:14:54.126000 main     ERROR [COM]: aRC=VBOX_E_OBJECT_IN_USE (0x80bb000c) aIID={4afe423b-43e0-e9d0-82e8-ceb307940dda} aComponent={MediumWrap} aText={Medium 'r:\WinXP_Banzai\Snapshots/{46b8216e-e107-429a-a4c5-2be610d29b83}.vdi' cannot be closed because it is still attached to 1 virtual machines}, preserve=false aResultDetail=0
00:14:54.126000 main     ERROR [COM]: aRC=VBOX_E_OBJECT_IN_USE (0x80bb000c) aIID={4afe423b-43e0-e9d0-82e8-ceb307940dda} aComponent={MediumWrap} aText={Medium 'R:\WinXP\WinXP_HD2.vdi' cannot be closed because it is still attached to 1 virtual machines}, preserve=false aResultDetail=0
00:14:54.126000 main     ERROR [COM]: aRC=VBOX_E_OBJECT_IN_USE (0x80bb000c) aIID={4afe423b-43e0-e9d0-82e8-ceb307940dda} aComponent={MediumWrap} aText={Medium 'r:\WinXP_Banzai\Snapshots/{4ac5ebdf-82ff-4800-8758-989971aacb20}.vdi' cannot be closed because it is still attached to 1 virtual machines}, preserve=false aResultDetail=0
00:14:54.126000 main     ERROR [COM]: aRC=VBOX_E_OBJECT_IN_USE (0x80bb000c) aIID={4afe423b-43e0-e9d0-82e8-ceb307940dda} aComponent={MediumWrap} aText={Medium 'R:\WinXP\WinXP_HD3.vdi' cannot be closed because it is still attached to 1 virtual machines}, preserve=false aResultDetail=0
00:14:54.132000 Watcher  ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={0169423f-46b4-cde9-91af-1e9d5b6cd945} aComponent={VirtualBoxWrap} aText={The object is not ready}, preserve=false aResultDetail=0

I guess the main problem is shortage of lower shared memory. After boot I've about 175MB free. Now with Seamonkey and the VirtualBox Manager (VirtualBox.exe) running there I have -
Code: [Select]
pm: 248192 sm: 150464  <---512---> pm: 1376256 sm: 957428
Seems a bit less for current VBox.

Suggestions?

Btw. I can't read the readme at http://trac.netlabs.org/vbox/browser/trunk/doc/ReadMe-OS2.txt cause I constantly get -
Code: [Select]
Oops …
Trac hat einen internen Fehler festgestellt:

UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 28: ordinal not in range(128)
 ....

11
Setup & Installation / How to convert a GPT disk with Win10 to MBR
« on: October 12, 2019, 06:17:58 pm »
I don't want to loose the Win10 installation. How can I convert the disk to MBR so I can add some OS/2 partitions?

12
Setup & Installation / T540p - OS/2 is unable to operate your hard disk
« on: October 12, 2019, 06:16:22 pm »
Anyone successfully installed ArcaOS or OS/2 on a T540p?

Trying install ArcaOS from USB Stick leads to a reboot after selecting 'Booting with default values'.

When putting in another harddisk with preinstalled eCS and ArcaOS on different partitions I always get 'OS/2 in unable to operate your hard disk'. Any hints to get this Thinkpad running?

I've disabled Hyperthreading and USB3 in BIOS. I also enabled Legacy boot. What else?

13
Internet / Seamonkey Calendar - google CalDAV 'Modification failed'
« on: April 15, 2019, 06:19:53 pm »
I'm trying to synchronize my Seamonkey Calendar with google. Fetching entries works but I can not create a new event and synchronize to google.

I know how to setup and it works for me with SM running under Windoze. But can't get it to work with our OS/2 builds.

Has anyone ever successfully installed google calendar CalDAV synchronization? Any hints?

14
Networking / New xwlan beta - please test and give feedback
« on: October 02, 2018, 09:21:58 pm »
I've uploaded the new beta5 of xwlan. ftp://ftp.netlabs.org/pub/wlan/xwlan314beta5.zip
I want to ask people who have a wireless NIC supported by genmac to test this version. I've made significant changes in a lot of places to improve some code and in debug message handling. I've cross checked all changes numerous times and think I did not break anything. Hope it works for others too the same as the latest versions. Or better.

Included is wpa_supplicant from current official code repository and Spanish language files.

Before I concentrate on other topics I wanted to assure all my current changes works as designed (do not break any functionality of previous versions).

Btw. you can create tickets or post here. Don't be offended when I can not answer questions the next week. I've to meet some sharks. But I'll be back afterwards :-)

15
Applications / SmartGit - Problem with File Mode (Modified (File Mode))
« on: September 16, 2018, 11:22:08 am »
I'm using SmartGit now more often and there's an annoying problem I have. Our last version which runs with Java1.6 is 2.1.8a TTBOMK. I use it with a few GIT servers and the problem is, in the file panel it shows a lot of files as changed although they are not. Under Working Tree State it says 'Modified (File Mode)'. This is even after a fresh pull.

I've searched all options but did not find any to disable this for file compare. Anyone knows an external file compare utility which works with SmartGit and does no show this File Mode changes? Any hints?


Pages: [1] 2 3