Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Glenn

Pages: [1] 2
1
I did install the fonts (even the TTF fonts in the Windows 3.1 version of AHD), without any subsequent effect on the problem. I checked and my config.sys does have the environment variables.
Roderick now has ISOs of my installation disks so should be able to tell more when he has some time to look at it. Thank you so much to you all for your help!

2

Glenn can you put back the original version of pmmerge.dll and run the program ? Post the popuplog.os2 entry and then I might be able to tell why it crashes. Maybe a font that is installed ? I have no clue but then we MIGHT be able to trace why it crashes.

Roderick

The app not starting produces the following (do not look at the dates, I put back the original unpatched files tonight, to recreate the error message):

06-01-2022  16:07:21  SYS3175  PID 0058  TID 0001  Slot 0094
C:\AHD\AHD.EXE
c0000005
1fabd544
P1=00000002  P2=005bb000  P3=XXXXXXXX  P4=XXXXXXXX
EAX=000000e4  EBX=00039280  ECX=00000022  EDX=000081d3
ESI=000392f4  EDI=005bb000
DS=0053  DSACC=d0f3  DSLIM=5fffffff
ES=0053  ESACC=d0f3  ESLIM=5fffffff
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:1fabd544  CSACC=d0df  CSLIM=5fffffff
SS:ESP=0053:00039274  SSACC=d0f3  SSLIM=5fffffff
EBP=0003938c  FLG=00010206

PMMERGE.DLL 0004:0004d544


After applying the patches, when it freezes the WPS, it shows:

05-15-2022  17:04:40  SYS3170  PID 0026  TID 0001  Slot 004b
C:\OS2\PMSHELL.EXE
c0010001
1ffde411
EAX=00000002  EBX=00000000  ECX=00000000  EDX=00673720
ESI=00000000  EDI=00000000 
DS=0053  DSACC=d0f3  DSLIM=5fffffff 
ES=0053  ESACC=d0f3  ESLIM=5fffffff 
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:1f8f454e  CSACC=d0df  CSLIM=5fffffff
SS:ESP=0053:0004f80c  SSACC=d0f3  SSLIM=5fffffff
EBP=0004f814  FLG=00010202

DOSCALL1.DLL 0003:0000e411



3
Have all the (DUX/AHD) patches been applied?  I had crashes in pmmerge.dll with DUX, however, I fixed it long enough ago I don't recall what it was... my recollection is it was the patches.
I did apply all the patches I found... As mentioned previously, the remedy is worse than the disease, as applying the patches now causes the WPS to freeze when trying to start the program.

4
Are you using a multiprocessor system? - Just wondering if using markexe.exe (from os/2 toolkit) to "mark" the executable (dux.exe ?) as mpunsafe will help...
Hi Pete, It' s a VirtualBox system, one processor in the configuration. I' ll check that anyway, but I remember my "real" system in the early 2000s, a P4 (hence without multiprocessing), showed the same problem.

5
Applications / Re: Old problem.. any known solution ?
« on: May 16, 2022, 12:55:39 am »
Hi Glenn

I don't have the American Heritage Dictionary by DUX, but the only thing I had seen is that there are two patches at hobbes, but I'm not sure if those are for the same thing you are using? Those are patches for DUX.EXE.

Regards
Unfortunately the remedy is worse than the problem: instead of just not starting the application, applying these patches causes the app to somehow start minimized (can see the program in lSwitcher) but also to hang the WPS - I have to use TOP to kill the app AND reset the WPS before I can regain control on the system...

6
Hi all, when trying to run the good old American Heritage Dictionary (published by DUX) on ArcaOS 5.0.7, I get a SYS3175 with PMMERGE.DLL, the app does not start. Googling for that error gives many results with people mentioning similar problems. There are also patched versions of PMMERGE.DLL but all much older than the current ArcaOS version, that may or may not have integrated this patched version. IIRC this problem happened with eCS too but not with the original Warp 4.

Was there a known solution / workaround to be able to start such programs on current versions of the OS?

7
General Discussion / Re: Is the arcanoae website in maintenance ?
« on: March 21, 2022, 06:17:42 pm »
It is now back online.

8
General Discussion / Is the arcanoae website in maintenance ?
« on: March 21, 2022, 01:40:24 pm »
Hi all, I cannot seem to be able to access the www.arcanoae.com since this morning, whether from my home wired connection or 4G phone.
Is it a planned maintenance, or is there another problem ? Anyone can access it?

9
Setup & Installation / Re: Installing HPFS386 on ArcaOS
« on: November 07, 2019, 03:40:43 am »
    Add x:\IBMLAN\NETPROG; to LIBPATH
    Add x:\IBMLAN\NETPROG; to DPATH
    Add x:\IBMLAN\NETPROG; to HELP
    Add RUN=x:\ibmlan\netprog\cache386.exe

    Edit "lanroot = x:\IBMLAN" to match your install drive.

Thanks Pete for the link above, and these comments. My worry is about that IBMLAN folder. It might be possible to:
- install HPFS386 with an empty IBMLAN folder; or
- to copy the full IBMLAN folder from another OS to ArcaOS root

In the first case, my question is if there is any reliance of HPFS386 to files in that folder. Given that this folder is not present in ArcaOS, if any part of HPFS386 relies on what is in that folder, I fear that this could cause some trouble.
In the second case, my question would be about the DPATH and LIBPATH statements. If ArcaOS removed that folder, I suppose that the functionalities have been implemented another way. Would there be any conflict between the IBMLAN libraries and those used by ArcaOS?

10
Setup & Installation / Re: Installing HPFS386 on ArcaOS
« on: November 06, 2019, 01:38:53 am »
That's odd. 0x816 indicates an unspecified system error occurred. Beyond that I don't know. The log may tell you more; it's probably in wherever your %LOGFILES% directory is.

The log file puts me on the right track, I think:
HPFS386_Top :: ERROR: Failed to create directory: ERROR:\IBMLAN\NETPROG

ArcaOS does not have an IBMLAN folder.. Creating an empty IBMLAN folder does not solve the problem, it seems like the program does not pick up the drive letter for IBMLAN.

11
Setup & Installation / Re: Installing HPFS386 on ArcaOS
« on: October 26, 2019, 10:17:56 am »
Hi

Sorry to jump on the thread with more questions. I'm curious to know which programs depends on HPFS386, just to have those written down on the wiki.

Regards

Hi Martin,

I do not know of any program that relies on HPFS386 in particular, but a few programs do not like partitions larger than 2GB.

To get a partition with reported free space smaller than 2GB, either create one, or create one larger than 2GB and use something like "spacehog" (on hobbes); however, I am not sure that spacehog works with JFS so I prefer sticking to HPFS, and, in this case, switch to HPFS386 to have a bit better performance...

Now what programs don't like more than 2GB of free space? An example are the old dictionaries by Dux (AHD, Concise Columbia Encyclopaedia) which do not install at all if the TEMP folder is on a partition with more than 2GB of free space.

Now that does not mean they will work once installed (I should open a new thread about that, or about programs whose installers does not seem to work anymore, if there is any interest: AHD never starts, apparently something due to PMMERGE.DLL when I look at the popuplog.os2, and Dux shows a window which immediately hangs and necessitates a desktop reboot to get off the screen), but at least they do get installed. Both rely on the IBM-type installer (the same type of installer as Desktop On-Call, HobLink, MFS, etc.).

12
Setup & Installation / Re: Installing HPFS386 on ArcaOS
« on: October 26, 2019, 02:45:34 am »
Hi Alex,

I tried your installation tool (which looks nice!) but ended up with a "This installation was not successful. The return code is 0x0816" and a VX-REXX error console message (appearing twice): "CLI0057: ERROR occurred: please check the error.log or the file specified by /l1:" (I could not find an error.log in the temporary folder where I placed your installation tool).

Any idea of what this error is about?

13
Setup & Installation / old eCS CDs
« on: October 25, 2019, 10:10:17 pm »
Hi,

I was looking for the last SmartSuite updates, which were on some eCS CD (links on ecomstation.com have been removed), and I realized that I had not made an ISO backup of the old eCS CDs (only of the serial numbers): 1.0GA, 1.1, 2.0GA (mainly the releases that came by post on CDs, that I subsequently lost in a flood). I did backup 1.2MR, 2.1, CD1s of 2.0 RC4/RC5/RC6a.

The ecomstation.com website has a link for 2.0GA but that ftp is empty. The links for 1.0 (and its precious CD3) and 1.1 have been completely removed, and the Mensys website also removed the links to what was hosted on their website, so I cannot re-download any of the missing ISO files. I had sent an email to the eCS support a long while ago and Joachim Benjamins answered me "Unfortunately, we do not have the older eCS versions available for download anymore. All we have presently available is version 1.2 and 2.0/2.1. If you insist I may be able to retrieve the old ISO files and publish them for you somehow, but this would take considerable effort." I did not insist, maybe I should have...

Would someone be able to share these ISOs somehow (all CDs for 1.0, 1.1, 2.0)?

Bonus question: Does anyone remember where the SmartSuite updates (to 1.7.2 and 1.7.3) are located?

Thanks!

14
Setup & Installation / Re: Installing HPFS386 on ArcaOS
« on: October 25, 2019, 09:47:42 pm »
Hi Darius, thanks for pointing out the CID directory. I have no CID or IBMINST directory on my ArcaOS or eCS install, but I did find a CID directory on the eCS 1.2R CD; the DLL has the same buildlevel as yours. Now I probably need to have that LOCINSTU folder somewhere on the libpath before I check again the HPFS386 install.


15
Setup & Installation / Installing HPFS386 on ArcaOS
« on: October 25, 2019, 08:34:21 pm »
Hi,

I've been trying to install HPFS386 (with the same installer I used in eCS years ago) on ArcaOS, to use on a small partition dedicated to old programs that do not like JFS or even HPFS>2Gb, but I get the following message:
"SYS1804: The system cannot find the file RLANUTIL."

That's an error I never got on eCS where HPFS386 install worked every time I needed to reinstall my system. Strangely, if I look for an RLANUTIL.DLL on eCS, I also don't find that file.

Anyone would know how to make it work?

Thanks!

A.

Pages: [1] 2