Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Floyd

Pages: [1]
1
Hardware / SATA AHCI weirdness
« on: June 22, 2013, 07:46:00 pm »
Hi, long time lurker, first time poster. I was wondering if anyone might be able to help me out.

Let's start at the beginning. I have been trying to install Warp 4 on my primary desktop computer, I can give more detailed hardware info if you need it. It doesn't have a floppy drive so I installed a really basic version of OS/2 in Virtual PC and then wrote the virtual hard drive image to the physical disk. I added the latest versions of DaniATAPI.flt, and DaniS506.add to the system as well as OS2AHCI.add (not the latest version) before I transferred the image
OS/2 boots up to a point OS2AHCI correctly recognizes the Intel ich7 chipset but then DaniATAPI won't load and it gives the "OS/2 cannot operate your hard disk" error.
I did this with and without Fixpack 15 applied before the transfer and got the same results, the one time I did get it to work was from a FAT partition instead of HPFS, but it corrupted the desktop as soon as it was shut down.

I have done all I know to do, I don't really have the money to spend on a copy of eCS right now, though the Live CD does work great. I stared this just for something to do, but now I am determined to get it to work. I realize that it could be a problem with the image transfer, and if that is it, I guess I'm done, unless it is possible to make a custom boot CD.

Any help anyone can give would be greatly appreciated!

Pages: [1]