Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - David McKenna

Pages: [1] 2 3 ... 27
1
Applications / Re: SeaMonkey downloads and Unix permissions
« on: June 24, 2022, 02:17:58 am »
 Dave,

 Thanks for the head's-up on this. This problem was maddening for me, it took a long time to figure it out and it really was not acceptable, but I understand your situation, and you were able to fix it once notified, so I hope you can figure out a new solution eventually. Luckily, we have Dooble now (which seems to work OK). In the mean time I will stick with the fixed version.

Regards,

2
Off Topic discussions / Re: Lying low for a few days
« on: June 19, 2022, 09:17:18 pm »
 So sorry for your loss, Paul.

3
Games / Re: DOS VDM - USB and Game port Gamepad support
« on: June 12, 2022, 03:20:57 pm »
 I've also been following this with interest so ordered a Logitech F310 gamepad (seems to be popular and inexpensive). Once I get it, I'll use Mark's guide to try it out. Thanks for all the development work on this!

Regards,

4
Applications / Re: Test build of dooble with qt5
« on: May 17, 2022, 01:21:53 am »
 Hi Remy,

 Well, at least it works now! Not sure why, but if you uninstalled, then re-installed QT5, I can only guess that there may have been corruption in some configuration file somewhere from the first install. Enjoy!

Regards,

5
Applications / Re: Test build of dooble with qt5
« on: May 13, 2022, 10:25:00 pm »
 Hi Pete,

 My understanding is thet Dooble does not support saving passwords, see:

https://github.com/textbrowser/dooble/issues/102

 It could be added, just not by that guy. I personally kinda like that it doesn't because OS/2 does not have a logon to the desktop, so anyone can turn on your computer and use (and even see with SeaMonkey) your passwords. It is very convenient though, but I'm getting more and more security conscious in my old age (due to harsh experience)...

Regards,

6
Applications / Re: Test build of dooble with qt5
« on: May 12, 2022, 12:29:13 pm »
 Hi Remy,

  I looked at yout testlog file, but didn't see anything unusual there in comparison to mine. Maybe the php code you mention is the trigger of the issue? If you can describe how to use it, I'd be glad to try it out just to confirm it is if you want...

Regards,

7
Applications / Re: Test build of dooble with qt5
« on: May 10, 2022, 11:48:33 pm »
 Hi Remy,

 It is very strange! I watched your video so I see what you mean. The only thing I have seen here anything like that is when I tried to open a private window ('Settings'->'New Private Window') - Dooble immediately closed with no trap file. Are you trying to run in 'Private' mode? Maybe this is a bug (although I reported this and was told it is not supported in '--single-process' mode and Dooble closed on purpose).

 At this point we can only experiment - one thing I would try is removing or renaming the C:\Home\.dooble directory. There may be something corrupted in one of the settings files that would be fixed with a new one (created on first start). Of course any settings you may have made will be re-set, so be aware of that.

 Also, strange there is no trap file (unless not really a trap) - are you certain 'exceptq' is properly installed? Try re-installing just in case. Also, look for old versions of exceptq.dll and distorm.dll (the 2 DLL's installed by the exceptq rpm) elsewhere on your system that may interfere.

 If you upload a copy of 'testlog -c generic' I could compare that to mine and see if there are any obvious differences in installed packages that might give a clue if nothing else works.

 Overall, I am very happy with Dooble - yes it has issues, but compared to Firefox issues, they are minor (for me anyway - I can use my Bank again!). I am able to once again navigate the Internet without having to resort to Windows or Linux...

Regards,

8
Applications / Re: Media-downloader
« on: May 10, 2022, 11:01:45 pm »
 Hi Martin,

  In theory, you should be able to install all versions of python by opening a command prompt window and typing:

yum update python

  But when I did that, I got a massive amount of errors. ANPM did not work either - errors. The way I got it to update (after weeks of messing around) was to open ANPM, go to 'Manage'->'Repositories' and disable every repository (right click on one, then choose 'disable') EXCEPT netlabs-exp, then close ANPM. Then open a command prompt and type:

yum update python

 It worked! Of course, re-enable the repositories after trying this. I can't tell you it will work for you because I don't even know why it worked for me, but it did:

[C:\]python
Python 3.9.5 (default, Feb 21 2022, 12:29:29)
[GCC 9.2.0 20190812 (OS/2 RPM build 9.2.0-5.oc00)] on os2knix
Type "help", "copyright", "credits" or "license" for more information.
>>>

 Regards,

9
Applications / Re: Media-downloader
« on: May 10, 2022, 10:52:43 pm »
 Hi Tellie,

 I get this:

[media-downloader] *****************************************************
[media-downloader] To Disable These Checks, Do The Following:-
[media-downloader] 1. Go To "Configure" Tab.
[media-downloader] 2. Go To "General Options" Sub Tab.
[media-downloader] 3. Uncheck "Show Version Info When Starting".
[media-downloader] *****************************************************
[media-downloader] Failed to find executable "aria2c"
[media-downloader] Error, executable to backend "aria2c" could not be found
[media-downloader] Start Downloading yt-dlp ... ... ...
[media-downloader] Downloading: https://github.com/yt-dlp/yt-dlp/releases/download/2022.03.08/yt-dlp
[media-downloader] Destination: D:/HOME/.local/share/media-downloader/bin/yt-dlp.tmp

 and it just sits there forever. yt-dlp.tmp is 0 bytes. Could it be because my 'Home' directory is on a different drive from my %UNIXROOT%?

Regards,

EDIT: wait a minute - I let it sit for a half hour, then it actually downloaded something and now appears to have some functions! Gotta try it out...

10
Internet / Re: Dooble Browser rendering - missing characters
« on: May 10, 2022, 10:35:20 pm »
 Hi Mauro,

 Well - I guess I should have tried it first! When I go to 'la Reppublica' I also see what you see - missing letters in the headline. Probably for the same reason as Doug saw on 'TheWeatherNetwork'. No idea why, so probably should be reported at github as a bug.

Regards,

11
Applications / Re: Media-downloader
« on: May 10, 2022, 02:18:53 am »
 Hi Martin,

  You are probably correct - the only error I see when starting media-downloader is about aria2c, and I do have Python3 installed (it was very difficult to install for me). But even so, I can't do anything with media-downloader - everything is greyed-out and not working...

Regards,

12
Internet / Re: Dooble Browser rendering - missing characters
« on: May 09, 2022, 11:42:57 pm »
 Hi Mauro,

  Here is what I have set as fonts in Dooble (chosen automatically because I already had them installed when I got Dooble):

Cursive = Comic Sans MS
Fantasy = Impact
Fixed = Deja Vu Sans Mono
Pictograph = Deja Vu Serif
Sans Serif = Deja Vu Sans Serif
Serif = Deja Vu Serif
Standard = Deja Vu Serif

 The first 2 are from the MS Core Fonts msfontpack_2.0.wpi at http://Hobbes.nmsu.edu. The last 5 are from the Deja Vu pack you have. Check the 'Web' page under 'Settings' for the font settings.

Regards,

13
Applications / Re: Media-downloader
« on: May 09, 2022, 11:35:06 pm »
Hi Neil,

  I tried the media-downloader and got the 'aria2c not found' message too. A quick google showed that aria2c is some type of command line web media downloader executable (kinda like 'curl' I guess) that we don't have a port of. So 'Media-downloader' is probably supposed to be a 'front end' to that, but without aria2c kinda useless...

Regards,

14
Applications / Re: Test build of dooble with qt5
« on: May 09, 2022, 03:34:30 pm »
Hi Remy,

 I use both ffturbo and OO quickstart, and Dooble runs well here so I guess you can say it is compatible. Trap files usually end up in C:\var\log\apps on my system - look there for any you might have. Having the '*-debuginfo' rpm files installed for QT5 parts will also help get useful trap files.

 Are you running with '--single-process' enabled in Dooble settings? It seems to be much more stable (and faster) that way.

Regards,

15
Internet / Re: Dooble Browser rendering - missing characters
« on: May 09, 2022, 12:17:40 pm »
 Hey Dave,

  Those svg examples work on Dooble just fine here - maybe a missing dependancy? I do see the missing letters and logo on 'TheWeatherNetwork' though...

Regards,

Pages: [1] 2 3 ... 27