Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - jkrim

Pages: [1]
1
I don't think I can get the source code for the Windows driver but I don't know exactly where this would be.  As I said before,  I grabbed the NETwNx32.sys file from the Hiren's boot CD (Mini XP) used on the same system as the eCS install.  It worked to enable the Intel Centrino 6205 unders Win XP and allow internet access so I attempted to use it in eCS, but it crashes either hanging at the netbind.exe or as per this thread getting to the desktop and clicking on almost any app (Firefox, scan.exe, wlanstat.exe etc).

2
From popuplog.os2:

02-06-2022  15:50:57  SYS3171  PID 0003  TID 0001  Slot 000b
D:\OS2\F32CHK.EXE
c0000005
1ffe5db3
P1=00000008  P2=00000014  P3=XXXXXXXX  P4=XXXXXXXX 
EAX=00000000  EBX=00000000  ECX=00000000  EDX=00000000
ESI=00000000  EDI=00000000 
DS=0000  DSACC=****  DSLIM=******** 
ES=0000  ESACC=****  ESLIM=******** 
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=fff7:00005db3  CSACC=00df  CSLIM=0000e4ff
SS:ESP=0017:00005d0e  SSACC=****  SSLIM=********
EBP=00000000  FLG=00010212

DOSCALL1.DLL 0004:00005db3

3
When I was able to get to the desktop without crashing, I tried to run the scan.exe.  The system crashed with 2 screens.  The first one cleared so fast I couldn't see it to the second one which didbn't have a TRAP message as I recall.

4
When I could get to the desktop without a crash or reboot, as soon as I attempted to open the XWLAN monitor the system crashed.  I remember getting a TRAP 000E screen, so that verifies perhaps the problem that was stated regarding XWLAN's power control.

5
I have tried almost everything to get the Intel Centrino 6205 Wireless to work.  The files in GENMU load find, but the radio appears to not be enabled which of course means it doesn't work.    I have tried the .sys and .reg file extracted from booting the Hiren's Mini XP CD.  I know that some people have said that having too large a .sys file causes heartache for GENMAC, but the file was not terribly large.  I also tried one from Windows Vista which is also not too large but it hangs at the netbind.exe with a message "Exception = C0000005 occurred at EIP = 2268a".   No idea what this means.  I have also been able with various combos of .sys and .reg or .inf to boot to the eCS deskop where it hangs momentarily with the mouse icon busy before rebooting the system.  One question I have is that looking at the hardware manager, it appears that the IRQs for the hard drive are 10 and 11.  And, the IRQ for the Intel Centrino 6205 is also 10.  Is this a problem?   Any other thoughts regarding this problem appreciated.

6
Hardware / Re: Trap 000D when trying to go to command line
« on: February 02, 2022, 05:24:13 pm »
Thanks, Martin.  Yes.  It is the config.x.   I verified by adding PAUSE.SYS drivers to make sure it paused.  I am not exactly sure which driver was the culprit but I suspect it was at least the PRINT01.SYS which was also commented out in config.sys.   I commented out several others that didn't load (but no TRAP 000D, just a message) and now I can get to the command line.  This is going to make my life much easier as I had no way to recover from a normal boot hang other than restore a "good" image of the eCS partition with Dfsee.

7
Hardware / Trap 000D when trying to go to command line
« on: February 01, 2022, 11:43:23 pm »
I am trying to boot eCS to the command line by pressing the Alt-F1 when the white square appears in the upper left hand corner, then pressing F2 to get to the command line.   Immediately after pressing the F2 to get to the command line, I get a Trap 000D and stop.  I am wondering if anyone knows which CONFIG.SYS the system is using to boot to the command line at the blue selection screen after pressing ALT-F! at the square then pressing F2?  Aside from that question, is there any other way to identify/debug why there is a TRAP 000D?

8
Setup & Installation / Re: eCS hangs on boot loading OS2DASD.DMD
« on: January 29, 2022, 02:05:21 am »
I didn't modify anything, however, after a couple attempts it finally booted.  But it still seems like it fails for some reason a few times until it finally works again.  I am unable to boot any install media for this eCS installation so when it goes south I am forced to restore the entire partition with a "good" copy using a Dfsee saved image.     

9
Setup & Installation / eCS hangs on boot loading OS2DASD.DMD
« on: January 28, 2022, 04:24:10 pm »
I had a working eCS installation and suddenly when I boot it, it hangs loading OS2DASD.DMD because Alt-F2 at the logo shows the message on boot and it is stuck.  Any ideas?

10
Networking / Re: GenMU WIFI driver for Ralink 301
« on: January 28, 2022, 03:29:34 am »
Well, I guess I'm lucky  :)
I did get it to work by manually copying over a wpa_supplicant.exe file from another working eCs installation.  I also had to copy over DHCLIENT.EXE and DHCONF.EXE but I used a manual configuration setting the IP address on TCPIP configuration page because when eCS booted it was giving me the DCHP: message (counting down by 5 from 55 to 0) and delaying the boot process too much to suit me.

11
Networking / Re: GenMU WIFI driver for Ralink 301
« on: January 27, 2022, 06:35:52 pm »
What do you mean exactly by "doesn't work"?   I used Martin's guide.  I found that the GENM32W.OS2 file already has the RT61 entry so didn't need to hack it.  I copied the Windows (2K) files (.inf, .reg and .sys) over to eCS.   I created a .nif file and added the card through System Setup->Network->Adapters and Protocols .  When I booted, Genmac loaded the driver.  The only problems I seem to have are that the widget says it is installing but doesn't show up on the bar at the bottom of the screen and more importantly  that the "scan connection" on the wireless monitor is greyed out.  This is probably due to the fact that I notice that on the Wireless LAN monitor properties page I see this:

wpa_supplicant version on your system
wpa_supplicant.exe not found!
e:\xwlan_1.3_widget\xcenter\xwlan\

Does the wpa_supplicant need to be installed somewhere or am I missing something else?

I am attempting to use Wireless LAN monitor version 3.13.   

12
Networking / Re: GenMU WIFI driver for Ralink 301
« on: January 27, 2022, 04:03:39 pm »
The Windows (2K) driver is rt61.sys and the version is 1.00.03.0000.

13
Networking / Re: GenMU WIFI driver for Ralink 301
« on: January 27, 2022, 05:32:14 am »
Here is the information from pci.exe:

Vendor 1814h  Ralink
Device 0301h  RT2561/RT61 802, 11 g PCI
Subsys Vendor 1737h Linksys

This device is the Linksys WMP54G PCI WIFI adapter.

14
Networking / GenMU WIFI driver for Ralink 301
« on: January 26, 2022, 04:26:36 am »
Hello,

Is there a GenMU WIFI test version driver for RALINK 0301 or can I "make" one?  In Windows 2000, I see the DEV_0301 in the .inf file and it works under Win 2K in the same machine I am trying to install it under eComStation 2.0.

(I attempted to directly send this to Doug Bissett but it appears his personal email that I corresponded to him at several months ago is no longer valid as it bounced).

Thanks,
Jordan Krim

Pages: [1]