Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Martin Vieregg

Pages: 1 2 [3] 4 5 ... 19
31
Web applications / Re: Otter Browser 1.0 [teaser]
« on: March 08, 2021, 02:22:14 pm »
Dimitry,

great to hear about your efforts! Please make a focus to the installation process. Installation of simplebrowser was not funny and failed on my computer after a lot of trials.

32
Web applications / Re: QT5 simplebrowser
« on: February 23, 2021, 04:25:43 pm »
VIRTUALADDRESSLIMIT=3072 did had an effect. Now I get also a "bus error" message.

To come to this point, I had to run through the "YUM hell". It would be so much easier, if there would be an YUM cmd script where all dependencies are checked and installed.
My readme.txt has only 872 bytes (21-1-5) and has not the information which has been quoted here. It seems there is are different ones.

33
Utilities / Re: MeShell commandline frontend timetable
« on: February 22, 2021, 03:11:11 pm »
When running YUM INSTALL in MeShell, the following query (Y/N), or in german (J/N) is not shown when running YUM in MeShell. I have already told that this is not a MeShell bug. A handful commandline tools have this bug. The solution is simple: It is ISO standard that before a query (a stdin input) the last stdout output has been flushed by using the C function "fflush (stdout)". This line of code is missing in YUM. In Info-Zip UNZIP queries are sent via STDERR - stderr is never buffered in any OS -, but the fflush solution is better.

Can anyone write a RPM ticket? Thank you.

34
Web applications / Re: QT5 simplebrowser
« on: February 22, 2021, 02:39:10 pm »
Now I managed to install all the YUM/Package manager stuff after reading the thread hints here.

Running simplebrowser.exe from the command line has no effect, nothing happens, the command program appears half a second later.

Running "sh run.sh" crashes the whole computer, warm starting is no more possible.

I have got ArcaOS 5.0.2.

35
Web applications / Re: QT5 simplebrowser
« on: February 21, 2021, 06:40:21 pm »
OK, found. But now EVNT217 is missing and *EVNT* is not found in YUM and Package Manager.

A batch file with necessary YUM commands to instal Simplebrowser would be useful.

36
Web applications / Re: QT5 simplebrowser
« on: February 21, 2021, 11:16:41 am »
I cannot start simplebrowser.exe:

SYS1804: The system cannot find the file KAI1.

yum netlabs-exp and netlabs-rel has been installed. Any idea?

37
Utilities / Re: MeShell commandline frontend timetable
« on: January 07, 2021, 09:22:47 pm »
Yes, simply a backslash is missing. I could already fix it, it will be part of the next version.

38
Utilities / Re: MeShell commandline frontend timetable
« on: January 07, 2021, 11:02:55 am »
I have finished MeShell Version 0.84 (740 kB).

There are two useful additions:
  • In the Top Panel, there are buttons for navigation to error messages (stderr output)
  • A dropdown field in the navigation window let you change the order of the shown commands (by time, alphabetically)

And of course, again several minor bug fixes.
From my point of view, functionality is complete now. If you find bugs you can reproduce regulary, please send me a report.
Sometimes, the order of stderr output and stdout output can disarrange. But I still cannot reproduce the problem.

39
Setup & Installation / Re: Problem with SNAP resulution
« on: January 02, 2021, 11:09:28 am »
OK, there's a text file with the registration code. But where can I enter the registration code? I didn't find anything in the Screen Notebook.

40
Setup & Installation / Re: Problem with SNAP resulution
« on: January 01, 2021, 06:02:42 pm »
But meanwhile, I realized that I need to register SNAP. But I cannot register anymore The page www.scitechsoft.com is no more available, and registering makes no sense anymore because SNAP is part of ArcaOS. How to manage this problem now?

41
Applications / SkyChart from 1990
« on: December 16, 2020, 04:39:50 pm »
There's a tiny nice program SkyChart which has been written for OS/2 1.3 in 1990. It still works on current OS/2 systems:
http://www.hypermake.com/english/favorite.html
then press "SkyChart".

The program shows the night sky on a specific location and a specific time.

But there are two bugs:
- Date bug: the current date is 2000 instead von 2020
- Resolution bug: Screens larger than 1920x1200 immediately crash the program.

The authors are Hans Bloemendaal and Klaas van Ditzhuyzen, Netherlands. Does anyone has still contact with them? If I get the source code, I could try to fix the two bugs.

I like the program more than current Windows programs, because it is so simple.

42
Setup & Installation / Re: Problem with SNAP resulution
« on: December 16, 2020, 04:28:58 pm »
I have found a very simple workaround for my ArcaOS 5.0.6 problem where 1600x1200 is used instead of 1920x1200: I have simply installed an elder SNAP version from here:
https://ecsoft2.org/scitech-snap-graphics

and all works fine!
I only had to press a lot of times "YES" because old files have to be copied over newer files.

43
Utilities / Re: MeShell commandline frontend timetable
« on: October 21, 2020, 10:28:16 pm »
The normal behaviour is copying the content of the file into the editor. This is inherited from the editor project (ME, WSedit and others), but it is nearly nonsense in MeShell. Changing the default behaviour should be the file name and not the content. I have this point on my to-do-list. The filename with directory (if the current directory differs) should be the default behaviour.


Dropping with Ctrl copies the file without directory
Dropping with Ctrl+Shift copies the full file name

Dropping in the non-prompt area is only allowed for folders and performs a "CD dirname" operation.

44
Setup & Installation / Re: Problem with SNAP resulution
« on: October 11, 2020, 09:12:08 am »
I have replaced the c:\snap and the c:\os2\drivers\snap directories by the content of the eCS 2.0 installation. No effect. Even the "Wide Screen" checkbox is still not available.

45
Setup & Installation / Re: Problem with SNAP resulution
« on: October 11, 2020, 08:19:54 am »
The ATI X300 graphics card has its own 128 MB memory.

Does ist make sense to switch to an older SNAP version? Can I simply replace the \os2\drivers\snap directory? (running another installation, of course)

I have added my comment to an existing ticket, it has been reported some days ago:
https://mantis.arcanoae.com/view.php?id=3020

Pages: 1 2 [3] 4 5 ... 19