Recent Posts

Pages: 1 [2] 3 4 ... 10
11
Networking / Re: No files in network folders workplace shell
« Last post by Andreas Schnellbacher on May 22, 2022, 10:16:22 pm »
For non-experienced users it's near to impossible to get OS/2 Warp 4 (even 4.52) to work. Most of them try that because others are not available for nothing. Even the early ArcaOS versions can't be used (without fixes) on more modern hardware. That applies especially for SaMBa.

So, to non-experienced users: Always use the latest version. It's currently ArcaOS 5.0.7. Note that the systems actually lacks a recent and stable browser, even when Dooble is a great step forward. That may be changed in the near future.
12
Networking / Re: No files in network folders workplace shell
« Last post by Martin Iturbide on May 22, 2022, 09:36:14 pm »
Hi

I was told that on the old Compuserve forums there where peope hired for FUD that usually post something not working about OS/2 (focusing on the weak spot), complain a lot, didn't have any patience and at the end say they are switching to Windows.

I would belive that on this case, but the OS wars were over a lot of years ago.

Jacco, welcome to the OS2World forum, do you want help with you OS/2 system? or just want to complain and FUD?

Warp 4 is very old, I would recommend you to at least to use Warp 4.52 or ArcaOS.
The out of the box file sharing on OS/2 (NETBIOS?), is not that compatible with Windows on purpose, becase Microsoft didn't want people with OS/2 can play nice with Windows, since they don't tolerate competition.
 
I have no idea how to install Samba on Warp 4, since it is very old, and we are using Warp 4.52, eComStaiton or ArcaOS. If you Warp 4 has an important business application that is used in producction I recommend to back up it first.

Regards
13
Games / Re: DOS VDM - USB and Game port Gamepad support
« Last post by Jochen Schäfer on May 22, 2022, 09:28:27 pm »
Thanks Wim.

I will try that code snippets and build a test version.


Bye Jochen
14
Networking / Re: No files in network folders workplace shell
« Last post by ivan on May 22, 2022, 06:38:51 pm »
In other words you just wanted your 2 minuets of time in the spotlight and have no thought of learning how to use OS/2 or what is rerquired to work with other systems.

BTW all my OS/2 systems are able to communicate with the samba equipped NAS boxes without any problems.
15
Networking / Re: No files in network folders workplace shell
« Last post by jacco123 on May 22, 2022, 06:18:50 pm »
 :)
16
Networking / Re: No files in network folders workplace shell
« Last post by jacco123 on May 22, 2022, 04:36:17 pm »
ok i dont know how to do that ?
17
Games / Re: DOS VDM - USB and Game port Gamepad support
« Last post by Wim Brul on May 22, 2022, 01:14:30 pm »
Hi Jochen,

I don't know when I can get to it, but I will look into it.
Thank you. For starters I tried and modified SDL_os2joystick.c myself. I could send the modified source code to you or append it here. Please advice.

I replaced lines 440 thru 442 with the following:
Code: [Select]
                        joystick->hwdata->transaxes[i].offset = SYS_JoyData[index].axes_med[i];
                        joystick->hwdata->transaxes[i].scale1 = (float)(SDL_JOYSTICK_AXIS_MIN/(SYS_JoyData[index].axes_med[i]-SYS_JoyData[index].axes_min[i]));
                        joystick->hwdata->transaxes[i].scale2 = (float)(SDL_JOYSTICK_AXIS_MAX/(SYS_JoyData[index].axes_max[i]-SYS_JoyData[index].axes_med[i]));

I replaced lines 550 thru 560 with the following:
Code: [Select]
                value = pos[i];
                if (value < transaxes[i].offset)
                {
                        value = (transaxes[i].offset - value) * transaxes[i].scale1;
                        if (value < SDL_JOYSTICK_AXIS_MIN) value = SDL_JOYSTICK_AXIS_MIN;
                }
                else
                {
                        value = (value - transaxes[i].offset) * transaxes[i].scale2;
                        if (value > SDL_JOYSTICK_AXIS_MAX) value = SDL_JOYSTICK_AXIS_MAX;
                }
 
What I am after is that you build an SDL1 test version of DOSBox for us to try out.
I regard this still very experimental, so not yet suitable for an official release.

EDIT1: 20220523 - Updated lines 440 thru 442 with the new code!
EDIT2: 20220523 - Updated line 551 too (with proper code I hope!
18
If it's a crash in PMMERGE.DLL, have you tried the OS/4 team's patched PMMERGE.DLL?

Obviously it won't be supported by Arca Noae in any way, so backup your current .DLL first!

http://os4.team/os4/pmmerge/pmmerge6111.zip
19
Games / Re: DOS VDM - USB and Game port Gamepad support
« Last post by Mark Szkolnicki on May 21, 2022, 07:49:00 pm »
Heh Lars!

Hope your having a fine weekend - the long Victoria Day weekend here.


It`s a trap 3 which means it is a hard coded int3 breakpoint, put there deliberately by the programmer. The reason it fires is that something is calling/jumping to address 1000:0, that is, a ZERO offset. Since this is not expected and likely is a programmer error in that somebody tries to do an indirect near call/jump with a near NULL pointer, that is caught by this breakpoint.
Note that the trap address is 1000:0001 because for an int3 the trap screen will show the address of the instruction following the int3 and the int3 instruction is 1 byte long.

In order to analyze that, you´d need a trap dump in order to find out what code tried to call/jump to 1000:0 (or rather do an indirect near call/jump with a near NULL pointer).

Thinking about it: selector 1000 points to the DOSCODE segment that contains many low level kernel routines. And the DevHelp Routine is located in that segment (and all the subroutines it calls). The DevHelp Routine in turn is the main entry point for any device driver services and therefore used by about any device driver and a pointer to the DevHelp Routine is passed to each device driver on driver load. If that pointer is not properly saved or subsequently accidentally overwritten then you might see that trap.

So if it`s about a driver, Wim should check that the saved DevHelp pointer was not accidentally overwritten (the offset part of it) by a NULL value.


Thanks for the detailed explanation.

As mentioned I'm not a programmer myself, but I appreciate when someone will explain not just that there is a problem, but what it may be as well as its implications. It also assists greatly in testing at the moment, to analyze  exactly what I did that made it trigger.

In this case I'm simply acting as a tester and reporting anything I may see, that may be of significance or interest, hopefully in a way useful to you, Wim, Jochen or anyone else participating or observing.

However, in my emergency / environmental consulting practice, as well as my senior roles in both government and corporate in my career, I've been a senior project manager leading teams of hundreds - I always appreciated being informed by my staff as to potential roadblocks, pitfalls or problems, and what may need to be done, in a way I can comprehend, as being forewarned allows planning to proceed smoothly. Analysis is key to success, as well as being methodical IMHO.

I've learned a lot in this what I consider a "project" - it is fascinating to look "under the hood" so to speak as to what actually makes up a device driver and how it operates.

Best!

M
20
Programming / Re: getting a single keypress?
« Last post by Dave Yeo on May 21, 2022, 07:21:31 pm »
Hi Rich, the test program was written by Thomas the maintainer, based on the mpg123 code. It does run on the same thread so the DosSleep()  is required and the file itself is term_posix.c with HAVE_TERMIOS a requirement and Thomas did add the comment,
Code: [Select]
#ifdef __OS2__
// Hoping for properly working termios in some future (?!), but until then,
// we need keyboard access bypassing that.

It does seem to work well.
Pages: 1 [2] 3 4 ... 10