Recent Posts

Pages: 1 ... 5 6 [7] 8 9 10
61
Multimedia / Re: Updated Uniaud32 build
« Last post by Mark Szkolnicki on August 08, 2022, 09:16:39 pm »
Hey Martin,

Thanks - I'll see if I can reproduce with the release version tonight, and try and debug it.

Looks like it's trapping in a similar spot to the initial 5.15.59 build - during the initialisation of the hardware.

Cheers,

Paul.

Hi Paul!

Hope your having a fine day!

I've been off-line for most of the last 4 weeks, as our summer up here is pretty short, and lots of work to do around our quarter acre, as with every summer. But saw you were updating the UniAud32 builds at the moment, and thought I would chime in with my test results as well.

I wasn't one of your original "Merry Men" that have helped out so extensively with the testing, but I did post a full report of my findings on two of my systems back on March 1 when your development build 5.14.7 and the HDMI version of same was last released, and you took a well deserved hiatus (as a result I won't repeat all that, as you can reference back to it in the forum here, with the detailed data and TestLog attachments).

At the time I found that I was able to get that build working perfectly on one of my systems (MANTICORE II) using that version of the driver with a ASUS M3N-HT Motherboard and the on-board ADI AD1988B BH 8 Channel High Definition audio chipset.

However, I was unable to get any sound on the other system (HYPERFIRE) which has an F1- A75V Motherboard equipped with an ALC892 8 channel HDA chipset, using the March releases of UniAud32. On that system, the chipset (Adapter 0) generates no sound but PMUnimix v0.8.2 reports all 9 normal volume sections - putting sound volumes to the max produces no sound. Sound is generated using the UniAud32 version that comes with the ArcaOS package. Tested both the release and debug versions at the time.

Moving on to your latest package (5.15.59b) I have the same results to report - MANTICORE II works well with the latest version, but  5.15.59b still does not generate any sound on HYPERFIRE, using the on-board chipset.

In the March tests I also used the /a:2 switch to address Soundblaster cards I also have installed on each system, which up to this point could only be used in Windows - In MANTICORE II, I have a Soundblaster Recon3D / Z-Series Sound Card, while HYPERFIRE has a Soundblaster X-Fi Titanium Series Sound Card.

I have not tried these cards yet with the new UniAud32 build, but previously HYPERFIRE and the Soundblaster X-Fi reported 6 volume sections under PMUnimix but no sound. MANTICORE II  and the Soundblaster Recon3D reported under PMUnimix the Master Playtback Volume with sound present after a cold reboot, but it did not control the sound. Sound was only present from the front speakers of a speaker set consisting of two front, two rear and one bass speaker. I needed to turn down the hardware speaker volume, as no software sound control seemed to be present.

I have not tested the Soundblasters with 5.15.59b as of yet - will possibly try that later today.

Let me know if you want any further information, Paul, related to the items above, if it would be of any help in development, and thanks for the yeoman's work you've put into advancing development of UniAud32.

As always and Best, Sir!

Mark

 
62
Multimedia / Re: Updated Uniaud32 build
« Last post by Martin Iturbide on August 08, 2022, 04:10:04 pm »


Enable serial port in Virtualbox, and there's an option to save the serial port output to a text file.
Make com.sys (or pscom.sys) is loaded
add /p:1 to the uniaud32 driver line in config.sys
reboot

Cheers,

Paul.

Hi Paul, the uniaud drivers installation is a task I left undone last year (Warp 4.52 on Virtualbox) since I could not obtain sound from video streaming on browser (ie. youtube), which is still my actual issue in soundblaster mode as well. Following these latest posts I feel I could try again now. Where can I find an installation steps how-to, like config.sys editing?
Thank you

Hi Mauro.

I would do it this way.
- Install the full Uniaud using the latest full installer. (ftp://ftp.netlabs.org/pub/uniaud/Uniaud-20211023.exe)
- Check everything is fine on the VM
- Later install the latest devbuild that Paul's offers here.

Regards
63
Multimedia / Re: Updated Uniaud32 build
« Last post by Paul Smedley on August 08, 2022, 11:03:40 am »
Hey Martin,

Hey Martin,

Hi Paul

I'm using the "release" version.
- Enabled Serial port and take the output as a RAW file.
- Enabled COM.SYS
- Added /p:1 on Uniaud.
- Rebooted and changed to "ICH AC97" to reproduce the trap.

This is what it showed on the RAW text file.

Quote
Uniaud32 version 3.01.01
Based on linux 5.15.59
pci_register_driver: query_device found 28 8086:2415 class=40100 checking intel8x0
pci_register_driver: matched 0 8086:2415/40100 with 8086:2415/0 0 (intel8x0)

It is something else I need to do?

Thanks - I'll see if I can reproduce with the release version tonight, and try and debug it.

Looks like it's trapping in a similar spot to the initial 5.15.59 build - during the initialisation of the hardware.

I can reproduce the trap with a release build of uniaud32.sys on ac97 hardware. Investigating now.

Edit: really weird why it's trapping where it is with release vs debug....

Cheers,

Paul
64
Networking / Re: WIFI on Dell Latitude D610
« Last post by Vanzeveren François on August 08, 2022, 10:08:32 am »
Hello,

Thank you for your answers/comments. Meanwhile, I completely messed up my configuration (trials and errors), so I prefer to reinstall my system completely. But now that I know which wireless network adapter to choose, i will install it from scratch.
I will keep you posted of the results :)

Cheers

François
65
Multimedia / Re: Updated Uniaud32 build
« Last post by mauro on August 08, 2022, 09:03:02 am »


Enable serial port in Virtualbox, and there's an option to save the serial port output to a text file.
Make com.sys (or pscom.sys) is loaded
add /p:1 to the uniaud32 driver line in config.sys
reboot

Cheers,

Paul.

Hi Paul, the uniaud drivers installation is a task I left undone last year (Warp 4.52 on Virtualbox) since I could not obtain sound from video streaming on browser (ie. youtube), which is still my actual issue in soundblaster mode as well. Following these latest posts I feel I could try again now. Where can I find an installation steps how-to, like config.sys editing?
Thank you
66
Multimedia / Re: Updated Uniaud32 build
« Last post by Paul Smedley on August 08, 2022, 04:56:13 am »
Hey Martin,

Hi Paul

I'm using the "release" version.
- Enabled Serial port and take the output as a RAW file.
- Enabled COM.SYS
- Added /p:1 on Uniaud.
- Rebooted and changed to "ICH AC97" to reproduce the trap.

This is what it showed on the RAW text file.

Quote
Uniaud32 version 3.01.01
Based on linux 5.15.59
pci_register_driver: query_device found 28 8086:2415 class=40100 checking intel8x0
pci_register_driver: matched 0 8086:2415/40100 with 8086:2415/0 0 (intel8x0)

It is something else I need to do?

Thanks - I'll see if I can reproduce with the release version tonight, and try and debug it.

Looks like it's trapping in a similar spot to the initial 5.15.59 build - during the initialisation of the hardware.

Cheers,

Paul.
67
Multimedia / Re: Updated Uniaud32 build
« Last post by Martin Iturbide on August 08, 2022, 12:54:49 am »
Hi Paul

I'm using the "release" version.
- Enabled Serial port and take the output as a RAW file.
- Enabled COM.SYS
- Added /p:1 on Uniaud.
- Rebooted and changed to "ICH AC97" to reproduce the trap.

This is what it showed on the RAW text file.

Quote
Uniaud32 version 3.01.01
Based on linux 5.15.59
pci_register_driver: query_device found 28 8086:2415 class=40100 checking intel8x0
pci_register_driver: matched 0 8086:2415/40100 with 8086:2415/0 0 (intel8x0)

It is something else I need to do?

Regards
68
Multimedia / Re: Updated Uniaud32 build
« Last post by Paul Smedley on August 08, 2022, 12:07:40 am »
Hey Martin,

https://smedley.id.au/tmp/uniaud32-linux-5.15.59-20220807b.zip hacks around the issues causing traps with non-HDA hardware (tested with AC97 on Virtualbox).
I also went straight for the 20220807b and got a trap on VirtualBox.
I tested it with ArcaOS 5.0.7 VM guest on VBox 6.1.36 (Windows 10 host).
- VM ICH AC97: traps
- VM Intel HD Audio: Works, Audio control working, no traps.

I'm pretty interested in the trap on Virtualbox - as I specifically tested AC97 here on Virtualbox (but under Ubuntu). Was this with the debug or release driver? I only tested the debug driver. Are you able to get a serial port log?

Enable serial port in Virtualbox, and there's an option to save the serial port output to a text file.
Make com.sys (or pscom.sys) is loaded
add /p:1 to the uniaud32 driver line in config.sys
reboot

Cheers,

Paul.
69
Networking / Re: WIFI on Dell Latitude D610
« Last post by Andreas Schnellbacher on August 07, 2022, 09:23:58 pm »
But 8068:4220 is also contained in the original GeMac package 2.20. pcklist.txt has:
Code: [Select]
genmac220_intel.wpi:908:GenMac Wrapper Intel 2200 Wlan [8086:4220]
So the original package should match. Interesting would be the content of ?:\ibmcom\lantran.log and ?:\mptn\bin\setup.cmd, which are contained in "testlog generic".
70
Networking / Re: WIFI on Dell Latitude D610
« Last post by Martin Iturbide on August 07, 2022, 07:45:37 pm »
Hi François, welcome to the forum.

I will also like to also suggest you to install testlog (link here), run "testlog generic" and upload the text the report. With that we can have a first idea of your configuration.

I found that the Intel 2200 Wlan [8086:4220] is listed as supported devices of GenMU, which is a extra set of driver for GenMAC.

Regards
Pages: 1 ... 5 6 [7] 8 9 10