OS2 World Community Forum

OS/2, eCS & ArcaOS - Technical => Setup & Installation => Topic started by: Thomas Hellsén on October 13, 2021, 10:57:58 am

Title: YUM update qt5-qtbase-common fails
Post by: Thomas Hellsén on October 13, 2021, 10:57:58 am
Hi everybody!
I recently ran into a problem while updating via YUM. 'yum update' results in the message

Code: [Select]
---> Package qt5-qtbase-common.noarch 0:5.13.1-1.oc00 will be updated
--> Processing Dependency: qt5-qtbase-common = 5.13.1-1.oc00 for package: qt5-qtbase-5.13.1-1.oc00.i686
---> Package qt5-qtbase-common.noarch 0:5.15.2-1.oc00 will be an update
--> Processing Dependency: qt5-qtbase = 5.15.2-1.oc00 for package: qt5-qtbase-common-5.15.2-1.oc00.noarch
--> Finished Dependency Resolution
Error: Package: qt5-qtbase-5.13.1-1.oc00.i686 (installed)
           Requires: qt5-qtbase-common = 5.13.1-1.oc00
           Removing: qt5-qtbase-common-5.13.1-1.oc00.noarch (installed)
               qt5-qtbase-common = 5.13.1-1.oc00
           Updated By: qt5-qtbase-common-5.15.2-1.oc00.noarch (netlabs-rel)
               qt5-qtbase-common = 5.15.2-1.oc00
           Available: qt5-qtbase-common-5.11.0-1.oc00.noarch (netlabs-rel)
               qt5-qtbase-common = 5.11.0-1.oc00
Error: Package: qt5-qtbase-common-5.15.2-1.oc00.noarch (netlabs-rel)
           Requires: qt5-qtbase = 5.15.2-1.oc00
           Installed: qt5-qtbase-5.13.1-1.oc00.i686 (installed)
               qt5-qtbase = 5.13.1-1.oc00
           Available: qt5-qtbase-5.11.0-1.oc00.i686 (netlabs-rel)
               qt5-qtbase = 5.11.0-1.oc00
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

I tried 'yum update --skip-broken'. It allows updating the other packages but not fixing the actual problem.
I ran 'rpm -Va --nofiles --nodigest' but that didn't fix the problem either.
I also tried running 'package-cleanup', which I had installed previously:
Code: [Select]
python f:\usr\bin\package-cleanup --problems
No problems found

python f:\usr\bin\package-cleanup --orphans
brlaser-6.0.0-0.i686
heimdal-7.7.0-3.oc00.i686
heimdal-libs-7.7.0-3.oc00.i686
samba-client-4.11.5-0.oc00.i686

python f:\usr\bin\package-cleanup --dupes
(No output, i.e. no duplicates found)

There were a few orphaned packages, but that was all. Does anyone have an idea how to solve this?

Best regards, Thomas Hellsén
Title: Re: YUM update qt5-qtbase-common fails
Post by: roberto on October 13, 2021, 03:19:02 pm
Try to install the os2-base first by updating it to version 0.0.1-3.oc00.
Then you retry the update.
I'm not sure if it works.
Saludos
Title: Re: YUM update qt5-qtbase-common fails
Post by: Dave Yeo on October 13, 2021, 04:12:11 pm
Try to install the os2-base first by updating it to version 0.0.1-3.oc00.
Then you retry the update.
I'm not sure if it works.
Saludos

After installing os2-base, you need to install dbus-libs, then the update should work.
Title: Re: YUM update qt5-qtbase-common fails
Post by: Thomas Hellsén on October 14, 2021, 12:22:27 am
Thank you, that worked!
yum install os2-base dbus-libs
made the update of qt5-qtbase-common function again.

Aside from asking in the forum, is there some way I could have diagnosed this problem myself?