Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - mauro

Pages: [1] 2 3 ... 19
1
Multimedia / Re: Updated Uniaud32 build
« on: March 01, 2021, 12:35:06 pm »
Hi Mauro, 2 things to try.adding "SET KAI_AUTOMODE=DART" (without quotes) in your config.sys, reboot and test.
Download PMUniMix from Hobbes and play with the volume sliders. Sometimes the mixer is not set up correctly and something like the front volume needs turning up.

Hi Dave, SET KAI_AUTOMODE=DART was already active in config.sys, then tested Uniaud mixer again (tried also previously as you gave me this tip), activating all audio device controls including front, video, aux, pcm  and their cursors .  All as before.
Thank you

2
Multimedia / Re: Updated Uniaud32 build
« on: February 28, 2021, 06:04:44 pm »
Hi Mauro,

To update a working system:
1) backup \mmos2\uniaud32.sys
2) copy a release\uniaud32.sy* to \mmos2
3) reboot

Ok thank you Paul, did as above. On both ICH AC97 (first) and Intel HD item (after) selected in Virtualbox audio system, everything like before; audio events are well working except sound from FF video play (Youtube). Almost sure it is not an audio driver matter.
So I would say this Uniaud versio is working on my virtual machine system

3
Multimedia / Re: Updated Uniaud32 build
« on: February 28, 2021, 08:36:07 am »
Hi all, sorry to ask this question, can I get installation tips somwhere or is it just un upgrade to a previous installed version ?  If so, which is the uniaud.diff  placing ?
I'm asking because previously -months ago-  I installed uniaud on my OS2 Warp 4.52 Virtualbox machine trying to solve the issue of no sound coming from youtube video in Firefox 45.9, whith the result of not solving this .
By reading these posts I'm understanding that after the update a new attempt  could be done.
Thank you

4
Applications / Re: highmem.exe can't load xul.dll
« on: February 17, 2021, 06:19:38 pm »
Well, you should update your kernel. If you don't have access to eCS or ArcaOS, the latest free one is 104a, available at http://www.os2site.com/sw/upgrades/kernel/. You'd need w420050811.zip to replace your W4 kernel.

There's also an updated DOSCALL1 at http://www.os2site.com/sw/upgrades/kernel/dc20050811.zip, make sure that you use the w4 version.

downloaded and applied these ones as well, kernel update first and DOSCALL1.DLL substitution after.

while the kernel update went ok, with the current version 14.104a_W4 reported on the boot splash screen, the DOSCALL1.DLL replacement caused a trap at boot.  Message screen here attached.
Could not even use FC2 loading in safe mode, it traps again.
Anyway I could reload the previous working machine state (it is a Virtualbox emulation) made just before this change.

The important to say is that after having applied again the kernel update, worked on the xul.dll attributes and loaded it in the high memory, now the issue is solved!    :D
Firefox, Staroffice, ANPM and Java ImageEditor running at same time
Thank you all


5
Applications / Re: highmem.exe can't load xul.dll
« on: February 17, 2021, 05:28:08 pm »
Hi mauro,


when you run the same command now you should see the following (I will show just the stuff relevant to having marked the CODE to load-high (which is the '-c' parameter in highmem.exe):

Code: [Select]
[C:\USR\LIB\FIREFOX-45.9.0]highmem -vv xul.dll
Processing module : xul.dll
 object 0 : base 0x00010000, size 0x0291b780, flags 0x00002005, executable, m
em
  readable, !writeable, executable, !resource, !discardable, !shared,
  !preload, !invalid, swappable, !16:16 alias, !conforming,
  32bit, !IOPL

The 'object 0:' stuff is CODE, and the 'himem' vs '!himem' you saw previously indicates that the CODE is marked to load high.

yes, here it is:

[C:\USR\LIB\FIREFOX-45.9.0]highmem -vv xul.dll
Processing module : xul.dll
 object 0 : base 0x00010000, size 0x0291b780, flags 0x00012005, executable, himem
  readable, !writeable, executable, !resource, !discardable, !shared,
  !preload, !invalid, swappable, !16:16 alias, !conforming,
  32bit, !IOPL

seems responding to your description (himem replaces !himem)

6
Applications / Re: highmem.exe can't load xul.dll
« on: February 17, 2021, 02:01:34 pm »
check if XUL.DLL is marked as read-only. If it is, remove the readonly attribute.

I have applied the command
[C:\USR\LIB\FIREFOX-45.9.0]attrib -r -s -h xul.dll

then:
[C:\USR\LIB\FIREFOX-45.9.0]highmem.exe -c xul.dll
Processing module : xul.dll

[C:\USR\LIB\FIREFOX-45.9.0]

it should mean that xul.dll has been successfully loaded in high memory , does it?

But still no improve in the memory handling between Firefox and Staroffice.

Later on I'll apply the kernel patch and doscall1.dll replace suggested by Dave

7
Applications / Re: highmem.exe can't load xul.dll
« on: February 16, 2021, 07:54:03 pm »
... and which OS/2 version and kernel you have installed.

Warp 4.52
--
14.086W4 - this is the info bottom of the splash screen

8
Applications / Re: highmem.exe can't load xul.dll
« on: February 15, 2021, 05:22:28 pm »
Hi Dariusz:

[C:\USR\LIB\FIREFOX-45.9.0]highmem -vv xul.dll
Processing module : xul.dll
 object 0 : base 0x00010000, size 0x0291b780, flags 0x00002005, executable, !him
em
  readable, !writeable, executable, !resource, !discardable, !shared,
  !preload, !invalid, swappable, !16:16 alias, !conforming,
  32bit, !IOPL
 object 1 : base 0x02930000, size 0x00079cb0, flags 0x00002003, data, !himem
  readable, writeable, !executable, !resource, !discardable, !shared,
  !preload, !invalid, swappable, !16:16 alias, !conforming,
  32bit, !IOPL
 object 2 : base 0x00000000, size 0x00002324, flags 0x00002039, data, !himem
  readable, !writeable, !executable, resource, discardable, shared,
  !preload, !invalid, swappable, !16:16 alias, !conforming,
  32bit, !IOPL

but no change about the described situation.
Then also given the command highmem.exe -c xul.dll  with same negative answer. 
All this tried before running FF first time.   Tried with FF already running, in this case "unlock xul.dll" result is positive:" xul.dll UNLOCKED",  but with no success for the purpose to have Firefox and Staroffice running meantime.
If Firefox is running, then Staroffice Writer just won't load, if Staroffice Writer is running then Firefox won't load, with this message instead : "Couldn't load xul.dll (OS2 error 8 faulty module : C:\USR\LIB\FIREFOX-45.9.0\XUL.DLL)"

9
Applications / Re: highmem.exe can't load xul.dll
« on: February 15, 2021, 01:46:56 pm »
yum install lxlite-tools

thank you Andreas, now I've gone a little bit ahead, still with an oppositive (but different rc code) warning result:

[C:\USR\LIB\FIREFOX-45.9.0]unlock xul.dll
┌[ unLock ]──────────────────────────────[ Version 1.3.9 ]┐
├ Copyright 1996 by FRIENDS software ─ No rights reserved ┘
└┤Done

[C:\USR\LIB\FIREFOX-45.9.0]highmem.exe -c xul.dll
Error: "xul.dll" cannot be opened, rc=5.

10
Applications / Re: highmem.exe can't load xul.dll
« on: February 15, 2021, 12:53:05 pm »
Hi Remy, thanks for replying.

SYS1041: The name unlock is not recognized as an
internal or external command, operable program or batch file.

however, Firefox has not been executed before attempting to load xul.dll in high memory, this command is given first of all as the system boots

11
Applications / [SOLVED] highmem.exe can't load xul.dll
« on: February 15, 2021, 09:11:47 am »
Hi all, in order to solve my old issue that prevents running Firefox and another application meantime like Staroffice (maybe also happens with other ones), understanding that is a high memory handling issue mainly belonging to Firefox, I read that loading xul.dll in high memory by highmem.exe with the following OS2 command should be the the solution :

highmem.exe -c xul.dll

but the answer is

Error: "xul.dll" cannot be opened, rc=110.

Do you already have the knowledge on how to solve it?
Thank you

12
Web applications / Re: clipgrab
« on: February 06, 2021, 09:16:18 am »
Hi,
The version you downloaded is a bit outdated unfortunately.
The newer version of clipgrab needs webenginewidgets and that we dont have yet.
So  we need to wait till BWW have made it ready for us...

But  donations, are welcome for BWW, so they can further work on QT5 and more OS/2 based projects ....

Understand, thank you

13
Web applications / Re: clipgrab
« on: February 03, 2021, 07:07:53 pm »
Thank you for answering Dave, no amperstands appear in the URL

14
Web applications / clipgrab
« on: February 02, 2021, 11:57:12 pm »
Good evening, I've just downloaded/installed ClipGrab 3.7.2  by his rpm package (ANPM).
It starts, but after pasted a youtube video link in the field for downloading, it warns that link is not a valid one for video contents.
Has it maybe become obsolete due to a Youtube platform update against video grabbing?
Thank you

15
Multimedia / Re: again on Uniaud
« on: December 24, 2020, 08:24:38 am »

I just wanted to state that the USB audio driver package contains an application to properly switch between different audio devices.
Understand. How can I find it to have a look ?  I actually switch between different audio devices in the Multimedia Panel

Pages: [1] 2 3 ... 19