Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - mauro

Pages: [1] 2
1
Applications / [SOLVED] highmem.exe can't load xul.dll
« on: February 15, 2021, 09:11:47 am »
Hi all, in order to solve my old issue that prevents running Firefox and another application meantime like Staroffice (maybe also happens with other ones), understanding that is a high memory handling issue mainly belonging to Firefox, I read that loading xul.dll in high memory by highmem.exe with the following OS2 command should be the the solution :

highmem.exe -c xul.dll

but the answer is

Error: "xul.dll" cannot be opened, rc=110.

Do you already have the knowledge on how to solve it?
Thank you

2
Web applications / clipgrab
« on: February 02, 2021, 11:57:12 pm »
Good evening, I've just downloaded/installed ClipGrab 3.7.2  by his rpm package (ANPM).
It starts, but after pasted a youtube video link in the field for downloading, it warns that link is not a valid one for video contents.
Has it maybe become obsolete due to a Youtube platform update against video grabbing?
Thank you

3
Multimedia / again on Uniaud
« on: December 20, 2020, 09:31:07 am »
Hi all, nice to meet you again after some silence period  :-X .
OS2 Warp 4.52 usage (VirtualBox guest machine), I've tried to solve the no-audio issue in Youtube video played in Firefox 45.9.  Have been suggested here in another thread to install Uniaud drivers, and PMUnimix after that.
So, downloaded  ftp://ftp.netlabs.org/pub/uniaud/Uniaud-20200506.exe  and execute the file, Warpin dialogue windows begins with "no Uniaud Installation found" to proceed for a fresh one, confirm everything and at the end the installation is given as successful, advicing to reboot for running the modified config.sys. As rebooted I then run a PMUniMix.EXE but it does nothing, it only shows its property panel.  Running it under OS2 Command, the answer is "Uniaud.exe file not found".
Therefore I went to look for the uniaud files path stated in the Warpin installation panel, given as deployed in MMOS2.  But checking that folder, none of the Uniaud files is there.  In fact if I try to re-run Uniaud-20200506.exe , Warpin tells "no Uniaud Installation found" and goes again for a fresh installation not changing the situation after it .
Do you see a reason for this behaviour ?
My target is only to obtain audio from Youtube videos, as the default audio system works well in video play both with VLC and SMplayer.
Thank you in advance for your attention

4
Applications / Logical Volume Manager GUI not starting
« on: April 21, 2020, 06:53:46 pm »
Hi all, after sometime not having the need to open the LVM by its program icon (in the System Setup folder), today i wanted to have a look on it, but it did not start in WPS.
Then tried in the OS2 command prompt and found:
[C:\]lvmgui
JAVAI.dll not found via JAVA_HOME=C:\APPS\OpenJDK\, so setting JA
11\BIN\..
Unable to initialize threads: cannot find class java/lang/Thread

Said that  from last time I had run it successfully, I meantime installed OpenJDK, now reading the command answer for what is specifically missing, I simply copied JAVAI.ddl from the old JAVA11\BIN directory to the C:\APPS\OpenJDK\ one, but the answer is still same not finding that dll.

Do you have suggestions on how to recover the situation?
Thank you much

5
Multimedia / audio volume gadget on the side bar
« on: February 20, 2020, 07:28:21 am »
can someone tell me how can I make it appear (image below) ?  My sidebar hasn't it.
OS2 Warp 4.52 on Virtualbox
Thank you

6
Applications / Odin on Warp 4.52 virtualbox
« on: January 10, 2020, 03:47:58 pm »
Hi all, I've installed Odin 0.9 and all packages called "Odin" in ANPM  (netlabs repository) and I think all went well, no issues, no error and a folder "Odin" appeared un the desktop.
But I cannot run a win32 installer, just tried Paint Shop Pro 7 which was an XP (win32) version , and I get the message "cannot find file: check to ensure the path and filename are correct".
Maybe I missed something.  I've also installed XWorkplace and XSystray

7
Applications / program locked and cannot terminate its execution
« on: January 04, 2020, 09:10:27 pm »
Hi all, I've have had the bad idea to try to directly open an avi file which then could not be handled by the default media player.
This locks the player window and file status as opened. Nothing can close it. I run TOP but I cannot see this task name to terminate.
I run the windows list (ctrl-esc) and by context menu select "close" to the corrisponding task running, but it remains opened. After some time a message asks me if I want to terminate that program, of course I do, and soon click ENTER to confirm it, but everything remains there.
And at forced reboot of the virtualbox machine (Warp 4.52) the situation is still there as before.
Can you give me a suggestion to solve?
Thank you

8
Storage / changing USB volume letter
« on: June 18, 2019, 02:49:01 pm »
Hi, I've made an USB stick detectable-handlable on OS2 W 4.52 (Virtualbox guest machine) with DFsee following the precious instructions received here.
Now I realized that the choosen drive letter (G) conflicts with the Shared Folder drive wich is G as well.  When plugged in, the USB volume functionality hangs after being automatically shifted to H letter, it remains locked and often make OS2 WPS not responding as well, so a letter change to a still unassigned drive letter appears to be the solution.
Can you suggest a way to just re-assign the USB volume letter avoiding the whole volume creation process in DFsee, that would wipe all data in it ?
Thank you

9
Hi all, I'd like to resume the results obtained joining this forum in sept 2018 starting from a very basic iniztial knowledge, maybe someone will read something interesting to pick ideas.
OS2 was my first contact pc system, found preinstalled in a Hyundai pc, 1996. After 4 years I felt forced to switch to Windows XP due to the hardware/software requirements, which OS2 could not follow as needed at that moment.

I just kept remembering OS2 as a vintage old car which was nice to have owned once but with no more chances to drive it again on the today roads.
This till last summer, when on a Windows 10 usenet newsgroup an expert member told that it was not impossible getting an OS2 Warp 4.52 virtual machine full working for VirtualBox but just good to load and leave as-it-is, with not much more to do for real use, except some exciting WPS menu browsing to feel back in the latest nineteens.

Meantime I was aware of the most recent OS2 system adapted distributions; Ecomstation first and then ArcaOS, good to have but not freeware and not even cheap.

Then I found online a downloadable OS2 Warp 4.52 ready-to-boot virtual machine in its first-boot state: ready, go.

Tried to get help for updating/actualization on an OS2 usenet group nearly abandoned, where the only member listening suggested to join your forum.
Ready, go.

From its first-boot situation -I believe corresponding to 1998 HW/SW-, you here have lead me to implement and update much more than expected :  dedicated Guest Addition for VirtualBox including shared folders and display custom resolution, Yum-Rpm packages Manager, USB volume handling, printer configuration, scanning device capabilities (Tame2), XWorkplace, Firefox, VLC, Samba and Netdrive for browsing external directories, and other useful features.

Now, since I like very much  systems on a self-bootable USB stick, and also said that OS2 W4 cannot support itself such capability, I created a self-bootable fully installed Ubuntu 18.04 USB stick, and setted an autostart command for the OS2 Warp 4.5 guest machine (updated as above described) cloned and moved from the initial Win10 host system to the Linux VirtualBox application there.

This is the result: plug the USB stick in, turn the laptop on, select the usb volume to boot, wait about 90 secs, and OS2 Warp 4.52 full screen appears ready to use, you know that is a virtual machine hosted in Linux only for the 5 secs initial Ubuntu splash screen.

Cool.
Thank to you

10
Applications / how to change a directory permission level in OS2
« on: June 01, 2019, 07:42:30 pm »
from 0777 to 0775 ?
Same Unix command line?
Thank you

11
Applications / Samba client on OS2 Warp 4.52
« on: April 23, 2019, 10:19:42 am »
Hi all, I've seen that a few packages have been introducted on Arcanoae subscription repository, and Samba Client Utility among them.
I do not have a strong knowledge on what it could be useful for, I just presume that it could be good to implement the browsing of the volumes belonging to my  host pc HD (being OS2 running on VirtualBox), or else other pc connected in my domestic lan.
Could someone help me in understanding more?
Thank you

12
Hi all, after having intalled/configured OS2 Warp 4.52 in Virtualbox Windows hosted with a satisfactory result,  I'm now doing same in Ubuntu.
Of course I have imported same virtual machine latest version developed in Virtualbox Windows hosted including the OS2 guest addition installed.
I'm having problem with the custom screen resolution, cannot obtain the one I'd like to set.
While in Windows hosting I had successfully applied the given commands 

C:\Program Files\Oracle\VirtualBox>VBoxManage setextradata global GUI/MaxGuestResolution any

C:\Program Files\Oracle\VirtualBox>VBoxManage setextradata "OS2 Warp 4.52" "CustomVideoMode1" "1280x720x32"

now I cannot find an equivalent working in the Ubuntu terminal.

Can someone help me?
Thank you

13
Applications / TAME/2 (OS2 Warp 4.52 on Virtualbox)
« on: March 10, 2019, 02:35:13 pm »
Hi, have installed Tame/2.
On Virtualbox devices menu I have activated the usb connection to my Canon Lide 100 usb scanner.
Runned Tame2 for first time, it asks for scanner model selection, and among Canon models it goes up to Canon Lide 60 wich seems the nearest to my Canon Lide 100 (not in the list). Selected it, then I begin scanning preview or scan to file which take to the same output: a 0 kb tif file = non file scanned.  And I expect such result, as during the scanning interface displaying  the progress bar, which means that the scanner is doing the job, I do no not hear any working noise from my scanner, it is not active.
Could it be a usb port connection matter or what else?
Thank you

14
Multimedia / OS2 volume cursor (virtualbox machine)
« on: March 10, 2019, 11:16:36 am »
Hi, in my Virtualbox OS2 Warp 4.52 installation I do not have the volume cursor on the tray, not even in the system setup. How can I get it?
Also, I've just upgraded to Vbox 6.04 , and it seems that system sound now are "cutted" after one sec playing, they do not go to the end.
Is someone experiencing same?
Thank you

15
Utilities / best process killer application
« on: January 16, 2019, 08:49:59 pm »
I'm looking for a process killer program for OS2 Warp 4.52 (guest in Virtualbox), simple to run, intuitive (GUI welcome), free.
Know a good one is CAD, but it's payware.
Could you recommend another?
Thank you

Pages: [1] 2