Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Dave Yeo

Pages: [1] 2 3 ... 211
1
You probably could update the certificate then, at least it supports a new enough TLS, probably 1.2

2
Hardware / Re: OS/2 Video Performance
« on: Today at 05:53:59 am »
OTOH, My old I5-2400's built in graphics gives,
PMGraphics score 190
Dive Marks 7511

3
Web applications / Re: firefox - newtab thumbnail images are empty, why?
« on: October 20, 2021, 06:27:03 pm »
Could it be a page that needs lots of JavaScript to display images?
You can always go to about:support to review any preference changes you have made.

4
Comments, Suggestions & Questions / Re: Hobbes (Files) Reoganization
« on: October 20, 2021, 01:21:40 am »
At least, "firefox-31.8.0.en-us.os2.beta_5-wpi.wpi" still works.

Good to know. Have you tried updating the letsencrypt certificate or did you just add an exception for here?
I'm inclined to keep all working browsers on Hobbes.

5
Comments, Suggestions & Questions / Re: Hobbes (Files) Reoganization
« on: October 19, 2021, 04:31:32 pm »
Hi Martin, missed this.
For the name of the directory, either of your ideas seems fine.
As for which versions. I guess if you want to trim older ones, I'd keep at least the 38ESR and the 45ESR various versions as there still seems to be people who prefer SM 2.35 at least and they still work. Older versions are getting useless as they don't support new enough encryption.

6
Setup & Installation / Re: YUM default platform setting
« on: October 19, 2021, 04:26:24 pm »
Hi Martin, you will have to turn off the hyperthreading on the command line of ACPI, not the simplest thing to do as yo have to figure out which cores are real and which are fake and use a bitmask to only use the real ones. First try adding /CPUMASK=1 to the PSD line in config.sys to test with only one CPU. If OO now works on the problem system, that will tell you it is a hyperthreading problem.
The PSD documentation is under x:\sys\docs\ACPI as psd_en.pdf. See the ACPI command line section. You might have to open an issue to get help.
As for the i686 vs Pentium 4 thing, Bitwise seems to be guiding us to Pentium 4 systems to support the new browser. As Neil said, more to come.

7
Applications / Re: Seamonkey Data Leakage
« on: October 15, 2021, 09:20:56 pm »
Our old Mozilla (SM, FF and TB) is full of security holes I'm sure, as well as design decisions that may allow leakage. Mozilla did go to sandboxing each tab in its own process as that seemed the only universal fix.
For now, a Master Password might help, untested. And under Preferences-->Privacy & Security-->Private Data you can set it up to clear a lot of that stuff when closing the browser.
There's also the right mouse buttons context menu when right clicking on a link "Open Link in Private Window" which I use quite often.
Edit: I'll add that at least SeaMonkey does give these options unlike Firefox.

8
Setup & Installation / Re: YUM update qt5-qtbase-common fails
« on: October 13, 2021, 04:12:11 pm »
Try to install the os2-base first by updating it to version 0.0.1-3.oc00.
Then you retry the update.
I'm not sure if it works.
Saludos

After installing os2-base, you need to install dbus-libs, then the update should work.

9
Applications / Re: Otter Browser
« on: October 13, 2021, 05:30:54 am »
Posting from Otter, one drawback is no add-ons, or rather just user JS scripts. Can turn off JavaScript globally but I'd miss No-Script though having an up to date hosts file would help.
Ok. I see it does have content blocking along with a way to import various lists.

10
Applications / Re: Otter Browser
« on: October 13, 2021, 05:24:08 am »
You're right, it is not really supported but I installed it on Mint, a Ubuntu based distribution with this method, seems to work fine and seems pretty good. This is actually the procedure for Ubuntu
Code: [Select]
sudo add-apt-repository ppa:otter-browser/release
sudo apt-get update
sudo apt-get install otter-browser

11
Applications / Re: Otter Browser
« on: October 13, 2021, 01:00:38 am »
That almost sounds like a build issue. Might be some missing libs though, perhaps the readme gives a hint?
Under Ubuntu, you can use apt in similar ways to yum. "sudo apt update" to update package list, "sudo apt upgrade" to install updates, "sudo apt install foo" to install. Should also be graphical frontends available too. I haven't used Ubuntu in a while but all Debian based Linuxes work much the same. Trick is to figure out what packages Otter needs. I guess ours is going to use NSS for secure browsing so try installing NSS and NSPR4 perhaps.

12
Applications / Re: Updated RPMs - big release chunk...
« on: October 12, 2021, 12:01:30 am »
I recently ran Netlabs-exp for a week straight, the Mozilla apps were stable. Perhaps a libc upgrade or such fixed things.
There is always the option of putting the older DLLs in Firefox etc directory so they get picked up.
Note also this update also updates some certificates (actually I think it fixes using the installed ones) such as letsencrypt's
As for these updates, you need to first update os2-base, which will make sure your platform is Pentium 4, then install dbus-libs for QT5. Then the rest should install.

13
Comments, Suggestions & Questions / Re: Hobbes (Files) Reoganization
« on: October 11, 2021, 08:05:24 pm »
"/pub/os2/apps/mmedia/video/capture" seems good.

14
Setup & Installation / Re: ArcaOS USB installation - Rufus?
« on: October 10, 2021, 07:51:14 pm »
Hi Mentore, good chance your stick is going bad. Being 4GB's (big enough), it is probably old. I've had a couple fail, always in subtle ways. One wouldn't boot and another failed to mount the ISO image.
As for programs like Rufus, remember that OS/2 can't access USB until late in the boot, so the installer starts out by installing to a ram disk and running OS/2 of of that.

15
Applications / Re: Accelerated Installs
« on: October 09, 2021, 12:32:54 am »
For a loader, I just use a cmd file to set all the environment variables, usually a minimum of PATH and BEGINLIBPATH and maybe LIBPATHSTRICT as well as any other needed ones with things like compilers needing quite a few environment variables. Then you can put the cmd files in the PATH, create a program object or remember where they are.

Pages: [1] 2 3 ... 211