Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Neil Waldhauer

Pages: [1] 2 3 ... 47
1
Utilities / Re: QT5 Runtime
« on: April 21, 2021, 09:30:29 pm »
Code: [Select]
yum install qt5
If you already have simplebrowser running, you already have QT5 installed.

2
Setup & Installation / Re: Booting with NVMe
« on: April 15, 2021, 05:51:48 am »
I got a Vantec PCIe adapter, and installed a 250 GB Samsung 980 PRO (PCIe 4.0 NVMe M,2). It works well, after the driver loads, but I cannot boot from it. The problem is that it is mounted on a plug in card, that the BIOS doesn't know about, so it won't boot from it (because it doesn't know it is there). Air Boot also cannot "see" it, because BIOS doesn't know about it. Most (if not all) machines cannot boot from a plug in card, if the BIOS doesn't know about it. This is true for USB too.

If you have a machine, that knows about the adapter, it should boot from it.

Then again, it really doesn't make much sense to waste one of those things for boot code, unless you boot 14 times a day, or it is your only choice. I am still thinking about how to use it effectively. At least it is non volatile, so it remembers what was put on it, unlike what the RAMDISK does.

I'm booting just fine from a Lenovo ThinkCentre M900 with a StarTech PCIe-4x NVMe card. It's easily twice as fast as a SATA SSD. As far as being a waste, new machines only have this type of drive, so we need booting support.

3
Multimedia / Re: Updated Uniaud32 build
« on: April 15, 2021, 01:08:24 am »
Hi Mike, can you please let me know the model of the Lenovo docking station that you are using? If it is not much to ask, can you please take a pci.exe report without the dock and with the dock to notice the difference, so I can add it to the OS2World wiki?

Hi Martin,

I am using the Thinkpad Pro Dock 90W. Please see attached picture for the type plate.


Kindly note that I have the USB3 feature of the X250 disabled, due to problems with the AN USB drivers. Even if only USB2 is enabled I need Lars Erdmann's drivers to use my external keyboard and mouse.

Greetings,
Mike

I have the same dock. It does not work well with Arca Noae USB. If you must use Arca Noae USB with this dock, set USB to Auto in the X250 BIOS and use USB 3.0. Even then I need to unplug and replug the keyboard and/or mouse to get it to work. Before 12.08, it didn't really work at all. Once in 50 times, it traps. If you get a trap screen for this Dock, post it here or open a ticket at Arca Noae.

4
Setup & Installation / Re: Booting with NVMe
« on: April 15, 2021, 01:00:24 am »
If you want to boot from NVMe drive, and you use AirBoot, how are you going to install AirBoot on NVMe drive? That's why you need to boot from the installer USB stick.

If you have another drive besides NVMe one, better read this page from the Arca Noae wiki.

https://www.arcanoae.com/wiki/arcaos/multiple-disk-types/

5
Setup & Installation / Re: Booting with NVMe
« on: April 14, 2021, 05:26:07 pm »
I have now done it using the ArcaOS 5.0.6 USB stick. I'm sure a Wiki entry from Arca Noae will come soon, as I have reported the result to the tester's list.

You'll need to edit the Config.Sys in the pre-boot menu to comply with what it says in the NVMe readme. The PSD line needs to NOT have /VW

If you install, you need to edit Config.Sys at the end of Phase 1 with the same changes the pre-boot menu got. After that, it should work.

6
Thanks, the hint about "1" was what I needed.

wrong: CustomVideoModel
right: CustomVideoMode1

I now have ArcaOS running at 1920 x 1200 x 32 in full screen mode.

7
I carefully tried jailbird's instructions above, but I don't see a 1920 x 1200 x 32 selection appear.

I didn't notice before, but I do see 2 lines containing 1280 x 1024 x 16M in the OS/2 screen applet. Next step is to repeat the ArcaOS installation.

8
Hardware / Re: Virtualbox, eCS and USB 12.08
« on: April 13, 2021, 05:12:46 am »
I just installed USB 12.08 on my Virtual Box system. No problems observed so far.

Maybe it is widescreen that is causing your crash? ;)

9
Thanks for the suggestions.
I am using Virtual Box 6.1.18 under Windows 10 64 bit (and also Ubuntu, but I checked your suggestions under Windows)
I left monitor unselected, as I had seen Martin's page with no monitor, but wide screen working
I am using VBoxVGA and I increased video memory to 32 MB
I had been trying 1920 x 1080 x 32, but then I saw your suggestion, and I changed to the native 1920 x 1200. Both Windows and ArcaOS are fine with 1920 x 1200 x 32. Unfortunately, this change did not get VirtualBox to cooperate.

My OS2Addtions are dated 8-15-20. These do not have VBXGRADD.DLL

10
I am using Ubuntu Linux, but I also have a Windows 10 host. I am quite unfamiliar with Windows 10 and Ubuntu, but I thought Virtual Box might be helpful to develop. I've tried to follow your instructions, and those at Arca Noae, but nothing seems to set that resolution.

Your helpful Wiki helps me see that monitor definitions are not the answer. But I'm still unsuccessful at adding any wide screen video.

11
I tried VBoxManage and I am using the same GRADD.DLL as Martin. But so far no joy with getting a wide screen resolution. The screen applet suggests that I select a monitor to enable higher resolution, but offers me a list of monitors from 1996. Did anyone using a wide screen select a monitor? What did you choose?

For what it is worth, I do see a slight flicker to the cursor at 1280 x 1024. It's not crippling, but I think original poster is right that it is a little slow.

12
Programming / Re: VSLICK - OS/2 Toolkit Support Package
« on: April 08, 2021, 03:34:08 pm »
Well, consider me subscribed. I use Vslick daily. I would love to see the feature with Document->Format paragraph default to one space after the period.

I do HTML and CSS with Vslick also, and of course that's a little behind the times, too.

13
How do you get 1980 x 1080 resolution with GenGradd? On my Virtual Box, I only see non-widescreen resolutions offered.

14
Applications / Re: Problems with lsusb and usb.ids
« on: April 04, 2021, 06:44:40 pm »
I needed to move the usb.ids from \sys\bin to \mptn\etc, but lsusb 013 seems to work well here.

15
Web applications / Re: QT5 simplebrowser
« on: April 01, 2021, 03:49:10 pm »
Thanks, Paul!

For me, the exciting thing was a pointer to another article with a news site that would probably work on IBM Web Explorer.

http://68k.news/

Quote
Philadelphia retro computing enthusiast Sean Malseed, have opted to create parts of the modern internet in a way that's intelligible to the earliest of machines.

His latest effort is a reworking of Google News designed to run on browsers as early as Netscape 1.1, first released in mid-1995

Pages: [1] 2 3 ... 47