Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Mike Kölling

Pages: [1] 2 3 ... 8
1
Programming / Re: Qt6
« on: January 22, 2023, 05:24:24 pm »
Say after 50 or so characters. When it happens I can barely continue typing and the "back" key will also cease to work.
Initially, I suspected a problem with the USB mouse driver (I am using my driver set) but I have no problem typing in Firefox 45 (which is what I am doing right now).
I have a fully updated set of Qt5 files. I am really out of ideas of where it is going wrong.

Hi Lars,

First off all, the <BACKSPACE> is the only way to delete a character within Dooble (QT5 and QT6). So this keystroke is important because of the non-functioning <DELETE>-key and it is working normally for me. By now these are more then 100 characters and I don't experience any slowdown. So it might be something on your OS/2 setup causing the problems you see. This ist still Dooble-QT6 version 2023.0.18 - the latest release - I am using for this post.
FYI: bare metal - Thinkpad T430

Greetings, Mike

2
Programming / Re: Qt6
« on: January 22, 2023, 04:17:31 pm »
Does this Qt6 version of Dooble (rather: the Qt6 libraries) fix the problem that typing a lot of text into an entry field (like this comment field) slows down the typing more and more until finally you cannot type at all ? That`s what happens with my Dooble based on Qt5.

Hi Lars,

I haven't experienced such a behaviour. However I used Dooble-QT5 mostly for visiting the bank pages for Online-Banking (to download documents). So not much text typing.
I just answered Martin and I type this also with Dooble-QT6 and don't see any slow down. But maybe it is to less text to write. Do you have a number of characters / words one should test to see a slow down?

Greetings, Mike

3
Programming / Re: Qt6
« on: January 22, 2023, 04:12:49 pm »
Hi.

I was able to load OS2World.com on Dooble now. The thing that I was missing was the right click over the tab and "Disable Javascript". I'm replying from Dooble Qt6 now.

How do you add the blocklist on Dooble?

Regards

Hi Martin,

I don't need to disable Jacascript to get OS2World loaded. I guess it comes with the blocklist imported.
You need to download the list Dave Yeo has provided earlier in this topic.
Then you go to Tools => Accepted / Blocked Domains. There you select Block Mode and use the button "Import..." to import the text file "blocklist.txt". That's all.

Greetings, Mike

Edit: Just fixed a typo and another one.

4
Programming / Re: Qt6
« on: January 22, 2023, 02:05:26 pm »
Hi Paul, latest seems to work much the same as previous. Needed to import the blocklist (new profile) to load os2world.

Hi Paul,

This hint from Dave solved the issue with www.os2world.com in Dooble-QT6.
I'm now writing this in your QT6 Dooble version.

Greetings, Mike

5
Programming / Re: Qt6
« on: January 22, 2023, 02:01:18 pm »
Hi MIke,
Try:
Code: [Select]
set QTWEBENGINE_CHROMIUM_FLAGS="ignore-certificate-errors -ignore-ssl-errors -log-level=1"Before starting Dooble....

Hi Paul,

Sorry, this set command doesn't help against the crash in loading www.os2worl.com.
However you new qos2.dll solves the menu issue. Now it looks nice with the drop down menus - that's great work.

Greetings, Mike

6
Programming / Re: Qt6
« on: January 21, 2023, 02:05:58 pm »
Not tested...  but https://smedley.id.au/tmp/dooble-2023.01.18-os2-qt6-20230121.zip for *qt6*

Hi Paul,

Dooble-QT6 starts here. I can key in "www.os2world.com", the page is coming up, I can see that some "google" things are loaded in the lower left corner and then Dooble-QT6 disappears. No popup.log or other indication what has gone wrong.

Greetings from Potsdam,
Mike

7
Paul,

  The only way I was able to install python3 was by disabling all repositories in ANPM except netlabs-exp, closing ANPM, then on a command line typing 'yum update python' (no '3'). This updated both python 2 and added python3. YMMV.

Regards,

Hi David,

Thanks for your explanation how to install Python 3. It was working here quite well.

Greetings, Mike

8
Programming / Re: Qt6
« on: January 14, 2023, 12:01:27 pm »
Hey Mike,

Thanks for trying! If the app starts - that's a pretty good sign that you have all the requisite DLLs. I have seen some symptoms like this in my testing, have you recently rebooted? Qt6 is pretty memory hungry.

Also, what's your VIRTUALADDRESSLIMIT set to? if it's only 1536, try increasing it to 2048 or 2560.

Dear Paul,

Thanks for your speedy reply. I will apply your recommendations and do another test. However, due to tight schedule for today, I can do it at earliest over the weekend. I will keep you updated.
Wish you a great weekend.

Mike

Dear Paul,

as recommended I checked the virtualadresslimit. It was set to 2048 already, however changing it to 2560 didn't helped.
Trying to start Dooble after a fresh reboot didn't help either.
Also using your latest Dobble from 20230113 doesn't improved behavior.
But deleting the .dooble profile in my Userhome folder did the trick. Now Dooble(QT6) ist starting much faster and is able to load web pages. I tried first "www.os2.org".
I can even start Dooble with the Firefox already open and it is working  :), which is how I actually write this answer.
Thanks again for your great work.

Greetings from Potsdam / Germany,
Mike

9
Programming / Re: Qt6
« on: January 13, 2023, 09:59:22 am »
Hey Mike,

Thanks for trying! If the app starts - that's a pretty good sign that you have all the requisite DLLs. I have seen some symptoms like this in my testing, have you recently rebooted? Qt6 is pretty memory hungry.

Also, what's your VIRTUALADDRESSLIMIT set to? if it's only 1536, try increasing it to 2048 or 2560.

Dear Paul,

Thanks for your speedy reply. I will apply your recommendations and do another test. However, due to tight schedule for today, I can do it at earliest over the weekend. I will keep you updated.
Wish you a great weekend.

Mike


10
Programming / Re: Qt6
« on: January 13, 2023, 09:48:48 am »
PS Posted from Dooble/2 with Qt 6.2.4

Hi Paul,

First off all THANKS for your ongoing effort to port software to OS/2.
I downloaded yesterday your QT6 version (20230108), the latest qtwebee (20230112)  as well as Dooble (20221225) for QT6. I applied highmem -b to the DLLs in QT6 folder.
Dooble starts (with quirky menus) but couldn't load any page. It still showing the running circle indicator but no web page will be displayed.
I wonder if my system might be missing some necessary programs / DLLs because I don't have any development tools on my system.

Greetings from Potsdam,
Mike

11
Storage / Re: JFS failing in a disastrous way - without the user knowing
« on: November 30, 2022, 01:29:49 pm »
Hi Lars,

Thanks for your detailed explanation about the JFS issue without the unicode.sys driver.
As a German user of ANOS with a lot of Umlaute, because I renamed a lot of the originally English named folders to common German names, I think it might help me to avoid similar waste of time for finding out the root cause of the problem.

Thanks and Greetings from Potsdam / Germany,
Mike

12
Multimedia / Re: Updated Uniaud32 build
« on: September 08, 2022, 12:14:29 pm »
https://smedley.id.au/tmp/uniaud32-linux-5.15.65-20220908.zip is now available - adds support for the __GFP_ZERO flag in __vmalloc, which fixes audio on some emu10k1 audio cards.

This may also fix some other stuff too - certainly shouldn't break anything :)

Hi Paul,

works on my TP X250. tested with system sound and pm123  :) - Thanks.

Greetings, Mike

13
Multimedia / Re: Updated Uniaud32 build
« on: September 07, 2022, 11:22:26 am »
Thanks!! I haven't commited the change yet, but https://smedley.id.au/tmp/uniaud32-linux-5.15.65-20220907.zip will hopefully still work for those that previously had traps :)

TRAP is gone on my TP X250 after installing the latest version "uniaud32-linux-5.15.65-20220907.zip".
Thank you Paul.

Greetings, Mike

14
Networking / Re: Samba 4.13.x Update/Status
« on: August 31, 2022, 12:10:35 pm »
2022-08-31 Short update:

Copying complete folders to and from my OS/2 station (JFS formatted drives) using the new test SAMBA version from a Windows 10 Pro (x64) computer is working fine.  :)
Copying files to and from an encrypted drive (Netdrive with ndcrypt) via SAMBA 4.15.9 is working.  :)
Copying complete folders from an encrypted drive (Netdrive with ndcrypt) via SAMBA 4.15.9 is working.  :)
But copying folders to the encrypted drives fails as well creating a new folder at the encrypted drive from W10.  :(

Greetings,
Mike

15
Networking / Re: Samba 4.13.x Update/Status
« on: August 30, 2022, 12:14:18 pm »
Hi Mike,

Thanks - look out for an email from me this evening AU time :)

Cheers,

Paul.

Hi Paul,

smbd-4.15.9-20220828 well received. Both files placed in my SAMBA test and first impression is promising.
Kindly see attached picture.

No changes for my smb.conf needed  :D.
Access from W10_x64 is working (read & write of files).
I will give it more testing the coming days and keep you updated.

Greetings,
Mike


Pages: [1] 2 3 ... 8