Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Dave Yeo

Pages: [1] 2 3 ... 209
1
Applications / Re: Running old OS/2 Software - Issues
« on: September 17, 2021, 10:51:19 pm »
Hi Martin,
I unzip it and run it, its starting up without a error..
I use Arcanoae

Same result here, runs fine after unzipping. Did you run the install script?

2
Applications / Re: Running old OS/2 Software - Issues
« on: September 16, 2021, 05:28:11 pm »
Packaged version with updated makefile and minor changes (comments and an added include) to make the compiler happy.

3
Applications / Re: Running old OS/2 Software - Issues
« on: September 16, 2021, 04:51:12 pm »
OK, that made the compiler dislike C++ type comments :) After fixing and adding a missing include, seems to work.
I'll package it after work and post the fixed package.

4
Applications / Re: Running old OS/2 Software - Issues
« on: September 16, 2021, 01:22:46 am »
Might want to see if Lars has any suggestions about the CFLAGS such as using the multi-thread library.

5
Applications / Re: Running old OS/2 Software - Issues
« on: September 15, 2021, 04:52:49 pm »
1) I suspect that OPENDLG.LIB was a library that was necessary to build a OS/2 version 1.3 PM application. Of course, the question is, why is it still listed in the makefile ? Maybe that was an omission to remove it.

2) I suspect that problem with CPPOS30.LIB is that it follows a newer OMF library format than what LINK386 understands. The easiest thing is to replace "link386" with "ilink /NOFREE". /NOFREE will force ilink to follow the same command line syntax as LINK386 but it will be able to link to CPPOS30.LIB.
In any case, it is not wrong to link to the RTL dynamically (but it might be a better idea to link against CPPOM30.LIB, that is, specify /GM+ as compiler switch: link multi-threaded).

David, can you post the makefile as you have corrected it ?

OK, the "ilink /NOFREE" fixed the linking and produced a working present.exe. Thanks
Code: [Select]
# IBM Developer's Workframe/2 Make File Creation run at 12:29:23 on 04/08/92

# Make File Creation run in directory:
#   E:\C\SHEET;

.SUFFIXES:

.SUFFIXES: .c .rc

ALL: PRESENT.EXE \
     PRESENT.RES

PRESENT.EXE:  \
  PRESENT.OBJ \
  PRESENT.RES \
  PRESFONT.OBJ \
  MAKEFILE
   @REM @<<PRESENT.@0
     PRESENT.OBJ +
     PRESFONT.OBJ
     PRESENT.EXE
     
<<
   ILINK.EXE /NOFREE /PMTYPE:PM @PRESENT.@0
   RC PRESENT.RES PRESENT.EXE

{.}.rc.res:
   RC -r .\$*.RC

{.}.c.obj:
   ICC.EXE /c /I. /Ss .\$*.c

!include MAKEFILE.DEP

Here's the working exe.

6
Applications / Re: Running old OS/2 Software - Issues
« on: September 15, 2021, 07:07:45 am »
Trying to compile with VACPP v3.08, I see it wants an unknown library, OPENDLG.LIB, which I nor Google have never heard off. Removing it results in this error,
Code: [Select]
LINK386 :  fatal error L1104: G:\IBMCPP\LIB\cppos30.lib : not valid library
Which I don't understand as cppos30.lib seems to be a valid import library. Seems that is the runtime and there should be a way to statically link it instead of depending on a runtime DLL. Anyone know the recipe?

7
Applications / Re: Running old OS/2 Software - Issues
« on: September 15, 2021, 12:39:22 am »
I had a quick look at the package. The readme does say,
Quote
The current version is a simple port from my OS/2 1.3 version that I wrote
two years ago.

So I assume the author ported it to 32 bit OS/2 v2.  Possibly a simple recompile would fix it or show where the error is.

8
Hi Lars, likely yours is the P4 build and mine is the i686 build, or the opposite, I haven't booted to that partition to check but would explain the aprox 1/2 hour difference.

9
Off Topic discussions / Re: Lo Res Car?
« on: September 10, 2021, 12:29:27 am »
Wrong forum.

Well, he is posting to the offtopic section.

10
IIRC, you need to update to the latest Python 2.7 to get the new python27.dll, reboot, then update Python (and yum) and to be safe, reboot.
Well written scripts should find the correct Python version, with python pointing at python.exe which is Python3 and python2.7 which points to python2.7.exe. Sometimes it helps to have %PYTHON% = python2.7.exe to run python2.
Anyways the reboots are important to replace the locked DLL.

11
The version I have installed in my exp partition has the export so you're loading the wrong gtls30.dll or need to update it, which is a bug.
Code: [Select]
K:\usr\lib>bldlevel gtls30.dll
Build Level Display Facility Version 6.12.675 Sep 25 2001
(C) Copyright IBM Corporation 1993-2001
Signature:       @#bww bitwise works GmbH:3.6.12-1.oc00#@##1## 04 Apr 2020 12:31:21     ECS26154618::::0::@@gnutls
Vendor:          bww bitwise works GmbH
Revision:        3.06
Date/Time:       04 Apr 2020 12:31:21
Build Machine:   ECS26154618
File Version:    3.6
Description:     gnutls

12
Comments, Suggestions & Questions / Re: Hobbes (Files) Reoganization
« on: September 09, 2021, 02:24:17 am »
It seems to me they should be kept under apps. While it's true you can stretch html composers/editors to call them developer stuff, they're really aimed at regular users who want to throw together a web page. I wouldn't expect to find them under dev/

13
Did you update OpenSSL (or perhaps gnutls) and reboot to make sure you were using the new version?
Oh, I see not. Reboot and retest

14
Comments, Suggestions & Questions / Re: Hobbes (Files) Reoganization
« on: September 05, 2021, 11:44:40 pm »
For the various Mozilla apps, the latest of each architecture is probably fine.
As for the browser, it is even worse as only Firefox is a pure browser. SeaMonkey is a browser and email (and news and IRC and composer) client and even Thunderbird is quite capable of acting as a browser as well as newsgroups and various chat protocols such as IRC.
Perhaps they all should be under  "/pub/os2/apps/internet/apps" or  "/pub/os2/apps/internet/mozilla" or "mozilla/apps"
It is awkward when programs have various uses but to me it seems FF, SM and TB should be in the same place or better, symlinked or hard linked to a couple of locations.

15
Networking / Re: speedtest-cli no longer working...or partially...why?
« on: September 05, 2021, 01:29:44 am »
Perhaps your ISP's server was down?
Running list here results in a list that looks sane besides that it puts Telus as 300 km away. Their headquarters (and Vancouver in general) is perhaps 70- 80 km by road.
Code: [Select]
Retrieving speedtest.net configuration...
 3049) TELUS (Vancouver, BC, Canada) [300.42 km]
16691) TeraGo Networks (Vancouver, BC, Canada) [300.42 km]
37272) Rogers Wireless (Vancouver, BC, Canada) [300.42 km]
41509) AEBC Internet (Vancouver, BC, Canada) [300.42 km]
40141) San Juan Cable (Bellingham, WA, United States) [304.78 km]
22154) Eastlink (Delta, BC, Canada) [308.77 km]
31110) City of Anacortes (Anacortes, WA, United States) [331.62 km]
 9551) Whidbey Telecom (Langley, WA, United States) [365.97 km]
 8008) JUCE Communications (Victoria, BC, Canada) [375.67 km]
12192) Nitel (Seattle, WA, United States) [405.28 km]
BTW, version reports,
Code: [Select]
speedtest-cli 2.1.4b1
Python 2.7.6 (default, May 16 2020, 17:42:14) [GCC 9.2.0 20190812 (OS/2 RPM build 9.2.0-4.oc00)]

Pages: [1] 2 3 ... 209