Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Jochen Schäfer

Pages: 1 ... 10 11 [12]
166
Programming / Re: libc panic
« on: August 03, 2015, 03:35:53 pm »
Hi Boris.

Thanks for the hints. Imwill look into the tools.
I didn't forget your PM, I just didn't get to packaging and uploading the binary. Sorry.
Hope to get to it this evening.

167
Programming / Re: libc panic
« on: August 03, 2015, 01:41:40 pm »
I don't think, it's an memory problem. The problem is consistently the start of nginx after a previous shutdown.

The nginx code for the use of shared memory relies on the automatic removal of shared memory at process shutdown.
My guess is, that klibc ignores this flag and by the time nginx is started the second time, the shared semaphore is still in use and can't be recreated.
That leads to the lib panic.
Does someone know whether I can fetch a list of shared memory segments to release?

168
Programming / Re: libc panic
« on: July 31, 2015, 08:11:25 am »
I have already compiled nginx with -Zhigh-mem.
Actually, I used:
Code: [Select]
CFLAGS = -D__EMX__ -DEMX -DOS2 -Zmt  -D__ST_MT_ERRNO__ -g -march=pentium -mtune=pentium4 -static-libgccand
Code: [Select]
LDFLAGS = -Zomf -Zmap -Zhigh-mem -Zstack 8000 -D__ST_MT_ERRNO__ -static-libgcc -lmmap -Zexe

169
Programming / libc panic
« on: July 31, 2015, 07:34:33 am »
Hi.

I'm porting nginx. I was able to build a binary and nginx can serve me static HTML pages.
I can stop nginx via process signaling. That just works fine.
But if I want to restart nginx, I get the following:
Code: [Select]
nginx: [alert] shmget(384) failed (22: Invalid argument)

LIBC PANIC!!
safesem mutex requested failed, rc=0x6. pmtx=5fe10960:{.hmtx=0x800100fb .fShared
=0x1}
pid=0x0fbb ppid=0x0b43 tid=0x0001 slot=0x009c pri=0x0200 mc=0x0001 ps=0x0017
U:\WORK\NGINX\OBJS\NGINX.EXE
Process dumping was disabled, use DUMPPROC / PROCDUMP to enable it.

Now, I have to reboot to get nginx running again.

I have the newest klibc installed and the binary is compiled with gcc 4.9.2.
Does anyone have suggestions, how to handle the problem?

Bye Jochen

PS: If someone wants to test the port, PM me.  I'll send you the binary.

Pages: 1 ... 10 11 [12]