Recent Posts

Pages: [1] 2 3 ... 10
1
Note that OAuth 2.0 seems to only be for IMAP and unavailable for POP
OK, that's why I couldn't find the option anywhere -- I had to create a new IMAP mail account under SM for it to be listed.

I'm not big on having my mail permanently stored on Google's servers*, though, so one-time 'application password' it is -- especially seeing that you seem to have trouble with OAuth2 anyway. Of course, they have my phone number now :( but application password seems to work so I can go missing for 36 hours without losing access to the account at just the right moment.

Great, thank you everyone!

*It is, anyway. I don't have "leave messages on server [...]" checked, which I take it to mean messages are deleted when I fetch them (classic POP style) -- but I can still get them from my phone too afterwards (only until tomorrow?).
2
I tried a new profile without success. It's likely that things have changed on Gmail's end and adding a new account is no longer allowed due to deficiencies in our OAuth implementation.
If I get ambitious,  I'll try to trace the changes between 45ESR and 52ESR where it uses OAuth2Module.jsm. Unluckily it looks like the whole of mailnews\base\src has changed and probably dom changes as well.
3
Looking again at what occurs, it seems the OAuth login is fine here in Thunderbird, however, then it asks if I want to allow the app and that is where it hangs (wrong password is seen as a wrong password and no request to allow the app is presented).  Seamonkey was long ago allowed here... I may have cleared Thunderbird (either on purpose at some point or by mistake) and now there is a problem at the point where I am trying to allow it.
4
Well you could double check the prefs,
user_pref("mail.server.server<x>.realuserName", "username@host.tld");
user_pref("mail.server.server<x>.userName", "username");
and make sure they agree though it didn't seem to help here. That's from bug#1518126. Seems that oath2 only really works reliably with TB78+ and now the latest SM.
I'll apply the patch anyways.

Edit: Actually our msgOAth2Module.js is much different then current OAth2Module.js so above probably doesn't apply and the patch doesn't apply at all
5
Trying OAuth 2.0 on SeaMonkey, it seems to work with notifications happening on my phone to allow me to proceed but it seems to be hung on Sending login information...
Have to try restarting SM
Note that OAuth 2.0 seems to only be for IMAP and unavailable for POP

Edit: Restarting didn't help, nor did safe mode. Could be my profile but the error console shows a problem adding the new login and that it was sending an empty password.

Interestingly, the hang on sending login information is what I now see in Thunderbird... I do not know what changed there, as far as I recall, the last time it worked successfully with Thunderbird was with the version I now have (which is dated the same as the Seamonkey that works -- 08-29-21).
6
Have all the (DUX/AHD) patches been applied?  I had crashes in pmmerge.dll with DUX, however, I fixed it long enough ago I don't recall what it was... my recollection is it was the patches.
7
Hardware / Re: ArcaOS 5.1 UEFI support - GOP?
« Last post by Roderick Klein on May 28, 2022, 06:07:07 pm »
With the phase out of the BIOS, the VGA BIOS and VGA hardware is also gone. That is pretty big step! VSVGA.SYS is basically a big wrapper around the video BIOS and VGA hardware. VEFI.SYS partly emulates the VGA hardware. So there is some slowdown, but on new UEFI only systems the system is that quick you should not notice it.  But it should be faster then DOSbox possibly, because the rest of the hardware is "real".

A lot of the stuff for me does not look totally unknown as I looked at in my Mensys days working on eCS... It just never got of the ground.

Roderick
8
Games / Re: DOS VDM - USB and Game port Gamepad support
« Last post by Lars on May 28, 2022, 03:55:17 pm »
Use Panorama, but as a test, disable the screen buffer (it's in the screen settings). If that helps then unfortunately, you will have lousy overall video performance.
9
Others need to distribute the patches, and let the user do the work to apply them. Patches are often done automatically, by installers, when something is installed.

Seems this idea is not new. Once, I have seen ftp with patches to convert OS/2 kernel to OS/4 level. Somehow I did not pay attention to this and did not add it to my bookmarks. I tried to find it again, but unfortunately without success.
10
Games / Re: DOS VDM - USB and Game port Gamepad support
« Last post by Dave Yeo on May 28, 2022, 04:46:32 am »
You could try adding DEVICE=X:\OS2\SDDHELP.SYS to your Panorama install with X: being your SNAP install and testing. Not likely to help but who knows.
Your lockup, does CTRL-ALT-F10 twice force a dirty reboot after failing to find a dump partition? Slightly cleaner then hitting the power button.
Pages: [1] 2 3 ... 10