Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Sean Casey

Pages: [1] 2 3 ... 8
1
Applications / Re: ssh - sshd
« on: January 09, 2023, 02:07:47 am »
Haven't used OpenSSH server on OS/2, but the v.5.3 client worked well as did OS/2 ZOC with Linux OpenSSH v.7 servers.   It seems OpenSSH v.8.9 server, which I'm now using on my Linux machines, no longer allows a workaround for the older key exchanges/ciphers supported by OS/2.  Was using diffie-hellman and DSA with overrides in sshd_config, but these no longer work with OpenSSH v.8 with my config overrides.

Recently installed the OS/2 v.7 OpenSSH client, but I preferred using ZOC.  I need to look into the possibility of not passing my OS/2 term environment variable "os2ansi" with SSH as this causing me issues in Linux (e.g., seeing junk characters using vi).   

Update:  I manually set ANSI for my SSH session which helped with vi, but keyboard mapping is borked while working in vi.   Keyboard mapping is on the client side, so something is off on my v.7 OS/2 SSH client. I'll come back to this in the future as I don't need SSH on OS/2. 

2
Applications / Re: HOBLink and ArcaOS
« on: January 09, 2023, 01:20:59 am »
If anyone is able to use a modern browser via an OS/2 Xserver please post your config.   I have tried both Chrome and Falkon and ran into issues with modern Xserver extensions not being supported in PMX and HOBLink servers (e.g., MIT screen saver and shared memory extensions).   

I have tried to disable the extensions in xorg.conf without success.   For example, for the MIT-SHM shared memory extension, I added the following to xorg.conf which should have disabled the extension but the browsers still choked when starting:

  Section "Extensions"
      Option "MIT-SHM" "disable"
  EndSection

I wanted to try Exceed for OS/2, but unfortunately my floppies have been sitting too long and disk-2 and disk-5 have read errors preventing an installation without corruption.  Tried recovering the two disks with ddrescue without success.   Exceed for OS/2 is also very old and wouldn't resolve the issues with newer extensions.

3
General Discussion / Re: SCOUG
« on: January 09, 2023, 12:57:04 am »
Hi JTA,

SCOUG is still alive and well.  We did stop meetings back in 2020 due to Covid, but hope to soon have live meetings again.  For now, you can join the SCOUG mail list by sending an email to MajorMajor@scoug.com with the following in the email body:

      SUBSCRIBE SCOUG-HELP
      END

I believe Neil Waldhauer (BlondGuy) coordinates an OS/2 group in Northern CA.   

- Sean

4
JTA, many of us are using virtualization.  Everything is a compromise. I wish I could ditch one of my Linux VMware WS installations and replace Linux with ESXi, but multi-LUN SCSI passthrough doesn't work on ESXi, and ESXi limits me to only 2GB RAM for OS/2.  I split my time between Linux and ArcaOS desktop.

1. Ubuntu Server (24x7 - 12 core):
    Mail, DHCP, LMS Squeezebox servers
    SIEM
    VMware WS Pro v.17:
         Windows 2000 - ARCserve backup for WSeB, ArcaOS, Windows 2000/2003 to disk/tape; SQL Svr 6.5; home automation
         Windows 2003 - DB/2 v.7.2, SQL Svr v.4.21
         OS/2 WSeB - Relish Net, DB/2 v.6.1, SQL Svr v.4.2, home directory for my ArcaOS desktop. PC-Bax backup to tape, BA/2 to disk.

2. ESXi v.8.0 Server (24x7 - 10 core):
    FreeBSD - PFSense Firewall (SNORT, pfBlockerNG) w. NIC passthrough for SNORT in-line
    Ubuntu Server - cold spare mail, DHCP, LMS servers; SIEM

3. Kubuntu desktop applications (My desktop systems - 22 core):
       VMware WS Pro v.17
            ArcaOS desktop/database applications
            Windows Svr 2019 desktop applications (Saracon DSD, Capture One)
            Windows Svr 2012 - ARCserve backup for ESXi live VMs, Ubuntu/Kubuntu, Windows Svr 2019
 
4. ESXi v.8.0 Server (mostly offline - 8 core)
       Ubuntu - NFS Server w. RAID 10 passthrough for offline archives of various backups, disk images
       VM test environments

5.  T60P laptop (w. T61 mobo - 2 core):
     Windows 2000 desktop apps
     ArcaOS desktop apps

My Linux machines get live imaged via Acronis and I periodically make images via Clonezilla.  I also make scp backups of my ESXi VMs when they are offline.  I'm neurotic about having backup redundancies :-)
   

5
This reminds me of the once Holy Grail of operating systems I once dreamed of using - IBM's Workplace OS with its various "personalities".   I recall OS/400, OS/2, AIX and Windows were the initial personalities implemented on Workplace OS.  Sadly, Workplace OS only made it to a preview build before being cancelled. 

Microsoft Windows was once headed in the same direction, having distinct Win32, OS/2 and POSIX subsystems.  I still use Windows 2000 where I have used all three.

6
Applications / Re: VLC3018 IDN11.DLL
« on: January 08, 2023, 05:28:27 pm »
Ivan - I am a convert on RPM/YUM/Acra Noae Package Manager.  I didn't like it at first and I am still annoyed at not being able to specify the install location of packages, but the benefits so outweigh the deficits.  The system is actually pretty amazing: you can get access to, and install, applications and libraries that you need - along with updates - and it is really pretty painless (when you pay attention to the menu options, which obviously I didn't.)

ANPM is nice, but ANPM and YUM seem to be missing key functionality.   

A couple of days ago I wanted to install the long term support version of the samba client (samba-client-lts).  When installing, ANPM identified two additional packages to install, heimdal and heimdal-libs.   I stopped the install and looked to ANPM to report what dependencies were needed for the samba package, but I found that ANPM does not report package dependencies.   I then went to a command line and typed "yum deplist samba-client-lts" and no dependencies were reported, but ANPM would not install the samba client without also installing the two heimdal packages.  Also, while ANPM did generate a log file for the samba package installation, I didn't see both heimdal package installations in the log?

As I'm accustomed to using APT and only use YUM on ArcaOS, there might be other ways of navigating and reporting package management on ArcaOS?

7
Storage / Re: Cloning a drive
« on: October 14, 2022, 08:36:12 pm »
I have read in this forum people successfully cloning drives using DFSee.   

I have cloned OS/2 two different ways, once using Acronis Cyber Backup 12.5 with a bit-stream backup where the target remained the same partition size for OS/2.  The second method I made a zip backup of the source OS/2 partition.  I then did a fresh install of OS/2 into a second (i.e., D-drive) partition on a new drive.  Booting into OS/2, I formatted a larger C-drive partition and then restored my OS/2 backup.  I was using the AiR-BOOT manager.

8
Marketplace / Re: HyperAccess/6 or HyperAccess Pro
« on: October 05, 2022, 12:40:49 am »
Have you considered ZOC?   It's a full featured SSH client and terminal emulator for Windows and Mac that's currently supported, and last I looked (in 2019), you could still purchase an OS/2 license.   I use it on Windows, Linux via Wine, and also on OS/2.  Highly recommended.

9
Applications / Re: ColorWorks ArcaOS
« on: October 01, 2022, 04:21:46 am »
Hi,

Per Arca Noae...

The new FOC is enabled by default. To disable it and switch back to the original OS/2 file open dialog:
1. Open an OS/2 command prompt.
2. Change to the \sys\INSTALL\FOC directory on the boot volume.
3. Type “filedlgtofocdlg /U” and press <Enter>.
4. Restart the system.

To reenable the new FOC (any previous settings should be restored):
1. Open an OS/2 command prompt.
2. Change to the \sys\INSTALL\FOC directory on the boot volume.
3. Type “filedlgtofocdlg /I” and press <Enter>.
4. Restart the system.

Also, ColorWorks does not work well on OS/2 systems that use display drivers based on GRADD.  Issues include missing (all black) effects previews if the stacking option is used, and lockups in various effects dialogs.  A patch is available for v.1 and v.2 to address these issues.

10
Applications / Re: PDF Printer
« on: September 25, 2022, 11:55:23 pm »
So now that you've got it running, I am curious: what is the advantage of using PMPDF vs ePDF?

I looked at ePDF, but I wanted something easy to set up and use.  Easy to set up because there's limited OS/2 help available and I would probably be on my own to get it working as both ePDF and PMPDF don't appear to be currently supported. I know Steven Levine, a friend from SCOUG, is using ePDF, and Martin Iturbide had been using PMPDF.   

With PMPDF, I can use any application to print to the "PDF Writer" printer, like I would print to any other printer, and select the location where I want to save the PDF.  It's that simple.  If I want to change the attributes on the output PDF, I can modify the properties on the PDF output port where I can set the PDF Information - Title, Subject, Author, Keywords.

Using ePDF appeared to be a multi step process where I first print to a postscript file, then drag the file to ePDF to make the PDF file.  It's possible to print directly from an application to create a PDF file, but I would have to install other software, such as quePDF, to intercept the print job from the print queue/pipe and invoke ePDF.   

I only had to kill a few grey cells to get PMPDF working, so I'm happy.
 



11
Applications / Re: PDF Printer
« on: September 24, 2022, 04:39:52 am »
Can somebody point me to some documentation on how to use CUPS to create a PDF Printer?

I use a PDF printer with CUPS on Linux, but unfortunately, I wasn't able to get this working with the OS/2 version of CUPS.  This same Linux CUPS PDF printer is also available via an SMB share, but the OS/2 version of CUPS is missing functionality to create the SMB printer to point to this printer. This is why I resorted to using PMPDF, but I would have preferred using CUPS, either locally on OS/2, or via my Linux CUPS PDF printer.

12
Applications / Re: PDF Printer
« on: September 24, 2022, 04:23:13 am »
Now it seems to work with ghostscript 9.18-5 installed from ANPM. I just wrote it down here to don't forget about it next year.
http://www.os2world.com/wiki/index.php/Remembering_How_to_Use_PMPDF

PMPDF was not working for me as I believe the documents I was printing were relying on fonts that were not available with the current ghostscript (v9.18-7) installed via ANPM.

I initially elected to manually install the prior version of ghostscript (v8.71) via a zip file and point PMPDF to this directory tree, as you describe in your tutorial.  This required that I uninstall v9 ghostscript without impacting CUPS which I use.  I used the "--nodeps" option to do this...

   rpm -qa | grep "ghostscript"

        ghostscript-fonts-6.0-1.oc00.noarch
        ghostscript-9.18-7.oc00.i686

   rpm -e --nodeps "ghostscript-9.18-7.oc00.i686"
   rpm -e --nodeps "ghostscript-fonts-6.0-1.oc00.noarch"

After getting this running, I decided it would be better to keep v.9 ghostscript in case it was needed for something in the future, but only use the Fonts from the older v.8 ghostscript.   So, I reinstalled v.9 ghostscript and copied the fonts directory from v.8 moving it under the v.9 ghostscript directory tree.  I then passed the v.8 fonts directory location to PMPDF using the "Extra parameters to GhostScript" option in the PDF output port.  The override option I used was:

   -lc:/@unixroot/usr/share/ghostscript/9.18/Resource/Font;c:/PSFONTS

See the attached screenshot for the location of the override.

So you can use either v.8 ghostscript without v9 ghostscript installed, or you can use v9 ghostscript with the added v.8 fonts directory and PMPDF override.




13
Hardware / Re: Trying to get Sound in VMWare to run - help appriciated
« on: September 08, 2022, 04:23:00 pm »
I haven't had any issues with v.16 on two of my Linux machines with multiple AOS installs over the past 2.5 years, so maybe the issue is only on the Windows platform.   If it's a memory addressing issue, try the install with 256MB assigned to the VM.   If available, create your VM on Linux for use on Windows?

14
Hardware / Re: Trying to get Sound in VMWare to run - help appriciated
« on: September 02, 2022, 04:27:27 pm »
Hi,

I'm on Linux and have never had issues with ArcaOS installations, so  I'm not sure what the source of your problem might be.   Have a look at your ArcaOS 5.0.7.vmx file and compare to the following default installation configuration that was generated by my VMware New Virtual Machine Wizard:

.encoding = "UTF-8"
config.version = "8"
virtualHW.version = "19"
pciBridge0.present = "TRUE"
pciBridge4.present = "TRUE"
pciBridge4.virtualDev = "pcieRootPort"
pciBridge4.functions = "8"
pciBridge5.present = "TRUE"
pciBridge5.virtualDev = "pcieRootPort"
pciBridge5.functions = "8"
pciBridge6.present = "TRUE"
pciBridge6.virtualDev = "pcieRootPort"
pciBridge6.functions = "8"
pciBridge7.present = "TRUE"
pciBridge7.virtualDev = "pcieRootPort"
pciBridge7.functions = "8"
vmci0.present = "TRUE"
hpet0.present = "TRUE"
nvram = "ArcaOS 5.0.7.nvram"
virtualHW.productCompatibility = "hosted"
powerType.powerOff = "soft"
powerType.powerOn = "soft"
powerType.suspend = "soft"
powerType.reset = "soft"
displayName = "ArcaOS 5.0.7"
guestOS = "ecomstation2"
tools.syncTime = "FALSE"
sound.autoDetect = "TRUE"
sound.fileName = "-1"
sound.present = "TRUE"
memsize = "4096"
ide0:0.fileName = "ArcaOS 5.0.7.vmdk"
ide0:0.present = "TRUE"
ide1:0.deviceType = "cdrom-image"
ide1:0.fileName = "/Temp/ArcaOS-5.0.7.iso"
ide1:0.present = "TRUE"
ethernet0.connectionType = "nat"
ethernet0.addressType = "generated"
ethernet0.present = "TRUE"
extendedConfigFile = "ArcaOS 5.0.7.vmxf"
floppy0.present = "FALSE"

15
Hardware / Re: Trying to get Sound in VMWare to run - help appriciated
« on: September 01, 2022, 11:18:27 pm »
Using Lars' USB drivers with CM6553 USB audio on VMware Workstation Pro.   Works well.

Pages: [1] 2 3 ... 8