Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Silvan Scherrer

Pages: [1] 2 3 ... 13
1
Comments, Suggestions & Questions / Re: YUM libc-01.6.-1 local
« on: February 05, 2021, 03:52:53 pm »
here are the error mesages:
bash:
ERROR with transaction check vs depsolve:readln6.dll wird ben”tigt von (installiert) lua-5.3.4-2.i686readln6.dll wird ben”tigt von (installiert) hunspell-1.7.0-2.oc00.i686readln6.dll wird ben”tigt von (installiert) gawk-4.0.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) sqlite-3.28.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) bc-1.07.1-1.oc00.i686readln6.dll wird ben”tigt von (installiert) gutenprint-5.3.3-2.oc00.i686Bitte melden Sie diesen Fehler unter http://trac.netlabs.org/rpm/

cups:
ERROR with transaction check vs depsolve:cups-filesystem = 1:2.2.12-1.oc00 wird ben”tigt von cups-1:2.2.12-1.oc00.i686Bitte melden Sie diesen Fehler unter http://trac.netlabs.org/rpm/

cups-client:
ERROR with transaction check vs depsolve:cups-filesystem = 1:2.2.12-1.oc00 wird ben”tigt von cups-1:2.2.12-1.oc00.i686Bitte melden Sie diesen Fehler unter http://trac.netlabs.org/rpm/

cups-libs:
ERROR with transaction check vs depsolve:cups-filesystem = 1:2.2.12-1.oc00 wird ben”tigt von cups-1:2.2.12-1.oc00.i686Bitte melden Sie diesen Fehler unter http://trac.netlabs.org/rpm/

db4-utils:
ERROR with transaction check vs depsolve:db4 = 4.8.30-9.oc00 wird ben”tigt von db4-utils-4.8.30-9.oc00.i686Bitte melden Sie diesen Fehler unter http://trac.netlabs.org/rpm/

openssl:
ERROR with transaction check vs depsolve:readln6.dll wird ben”tigt von (installiert) lua-5.3.4-2.i686readln6.dll wird ben”tigt von (installiert) hunspell-1.7.0-2.oc00.i686readln6.dll wird ben”tigt von (installiert) gawk-4.0.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) sqlite-3.28.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) bc-1.07.1-1.oc00.i686readln6.dll wird ben”tigt von (installiert) gutenprint-5.3.3-2.oc00.i686Bitte melden Sie diesen Fehler unter http://trac.netlabs.org/rpm/

openssl-libs:
ERROR with transaction check vs depsolve:readln6.dll wird ben”tigt von (installiert) lua-5.3.4-2.i686readln6.dll wird ben”tigt von (installiert) hunspell-1.7.0-2.oc00.i686readln6.dll wird ben”tigt von (installiert) gawk-4.0.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) sqlite-3.28.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) bc-1.07.1-1.oc00.i686readln6.dll wird ben”tigt von (installiert) gutenprint-5.3.3-2.oc00.i686Bitte melden Sie diesen Fehler unter http://trac.netlabs.org/rpm/

python:
ERROR with transaction check vs depsolve:readln6.dll wird ben”tigt von (installiert) lua-5.3.4-2.i686readln6.dll wird ben”tigt von (installiert) hunspell-1.7.0-2.oc00.i686readln6.dll wird ben”tigt von (installiert) gawk-4.0.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) sqlite-3.28.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) bc-1.07.1-1.oc00.i686readln6.dll wird ben”tigt von (installiert) gutenprint-5.3.3-2.oc00.i686Bitte melden Sie diesen Fehler unter http://trac.netlabs.org/rpm/

python-libs:
ERROR with transaction check vs depsolve:readln6.dll wird ben”tigt von (installiert) lua-5.3.4-2.i686readln6.dll wird ben”tigt von (installiert) hunspell-1.7.0-2.oc00.i686readln6.dll wird ben”tigt von (installiert) gawk-4.0.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) sqlite-3.28.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) bc-1.07.1-1.oc00.i686readln6.dll wird ben”tigt von (installiert) gutenprint-5.3.3-2.oc00.i686Bitte melden Sie diesen Fehler unter http://trac.netlabs.org/rpm/

readline:
ERROR with transaction check vs depsolve:readln6.dll wird ben”tigt von (installiert) lua-5.3.4-2.i686readln6.dll wird ben”tigt von (installiert) hunspell-1.7.0-2.oc00.i686readln6.dll wird ben”tigt von (installiert) gawk-4.0.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) sqlite-3.28.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) bc-1.07.1-1.oc00.i686readln6.dll wird ben”tigt von (installiert) gutenprint-5.3.3-2.oc00.i686Bitte melden Sie diesen Fehler unter http://trac.netlabs.org/rpm/

attached you find a png-file that shows what i get when i ask for updates.
you miss packages. using a local repo is working well, but you have to know what you do and how to interpret error messages. as we have no idea what you already have downloaded it's hard to tell which package you exactly miss. but for sure you miss some readline packages. most probably the legacy one.

2
Comments, Suggestions & Questions / Re: YUM libc-01.6.-1 local
« on: February 04, 2021, 09:36:06 am »
did that.
still it didn't work. realized that the slashes were changed to "\". changed them back to "/"
and the initial erroro message dissappeared ;-)
all works fine so far.
also managed now to install my libc.dll

most of the prevously uninstallabe packages are now installable.
there's only 10 left that won't work (bash, cups, cups-client, cups-libs,db4-utils, openssl, openssl-libs, python and python-libs)

no error message no help I'd say. and what does "yum check-update" say? As you can't install whats already installed. "yum update" is needed then.

3
Comments, Suggestions & Questions / Re: YUM libc-01.6.-1 local
« on: February 03, 2021, 05:43:29 pm »
tried. here's what i get:
[E:\DESKTOP]yum install D:\install\repo\libc-0.1.6-1.oc00.i686.rpm
file:///D%3Ainstallrepo/repodata/repomd.xml: [Errno 14] curl#37 - "Couldn't open
 file /D%3Ainstallrepo/repodata/repomd.xml"
Versuche anderen Spiegel-Server.
Fehler: Cannot retrieve repository metadata (repomd.xml) for repository: local.
Please verify its path and try again

btw. when i start ANPM i get:

"Cannot retrieve repository metadata (repomd.xml) for repository: local. Please verify its path and try again
Temporarily disabling repository: local"

my entry there is:

[local]
name = My local repo
baseurl = file:D:\install\repo
enabled=1

did you follow http://trac.netlabs.org/rpm/wiki/RpmHowToEndUsers#LocalRPMrepository ?

4
Networking / Re: OpenSSH_7.7p1 tcgetattr: Invalid argument
« on: December 03, 2020, 12:26:22 pm »
Hi,
I have updated my rpm packages and so openssh-clients version 7.7p1 was installed. This version has some problems:

Code: [Select]
[C:\]ssh -V
OpenSSH_7.7p1, OpenSSL 1.0.2t  10 Sep 2019

[C:\]ssh prometheus
root@prometheus's password:
[b]tcgetattr: Invalid argument[/b]
Last login: Thu Dec  3 08:31:12 2020 from einstein.intern.openit.at
[root@prometheus ~]#
LIBC PANIC!!
_um_free_maybe_lock: Tried to free block twice - block=20034694 lock=0x1
pid=0x0041 ppid=0x003e tid=0x0001 slot=0x0078 pri=0x0200 mc=0x0000 ps=0x0010
C:\USR\BIN\SSH.EXE
Process dumping was disabled, use DUMPPROC / PROCDUMP to enable it.

The external process was cancelled by a Ctrl+Break or another process.

The problem is the line "tcgetattr: Invalid argument". I have an older Version as OpenSSH_5.3p1 as wpi installed; this version does not show the error and is working proper. Is there a solution for version 7.7p1.

best regards
please write mail to info@bitwiseworks.com. we can then workout the issue way better than in here. as I have new builds since longer but never uploaded so far.

5
EDIT: I'm not sure how relevant this might be, but I just realized this may have started after updating to the latest version of CUPS, npth, poppler and libassuan. I'm unable to add new printers (log says: A non-recoverable error has occurred, very informative :P) but the printers I already had installed are working fine. There's probably no correlation but due to the closeness of both incidents I felt like it might be worth including just in case.
this sounds a bit strange. But all is possible with exp rpm. The non-recoverable issue might put some message to popuplog.os2

For the AOO ssue i'm pretty sure you updated ICU. This is known to not work with AOO. A new AOO wich then works is about to be released soon.

6
Applications / Re: Firefox 45.9.0 and libtheora 1.1.1-1 not compatible
« on: September 16, 2020, 06:05:18 pm »
I just installed ffmpeg from netlabs-exp. During the installation, it installs dlls and one of them is the package libtheora 1.1.1-1 from netlabs-rep.
After installation and reboot, I start firefox but as soon I open a web link with available video/audio media, it closes.
Under popuplog.os2, i have:

AVCODE57->THEORAE1._th_info_init
127

I then renamed new theora*.dll and put back my older saved theora* dlls.
After reboot, firefox stays up and no more issue.

Either libtheora has a problem or firefox may need be upgraded to work with libtheora 1.1.1-1 build
 
Regards
Remy

Did you reboot after update? As ffmpeg works w/o issues here. Might be you had a older libtheora loaded somewhere.

7
Applications / Re: DOSBox Issue - STDCPP6?
« on: May 26, 2020, 09:00:26 am »
Hi Silvan, this is still broken. After a yum clean all,
Code: [Select]
--> Finished Dependency Resolution
Error: Package: mpc-devel-1.0.1-3.i686 (@netlabs-rel)
           Requires: libmpc3 = 1.0.1
           Removing: libmpc3-1.0.1-3.i686 (installed)
               libmpc3 = 1.0.1-3
           Obsoleted By: libmpc-1.1.0-1.oc00.i686 (netlabs-rel)
               libmpc3 = 1.1.0-1.oc00
           Available: libmpc3-1.0.1-1.i686 (netlabs-rel)
               libmpc3 = 1.0.1-1
           Available: libmpc3-1.0.1-2.i686 (netlabs-rel)
               libmpc3 = 1.0.1-2
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
On my system, YUM can't find mpfr6.dll.
to see whats wrong we need the yum log. everything else tells not really much. As Dave's issue was different and a one time issue. If you face the mpc-devel issue you have to uninstall mpc-devel. and then it should run.

8
Applications / Re: DOSBox Issue - STDCPP6?
« on: May 25, 2020, 03:54:54 pm »
Does anyone of you have netlabs-exp activated. I can't upgrade to GCC 9, because a dependency is missing.

PS: Yes, I'll file a ticket, if I can't resolve this issue.
There should not be anything missing. Please try again. Init still doesnt work with netlabs-rel post the output please.

9
Applications / Re: YUM
« on: March 23, 2020, 10:58:09 am »
Poppler seems to be broken currently. My workaround is to update a few packages at a time and avoid poppler.
hmm poppler is broken? I wonder about that, as there is no ticket for it. And I update it regularly on some installations and saw no issue so far.

10
Article Discussions / Re: Qt 5 version 5.13.1 OS/2 Beta 1
« on: March 16, 2020, 05:29:50 pm »
Does that mean that it will be desirable that Tellie will recompile his Qt5 software ports? Or something else can be worked out?

I'd say that updating gcc1.dll will be enough....
Hi

I had tried the latest gcc1.dll that provides the Netlabs exp and it provides the same error.
Quote
1-15-20 10:15a        65,857    124 a---  gcc1.dll

If someone can run CuteChess and let me know if it is only an issue of my machine, it will be helpful.

Regards
I really hope you rebooted afterwards, as gcc1.dll is to almost 100% always used. So no reboot no joy.

11
Try to send the Signal with this snipped
http://www.edm2.com/index.php/DosSendSignalException
And see if you get the same 205.

12
General Discussion / Re: OS2World Server Issues (2020-01-04)
« on: January 08, 2020, 05:39:44 pm »
Hi Dave

No, no change there, no "New" indicator displayed.


Regards

Pete

strange as I see it as well. Just tested

13
Applications / Re: Tea - Hunspell errors
« on: December 12, 2019, 07:06:45 am »
Sounds like a ticket is needed. Not sure whether Tea should be adjusted or Hunspell should have some symlinks for apps like Tea.
no no no ticket for that. all works as designed when nothing is set.
you need to set "spell_lang" and "hunspell_dic_path" in the settings. At least thats what the code says.

14
Applications / Re: Can't connect to Google after Update using ANPM
« on: December 02, 2019, 02:35:12 pm »
Just before reading this thread I spent half an hour trying to figure out how to downgrade NSS. The version in the exp repo leads to traps in firefox 45,9,0 too. This is how I downgraded:
From the directory where the packages are located (here F:\var\cache\yum\netlabs-rel\packages\) execute:
rpm -Uvh nss-3.23.0-4.oc00.i686.rpm nss-util-3.23.0-4.oc00.i686.rpm nss-softokn-3.23.0-4.oc00.i686.rpm nss-softokn-freebl-3.23.0-4.oc00.i686.rpm  --oldpackage
why not reporting possible traps in our github repos? As when we see no reports we move it to netlabs rel repo. And to be honest on my system and the testers system it seems stable and connects to all sites, but this might be luck. I don't know.

just to say it once again: no report on github or even netlabs trac there will be no fix.

regards
Silvan

The reason I did not report it is because it was in the experimental repo. I assumed it is work in progress and not supposed to be bug free. Didn't want to clutter up the github repo wirh unnecessary bug reports, Ticket made.
if all think like that, then we will never find issues. as usually what we add to exp works for us. and mostly it just gets moved after some weeks.
Please send the trap's also to Dave, as I see a lot traps in XUL and not NSS. Eventually he sees something in his ffox which is wrong.
And as said, we will of course take a closer look as well.

15
Applications / Re: Can't connect to Google after Update using ANPM
« on: December 02, 2019, 10:08:12 am »
Just before reading this thread I spent half an hour trying to figure out how to downgrade NSS. The version in the exp repo leads to traps in firefox 45,9,0 too. This is how I downgraded:
From the directory where the packages are located (here F:\var\cache\yum\netlabs-rel\packages\) execute:
rpm -Uvh nss-3.23.0-4.oc00.i686.rpm nss-util-3.23.0-4.oc00.i686.rpm nss-softokn-3.23.0-4.oc00.i686.rpm nss-softokn-freebl-3.23.0-4.oc00.i686.rpm  --oldpackage
why not reporting possible traps in our github repos? As when we see no reports we move it to netlabs rel repo. And to be honest on my system and the testers system it seems stable and connects to all sites, but this might be luck. I don't know.

just to say it once again: no report on github or even netlabs trac there will be no fix.

regards
Silvan

Pages: [1] 2 3 ... 13