Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Joop

Pages: [1] 2 3 ... 41
1
Applications / Re: Java applications
« on: October 28, 2022, 09:26:23 pm »
Hi Joop

Sorry but I don't understand what .." "smell" around it " means.

In other words, there was a mismatch with the group which did the translation in Dutch up to eCS2.2. I heard this which is sad. From one I got a book which is usefull with translations. I translate programs, yes, translating can be time consuming and you have to run the program in order to see if the translation is right because English as language sucks because words can have very different meanings.

2
Applications / Re: Java applications
« on: October 28, 2022, 09:09:16 pm »
Hi Joop, I for one was sorry to see your site disappear. It was a useful resource for finding Java applications to run on eCS/ArcaOS. I checked it occasionally and I also thought your recommendations on how to make each program run (if it was possible) to be very useful.

Best regards, Thomas H.
Thank you for your visits to my site, I can set the site back, that is not a problem, the real problem is that many developers left Sourceforge due to their new policies. With it also the version which could run on Java 6 disappeared. Next Sourceforge did shift a lot of directories so that links don't work and they upgraded the site so it doesn't work any more with FF we have. Last, lot of developers deleted the versions which did run with Java 6. So in the end, setting my site back doesn't help much. If you have a Java program which won't run, put it up here. I still have OS/2 on a machine, just have to push the button. Today I'm typing on a Raspberry PI, the good news from that is that lots of Java programs from my site still do work fine with Java 11. Another thing I noticed is that lots of programs in U-nix are in fact beta or worse, no where near for public, but that is my oppinion, ask U-nix users and they disagree, where did we hear that before ;-). So, don't complain when it doesn't do what you want when your in OS/2, its not better in U-nix, its different.

3
Applications / Re: Java applications
« on: October 28, 2022, 08:52:19 pm »
The NLS versions do seem to be coming along, with it looks like EN, DE, ES, FR, IT, NL, RU at least will be available. I believe it is all volunteers doing the translating and there is a lot to translate.
I'm not speaking for Arca Noae so could be wrong
Sorry, lot to translate? Only totally new stuff, all other translations are already there. And doing the translation is also something with some lets say "smell" around it if I had understood the comments in the Dutch user group, many years ago, correct.

4
Applications / Re: Password manager
« on: June 04, 2022, 09:17:56 pm »
I don't know of any Java Runtime for iOS.

On my company server, I run Jetty (a Java web application server). If I knew of one, I could run a server side password manager written in Java (limited to the OS/2 OpenJDK port)

I suppose that would not be very secure, either.
There are some very nice search engines available, I use DuckDuckGo. Just type in "iOS Java" and you have some reading to  do.

Regards,
Joop

5
Applications / Re: Password manager
« on: June 03, 2022, 07:12:35 pm »
I'm not seeing a Java password manager running on iOS. Running Java means having a supported run-time, so both of my principle platforms are a problem.

I wish OpenJDK had a little more development on our platform. The Java approach is better than Qt, as you say, but we have a pretty up-to-date Qt, but not so much with Java.
I am a little disappointed, seems you never tried. The programs summed up in my previous answer are tested on the Java we have, that's version 6 and that's why they had a page on my home page. As far as I know iOS does have also a version with a low version number, certainly it will run there too. I have also tested UPM on my Windows machine and my Raspberry Pi 400 with both Java 11 and it runs there fine too, no problems. So there seems to be a wide spread of Java versions in which the programs run without a problem.

Another option is Firefox. Our Firefox45 does save passwords, and can be used as a password manager for Dooble or any other new browser that lacks a password manager. It's a very heavy client for just remembering passwords. Synchronizing used to be a problem, and I haven't tried for a while.
That's not a wise decision because the FF version seems not proof for malware. Never have your passwords inside a program which can go  online.

Regards,
Joop

6
Applications / Re: Password manager
« on: June 03, 2022, 12:12:00 pm »
I use eAccounts from Frank Wochatz: https://ecsoft2.org/eaccounts-account-manager
For a password manager it's important that its database can be copied/shared to/with other devices and OSs. That's the point Neil made also in his first post.
That's why I use Java, the program stays the same and can be used on every system which supports Java. With QT you have to recompile the source for your system, that's not portable in my mind. Further you have to think very carefully about having passwords in software which make contact with www in some way. Its not safe today, better have a password system which stands as a different program from which you can copy and past the necessary fields. No connection.

7
Applications / Re: Password manager
« on: May 31, 2022, 06:39:45 pm »
In Java are some available which will work with Java 6;
http://sourceforge.net/projects/upm/files/upm-1.14/upm-1.14.tar.gz/download
https://github.com/gaborbata/jpass/releases/download/v0.1.14a/jpass-0.1.14-dist.zip
https://sourceforge.net/projects/mypasswords7/files/binary/2.95/MyPasswords_2_95.zip/download

These where available on my site which is offline. UPM is at version 1.15.1, does work in Java 11, don't know if that's also true for Java 6.

I didn't test others, but there are more. You need latest version of Java available for OS/2 and that's Java 6.
As I'm migrated to a RaspberryPi for the time being, most of the tested programs runs also in Java 11 which is not available for OS/2 yet, but its good to know that you can migrate your programs and data to a complete other platform and it will work there too without changing anything. Of course you setup file for running is somewhat different because "batch" commands do differ between platforms. But that's it.

I don't know anything about QT, but it seems not that portable as Java. As far as  I know you have to recompile a program for your platform with QT.
I have no knowledge of programs which are "native" for OS/2 because I wanted a true portable system because I do have more platforms.

Regards,
Joop

8
Internet / Re: simble browser does not handle URL by domain name
« on: May 15, 2022, 07:31:59 pm »
The address is not a valid IP address, it has to be https://www.libero.it/

9
Applications / Re: Java applications
« on: May 14, 2022, 08:09:28 pm »
ArcaOS is NOT going to work with an ARM processor. It must be x86 capable.
I know, but as FF on OS/2 is to far behind I had to replace the system with a more recent browser in order to keep access to some systems.
Good to know that it runs on a singe processor system, but my system is about 16 years old and behind for more modern disks.

10
Applications / Re: Java applications
« on: May 14, 2022, 05:16:30 pm »
I'm surprised by your concerns about my health, thank you. To help that out of the world, I'm alive and still kicking and very pissed off when it comes to OS/2. Surprised because my site didn't receive any visits than only (ro-)bot-systems. So I took it off-line. It could be on-line in a minute or so (I hope, because my provider is eaten by its big brother). Only on-line won't be of much help. Let me explain.

I'm pissed off on OS/2 because its the fourth time they shift nationalized version for a year. So, now I'm waiting for four years. Still no sign when it will come, if ever! I want my OS in my language in case of trouble and want to understand what's going on. English sucks when it comes to pinpointing problems. Don't get me wrong, I'm not alone in this. Next I did donate a lot of money for the new browser. And what pissed me off was the message in the end that you need at least a system with two processors, because its big (my databases are also big, no problem there). I use a P4 with 1G. Everything runs happy. Including concurrent Java versions for testing. So, I need a multiprocessor motherboard, this gives the problem I have to buy a new computer. Fine, money, not really a problem, getting it the way I want it, dream on. New motherboard multiprocessor means a system with no bios. My OS/2 versions (whatever its called) do not understand multiprocessor. So I need a new OS/2 (whatever its called) that does understand multiprocessor. But we are not there yet. New motherboards which might be available in MY COUNTRY are all without bios. So I need an OS/2 (whatever its called) that can support this. And here is a line, its not there yet.

Lets  assume I get it running, so new computer, new OS/2, but we still facing problems. We don't have a browser which is rock solid and with which you can do your thing on the internet. Still lots of trouble. Lots of promises which can't or are not fulfilled. An installation system which sucks while OS/2 has a nice system that addresses such problems. With FF I have problems on sources for Java programs. Next "Source Force" seems to play a faulty game, that's why most developers are going to Github. But with this switch all old versions are gone too. And we still stuck with Java 6.0. Github is big, but sucks when it comes to a ui with good search options. I'm not interested in code, I want ready to run Java programs. Up to now I'm unable to get a search pattern in Github which will do just that. And then you still have to deal with lots of misinformation. Programs on my Java pages can't be reached anymore because or its moved to Github, or its moved to an other directory, or its erased or Source Force has thought out other things. For sure I can't go there anymore because of FF too old. So I can't maintain my Java pages anymore (updating links). If I want that, then I need a new computer, new OS/2 (whatever its called) and a new browser. With the present problems with chip shortage, war's and lock downs due to diseases its a no, no and no. So getting my pages back on line won't help, almost all llnks to programs are obsolete. And there are other wishes.

Right now I'm typing this on a Raspberry Pi 400, in EU it cost you Euro 85.= if available. Quad core, 4Gb, twin Video output, USB and so on. Its an ARM, so Linux X86 doesn't run, programs have to be recompiled to ARM. Got SysJoker too, but that was a no go. SysJoker expects X86 family and  my processor is an ARM, so with the installation I got corrupt messages. That micro SD-card is erased, I had a backup. If you have a Windows system, boot without connection to the internet, systems like SysJoker want to do their thing in the boot process. If you are complaining about quality of the programs in OS/2, let me assure you its even worse in Linux, whatever they say. The first four months I had to make my keyboard understand Dutch, understand that it had to mount my Wacom tablet every time after booting. Had to find a way in the bash script that I can run a Java program the way I want it and so on. In short, Linux structure sucks and they issue new programs which are no where near for public without even testing it. That said, there are also little gems, so its not all negative. Right now I'm translating the manual from FidocadJ to Dutch. With it I  also have to update the translation of the program.

That's it for short. I'm watching these pages in order to find out when there is a new OS/2 (whatever they call it) and then find a system on which it  can run.

11
Really, you need cookies to improve? What other bullshit can you tell us? No site never ever did improve by using cookies, never. Only false assumptions to sell illegal private property of your visitor. Well, I get really sick of this, so bye bye, have fun with your cooky shit.

12
Utilities / Re: QT5 Runtime
« on: April 23, 2021, 06:36:50 pm »
ivan, Joop,

Head on over to the GitHub HOME for QT5 => https://github.com/bitwiseworks/qtbase-os2

Scroll down a tad, you have the option to d/l the ZIP files as well.

I downloaded those files, but there are heavenly polluted. Still in all files for compiling, perl scripts from the original. What should I do with .dbg files? As far as I can imagine you can omit the directory "include". What are .pc files? The directory "mkspecs" is not for us when you are not in for compiling. And the list is going on.

13
Utilities / Re: QT5 Runtime
« on: April 22, 2021, 09:53:59 pm »
Ahh, that's all totally bull. You do rpm and all is going well. Well, rpm needs a list for yum which tells yum what to do. So what's the problem to give that list in ascii? They didn't complain when I send money as a contribution for the development of QT, so is it too much to listen to you customers who did donate money? The totally QT download is a big package with lots of stuff for the trashcan. How difficult is it to give an readme file with what files you need, what files are for some other purpose. Really, this is beyond me.

14
Applications / Re: Java applications
« on: March 06, 2021, 07:49:54 pm »
Give it a try!
Thanks, downloaded version 9.8, I'm not sure if this version will also run with Java 6 if I see on what date it did go pubic.
Okay, big package, lots of stuff which has to do with Windows, can be deleted to make room on your disk. Also complete JRE inside, can also be deleted. Even then, still a big program. Made a cmd file and I after starting that I got back that it needs version 52, that's some short for Java version 8. So a no go. Downloaded version 9.2 with
the remark that it runs in Java 6, but no, also here I get back version 52 ie Java version 8. Probably some versions down it will run, but with what bugs?

15
Internet / Re: Password Managers
« on: February 17, 2021, 11:10:46 pm »
You can also go to my Java pages, there are 4 Java programs which can hold your passwords. Have a look at http://joopn.home.xs4all.nl/os2ecs/ecs6eB.htm or in Dutch http://joopn.home.xs4all.nl/os2ecs/ecs6nB.htm. Of course you need Java 6. If that is not enough, let me know, there are more out there for Java ;-)

Pages: [1] 2 3 ... 41