Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Charles Hudson

Pages: [1]
1
Yes, the VLB machine is part of a collection of old iron.  The reason for using the Genoa card is because it is designed for a VESA system (has an extended slot on the motherboard) as is the DTC SCSI controller**.  I brought it out because I needed to use the PC to format a disk for use in another machine.  The OS install was performed in 2019 and the BIOS backup battery had gone flat from disuse.  Once I got the geometry set and booted to the OS I found the display "wavy".  It turned out to be a blown capacitor in the PSU; replaced PSU.

I have spent most of my working life using machines from the DR - CP/M and MS-DOS continuum.  I am fairly conversant with that topic but was curious to see what OS/2 could do.  I'm still making baby steps; I have found some resources, however, and I thank once again those who have responded.

May I ask, regarding fixpacks:  Must they be applied in order or is the latest an accumulation of all the previous issues?

-CH-

** Drive A: is 1.4MB 3.5 floppy, drive B: is 1.2 Mb 5.25 floppy, drive C: is 120 Mb Viking SCSI, drive D: is CDR.  Also on board,  ISA cards: Everex ser/par I/O, Intel 8/16 LAN card, SoundBlaster, SIIG I/O card.  VESA motherboards typically did not carry I/O ports or supporting hardware - you added your own.  As I can not invoke the system information utility, except for the drives  I have no idea whether these are recognized or configured by the OS.  Of particular interest are the serial ports.

2
If I go to system setup the only option I have for screen resolution is 640x480x16.  If I go to selective install then for display I have several driver options including the "blitter" (recommended by the Hobbes driver) for Cirrus Logic 5426.  It may be these drivers were installed when I tried to update the display driver (and failed).  I may also have selected "generic VGA" when setting up the machine, thinking I could change it later.

If I invoke the system information tool I get an error screen.

Screen shots attached.

-CH-

3
Thank you all for your responses.

The machine is running OS/2 Warp 3 on a VESA local bus motherboard.  No fixpacks have been applied.

The video card is a Genoa Windows VGA 24 (model 8500 VL) which features a Cirrus Logic CL-GD5426 chipset.  I downloaded the driver file for this chipset from Hobbes, read the README files and tried to install the driver.  Installation of the files went well until I was asked to specify the monitor; I couldn't, and the install left me with an unstable system.

The Genoa card probably came with a supplemental or "utility" disk when packaged by the manufacturer, but if I recall correctly this card was purchased second-hand from eBay and no disk was supplied.  Furthermore, the Viewsonic display didn't exist when the card was produced, so I would have to find an analogue.

The default display parameters for the OS are VGA 640x480 256 colors.  I know the Genoa card can do better and was trying to find a better resolution and bit depth.  But, as I say, I am not very experienced with the OS and don't really know what's possible or how to achieve it.  I thank you all for your help.

-CH-

4
As you described:  When the white rectangle appeared in the upper left corner of the screen, pressing ALT-F1 brought up a menu of options; one of which, "V" forced the machine to reinstall VGA.  The machine has done so successfully and I now have a desktop on the display.

Thank you indeed for your assistance.

The Genoa card uses the Cirrus Logic CL-GD5426 chipset, according to the information I found, but apparently there is another software tool to identify the monitor that is on a utility disk.  As the monitor I have attached to the machine is a Viewsonic LCD I don't think I would have found it anyway.  I do have other CRTs, however.

Eventually I would like to upgrade to Warp 4.52 but I think I'll get a little more familiar with the OS first.  Thanks again for your help.

-CH-

5
Setup & Installation / How to reverse a failed driver installation
« on: May 11, 2021, 12:54:50 pm »
I need to reverse a failed video driver installation which has resulted in a general protection fault (trap: 000d, errc: 0000, exception SINGLEQ$) that prevents the machine from booting.  I am completely inexperienced ("noob") with OS/2 but I installed V3 on a '586 VLB machine and had a running system until I tried to install a video driver for the Genoa Windows VGA 24 VLB video card.  I found the driver on the Hobie(?) site and got halfway through the install before it failed.  The install mentioned saving the original files but didn't say what they were named or where they were saved.

I have a boxed set of OS/2 2.1 with disks and a manual.  With the help of these materials I am able to at least get the machine to a command prompt and access the C: drive, but from there I am unsure how to proceed, not knowing enough about the file structure or command syntax to search for most recently modified files.

Suggestions welcome, thanks.
-CH-

Pages: [1]