Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Pete

Pages: [1] 2 3 ... 76
1
Hi Glenn

Are you using a multiprocessor system? - Just wondering if using markexe.exe (from os/2 toolkit) to "mark" the executable (dux.exe ?) as mpunsafe will help...


Regards

Pete

2
Applications / Re: Test build of dooble with qt5
« on: May 13, 2022, 09:00:53 pm »
Hi All

Having just had to login again the earlier tip by Dave Yeo about setting cookie policy to Save All does not seem to cure this problem.
Any other ideas?

Regards

Pete


3
Off Topic discussions / Re: Slowing Down But Not Hitting the Brakes
« on: May 13, 2022, 07:09:26 pm »
Hi Martin

Condolences to you and your family


4
Applications / Re: Test build of dooble with qt5
« on: May 11, 2022, 08:26:19 pm »
Hi Remy

Might be worth checking the following are installed, replace any i686 versions with P4 versions

libxslt  - 1.132-1 P4
libxml2  - 2.9.10-3 P4
libssp  - 9.2.0-5 P4
libstdc++  - 9.2.0-5 P4
libc  - 0.1.10-1 P4
libgcc  - 9.2.0-5 P4
libgcc-fwd  - 9.2.0-5 P4
libicu  - 68.1-1 P4


Other than that I am out of ideas...


Regards

Pete

5
Applications / Re: Test build of dooble with qt5
« on: May 11, 2022, 03:15:08 pm »
Hi Remy

I saw your video and was surprised to see Dooble crash almost immediately on opening a page. I never had Dooble crash that quick, I usually got at least 10 minutes use before it crashed. It does suggest a support package may not be at a required level. Checking my notes these are what I needed to update to extend Dooble uptime here

Replaced libcx and libgcc packages (pulls in gcc-stdc++-shared-library, libgcc-fwd, libssp, libssp-fwd, libstc++) with P4 versions- were i686

libicu is current release, libxslt is previous release - all P4 versions

The above resulted in Dooble running for around 30 to 40 minutes before crashing - without an exceptq log.

I updated pthread package to 0.2.6-1 P4 a couple of days ago and that seems to give me more Dooble "uptime" before Dooble simply disappears - watched a 45 minute video and browsed ebay for over 30 minutes without a crash, I actually closed the browser rather than it closing itself. Has not resolved the problem completely though as Dooble does still disappear without obvious cause.


When Dooble crashes there are no exceptq logs produced here - you can make Dooble produce a log by starting from the command line. Open a window in \usr\bin  - or wherever dooble.exe is located - and enter

dooble.exe 2>&1 | tee dooble.log

which should produce a dooble.log in the dooble.exe directory. Not sure if it will be of any use as the logs produced here seem to be full of javascript errors...


Looking at your video I also see your installation does something my Dooble cannot do: Open a webpage in the only tab after starting. Attempting to load a webpage from Favourites, History or entering a url results in Dooble loading the page but failing to display it - the page is loaded but blank! Usually takes opening another tab or 2 before I can get any webpage to load *and display* - and, No, using Reload does not display the content of the blank page.


Hmm... browsing ebay... seems some ebay options are simply not visible with Dooble unless you know where to put your mouse pointer and click. I am looking at this page  https://www.ebay.co.uk/sch/i.html?_from=R40&_trksid=p2380057.m570.l1313&_nkw=proac&_sacat=0  and notice the box that should display the List or Gallery view option is blank - that is the empty box to the right of the box containing the text Best Match. This is probably the same problem with SVG as mentioned in this discussion https://www.os2world.com/forum/index.php?topic=3058.msg34767


How do I get os2world forum to "remember me"? - I login with the Forever option but next time I visit I have to login...


Regards

Pete

6
Applications / Re: Apache Open Office 4.1.8 Crash
« on: May 06, 2022, 09:27:13 pm »
Hi roberto

No, Ii definitely do not have that file anywhere.
Possibly an application created that file on your system so *before* deleting make a backup somewhere.


Regards

Pete


7
Applications / Re: Apache Open Office 4.1.8 Crash
« on: May 06, 2022, 06:48:56 pm »
Hi roberto

I would give that a try except I do not seem to have a xslt-config file anywhere...
What directory did you find the file in?


Regards

Pete

8
Applications / Re: Test build of dooble with qt5
« on: May 06, 2022, 02:37:39 pm »
Hi ivan

No, there is not a version of NoScript- but Daves "block list" posted above and only recently imported into Dooble here certainly helps block adverts on the few sites I have tried so far some of which are almost hidden by adverts otherwise.

Now, if I can get Dooble to run for longer than around 30 minutes - logs show js errors as last entries, maybe using the "block list" will reduce those errors. Will have to test...


Regards

Pete



9
Applications / Re: Apache Open Office 4.1.8 Crash
« on: May 06, 2022, 01:58:44 pm »
Hi Wayne

After updating lots of packages in order to try Dooble I found AOO 4.1.7 would no longer start - splash screen shows then app exited.

I initially thought libicu need backleveling but that did not cure the problem.

Then I remembered from trying SimpleBrowser that libxslt is also a possible problem. Sure enough, backleveling libxslt to 1.1.32-1(oc00) resolved the problem - currently using libicu 68.1-1 without problems.


Regards

Pete


10
Applications / Re: Test build of dooble with qt5
« on: May 04, 2022, 03:21:22 pm »
Hi Silvan

When Dooble simply closes - as experienced by mauro, Remy and myself - no trp files are generated.

If Dooble is started from the command line using
dooble.exe 2>&1 | tee dooble.log
A log does get generated but no trap file.

I have several dooble log files that show  js errors as the last line eg:-

js: A cookie associated with a cross-site resource at http://youtube.com/ was set without the `SameSite` attribute. A future release of Chrome will only deliver cookies with cross-site requests if they are set with `SameSite=None` and `Secure`. You can review cookies in developer tools under Application>Storage>Cookies and see more details at https://www.chromestatus.com/feature/5088147346030592 and https://www.chromestatus.com/feature/5633521622188032.
js: 'window.webkitStorageInfo' is deprecated. Please use 'navigator.webkitTemporaryStorage' or 'navigator.webkitPersistentStorage' instead.
js: Uncaught TypeError: Cannot read property 'postMessage' of undefined


I may have been trying to watch or pause a video here:-

This plugin does not support setParent!
js: The disableRemotePlayback attribute should be used in order to disable the default Cast integration instead of using -internal-media-controls-overlay-cast-button selector. See https://www.chromestatus.com/feature/5714245488476160 for more details.
js: The disableRemotePlayback attribute should be used in order to disable the default Cast integration instead of using -internal-media-controls-overlay-cast-button selector. See https://www.chromestatus.com/feature/5714245488476160 for more details.
URL scheme handler already installed for the scheme: gopher
This plugin does not support setParent!
URL scheme handler already installed for the scheme: gopher
This plugin does not support setParent!
js: A cookie associated with a cross-site resource at https://www.google.com/ was set without the `SameSite` attribute. A future release of Chrome will only deliver cookies with cross-site requests if they are set with `SameSite=None` and `Secure`. You can review cookies in developer tools under Application>Storage>Cookies and see more details at https://www.chromestatus.com/feature/5088147346030592 and https://www.chromestatus.com/feature/5633521622188032.
URL scheme handler already installed for the scheme: gopher
This plugin does not support setParent!
URL scheme handler already installed for the scheme: gopher
This plugin does not support setParent!
js: <link rel=preload> must have a valid `as` value


Possibly of interest: When a trap file is generated it has this filename format 62667a10-0055_1e-DOOBLE-exceptq.txt so people should not search for *.trp files in relation to dooble but should search for *DOOBLE-exceptq.txt


Regards

Pete



11
Applications / Re: Test build of dooble with qt5
« on: May 02, 2022, 07:34:50 pm »
Hi All

I replaced libcx and libgcc packages (pulls in gcc-stdc++-shared-library, libgcc-fwd, libssp, libssp-fwd, libstc++) with P4 versions - they were i686 - and have had Dooble running for longer than 15 minutes at a time.

 @mauro: You may want to check if the above helps.

Looking at the last log generated I see quite a few lines like this:-

js: A cookie associated with a cross-site resource at http://youtube.com/ was set without the `SameSite` attribute. A future release of Chrome will only deliver cookies with cross-site requests if they are set with `SameSite=None` and `Secure`. You can review cookies in developer tools under Application>Storage>Cookies and see more details at https://www.chromestatus.com/feature/5088147346030592 and https://www.chromestatus.com/feature/5633521622188032.
js: 'window.webkitStorageInfo' is deprecated. Please use 'navigator.webkitTemporaryStorage' or 'navigator.webkitPersistentStorage' instead.
js: Uncaught TypeError: Cannot read property 'postMessage' of undefined


Could the last line be responsible for Dooble closing?


Regards

Pete



12
Applications / Re: Test build of dooble with qt5
« on: May 01, 2022, 01:49:03 pm »
Hi All

The real downside to Dooble here is that it closes after 10 to 15 minutes use - no beeps,squeaks or log files. Dooble can be restarted immediately for another 10 to 15 minutes use.

I was presuming it is NSS/NSPR related - the same problem Mozilla has with the latest NSS/NSPR - but if others are not having this problem maybe it is not.
What versions of NSS/NSPR are other people using? - I currently have NSPR 4.23.0-1 and NSS 3.47.0-2  installed.

If not a NSS/NSPR problem what else should I look at?


Regards

Pete

13
Applications / Re: Test build of dooble with qt5
« on: April 28, 2022, 10:21:36 pm »
Hi klipp

Glad you got Dooble running - I cannot take any credit as Tom pointed me in the right direction a few days ago  :-)

Regards

Pete


14
Applications / Re: Test build of dooble with qt5
« on: April 28, 2022, 04:15:49 am »
Hi klipp

I wonder if you are hitting the same problem I found: ANPM here was set as Platform i686 so the qtweb packages were not found. If so add P4 to the Platform - I moved it to the top. I then restarted ANPM and the "missing" qtweb packages appeared.


Regards

Pete


15
Applications / Re: Test build of dooble with qt5
« on: April 27, 2022, 01:23:01 pm »
Hi All

I am currently trying Pauls gcc11 build which works reasonably well but suffers from the following problems. I suspect they are common to all current Dooble for OS/2 builds...

1] A tendency to simply close after a little use - seems very like the NSS problem suffered by Seamonkey/Firefox. Maybe this can be sorted in the same manner as Dave has with his recent Seamonkey/Firefox releases that sufffer less from this problem.

2] Unable to display a page loaded from History or Favourites lists - browser goes through the loading motions and seems convinced that the page is loaded but nothing is displayed. Copying the url from the "loaded" page to a new tab results in the new tab displaying that page content.

3] There does not seem to be any way of importing Bookmarks and Passwords.

4] Some keys seem to be ignored - definitely the Delete key and I am sure there was at least 1 other key but did not make a note at the time and have forgotten which key...
Aha! I see Doug has spotted the problem as wel,l it is the Insert key. He also notes that there is a problem with the Caps Lock key.


There are probably a few more problems to find...

Oh, Yes. A port of NoScript would be good - I suddenly find I am seeing adverts I did not know existed on lots of websites.


On the plus side: More websites work without problems compared to Seamonkey.


Thanks to all involved in the various ports of Dooble.


Regards

Pete

Pages: [1] 2 3 ... 76