Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Neil Waldhauer

Pages: 1 2 [3] 4 5 ... 57
31
Applications / Re: Test build of dooble with qt5
« on: May 04, 2022, 08:44:30 pm »
I tried to use PayPal, and dooble crashes when it accepts a cookie. I authenticated, and it takes a cookie, but it crashes as soon as I try to make an invoice.

Firefox 45 used to work a few weeks ago, but it stopped working. It's encouraging to have the new webengine, but it's not what I would recommend as a good browsing experience.

My bank simply won't take dooble for login, but says, not very helpfully, that an error occurred.

I'm looking forward to improvements. (Edit: when I reopen the browser and try again, PayPal is working fairly well.)

32
Applications / Re: Test build of dooble with qt5
« on: May 04, 2022, 03:13:55 am »
https://github.com/textbrowser/dooble/tree/master/Documentation

Dooble.odt downloads just fine in Firefox.

33
Applications / Re: Test build of dooble with qt5
« on: April 24, 2022, 03:49:03 pm »
I'm able to run the test build on ArcaOS 5.0.7 that I already had Otter running. I did need to run Dave Yeo's mark_high.cmd to log into OS/2 World. Posting from dooble!

34
Utilities / Re: zip for Warp 4
« on: April 22, 2022, 09:24:02 pm »
That seems unlikely, Doug. Your zip2.exe identifies itself as Zip 2.31 (March 8th 2005)
Martin's zip.exe announces itself as Zip 3.0 (July 5th 2008)

Both of them would be fine on Warp4, according to PMDLL.

35
Utilities / Re: zip for Warp 4
« on: April 22, 2022, 03:22:31 pm »
Hi Neil

I think that on a very plain Warp 4, zip.exe 3.0 will work.
Do you want to try it? here it is attached.

Regards

This one looks good, but where is it from?

36
Utilities / zip for Warp 4
« on: April 21, 2022, 06:35:24 pm »
I want to run zip.exe on a system that lacks networking. Zip version 2.3.2 fails because the system lacks NETAPI.DLL. Is there another zip I can use?

(Note: rpm/yum works better on machines with a network)

37
I think we can probably get enough cores in one machine. The Ryzen ThreadRipper 3990X desktop PC processor already has 64 cores, the maximum possible with the OS/2 kernel.

What might help more for building the browser is cross compiling to OS/2 on a 64 bit platform.

38
Internet / Re: New Browser Delay Discussion
« on: April 15, 2022, 04:26:32 pm »
I tried Dooble on Ubuntu, and it isn't that much more stable than Firefox 45 on OS/2. But it works on modern websites. I'll bet something can be made for our environment that is good enough.

I see a lot of users on the sidelines, looking for a chance to move to an OS/2-based platform. Once we have any kind of reasonable browser, the most important obstacle will be removed for these people to make their move.

39
Internet / Re: Dooble works fine but does have some flaws
« on: April 08, 2022, 03:41:10 pm »
Looking at Dooble, I can't see any password management. Yet the help implies some password handling. What am I missing? Do we need to adopt a password manager to use Dooble effectively?

(edit: it looks like an external password manager would be the best option.)

40
Setup & Installation / Re: Airboot, Linux and ArcaOS
« on: March 31, 2022, 04:04:08 am »
I used DFSee to wipe the first part of the Ubuntu disk. After rebooting, I created /boot 512 MB FAT32 and all the rest in a root volume. I even formatted the FAT32 volume.

Then I booted the Ubuntu DVD, and installed specifying the /boot and the / in the installer.

Everything works as advertised. Thanks!

41
Setup & Installation / Airboot, Linux and ArcaOS
« on: March 30, 2022, 04:49:31 pm »
I want to install a system with Ubuntu and ArcaOS in a multi-boot configuration. But ArcaOS has one idea of disk geometry and Ubuntu another. If I use AirBoot, Ubuntu responds with "Load Error", which is not helpful.

Given ArcaOS already installed on hard drive 1, how can I get Ubuntu to boot on hard drive 2? The computer BIOS doesn't give that option. This really ought to be easy with the right boot manager.

42
Applications / Re: Scribus on ArcaOS
« on: March 25, 2022, 04:10:48 am »
Abandoning Scribus rpm until it migrates to rel.

43
Applications / Re: Scribus on ArcaOS
« on: March 23, 2022, 05:22:29 am »
I think there are problems updating. Martin mentioned something.

Code: [Select]
Executing: @python2.7 F:\SYS\APPS\ANPM\scripts\yum_update.py
Running Transaction Check
YumRPMCheckError(): [u'ERROR with transaction check vs depsolve:', 'git = 2.30.2-2.oc00 is needed by perl-Git-2.30.2-2.oc00.noarch', 'perl-Git = 2.11.0-4.oc00 is needed by (installed) git-2.11.0-4.oc00.i686', 'git-core = 2.30.2-2.oc00 is needed by git-core-doc-2.30.2-2.oc00.noarch', 'git-core-doc = 2.11.0-4.oc00 is needed by (installed) git-2.11.0-4.oc00.i686', 'qt5-qttools-common = 5.13.1-1.oc00 is needed by (installed) qt5-qttools-5.13.1-1.oc00.i686', 'qt5-qtbase = 5.15.2-1.oc00 is needed by qt5-qtbase-common-5.15.2-1.oc00.noarch', 'qt5-qtbase-common = 5.13.1-1.oc00 is needed by (installed) qt5-qtbase-5.13.1-1.oc00.i686', u'Please report this error at https://github.com/bitwiseworks/rpm-issues']
Error: ERROR with transaction check vs depsolve:git = 2.30.2-2.oc00 is needed by perl-Git-2.30.2-2.oc00.noarchperl-Git = 2.11.0-4.oc00 is needed by (installed) git-2.11.0-4.oc00.i686git-core = 2.30.2-2.oc00 is needed by git-core-doc-2.30.2-2.oc00.noarchgit-core-doc = 2.11.0-4.oc00 is needed by (installed) git-2.11.0-4.oc00.i686qt5-qttools-common = 5.13.1-1.oc00 is needed by (installed) qt5-qttools-5.13.1-1.oc00.i686qt5-qtbase = 5.15.2-1.oc00 is needed by qt5-qtbase-common-5.15.2-1.oc00.noarchqt5-qtbase-common = 5.13.1-1.oc00 is needed by (installed) qt5-qtbase-5.13.1-1.oc00.i686Please report this error at https://github.com/bitwiseworks/rpm-issues
YumRPMCheckError()
Return code: 0

44
Applications / Re: Scribus on ArcaOS
« on: March 22, 2022, 02:31:15 pm »
Sometimes I forget the obvious: Popuplog.OS2 is full of Scribus entries.

03-20-2022  17:03:09  SYS2070  PID 00c9  TID 0001  Slot 0014
F:\PROGRAMS\SCRIBUS\SCRIBUS.EXE
SCRIPTPL->PYTHON27._PyUnicodeUCS2_FromEncodedObject
127
------------------------------------------------------------

03-20-2022  17:06:30  SYS2070  PID 00ce  TID 0001  Slot 007f
F:\PROGRAMS\SCRIBUS\SCRIBUS.EXE
SCRIPTPL->PYTHON27._PyUnicodeUCS2_FromEncodedObject
127
------------------------------------------------------------

03-21-2022  06:41:25  SYS2070  PID 004e  TID 0001  Slot 0041
F:\PROGRAMS\SCRIBUS\SCRIBUS.EXE
SCRIPTPL->PYTHON27._PyUnicodeUCS2_FromEncodedObject
127
------------------------------------------------------------

These entries are from the attempts to run 1.4.4 and 1.4.5. There are no entries for F:\USR\BIN\scribus.exe, which would be 1.4.6.

45
Applications / Re: Scribus on ArcaOS
« on: March 22, 2022, 03:05:23 am »
Hi
Did you try the rpm package 1.4.6 ?

Where is that located?


Apparently it is in netlabs-exp

I enabled netlaps-exp and installed scribus. it fails on the splash screen loading a plugin. The screen disappears before I can read any more details.

Pages: 1 2 [3] 4 5 ... 57