Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Glenn

Pages: [1]
1
Applications / Archive tool problem
« on: May 05, 2024, 07:31:12 pm »
Hello all,

I have a problem with Archive Tool: it does not start anymore. No error message on command line either, no error in popuplog.os2.

I looked in the package manager and the reinstall option is grayed out. Only uninstall cannot be chosen, which I prefer not to (the wpi list of available packages appears empty, which is was not last week.. so something may have messed up my installation).

Any idea how to fix that problem?

2
Applications / WordPro issues
« on: May 05, 2024, 07:27:44 pm »
Hello all,

Somehow, WordPro started having some issues, without my touching any setting nor doing any update:
- When creating a blank file, it complains that it cannot open the default.mwp (that, I checked, is in its folder, and I copied one from another installation, to no avail)
- The icons at the top have all disappeared.Ctrl+q (or the equivalent menu) does not change anything, that menu never gets selected.

Any idea how to fix that?

3
Virtualization / ArcaOS in VirtualBox and mouse.
« on: April 04, 2024, 09:29:57 am »
I have a strange behavior from the mouse with ArcaOS 5.1 installed in VirtualBox (with standard properties of the VM / of the installation).

The pointer moves everywhere, but on the desktop, icons located in the bottom-half part of the screen cannot be clicked on. I have to click on other icons above then go with the keyboard to the folder I want to open/the app I want to start and open it with the enter key.
The xCenter at the bottom is working fine, so it seems to be specific to the desktop; it also affects full-screen win-os/2 sessions, in which nothing in the bottom-half of the screen is clickable. On Win-OS/2, the pointer also moves more randomly, sometimes it becomes difficult to click on a button even in the top half of the screen, because the pointer will go too high (or too low) and moving it towards the place to click on moves it too far.

I remember problems with VBox extensions in version 7 so I kept the version of extensions that come with VBox.

Are these known problems? Are there any known ways to solve these problems?

4
Networking / Netdrive and ArcaOS
« on: April 03, 2024, 01:13:48 pm »
Is the version of NetDrive included in ArcaOS the full version, in which many different plugins may be installed?  If yes, what is the name of the program that controls all of that (I have been out of the OS/2 ecosystem for a while, just getting back from time to time..)? If no, can one install the conventional netdrive without creating conflicts?

5
Applications / eCs 1.x & SmartSuite
« on: March 27, 2024, 04:50:02 pm »
Hi all,

I am reinstalling my ArcaOS VM and some of my eCS-originating programs..

1. Does anyone remember on which eCS CD SmartSuite was located, and for which versions of eCS (before it was replaced by openoffice)?

2. Someone has uploaded the 3 CDs of eCS 1.0 to Archive.org. This is the US version, when the one I bought at that time was the version with the CDs made by Mensys (in their usual green cardboard pouch). What are the known differences between both versions?

3. At the time (must have been around 2000-2001), I had ordered eCS early enough to get a sort of 1CD beta before the final one was released. I remember it also had some programs that did not make it to the final one. Anyone has any idea ?

4. I started making/keeping the ISOs of all eCS versions to which I had access since 1.1, but I am missing the ISOs of the beta and of 1.0, and I lost the CDs. 7 years ago, when I emailed Mensys about the inability to redownload my CDs, Menso answered

 “I am sorry to say that our download system is currently in maintenance. We are working on it!

I have forwarded your e-mail to info@ecomstation.com. They will send you a quote for the latest version of eComStation.”
Needless to say, the eCS download system never got out of “maintenance” and the forwarded request was never answered. Would someone have ISOs of the Mensys-version of eCS 1.0, and if possible of the preceding beta?

Thanks !

6
Storage / Virtualbox - LVM stopped working
« on: February 09, 2023, 09:48:21 am »
Hi all, I have my ArcaOS on VirtualBox, and everything was working fine, until yesterday when I saw that my second virtual HDD was not here anymore. I tried running LVM GUI, and nothing happened. Went to command line, and running the lvm command shows that it does not work anymore.. no idea why (maybe some INI cleanup at boot time that messed up an LVM-related setting?).
Has anyone experienced that problem ? If yes, how did you solve it?
Thanks for any help!

7
Applications / Future of Linux ports
« on: October 02, 2022, 10:53:56 am »
Hi all, On tech forums everyone is talking about Rust making it to the Linux kernel, which probably will mean more and more programs that will be Rust-based.
In the Firefox discussions, I read it was impossible to port Rust to OS/2. I’d like to better understand why, because I see that as an increasing difficulty to make OS/2 apps by porting Linux ones…

8
Applications / VisualAge for C Modern Installer
« on: September 21, 2022, 12:18:10 am »
Yes, it would be nice, but QtCreator is not a generic IDE. It's tailored to Qt development.

Thanks Joche, I guess you are right. I download it and I don't see any generic Non Qt project on the list.

I guess if we are dreaming we should aim for the Eclipse IDE and/or Apache Netbeans, right?

Regards

Well, from a non-commercial POV this is probably the best solution one can seek imho. On the "abandonware" side the best editors for OS/2 are the VAC 4 IDE and (AFAIK) Visual SlickEdit, together with I seem to remember VisualAge for SmallTalk.

There was some talk about how to retrieve at least Visual SlickEdit, but nothing more.
Mentore

Talking about VAC.. is there any way to convert Feature Installer based installers to something more modern, so programs like VAC could be installed without having to use Netscape ?..

9
Applications / HOBLink and ArcaOS
« on: September 18, 2022, 01:05:38 pm »
Hi,

How does one install / start on ArcaOS the HOBLink X11 version that was included with eCS ?

During the install, I get a "fatal error : cannot load C:\HOBX11\xwpdllid.dll" pops up (the file is present in the folder). That makes the installer stop, but after I copied the files from an eCS installation (and added the registration info to the registry), the message is the same when trying to start the X server.

Additional strange thing (but not a showstopper): the installer defaults to D:\HOBX11, even though I have no drive D on my ArcaOS VM...

Thanks for any tip!

A.

10
Hi all, when trying to run the good old American Heritage Dictionary (published by DUX) on ArcaOS 5.0.7, I get a SYS3175 with PMMERGE.DLL, the app does not start. Googling for that error gives many results with people mentioning similar problems. There are also patched versions of PMMERGE.DLL but all much older than the current ArcaOS version, that may or may not have integrated this patched version. IIRC this problem happened with eCS too but not with the original Warp 4.

Was there a known solution / workaround to be able to start such programs on current versions of the OS?

11
General Discussion / Is the arcanoae website in maintenance ?
« on: March 21, 2022, 01:40:24 pm »
Hi all, I cannot seem to be able to access the www.arcanoae.com since this morning, whether from my home wired connection or 4G phone.
Is it a planned maintenance, or is there another problem ? Anyone can access it?

12
Setup & Installation / old eCS CDs
« on: October 25, 2019, 10:10:17 pm »
Hi,

I was looking for the last SmartSuite updates, which were on some eCS CD (links on ecomstation.com have been removed), and I realized that I had not made an ISO backup of the old eCS CDs (only of the serial numbers): 1.0GA, 1.1, 2.0GA (mainly the releases that came by post on CDs, that I subsequently lost in a flood). I did backup 1.2MR, 2.1, CD1s of 2.0 RC4/RC5/RC6a.

The ecomstation.com website has a link for 2.0GA but that ftp is empty. The links for 1.0 (and its precious CD3) and 1.1 have been completely removed, and the Mensys website also removed the links to what was hosted on their website, so I cannot re-download any of the missing ISO files. I had sent an email to the eCS support a long while ago and Joachim Benjamins answered me "Unfortunately, we do not have the older eCS versions available for download anymore. All we have presently available is version 1.2 and 2.0/2.1. If you insist I may be able to retrieve the old ISO files and publish them for you somehow, but this would take considerable effort." I did not insist, maybe I should have...

Would someone be able to share these ISOs somehow (all CDs for 1.0, 1.1, 2.0)?

Bonus question: Does anyone remember where the SmartSuite updates (to 1.7.2 and 1.7.3) are located?

Thanks!

13
Setup & Installation / Installing HPFS386 on ArcaOS
« on: October 25, 2019, 08:34:21 pm »
Hi,

I've been trying to install HPFS386 (with the same installer I used in eCS years ago) on ArcaOS, to use on a small partition dedicated to old programs that do not like JFS or even HPFS>2Gb, but I get the following message:
"SYS1804: The system cannot find the file RLANUTIL."

That's an error I never got on eCS where HPFS386 install worked every time I needed to reinstall my system. Strangely, if I look for an RLANUTIL.DLL on eCS, I also don't find that file.

Anyone would know how to make it work?

Thanks!

A.

14
General Discussion / Older eCS downloads
« on: September 19, 2015, 05:34:11 am »
Hi all,

Would anyone know where to download the old eCS 1.0 or 1.1 CDs? IIRC, the Application Pack had some pieces of software that were not included with later releases (maybe HobLink, or SmartSuite, that I cannot remember..). Mensys still has "eComStation 1.1 Entry + Application Pack Media Pack English for Upgrade Protection Customers (no shipping costs) (CD1, CD2, CD3)" listed on my account, but then it only shows "Download currently not available, our apologies for the inconvenience". No better luck on the ecomstation.com website...

Thanks for the help!

A.

15
General Discussion / eCS for home-made NAS / file server
« on: September 19, 2015, 05:18:23 am »
Hi all,

It has been quite some time I have not used eCS (after it refused to install properly on my current laptop, bought 4 years ago..), so I am a bit out of phase with what has happened in the meantime, whether in terms of improvements, new apps, or new sales circuit (I have seen the Arca Noae posts but without really understanding what happened to SSI or Mensys).

Now let's get to the point of my question... When I was shopping for a new NAS enclosure today, the seller tried to convince me that building my own file server would be cheaper and better than the fancy Sinology or Qnap I was looking at. It may very well be true. While these file servers have their own, usually quite intuitive software OS to manage them, the seller told me that a well-configured Linux could also work, and I wondered if someone has already tried making a NAS / file server with eCS that would run flawlessly on modern hardware while providing the same kind of interface as the commercial solutions. After all, WSeB was known to be a pretty good server OS (although as a non-IT professional, some of the options kept me confused...).
Would a WSeB or eCS solution support hot swap of hard drives? Creating RAID arrays? Are there already some easy-to-install software packages that would set-up the web interface used to configure the various types of access to the data?
Has someone already done that and could share the experience (in terms of hardware configuration requirements, steps to follow, etc)?

Maybe this topic has already been discussed in the past few years, in which case redirecting me to the good forum page would be the best answer!

Thanks in advance for the help!

Sincerely,

A.

Pages: [1]