Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Martin Iturbide

Pages: [1] 2 3 ... 310
1
Applications / Re: Experiment: Moving OS/2 Graphic/MM Resources
« on: July 15, 2024, 05:06:03 pm »
Just one question, when you say "If I unpack WPCONFIG.DLL", what procedure are you doing there?

Sorry, I should explain myself better.
The right question is - What procedure are you doing there to know the information of the DLL that shows you the text string "STARTFOLDER=?:\OS2\POINTERS" from WPConfig.DLL?

I want to see if I can learn more about what information can I get from DLLs.

Regards

2
Multimedia / Re: OS/2 (Startup) Sounds
« on: July 14, 2024, 06:20:39 pm »
https://drive.google.com/file/d/1vJieRgZ5SkS9o7mw946nvIogELAFfyQB/view

Hello. The link is not public, it request for your to approval the access. It is something that always happens with the Google Drive GUI that is confusing.

Reards

3
General Discussion / Re: gmail validation is not supported ?
« on: July 14, 2024, 04:17:55 pm »
Hello

I changed you email by hand. But I will have to keep looking for the email sending issue on the forum.

Regards

4
General Discussion / Re: gmail validation is not supported ?
« on: July 13, 2024, 06:05:12 pm »
Hello  KO Myung-Hun

I don't understand the issue. The OS2World forum has some limitations and sometimes I found issues sending emails. I can not update the forum script, because Firefox 45 does not work on it.

Are you trying change your OS2World forum password?  Feel free to write to martiniturbide -at- gmail.com.

Regards




5
Applications / Re: Experiment: Moving OS/2 Graphic/MM Resources
« on: July 13, 2024, 05:09:09 pm »
Thanks for the feedback Lars.

I get that is hardcoded on WPConfig.DLL.

Just one question, when you say "If I unpack WPCONFIG.DLL", what procedure are you doing there?

Regards

6
Applications / Experiment: Moving OS/2 Graphic/MM Resources
« on: July 12, 2024, 04:58:47 pm »
Hello

I want to make a little experiment of moving the graphics resources like BMPs, Pointers, ScreenSavers to a different folder structure. This is just an experiment to for me try it out and document things on the wiki.

I'm looking forward to see what problems gives me ArcaOS-OS/2 and see if a workaround can be found. I will be asking for help here and you are welcome to try it yourself too, but remember I'm not pointing a gun for everybody to try it out.

I want to start with Pointers. I want to move C:\OS2\POINTERS to C:\RESOURCES\POINTERS as part of the experiment. My first issue is that the "Load Set" on the "Pointers" settings will break up. Is this locations stored somewhere on an INI file that can be updated to the new path?

Regards

7
Applications / Re: David's Doodles
« on: July 12, 2024, 03:42:27 pm »
Hello David, that is a very nice logo inspired on the OS/2 2.x boot.

Regards

8
Hello TJ

I'm trying to make it to Warpstock this year, but I won't talk about virtualization if I make it. But it is a good subject, and it is something I use everyday.

I use ArcaOS in VirtuaBox VM because I do some software testing organizing some old files that I want to upload to Hobbes Archive.

I use the VM to run and test software, and some of that are intrusive with changes on the config.sys, changing the boot dekstop, and it is software I just want to test, check it out if it works and sometimes just remove from my system since I don't like. In real hardware reverting the OS takes some time, in a VM is just a quick return to a previous snapshot and it is like nothing happened.
 
I also remember the old days of taking images of real hard drives, creating diskettes for drivers, etc. Now on a VM I just emulate the HDD and diskette drive, copy and backp the virtual HDD, if I need something.

So, I think that virtualization has helped me a lot with OS/2 and the hobbes archive reorganization.

Regards

9
Programming / Re: GCC - updates
« on: July 08, 2024, 10:13:11 pm »
Hi Paul.

I'm sorry I can not provide much feedback here because of my lack of skills on this area, but I appreciate a lot your efforts in something as important as porting this compiler, and thanks for sharing your progress.

Regards

10
Applications / Re: XWP Problem - Shut down
« on: July 03, 2024, 10:06:24 pm »
Hello Ivan

Just in case, can you check the settings first to rule out is not a configuration problem? Check on the desktop, right click and "Properties" on the XShutdown tab. Check that "Power off computer" is enabled.

Regards

11
Marketplace / Re: ebay Stuff
« on: July 02, 2024, 11:24:22 pm »
Yes, I know we all want it, even if we no longer get letters today  ;D

https://www.ebay.com/itm/196312607916


12
Marketplace / Re: ebay Stuff
« on: July 01, 2024, 02:56:56 am »
..and this plastic desk clock is very expensive  ;D
- https://www.ebay.com/itm/296404539886?itmmeta=01J1NRKM4J9B5NJHA7QXQBV3BZ


13
Marketplace / Re: ebay Stuff
« on: July 01, 2024, 01:49:30 am »
There is this VHS tape for OS/2 2.0 training.

https://www.ebay.com/itm/235626505270?itmmeta=01J1NRKM4JGWA7F78V8JHPJD06

14
Applications / Re: ArcaOS v5.1 and VirtualBox OS/2 Version
« on: June 28, 2024, 11:13:04 pm »
Hello Mark

In my case I don't have Virtual Box installed on my ArcaOS 5.1 VM machine, so I proceeded to install it:

I got:
1) http://hobbesarchive.com/Home/Download?path=/Hobbes/pub/os2/apps/emulator/VirtualBox_5-0-51.zip
2) Installed "yum install libaio"
3) I followed your comments on the config.sys
Code: [Select]
SET LIBCX_HIGHMEM=2
VIRTUALADDRESSLIMIT=3072
DEVICE=C:\Programs\VirtualBox\Bin\VBoxDrv.sys
SET VBOX_USER_HOME=C:\VMs

When I run VirtualBox.exe I get your same error.  "Callee RC: NS_ERROR_FACTORY_NOT_REGISTERED (0x80040154)"

As a general comment, since this version of VirtualBox was compiled on 2018, I really hope/wish that someone can recompile it just point to our currents DLLs. (if it works). I guess the full source code is here: http://trac.netlabs.org/vbox/browser?order=name

Regards



15
Applications / Re: General Software Testing
« on: June 28, 2024, 02:15:04 pm »
Hello again

Now I tried Lemon. (Musical Notation Recognition Software 1996-01)
- http://hobbesarchive.com/Home/Download?path=/Hobbes/pub/os2/apps/mmedia/sound/LEMON.zip

I run it in ArcaOS 5.1 and it quits with POPUPLOG message, and I even tried "start Lemon.exe" with the same results

Code: [Select]
06-25-2024  16:07:04  SYS3175  PID 0076  TID 0001  Slot 008f
C:\HOME\MARTIN\DOWNLOADS\LEMON\LEMON\LEMON.EXE
c0000005
0007aa0d
P1=00000001  P2=00000004  P3=XXXXXXXX  P4=XXXXXXXX 
EAX=00000004  EBX=00000000  ECX=000b5444  EDX=0009cd9c
ESI=00000023  EDI=00000000 
DS=0053  DSACC=d0f3  DSLIM=5fffffff 
ES=0053  ESACC=d0f3  ESLIM=5fffffff 
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:0007aa0d  CSACC=d0df  CSLIM=5fffffff
SS:ESP=0053:000b51b4  SSACC=d0f3  SSLIM=5fffffff
EBP=000b551c  FLG=00010202

LEMON.EXE 0002:0005aa0d

But some other people tell me it runs fine. Any idea?

Regards

Pages: [1] 2 3 ... 310