Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Sean Casey

Pages: [1] 2 3 ... 8
1
Storage / Re: Cloning a drive
« on: October 14, 2022, 08:36:12 pm »
I have read in this forum people successfully cloning drives using DFSee.   

I have cloned OS/2 two different ways, once using Acronis Cyber Backup 12.5 with a bit-stream backup where the target remained the same partition size for OS/2.  The second method I made a zip backup of the source OS/2 partition.  I then did a fresh install of OS/2 into a second (i.e., D-drive) partition on a new drive.  Booting into OS/2, I formatted a larger C-drive partition and then restored my OS/2 backup.  I was using the AiR-BOOT manager.

2
Marketplace / Re: HyperAccess/6 or HyperAccess Pro
« on: October 05, 2022, 12:40:49 am »
Have you considered ZOC?   It's a full featured SSH client and terminal emulator for Windows and Mac that's currently supported, and last I looked (in 2019), you could still purchase an OS/2 license.   I use it on Windows, Linux via Wine, and also on OS/2.  Highly recommended.

3
Applications / Re: ColorWorks ArcaOS
« on: October 01, 2022, 04:21:46 am »
Hi,

Per Arca Noae...

The new FOC is enabled by default. To disable it and switch back to the original OS/2 file open dialog:
1. Open an OS/2 command prompt.
2. Change to the \sys\INSTALL\FOC directory on the boot volume.
3. Type “filedlgtofocdlg /U” and press <Enter>.
4. Restart the system.

To reenable the new FOC (any previous settings should be restored):
1. Open an OS/2 command prompt.
2. Change to the \sys\INSTALL\FOC directory on the boot volume.
3. Type “filedlgtofocdlg /I” and press <Enter>.
4. Restart the system.

Also, ColorWorks does not work well on OS/2 systems that use display drivers based on GRADD.  Issues include missing (all black) effects previews if the stacking option is used, and lockups in various effects dialogs.  A patch is available for v.1 and v.2 to address these issues.

4
Applications / Re: PDF Printer
« on: September 25, 2022, 11:55:23 pm »
So now that you've got it running, I am curious: what is the advantage of using PMPDF vs ePDF?

I looked at ePDF, but I wanted something easy to set up and use.  Easy to set up because there's limited OS/2 help available and I would probably be on my own to get it working as both ePDF and PMPDF don't appear to be currently supported. I know Steven Levine, a friend from SCOUG, is using ePDF, and Martin Iturbide had been using PMPDF.   

With PMPDF, I can use any application to print to the "PDF Writer" printer, like I would print to any other printer, and select the location where I want to save the PDF.  It's that simple.  If I want to change the attributes on the output PDF, I can modify the properties on the PDF output port where I can set the PDF Information - Title, Subject, Author, Keywords.

Using ePDF appeared to be a multi step process where I first print to a postscript file, then drag the file to ePDF to make the PDF file.  It's possible to print directly from an application to create a PDF file, but I would have to install other software, such as quePDF, to intercept the print job from the print queue/pipe and invoke ePDF.   

I only had to kill a few grey cells to get PMPDF working, so I'm happy.
 



5
Applications / Re: PDF Printer
« on: September 24, 2022, 04:39:52 am »
Can somebody point me to some documentation on how to use CUPS to create a PDF Printer?

I use a PDF printer with CUPS on Linux, but unfortunately, I wasn't able to get this working with the OS/2 version of CUPS.  This same Linux CUPS PDF printer is also available via an SMB share, but the OS/2 version of CUPS is missing functionality to create the SMB printer to point to this printer. This is why I resorted to using PMPDF, but I would have preferred using CUPS, either locally on OS/2, or via my Linux CUPS PDF printer.

6
Applications / Re: PDF Printer
« on: September 24, 2022, 04:23:13 am »
Now it seems to work with ghostscript 9.18-5 installed from ANPM. I just wrote it down here to don't forget about it next year.
http://www.os2world.com/wiki/index.php/Remembering_How_to_Use_PMPDF

PMPDF was not working for me as I believe the documents I was printing were relying on fonts that were not available with the current ghostscript (v9.18-7) installed via ANPM.

I initially elected to manually install the prior version of ghostscript (v8.71) via a zip file and point PMPDF to this directory tree, as you describe in your tutorial.  This required that I uninstall v9 ghostscript without impacting CUPS which I use.  I used the "--nodeps" option to do this...

   rpm -qa | grep "ghostscript"

        ghostscript-fonts-6.0-1.oc00.noarch
        ghostscript-9.18-7.oc00.i686

   rpm -e --nodeps "ghostscript-9.18-7.oc00.i686"
   rpm -e --nodeps "ghostscript-fonts-6.0-1.oc00.noarch"

After getting this running, I decided it would be better to keep v.9 ghostscript in case it was needed for something in the future, but only use the Fonts from the older v.8 ghostscript.   So, I reinstalled v.9 ghostscript and copied the fonts directory from v.8 moving it under the v.9 ghostscript directory tree.  I then passed the v.8 fonts directory location to PMPDF using the "Extra parameters to GhostScript" option in the PDF output port.  The override option I used was:

   -lc:/@unixroot/usr/share/ghostscript/9.18/Resource/Font;c:/PSFONTS

See the attached screenshot for the location of the override.

So you can use either v.8 ghostscript without v9 ghostscript installed, or you can use v9 ghostscript with the added v.8 fonts directory and PMPDF override.




7
Hardware / Re: Trying to get Sound in VMWare to run - help appriciated
« on: September 08, 2022, 04:23:00 pm »
I haven't had any issues with v.16 on two of my Linux machines with multiple AOS installs over the past 2.5 years, so maybe the issue is only on the Windows platform.   If it's a memory addressing issue, try the install with 256MB assigned to the VM.   If available, create your VM on Linux for use on Windows?

8
Hardware / Re: Trying to get Sound in VMWare to run - help appriciated
« on: September 02, 2022, 04:27:27 pm »
Hi,

I'm on Linux and have never had issues with ArcaOS installations, so  I'm not sure what the source of your problem might be.   Have a look at your ArcaOS 5.0.7.vmx file and compare to the following default installation configuration that was generated by my VMware New Virtual Machine Wizard:

.encoding = "UTF-8"
config.version = "8"
virtualHW.version = "19"
pciBridge0.present = "TRUE"
pciBridge4.present = "TRUE"
pciBridge4.virtualDev = "pcieRootPort"
pciBridge4.functions = "8"
pciBridge5.present = "TRUE"
pciBridge5.virtualDev = "pcieRootPort"
pciBridge5.functions = "8"
pciBridge6.present = "TRUE"
pciBridge6.virtualDev = "pcieRootPort"
pciBridge6.functions = "8"
pciBridge7.present = "TRUE"
pciBridge7.virtualDev = "pcieRootPort"
pciBridge7.functions = "8"
vmci0.present = "TRUE"
hpet0.present = "TRUE"
nvram = "ArcaOS 5.0.7.nvram"
virtualHW.productCompatibility = "hosted"
powerType.powerOff = "soft"
powerType.powerOn = "soft"
powerType.suspend = "soft"
powerType.reset = "soft"
displayName = "ArcaOS 5.0.7"
guestOS = "ecomstation2"
tools.syncTime = "FALSE"
sound.autoDetect = "TRUE"
sound.fileName = "-1"
sound.present = "TRUE"
memsize = "4096"
ide0:0.fileName = "ArcaOS 5.0.7.vmdk"
ide0:0.present = "TRUE"
ide1:0.deviceType = "cdrom-image"
ide1:0.fileName = "/Temp/ArcaOS-5.0.7.iso"
ide1:0.present = "TRUE"
ethernet0.connectionType = "nat"
ethernet0.addressType = "generated"
ethernet0.present = "TRUE"
extendedConfigFile = "ArcaOS 5.0.7.vmxf"
floppy0.present = "FALSE"

9
Hardware / Re: Trying to get Sound in VMWare to run - help appriciated
« on: September 01, 2022, 11:18:27 pm »
Using Lars' USB drivers with CM6553 USB audio on VMware Workstation Pro.   Works well.

10
Applications / Re: DMARC error
« on: August 18, 2022, 12:22:36 am »
v=DMARC1;p=quarantine;sp=none;adkim=r;aspf=r;pct=100;fo=1;rf=afrf;ri=86400;rua=mailto:email@yourdomain.com;ruf=mailto:email@yourdomain.com

The DMARC entry is a recommendation provided to the receiving server on how to handle email received from Per's mail server that doesn't satisfy SPF and DKIM security checks.  Per's entry is communicating "relaxed/none" policies (i.e., don't reject/quarantine, no actions to be taken), so I don't see his DMARC record getting in the way of delivering his mail. 

Per is using a third party's mail server to host his domain and his SPF record seemed okay for that purpose, but I can't see his DKIM record.   If he doesn't have a DKIM record set up, he likely can identify the means to have the mail server generate a secure public key for his domain which he will need to use to create his DNS DKIM record. 

I host my own mail server, and after 18 years, I recently moved DNS from my ISP to a different DNS services provider which required me to brush up on creating DNS records.   My ISP managed my DNS entries and it was nearly impossible to talk to anyone who could make needed changes.  My new DNS services provider has now provided me full access to set up and manage DNS.   Unfortunately, I still need to work with my ISP to manage my reverse DNS entries.

11
Applications / Re: DMARC error
« on: August 17, 2022, 05:51:19 pm »
The receiving mail server looked at your DNS entries for DKIM and then SPF to validate your mail server's identity.   Your mail server's public encryption key is included in your mail server's DNS DKIM entry, usually in the form of:
   
     v=DKIM1;p=<public key here>

You can identify your DKIM record using this site: https://dnschecker.org/dkim-record-checker.php

Your mail server's DNS SPF entry tells the other mail server if it should accept mail from one or more mail servers for your domain.   My mail server's SPF record identifies a single mail server and looks like this:

     v=spf1 ip4:<IP address here> -all

You can use this site to view your SPF record details:  https://dnschecker.org/spf-record-validation.php


12
Setup & Installation / UEFI Boot Manager for 5.1
« on: May 17, 2022, 01:07:15 am »
Is AN going to provide a UEFI capable boot manager with the upcoming 5.1 release?  While one of my ArcaOS/Linux computers will continue using GRUB 2, I have another computer where I would like to boot into two different GUID ArcaOS system partitions.

13
Off Topic discussions / Re: Slowing Down But Not Hitting the Brakes
« on: May 12, 2022, 09:26:51 pm »
I’m so sorry to hear of your loss. Wishing you/your family peace during this difficult time.

14
Applications / Re: Test build of dooble with qt5
« on: April 30, 2022, 09:42:29 pm »
Its been ungodly slow and really crappy finding web sites that will load, this is probably due to the fact  its running in a virtual machine.

It can be a little quirky in loading some previously visited sites, but a couple attempts usually loads a site.  I'm using VMware and performance is fine (4c, 4GB RAM), even with sites having a lot of media (e.g., Dailymail.co.uk).   The browser has been very stable.

I'm very impressed with the preview, especially when considering the few resources that have been supporting the development effort. 

15
Web applications / Re: The MicroWeb DOS web browser
« on: January 05, 2022, 04:44:02 pm »
It is possible to run DOS packet drivers in a DOS session if you disable the DOS/2 networking, but not recommended, FTP Software (the company) also sold a TCP/IP stack for OS/2 that had a VDD that allowed DOS sessions to use DOS packets via emulation, but alas that is impossible to get hold of these days. The Essex Systems stack also had some VDD trickery, but I cannot remember it it supported the FTPS packets specification.

Is it true these older OS/2 TCP/IP and NetBIOS over TCP implementations used proprietary APIs which limited their use to only the network applications/services that were distributed with these packages? 

Pages: [1] 2 3 ... 8