Recent Posts

Pages: 1 2 [3] 4 5 ... 10
21
Multimedia / Re: How do I change this default behaviour?
« Last post by Dariusz Piatkowski on November 28, 2021, 06:23:21 pm »
Hi mauro,
Hi Dariusz, I had simply changed the default application for opening my media files using Assoedit (see images).

Yeah, I thought that doing this should take precedence over anything else, but in my case that is not the outcome. I suspect it is because of the MM file classes, but that's a standard OS/2 MM install and I figured basically everyone else out there would be impacted by this, unless I have of course installed something else in the past that I have simply forgotten about since then!
22
Multimedia / Re: How do I change this default behaviour?
« Last post by Dariusz Piatkowski on November 28, 2021, 06:21:37 pm »
Hi Pete!

...The cwmm MediaFolder help file - usually at [BootDrive]:\MMOS2\MEDIAFLD\DOC\mediafldr.inf provides an answer if using smplayer or vlc. See the section Hidden Features, Replace AVI Player as an example. Not sure if it can be tweaked to use mplayer without a frontend though...

Ahh, so these are the Chris W's MM classes I think, which I do not have installed on my machine, so that option is not currently available. Not to say I won't pursue it, just that it's not the setup I have deployed at the moment.
23
Multimedia / Re: How do I change this default behaviour?
« Last post by Dariusz Piatkowski on November 28, 2021, 06:18:42 pm »
Hi Martin,
I don't think it is good to deregister any class for what you want to do?

When you right click over the AVI or MPG file, and select "Open as", which options do you see?...

I agree, I do not want to de-register any classes, unless there is a single AVI/MPG specific class that will NOT impact anything else. By the looks of it so far, these both appear to be default OS/2 multimedia classes though, and for that reason I think it's best that I do not touch them.

Take a look at the attached screenshot for what "Open as" looks like. Basically all my other video apps show, along with the default OS/2 ones.

I can certainly force each AVI file to open using mplayer, but that requires me to open it's Settings and specifically select mplayer, as opposed to relying on normal OS/2 associations.

Regarding the "Associations Set Up" docs...very nice!!! I am aware of all of these options and have already tried them, but that's a great write-up for anyone that's not had the chance to work through these in the past.
24
Hardware / Re: New ArcaOS USB driver.
« Last post by Lars on November 28, 2021, 02:43:58 pm »
Sent to your private email.
25
Multimedia / Re: How do I change this default behaviour?
« Last post by mauro on November 28, 2021, 02:01:57 pm »
Hi Dariusz, I had simply changed the default application for opening my media files using Assoedit (see images).
26
Multimedia / Re: How do I change this default behaviour?
« Last post by Pete on November 28, 2021, 07:29:18 am »
Hi Dariusz

The cwmm MediaFolder help file - usually at [BootDrive]:\MMOS2\MEDIAFLD\DOC\mediafldr.inf provides an answer if using smplayer or vlc. See the section Hidden Features, Replace AVI Player as an example. Not sure if it can be tweaked to use mplayer without a frontend though...


Regards

Pete




27
Multimedia / Re: How do I change this default behaviour?
« Last post by Martin Iturbide on November 28, 2021, 04:05:34 am »
Hi Dariusz.

I don't think it is good to deregister any class for what you want to do?

When you right click over the AVI or MPG file, and select "Open as", which options do you see?

Do you want to take a look at my notes here, maybe it can give you some hints.

Regards
28
Hardware / Re: New ArcaOS USB driver.
« Last post by Remy on November 27, 2021, 08:58:52 pm »
I have that test version ready. Bumped up the version number to 14.106 so as to avoid confusion.
Where do you want me to send it to ?

Lars

Hi Lars, nice
You can use my email (PM sent)
Regards

Rémy
29
Multimedia / How do I change this default behaviour?
« Last post by Dariusz Piatkowski on November 27, 2021, 08:44:49 pm »
So I've got a bunch of AVI and MPG video files: family get-togethers, various car events, etc. My box currently insist on always opening the AVI and MPG stuff using the ancient default OS/2 AVI player. How the heck do I change that?

Before you say "adjust the associations", well they already have been. All of these media files are pointing to mplayer as the default, and yet each time I double-click on a AVI file the default viewer plays.

So I'm thinking that's because the 'Current class' is defined as MMAVI for the the AVI files and MMMPG for the MPG files. Meanwhile the MP4 stuff is simply showing up as XFldDataFile (which is to be expected given my XWP install).

Do I need to un-register a particular class?

Take a look at what currently shows up under 'Codecs' TAB of the Multimedia object (see attachment).
30
Hardware / Re: New ArcaOS USB driver.
« Last post by Lars on November 27, 2021, 03:40:49 pm »
I have that test version ready. Bumped up the version number to 14.106 so as to avoid confusion.
Where do you want me to send it to ?

Lars
Pages: 1 2 [3] 4 5 ... 10