Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - David McKenna

Pages: [1] 2 3 ... 51
1
Programming / Re: Qt6 Development
« on: May 19, 2024, 10:54:46 pm »
 Dave,

 Yep - putting en_US.bdic in the root of the %UNIXROOT% drive solves the error. Thanks for the tip...

Regards,

2
Programming / Re: Qt6 Development
« on: May 19, 2024, 10:01:55 pm »
Andy,

  At one point Paul changed the names of DLL's to avoid duplicates, so any version of Dooble for QT6  before that won't work now. Try Dave's new one (above) - it seems to work well.

Regards,

3
General Discussion / Re: Chuck McKinnis Passed Away
« on: May 19, 2024, 09:56:11 pm »
 Sorry to hear this Martin - Chuck was a big booster of OS/2. Thanks for letting us know.

Regards,

4
Programming / Re: Qt6 Development
« on: May 19, 2024, 09:52:46 pm »
 Thanks Dave! Working good here, also with new block list. One thing I notice with this one I didn't see before: at 'Settings'->'Web'-> 'Spell Checkers' there is a warning: 'en_US.bdic cannot be accessed!'. That file is available in the 'qtwebengine_dictionaries' directory and it worked with the 12/25/2023 version. Does it need to be updated or something?

Regards,

5
Programming / Re: Qt6 Development
« on: May 19, 2024, 04:55:02 pm »
Paul,

 I've tried all of the files in the \examples folders, here is what I found:

 In the \dbus, \multimedia, and \multimediawidgets folders nothing works. Stuff in the \multimedia folders says this platform is not supported. Stuff in the \dbus folders says to start the dbus. I have dbus installed, but don't know what to do to actually start it - any hints?

 \designer\worldclockbuilder doesn't work - gives an error.

 \help\contextsensitivehelp - works, but blank and SQL error in console

 \quick - all work, but any with sub-folders need the 'shared' folder moved into the same folder as the executable. Then the 'qmldir' file there needs the 'optional plugin xxx' line added with the name of the DLL there. Once that is done they all work, but some (mostly in \particles, \scenegraph, and \shapes directories) have display elements missing and console shows libpng warnings. Does QT6 use the system libpng?

 \widgets\desktop - system tray doesn't work and can't take a screen shot.

 One thing I noticed in the '\QML\QT5Compat\GraphicalEffects' folder - the qmldir file does not have an 'optional plugins xxx' line with the dll name. That dll name is also the same as the one in the 'private' subfolder, where the qmldir file there also has no 'optional plugins xxx' line. I added them and renamed the dll in the 'private' directory. Haven't come accross any other DLL name conflicts yet.

 Another small issue - some examples that work give a POPUPLOG on exit. Mostly in the \Charts\QMLCharts directory but a few others too. They all look very similar - I'll upload the POPUPLOG.

 That's it - as far as I can tell everything else works. This is the best QT6 version yet - much better than the last one! Thanks again! Can't wait for a new webengine...

Regards,

 

6
Programming / Re: Qt6 Development
« on: May 19, 2024, 01:48:19 pm »
Hi Paul,

  It HAS been awhile... hope all is well! I am running your last QT6 version of Dooble (could you build the latest?) with this new build of QT6.2 and it seems to work as well as the last. Looking forward to the webengine part too. I'll test the examples in the next couple of days... thanks!

Regards,

7
Programming / Re: ClassiCube porting thread
« on: May 09, 2024, 11:40:52 pm »
Lars,

 Tried these files, but ClassiCube still crashes when I try to open a file dialog in it. I can confirm that the exception list does not work with these - even with classicube-dev.exe in the exception list it crashes. I tried with both the 2017 and 2024 versions of all eCoSoft run time files.

 The fact an exception list was added kinda implies this problem was known, but not fixed for some reason. Maybe you could contact the author to find out why?

Regards,

8
Programming / Re: ClassiCube porting thread
« on: May 09, 2024, 12:30:53 pm »
Lars,

 I do have FOC set to scan only local drives. Tried backlevelling the 3 eCoSoft runtimes to the 2017 versions - rebooted - but no change. Classicube still crashes when a file dialog appears, but if I add it to the FOC exception list, it works. Maybe the newer PMEX.DLL is at fault? It does have a build level string:

[C:\os2\dll]bldlevel pmex.dll
Build Level Display Facility Version 6.12.675 Sep 25 2001
(C) Copyright IBM Corporation 1993-2001
Signature:       @#eCo Software:1.9.0#@##1## 05/10/16 14:41:04        GLASSMAN::
::::@@Presentation Manager Extension Library
Vendor:          eCo Software
Revision:        1.09.0
Date/Time:       05/10/16 14:41:04
Build Machine:   GLASSMAN
File Version:    1.9
Description:     Presentation Manager Extension Library

 FOC was an add-on from eCoSoft: http://en.ecomstation.ru/projects/foc, eventually installed from eCS 2.1 and higher...

Regards,

9
Programming / Re: ClassiCube porting thread
« on: May 08, 2024, 11:34:50 pm »
Lars,

 On ArcaOS, 'Computer'-> 'System Setup' -> 'Workplace Shell' -> FOC tab to setup FOC. Page 2 has the exception list. Don't remember if eCS has that or not...

Regards,

10
Programming / Re: ClassiCube porting thread
« on: May 08, 2024, 12:45:06 pm »
Hey Lars,

  I think I might have tried running ClassiCube several times, so the multiple traps in POPUPLOG may be one for each attempt. But in any case, it can be avoided by putting 'classicube-dev.exe' in the FOC 'do not use' list...

Regards,

11
Programming / Re: ClassiCube porting thread
« on: May 08, 2024, 12:01:20 pm »
Hi Jochen,

  I gave the new build a try and it looks a lot better than the last! Sound works too. I have the eCoSoft runtimes installed, so did as you asked and when I clicked on 'load file' a file choosing dialog briefly appears, then disappears and the game window disappears too. Get a popuplog, but no message. The initial Classicube window stays up though and can start a new game right away. Popuplog attached - thanks!

Regards,

EDIT: I added 'classicube-dev.exe' to the FOC 'do not use' list and now it doesn't crash until I hit 'Quit', then I get a message dialog saying:

Crash time: 08/05/2024 06:17:37
ClassiCube crashed.
Reason: Unhandled signal SIGSEGV (code -2147471358) at 05830000



12
Games / Re: PrBoom+
« on: April 16, 2024, 12:31:52 pm »
 Hi Jochen,

 Got it working - didn't realize I needed to install the Doom.wad file separately (it was included in your first alpha version). It works great, sound and mouse work well, everything worked that I tried... nice work, thanks!

Regards,

13
Games / Re: PrBoom+
« on: April 15, 2024, 10:44:20 pm »
Hi Jochen,

  No matter what I do, I can't seem to get this running at all. I installed with the RPM and it worked well, it also installed a folder with program object and 'Readme' file. The 'Readme' file will not open with a double click (must right click and choose text) because of the '*.command-line' suffix. The program object very briefly hatches, then nothing - no POPUPLOG, no exceptq file no error message. Command line start does not show any message - just returns to prompt. Do I need to create a 'Boom.cfg' file first?

Regards,

14
Games / Re: Minecraft
« on: April 12, 2024, 12:11:15 pm »
Hi Jochen,

  This last version does open the browser on the register page - thanks!

Regards,

15
Games / Re: Minecraft
« on: April 11, 2024, 12:36:50 pm »
Hi Jochen,

  Tried this new version of classicube, and trying to register, the web browser (SeaMonkey in this case) does open, but it opens on my home page, not the registration page.

  I use IAIUtil to edit the web apps in OS2.INI (IAI_1.0.9.2 on Hobbes). It requires the VPREXX.DLL runtime (found in VisiPro Rexx also on Hobbes).

Regards,


Pages: [1] 2 3 ... 51