Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Silvan Scherrer

Pages: [1] 2 3 ... 13
1
Applications / Re: Test build of dooble with qt5
« on: May 04, 2022, 12:09:59 pm »
How to do to have it running without crash ?
Very awfull compared to firefox which works far more better than this one but too limited due to new codes uses by many web sites
(I do not use virtual machine)

When will the official working browser be available ?   
I'm tied to switch between ArcaOS and windows many times per day.     

As well Thunderbird is out of use at end of this month for gmail account due to missing secured authorization process (except using application password but not sure it will accept it) , any new one ?

Why was this dooble browser put into normal repository ?
(it should be left into the experimental repository until it is fully tested and not crashing)

 ::) :-\
did you open a issue at github with the trp file? as without it we can't help. sorry

2
Programming / Re: Compiling a PM sample with GCC
« on: April 12, 2022, 06:23:38 pm »
3) use wlink instead of ilink. there is a wlink and wrc rpm.

Hi

I would prefer to use wlink since (I guess) it is open source. But I have no idea if how to call it, since on the makefile I'm not making a direct link to "Ilink", I don't know if gcc is the one calling it.

Any suggestion what to change on the makefile to call wlink and give it a try with these samples?

Regards
if you install it via rpm all gets set up for you. gcc then finds the right linker.

3
Programming / Re: Compiling a PM sample with GCC
« on: April 12, 2022, 04:10:00 pm »
Hi

Just as a note to myself and any comments are welcome.

I created a new development VM with ArcaOS 5.0.7 just with the goal to compile my samples, since my other VM had a lot of other dev software that I was not using with some the stuff on the config.sys. I wanted to started clean.

To recover my status of being able to compile these samples I did:
1) yum install gcc libc-devel binutils kbuild-make
2) SET INCLUDE=C:\usr\include; on Config.sys
3) Got "ilink50.zip" and put the exe on C:\sys\bin and DLLs on c:\sys\dll
(I guess there is no ilink on the rpm)

With that I have the basic stuff to compile the samples again.

Regards
never do 2)
3) use wlink instead of ilink. there is a wlink and wrc rpm.

4
Setup & Installation / Re: Transition from i686 to pentium4
« on: April 07, 2022, 05:43:05 pm »
Hi Martin,
thx for your reply. All yum or rpm commands are showing this error. But not always. From 5 yum or rpm commands 3-4 will fail and 1-2 commnds are running correctly.

Quote
{0}[c:\] yum list installed |grep python
python.i686                          2.7.6-25.oc00                  installed
python-libs.i686                     2.7.6-25.oc00                  installed
python-pycurl.i686                   7.19.5.1-2.oc00                installed
python2-rpm.pentium4                 4.13.0-20.oc00                 installed

{0}[c:\] rpm -qa |grep python
Fehler: Failed to initialize NSS library

{1}[c:\] rpm -qa |grep python
Fehler: Failed to initialize NSS library

{1}[c:\] rpm -qa |grep python
python-libs-2.7.6-25.oc00.i686
python-pycurl-7.19.5.1-2.oc00.i686
python2-rpm-4.13.0-20.oc00.pentium4
python-2.7.6-25.oc00.i686

{0}[c:\]

Python3 is not installed on this vm. I will try it on an other physical Arcaos system.

Regards
when they fail with the nss error. do you have some firefox running?

5
Programming / Re: i686 vs Pentium 4
« on: March 06, 2022, 05:38:32 pm »
While all the above may be true it also underscores the reason I will not use RPM/YUM on any of my OS/2 based computers.  If I absolutely have to use one of the RPM offerings, I will download from the repository and unpack it on my test computer transferring what is needed to my work computer.

In my opinion all this can/could be avoided by using what we had befor someone decided to follow SUSE linux route - in other words WARPIN.
Feel free to solve all dependencies by hand. And configure then right.  And go ahead and create wpi packages for all rpm. We certainly will not do it.

6
Programming / Re: i686 vs Pentium 4
« on: March 06, 2022, 05:35:17 pm »
As an end user, I don't care what instruction set is used. But if I change my settings from i686 to pentium4 with rpm/yum, everything should still work afterward. For me it's not the instruction set, but the quality of the rpm specs.
It does still work. Just let the update do its work.
Quote
Martin had to remove rpm/yum entirely and start over to change from i686 to pentium4. If that is what is needed, then please supply a tool to do it in one quick operation.
I dont know what he tried exactly.but he did it wrong for sure. As the update process works. And its not necessary to change arch for all. Just use yum update to update to later versions when available. And as said this works. If not open a ticket and we will solve it.

7
Internet / Re: RPM: Switching from i686 to Pentium4
« on: March 04, 2022, 08:57:37 am »
I don't remember the rest of this thread. But wouldn't it suffice to just update os2-base? That changes the platform.
Yes it does. And afterwards all new packages get updated to the right arch. Updating all is not needed as it gains nothing. Iirc this was discussed already several Times.

8
Games / Re: DOS VDM - USB and Game port Gamepad support
« on: January 13, 2022, 07:42:50 pm »
Rebooted to my netlabs.exp install, after upgrading and installing hidapi, things work as expected. Now to figure out what is different.
which hidapi version do you have? as I just uploaded the last available one 0.11.2
it includes your fixes as well. even done a bit different

regards
Silvan

9
Applications / Re: OpenOffice Spreadsheet charts
« on: November 16, 2021, 09:10:50 am »
Hi tried to download the files but dropbox no more works under current OS/2 firefox built !
I than tried to use firefox under windows 10 ans it failed too and finally, I could get files using google chrome !
Did bww check the link as been usable under os/2 arcaos before sending the download link ?

Regards   
 
To be honest, if we only use OS/2 friendly services we run out of possibilities very fast.
But I personally had no issue downloading it with OS/2. On Win I'm not using firefox since long, so I didn't test that. Chrome and Edge run ok.

10
Applications / Re: Apache OpenOffice no longer starts
« on: September 30, 2021, 10:54:40 am »
But now, it does not work anymore even I reinstall AOO. I tried 4.17 and 4.18. I have no idea anymore what to do. There are three different computers envolved, and an additional installation where I did not update the DLLs.
Anything in popuplog.os2 or a trp file? Whate does the stdout or stderr say? As AOO usually is not vanishing silently.
I'm pretty sure there is a pattern why it's the same on 3 different computers.
For sure we need more information to help further.

regards
Silvan

11
Comments, Suggestions & Questions / Re: YUM libc-01.6.-1 local
« on: February 05, 2021, 03:52:53 pm »
here are the error mesages:
bash:
ERROR with transaction check vs depsolve:readln6.dll wird ben”tigt von (installiert) lua-5.3.4-2.i686readln6.dll wird ben”tigt von (installiert) hunspell-1.7.0-2.oc00.i686readln6.dll wird ben”tigt von (installiert) gawk-4.0.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) sqlite-3.28.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) bc-1.07.1-1.oc00.i686readln6.dll wird ben”tigt von (installiert) gutenprint-5.3.3-2.oc00.i686Bitte melden Sie diesen Fehler unter http://trac.netlabs.org/rpm/

cups:
ERROR with transaction check vs depsolve:cups-filesystem = 1:2.2.12-1.oc00 wird ben”tigt von cups-1:2.2.12-1.oc00.i686Bitte melden Sie diesen Fehler unter http://trac.netlabs.org/rpm/

cups-client:
ERROR with transaction check vs depsolve:cups-filesystem = 1:2.2.12-1.oc00 wird ben”tigt von cups-1:2.2.12-1.oc00.i686Bitte melden Sie diesen Fehler unter http://trac.netlabs.org/rpm/

cups-libs:
ERROR with transaction check vs depsolve:cups-filesystem = 1:2.2.12-1.oc00 wird ben”tigt von cups-1:2.2.12-1.oc00.i686Bitte melden Sie diesen Fehler unter http://trac.netlabs.org/rpm/

db4-utils:
ERROR with transaction check vs depsolve:db4 = 4.8.30-9.oc00 wird ben”tigt von db4-utils-4.8.30-9.oc00.i686Bitte melden Sie diesen Fehler unter http://trac.netlabs.org/rpm/

openssl:
ERROR with transaction check vs depsolve:readln6.dll wird ben”tigt von (installiert) lua-5.3.4-2.i686readln6.dll wird ben”tigt von (installiert) hunspell-1.7.0-2.oc00.i686readln6.dll wird ben”tigt von (installiert) gawk-4.0.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) sqlite-3.28.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) bc-1.07.1-1.oc00.i686readln6.dll wird ben”tigt von (installiert) gutenprint-5.3.3-2.oc00.i686Bitte melden Sie diesen Fehler unter http://trac.netlabs.org/rpm/

openssl-libs:
ERROR with transaction check vs depsolve:readln6.dll wird ben”tigt von (installiert) lua-5.3.4-2.i686readln6.dll wird ben”tigt von (installiert) hunspell-1.7.0-2.oc00.i686readln6.dll wird ben”tigt von (installiert) gawk-4.0.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) sqlite-3.28.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) bc-1.07.1-1.oc00.i686readln6.dll wird ben”tigt von (installiert) gutenprint-5.3.3-2.oc00.i686Bitte melden Sie diesen Fehler unter http://trac.netlabs.org/rpm/

python:
ERROR with transaction check vs depsolve:readln6.dll wird ben”tigt von (installiert) lua-5.3.4-2.i686readln6.dll wird ben”tigt von (installiert) hunspell-1.7.0-2.oc00.i686readln6.dll wird ben”tigt von (installiert) gawk-4.0.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) sqlite-3.28.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) bc-1.07.1-1.oc00.i686readln6.dll wird ben”tigt von (installiert) gutenprint-5.3.3-2.oc00.i686Bitte melden Sie diesen Fehler unter http://trac.netlabs.org/rpm/

python-libs:
ERROR with transaction check vs depsolve:readln6.dll wird ben”tigt von (installiert) lua-5.3.4-2.i686readln6.dll wird ben”tigt von (installiert) hunspell-1.7.0-2.oc00.i686readln6.dll wird ben”tigt von (installiert) gawk-4.0.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) sqlite-3.28.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) bc-1.07.1-1.oc00.i686readln6.dll wird ben”tigt von (installiert) gutenprint-5.3.3-2.oc00.i686Bitte melden Sie diesen Fehler unter http://trac.netlabs.org/rpm/

readline:
ERROR with transaction check vs depsolve:readln6.dll wird ben”tigt von (installiert) lua-5.3.4-2.i686readln6.dll wird ben”tigt von (installiert) hunspell-1.7.0-2.oc00.i686readln6.dll wird ben”tigt von (installiert) gawk-4.0.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) sqlite-3.28.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) bc-1.07.1-1.oc00.i686readln6.dll wird ben”tigt von (installiert) gutenprint-5.3.3-2.oc00.i686Bitte melden Sie diesen Fehler unter http://trac.netlabs.org/rpm/

attached you find a png-file that shows what i get when i ask for updates.
you miss packages. using a local repo is working well, but you have to know what you do and how to interpret error messages. as we have no idea what you already have downloaded it's hard to tell which package you exactly miss. but for sure you miss some readline packages. most probably the legacy one.

12
Comments, Suggestions & Questions / Re: YUM libc-01.6.-1 local
« on: February 04, 2021, 09:36:06 am »
did that.
still it didn't work. realized that the slashes were changed to "\". changed them back to "/"
and the initial erroro message dissappeared ;-)
all works fine so far.
also managed now to install my libc.dll

most of the prevously uninstallabe packages are now installable.
there's only 10 left that won't work (bash, cups, cups-client, cups-libs,db4-utils, openssl, openssl-libs, python and python-libs)

no error message no help I'd say. and what does "yum check-update" say? As you can't install whats already installed. "yum update" is needed then.

13
Comments, Suggestions & Questions / Re: YUM libc-01.6.-1 local
« on: February 03, 2021, 05:43:29 pm »
tried. here's what i get:
[E:\DESKTOP]yum install D:\install\repo\libc-0.1.6-1.oc00.i686.rpm
file:///D%3Ainstallrepo/repodata/repomd.xml: [Errno 14] curl#37 - "Couldn't open
 file /D%3Ainstallrepo/repodata/repomd.xml"
Versuche anderen Spiegel-Server.
Fehler: Cannot retrieve repository metadata (repomd.xml) for repository: local.
Please verify its path and try again

btw. when i start ANPM i get:

"Cannot retrieve repository metadata (repomd.xml) for repository: local. Please verify its path and try again
Temporarily disabling repository: local"

my entry there is:

[local]
name = My local repo
baseurl = file:D:\install\repo
enabled=1

did you follow http://trac.netlabs.org/rpm/wiki/RpmHowToEndUsers#LocalRPMrepository ?

14
Networking / Re: OpenSSH_7.7p1 tcgetattr: Invalid argument
« on: December 03, 2020, 12:26:22 pm »
Hi,
I have updated my rpm packages and so openssh-clients version 7.7p1 was installed. This version has some problems:

Code: [Select]
[C:\]ssh -V
OpenSSH_7.7p1, OpenSSL 1.0.2t  10 Sep 2019

[C:\]ssh prometheus
root@prometheus's password:
[b]tcgetattr: Invalid argument[/b]
Last login: Thu Dec  3 08:31:12 2020 from einstein.intern.openit.at
[root@prometheus ~]#
LIBC PANIC!!
_um_free_maybe_lock: Tried to free block twice - block=20034694 lock=0x1
pid=0x0041 ppid=0x003e tid=0x0001 slot=0x0078 pri=0x0200 mc=0x0000 ps=0x0010
C:\USR\BIN\SSH.EXE
Process dumping was disabled, use DUMPPROC / PROCDUMP to enable it.

The external process was cancelled by a Ctrl+Break or another process.

The problem is the line "tcgetattr: Invalid argument". I have an older Version as OpenSSH_5.3p1 as wpi installed; this version does not show the error and is working proper. Is there a solution for version 7.7p1.

best regards
please write mail to info@bitwiseworks.com. we can then workout the issue way better than in here. as I have new builds since longer but never uploaded so far.

15
EDIT: I'm not sure how relevant this might be, but I just realized this may have started after updating to the latest version of CUPS, npth, poppler and libassuan. I'm unable to add new printers (log says: A non-recoverable error has occurred, very informative :P) but the printers I already had installed are working fine. There's probably no correlation but due to the closeness of both incidents I felt like it might be worth including just in case.
this sounds a bit strange. But all is possible with exp rpm. The non-recoverable issue might put some message to popuplog.os2

For the AOO ssue i'm pretty sure you updated ICU. This is known to not work with AOO. A new AOO wich then works is about to be released soon.

Pages: [1] 2 3 ... 13