Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Dave Yeo

Pages: [1] 2 3 ... 237
1
Hi LuigiThirty, welcome.
Does the machine actually support ACPI? You could turn on logging in \mptn\etc\acpid.cfg (might have to copy the sample) and/or run AcpiStat to see if it says anything interesting.
Might need the old OS2APIC.PSD.
Really you should consider opening an issue at Arca Noae.

2
Programming / Re: Desktop Apps from JavaScript - Electron?
« on: May 18, 2022, 11:59:05 pm »
As far as I'm aware, Electron uses Blink & V8, which are the Chromium/Chrome rendering engine and JavaScript VM.

So it would basically require porting Chromium to OS/2 :(.

Dooble is Chromium based, so Blink or Webkit and V8 are available. What we would need is a framework. Looking quickly I don't see what Electron uses but I'd guess GTK.
Actually it seems to be its own framework. I see on Linux it does use GTK but a quick search doesn't show a QT version.
The equivalent under QT seems to be nodegui, https://github.com/nodegui/nodegui seems to use Mesa on Linux so 3D graphics probably needed or more porting.

3
Applications / Re: Test build of dooble with qt5
« on: May 18, 2022, 04:22:25 pm »
Hi,

I defined  https://duckduckgo.com/  as my home page
After system reboot and starting Dooble, its look loading the page but nothing is displaied (blank page)
I load an other web page and then back to duckduckgo home page and this time, it display the page as it should !
Tried several times (closed/started dooble) and same issue each time !

What could be the culprit ?
Thx

It's a bug that everyone seems to experience. There's an issue already open.

4
Setup & Installation / Re: UEFI Boot Manager for 5.1
« on: May 17, 2022, 02:21:32 am »
Yes, it is the plan. Can always use other boot managers such as rEFIND.

5
Programming / getting a single keypress?
« on: May 16, 2022, 06:00:21 am »
Trying to fix the terminal control in mpg123 so things like pause work.
Example program which works on other systems but not on OS/2, at that sometimes hangs the system.
Ideas to get this to work?
Code: [Select]

#include <stdlib.h>
#include <stdio.h>
#include <fcntl.h>
#include <sys/select.h>
#include <unistd.h>
#include <termios.h>

int term_fd = -1;

int get_key(int do_delay, char *val)
{
fd_set r;
struct timeval t;
t.tv_sec=0;
t.tv_usec=(do_delay) ? 1000 : 0;
FD_ZERO(&r);
FD_SET(term_fd,&r);
int n = select(term_fd+1,&r,NULL,NULL,&t);
if(n > 0 && FD_ISSET(term_fd,&r) && read(term_fd,val,1) == 1)
return 1;
return 0;
}


int main(int argc, char **argv)
{
if(argc >= 2)
term_fd = open("/dev/tty", O_RDONLY);
else
term_fd = STDIN_FILENO;
if(term_fd < 0)
{
perror("failure opening terminal input");
return 1;
}
fprintf(stderr, "terminal fd: %d\n", term_fd);

struct termios old_tio;
int termsetup = 0;
if(!tcgetattr(term_fd, &old_tio))
{
fprintf(stderr, "proper terminal setup\n");
struct termios tio = old_tio;
tio.c_lflag &= ~(ICANON|ECHO);
tio.c_cc[VMIN] = 1;
tio.c_cc[VTIME] = 0;
tcsetattr(term_fd,TCSANOW,&tio);
termsetup = 1;
}

char val = 0;
while(val != 'q')
{
if(get_key(1, &val))
fprintf(stderr, "got key: %c\n", val);
}

if(termsetup)
tcsetattr(term_fd,TCSAFLUSH,&old_tio);
if(term_fd > 0)
close(term_fd);
return 0;
}


6
The readme is out of date as well as the libc DLL's that come with the additions.
You want to remove any in \os2\dll and only use the ones in \usr\lib.
Also note that the latest is libcn0.dll and the other libc06*.dll's are forwarders and need to be at the same level.
Dave,

Thanks for the additional information. I was not aware of the connection between libcn0.dll and libc06*.dll. Since the Guest Additions for OS2 do not include libcn0.dll, then we shouldn't be using the libc06*.dll files from the Guest Additions CDROM image.

Bennie

Libcn is a fork of libc as Knut who officially maintains libc has no time for it but requested that if anyone took over maintainence of libc to change the name of it. The forwarder DLLs are so that older programs benefit from libc updates and bug fixes. Example is the recent (last year?) DST break, when it was fixed, all programs using any libc6* version benefited and once again understood daylight savings time, important for mailers.

7
Internet / Re: simble browser does not handle URL by domain name
« on: May 15, 2022, 09:47:56 pm »
Loaded fine here as https://www.liberto.it/
Dooble is pretty simple and doesn't seem to try alternative domain names unlike Mozilla which will make a few attempts http vs https, www. or not and .com added

8
The readme is out of date as well as the libc DLL's that come with the additions.
You want to remove any in \os2\dll and only use the ones in \usr\lib.
Also note that the latest is libcn0.dll and the other libc06*.dll's are forwarders and need to be at the same level.

9
Applications / Re: Test build of dooble with qt5
« on: May 14, 2022, 01:49:59 am »
It's weird, just had to log in for this page, double checked the settings , closed Dooble and restarted, loaded this page from history and I was logged in.
One of the ideas of Dooble is privacy, which does include blocking most cookies. Perhaps in this case their is a time out or it is simply a bug. Other sites do work to keep me logged in. Different cookie policies I guess.
Once Martin feels up to it, we might be able to get him to change the OS2World cookie defaults.
See the spell checker still doesn't work either.

10
Applications / Re: Test build of dooble with qt5
« on: May 12, 2022, 02:11:09 am »
Hi Doug,
Not using authentication. Testing it earlier showed the best thing was to authenticate right after opening the browser. All it does is encrypt part of your profile.
There are a bunch of command line options for the webengine, linked from the documentation, which IIRC includes an option for different profiles. Simpler might be to change %HOME%, either with a script or using the program properties, could have a couple of program objects.

Hi Remy, the print preview and printing are known issues.
The timing thing sounds like worth opening an issue for, especially if you can reduce it to a small testcase.

Most of my packages are still i686 and Dooble is stable here.

11
Applications / Re: Test build of dooble with qt5
« on: May 11, 2022, 04:15:22 pm »
How do I get os2world forum to "remember me"? - I login with the Forever option but next time I visit I have to login...


Go to settings-->Privacy and change the cookie policy to save all

12
Internet / Re: Dooble Browser rendering - missing characters
« on: May 11, 2022, 07:55:08 am »
Hi David,

I doubt ant bug reporting would be any use.  It appears the developer gave up on the browser 7 years ago so I don't think we can expect any help from him.

You mean the upsteam developer? Latest commit was 17 hours ago according to https://github.com/textbrowser/dooble
As for the port, most of the problems are actually in the Qt5 webengine, think Gecko for Firefox, SeaMonkey and Thunderbird

13
Internet / Re: Dooble Browser rendering - missing characters
« on: May 11, 2022, 03:50:19 am »
Hi Mauro,

 Well - I guess I should have tried it first! When I go to 'la Reppublica' I also see what you see - missing letters in the headline. Probably for the same reason as Doug saw on 'TheWeatherNetwork'. No idea why, so probably should be reported at github as a bug.

Regards,

Probably SVG problem

14
Applications / Re: Test build of dooble with qt5
« on: May 11, 2022, 03:46:17 am »
Hi Remy, try adding set EXCEPTQ=Z in your environment, easiest is in a cmd window, then start Dooble in the same cmd window and see if it generates a trp when it exits. If not, try set EXCEPTQ=ZZ.

15
Applications / Re: Media-downloader
« on: May 10, 2022, 04:41:02 am »
OK, I think one problem is that media-downloader expects yt-dlp to be executable.
Copy it to yt-dlp.cmd and at the top of the file add
Code: [Select]
extproc k:\usr\bin\python.exe
adjust path to where your python is installed, perhaps c:\usr\bin\python.exe
Now it almost runs, with python failing like this,
Code: [Select]
[media-downloader] cmd: "f:/Home/dave/.local/share/media-downloader/bin/yt-dlp.cmd" "--newline" "--ignore-config" "--no-playlist" "-o" "%(title).200s-%(id)s.%(ext)s" "--progress-template" "download:[download] %(progress._percent_str)s of %(progress._total_bytes_str)s at %(progress._speed_str)s ETA %(progress._eta_str)s" "--progress-template" "postprocess:DoneDownloading" "https://www.youtube.com/watch?v=QJFFUT_WWpI"
k:\usr\bin\python.exe: can't open file 'F:/home/dave/yt-dlp.cmd': [Errno 2] No such file or directory

Seems python can't get past .local, on *nix a leading dot makes a file hidden, so we copy yt-dlp.cmd to %HOME% or f:\home\dave here and we get,
Code: [Select]
[media-downloader] cmd: "f:/Home/dave/.local/share/media-downloader/bin/yt-dlp.cmd" "--newline" "--ignore-config" "--no-playlist" "-o" "%(title).200s-%(id)s.%(ext)s" "--progress-template" "download:[download] %(progress._percent_str)s of %(progress._total_bytes_str)s at %(progress._speed_str)s ETA %(progress._eta_str)s" "--progress-template" "postprocess:DoneDownloading" "https://www.youtube.com/watch?v=QJFFUT_WWpI"
[youtube] QJFFUT_WWpI: Downloading webpage
[youtube] QJFFUT_WWpI: Downloading android player API JSON
[info] QJFFUT_WWpI: Downloading 1 format(s): 248+251
[download] Destination: Ladyva - Quarantine Boogie-QJFFUT_WWpI.f248.webm
[download] 100% of 38.28MiB at NA ETA NA
[download] Destination: Ladyva - Quarantine Boogie-QJFFUT_WWpI.f251.webm
[download] 100% of 1.78MiB at NA ETA NA
[media-downloader] Done downloading
[Merger] Merging formats into "Ladyva - Quarantine Boogie-QJFFUT_WWpI.webm"

So I guess Python has a bug with directories with a leading dot not being seen or perhaps expected behaviour.

Edit, quit now works here.

Edit:
Code: [Select]
extproc %UNIXROOT%\usr\bin\python.exeworks as well for yt-dlp.cmd and is portable.



Pages: [1] 2 3 ... 237