Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Igor

Pages: 1 [2] 3 4 5
16
Hardware / Re: Iomega ZIP 100 IDE
« on: February 09, 2022, 12:52:02 pm »
Wonder if a bootable Linux stick would recognize it?
If possible, a link to where to get and how to make such a stick.

17
Hardware / Re: Iomega ZIP 100 IDE
« on: February 07, 2022, 12:57:47 pm »

Did you try booting the machine with a ZIP diskette in the drive?
I remember, DOS never gave a letter to the drive, but the diskette, when using the IDE ZIP100 drive.

Perhaps it's the same with OS/2. Leave the disk inserted, and restart. - Does it have a drive letter now?
I tried to download the operating system having a diskette in the drive. This does not result.
I changed the definition of the device as a floppy disk. It did not help, and I recognize that the drive may simply spoil during this time. Until now, I have no opportunity to check the device's performance. And will this opportunity arise - it is not known.

18
Hardware / Re: New ArcaOS USB driver and Floppy drive
« on: January 11, 2022, 12:30:44 pm »
Ivan's question is not about broken floppies.
It's about "kicking" the drive to read the disk when you insert a new disk.
I remember that I had a hell of a time to get that to work correctly. I wish AN much fun with it :-).

I also want them to cope.  :)

19
Hardware / Re: New ArcaOS USB driver and Floppy drive
« on: January 11, 2022, 12:25:20 pm »
Hi Igor

I'm sorry but I don't understand your problem. Is it that the first time it reads the floppy and when you refresh the drive window does not reload it (reread).?

When you click on the floppy drive icon, it does not appeal and re-read the disk. Only for AN USB.
The initial reading of the disk occurs only when loading the system. After changing the disk, the FAT from the previous one can be recorded on it. This spoils the data on the disk.

20
Hardware / Re: New ArcaOS USB driver and Floppy drive
« on: January 11, 2022, 12:10:54 am »

Are you using the AN USB drivers or the Lars his USB drivers ?

Roderick
Problem only exists in the AN USB version.
Lars USB are working correctly.

21
Hardware / New ArcaOS USB driver and Floppy drive
« on: January 10, 2022, 06:15:11 pm »
I ran into a problem. USB drive of floppy disks does not reread the floppy disk when accessing the disk. In the 16-bit version, everything works successfully.
What can be done to solve the problem?

22
Internet / Re: Simple Browser revisited.
« on: January 02, 2022, 11:08:53 pm »
I installed all libraries, but I get an error when downloading a page:
Code: [Select]

______________________________________________________________________

 Exception Report - created 2022/01/03 01:04:35
______________________________________________________________________

 LIBC: Killed by SIGSEGV

 Hostname:         OS2HOME
 OS2/eCS Version:  2.45
 # of Processors:  4
 Physical Memory:  3535 mb
 Virt Addr Limit:  2944 mb
 Exceptq Version:  7.11.5-shl BETA8 (Jun  1 2020 18:37:02)

______________________________________________________________________

 Exception C0000005 - Access Violation
______________________________________________________________________

 Process:  C:\USR\LIB\QT5\EXAMPLES\WEBENGINEWIDGETS\SIMPLEBROWSER\SIMPLEBROWSER.EXE (09/25/2021 20:47:10 85,172)
 PID:      103 (259)
 TID:      07 (7)
 Priority: 200

 Filename: C:\USR\LIB\QT5WEBC.DLL (09/25/2021 20:47:11 92,191,016)
 Address:  005B:A903F5B8 (0001:00ACF5B8)
 Cause:    Unknown access fault

______________________________________________________________________

 Failing Instruction
______________________________________________________________________

 A903F5AF  MOV     EBX, [EBP+0x10]  (8b5d 10)
 A903F5B2  MOV     EDX, ECX         (89ca)
 A903F5B4  MOV     EAX, EDI         (89f8)
 A903F5B6  MOV     ESI, ECX         (89ce)
 A903F5B8 >DB 0xc5                  (c5)
 A903F5B9  STD                      (fd)
 A903F5BA  OUTSD                    (6f)
 A903F5BB  CMP     EAX, 0xa906dfb0  (3d b0df06a9)


23
Hardware / Re: Iomega ZIP 100 IDE
« on: January 02, 2022, 06:53:35 pm »
Igor,

I have an IDE Zip disk on an eComStation machine.  The motherboard does not have an IDE interface so I am using an expansion card with an IDE interface.  I have attached my config.sys in hopes it might be helpful.  I do not remember making any changes to my config.sys in order for the drive, or expansion card, to work - but it was a few years ago.

Thank you for your help. I will try to translate the device into floppy mode and then inform about the result.

24
Hardware / Re: Iomega ZIP 100 IDE
« on: January 02, 2022, 06:47:36 pm »
I seem to vaguely remember that with newer versions of DANIS506.ADD the DANIATAP.FLT is no longer needed.
What also seems odd that one driver reports use of IRQ 10 and the other of IRQ 16 for the very same controller. Just try without the FLT driver.

If you remove the Daniatapi, the disk icon in the minijm disappears.
Error with interrupts is a well-known Daniel error. There in one case does not correctly display interrupts if their number is more 15.

25
Hardware / Re: Iomega ZIP 100 IDE
« on: December 31, 2021, 03:58:39 pm »
Did you mention the master/slave status of the Zip drive?

My ZIP-drive is set as a master drive.

26
Hardware / Re: Iomega ZIP 100 IDE
« on: December 31, 2021, 03:55:27 pm »
Perhaps https://hobbes.nmsu.edu/download/pub/os2/system/drivers/storage/daniadsk.zip will help?
I installed this old Daniel driver. It did not help. The driver used by me for several years is newer and there is a disk icon in LVM, but it is supposedly not inserted.

27
Hardware / Re: Iomega ZIP 100 IDE
« on: December 31, 2021, 12:43:20 am »
I am guessing, that you need to mount a disk, and use LVM to assign a drive letter (same as required by USB sticks). That would need to be done for every disk, if it is actually the answer.
Thank you for the response. LVM does not allow you to create a volume on the disk, although the disk itself sees. Similarly, it displays flash drives that are missing. Of course, the drive in the drive is pre-inserted.

28
Hardware / [Solved] Iomega ZIP 100 IDE
« on: December 30, 2021, 10:48:35 pm »
I have iomega zip 100 with IDE interface. I want to access the disk.
I installed an additional IDE controller and drivers:

Code: [Select]
BASEDEV=DANIS506.ADD /!BIOS /A:0 /BM /U:0 /A:1 /I /V
BASEDEV=OS2AHCI.ADD
BASEDEV=DANIATAP.FLT /A:0 /U:0 /TYPE:Z /EJ /V

The system is successfully loaded.
I get a report:

Code: [Select]
R1.8.15      /!BIOS /A:0 /BM /U:0 /A:1 /I /V
            Daniela's Bus Master IDE Driver for OS/2 Version 1.8.15
Controller:0  Port:D020 IRQ:10  Status:OK
  JMicron JMB363 PATA host (197B:2363 rev:03) on PCI 2:0.0#1
 Unit:0 Status:OK ATAPI PIO0
  Model:IOMEGA  ZIP 100       ATAPI             14.A   

And

Code: [Select]
0/m: IOMEGA  ZIP 100       ATAPI              14.A    b                     
Port D020/D012, Irq 16, ATAPI, PIO0

0/s: (not present)

However, the drive letter in the system is not assigned and contact the device cannot be applied.

What can be done to get a drive letter in the system?
According to my memories, once a long time, this device worked in the OS / 2 system.

29
Applications / Re: patched PmMerge
« on: June 24, 2021, 09:47:31 pm »
Actually, it might indeed be a memory problem: a couple of secondary windows are created (and closed with exit) until I get a bunch of memory error messages, obviously one error message per attempt to open an additional window.

It's possible that PM (including the PM drivers) has some problem allocating memory. Potentially, because they have to allocate from some limited memory pool or region.
I have had success by decreasing the disk cache. This is a lack of kernel memory. In multiprocessor machines, the error message is not issued and the system is frozen.

30
Applications / Re: patched PmMerge
« on: June 24, 2021, 09:04:58 pm »
With the already mentioned config and with the ORIGINAL pmmerge, I do not get a hang on either testcase.
However, teststart2 eventually reports this:

SYS0008: There is not enough memory available to process this command.
All available memory is in use.

However, I cannot see memory depleting, therefore I think the root cause if something else. In any case, this seems to be a bug in the REXX interpreter.

What I can also see for testcase2 is that the initial window does not properly draw which might be a PM problem.
If this stuff crashes for you then there might be an SMP issue with PM (as I am only running on one core). I wouldn't be surprised.
Thank you for the error message! This is a very important point that I could not get on the SMP system. Perhaps another process is trying to still use the memory that is no longer left. And there is freezing.

Pages: 1 [2] 3 4 5