Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Martin Iturbide

Pages: [1] 2 3 ... 254
1
Hardware / Re: AHCI and Virtualbox
« on: March 27, 2023, 11:20:59 pm »
Hi Paul
.... but it would be nice not to have to try work out which rpm packages to reinstall....
Not sure if you want an answer for that, but Andy Willis once gave me this REXX script to list all the packages installed on my machine.

Code: [Select]
/* REXX to get just package names from RPM installed output */

rc = SysLoadFuncs()
Parse Arg fileout

rc = SysFileDelete(fileout)
fileinv = holdrpm.txt

address cmd 'yum list |grep install >'fileinv
list = ''
do while Lines(fileinv)
  text = LineIn(fileinv)
  parse var text package'.'.
  list = list || ' ' || package
end
rc = Lineout(fileout,'yum install -y 'list)
rc = SysFileDelete(fileinv)

Regards


2
Applications / Re: Java applications
« on: March 27, 2023, 12:38:10 am »
After the problem with Regim I want to point out that I have all programs on my system as original download (most of them). So if you run into trouble make a mark.

Ok, I got an older regim.zip from the Archive.org and it worked.
- https://web.archive.org/web/20060717013806/http://www.andreasroerig.de/regim/regim.zip

Regards

3
Applications / Re: Test build of dooble with qt5
« on: March 26, 2023, 07:46:47 pm »
Hi

Checking the Java applications, I got the doubt, "What happened to ICQ?".

So, I checked it out and it turned into a chat application that requires you phone number to be activated. I test it on Dooble, but I don't have people to chat with yet ;)
https://web.icq.com/

Regards

4
Applications / Re: Java applications
« on: March 25, 2023, 06:07:29 pm »
Hi

I can not also run Regim with the script listed on the site:
https://joopn.home.xs4all.nl/os2ecs/ecs6e84.htm

I get:
Quote
Exception in thread "main" java.lang.NoClassDefFoundError: regim/Regim
Caused by: java.lang.ClassNotFoundException: regim.Regim
   at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
   at java.security.AccessController.doPrivileged(Native Method)
   at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
   at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
   at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
   at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
Could not find the main class: regim.Regim. Program will exit.

Regards

5
Applications / Re: Java applications
« on: March 24, 2023, 06:09:27 pm »
Hi Joop

On this Netbeans page you have a dead link to "netbeans-7.3.1-netbeans-7.3.1-201306052037-javase.zip"
I found this one working:    
- https://github.com/tim-lebedkov/packages/releases/download/2019_Q1/netbeans-7.3.1-netbeans-7.3.1-201306052037-javase.zip

I followed your instructions, and I was sure to get the full "openjdk6_b27_sdk_os2_ga5-20130217.zip" on C:\PROGRAMS\OPENJDK

1) I don't know if deleting the "Locale" files are mandatory or optional, since just in case I want to keep the spanish things there.

2) I got this issue
Quote
[C:\netbeans\bin]netbeans.cmd --os2-install

[C:\netbeans]i:\utils\unzip -n C:\netbeans\nb\nbos2icons.zip -d C:\var\temp
SYS0015: The system cannot find the specified drive.
'NetBeans 7.3.1' folder created.
'NetBeans IDE 7.3.1' program object created.
'NetBeans Home' URL object created.
'NetBeans 7.3.1 README' URL object created.
'NetBeans 7.3.1 CREDITS' URL object created.
'NetBeans 7.3.1 Release Notes' URL object created.
SYS0002: The system cannot find the file specified.
SYS0002: The system cannot find the file specified.
SYS0002: The system cannot find the file specified.

It is because "i:\utils\unzip" is not in that location for me.  Easy fix, I fixed and worked.

3) I run the recently created "NetBeans IDE 7.3.1" inside the folder on the desktop.  It runs for a little while and stops.
Where can I get more info or log of what happened ?

If I run it by command line I get:
Quote
[C:\NETBEANS\BIN]netbeans.cmd
C:\NETBEANS
C:\NETBEANS\platform\lib
SYS1065: The input line is too long.

Regards

6
Applications / Re: Java applications
« on: March 24, 2023, 02:49:48 am »
Hi Ivan

I use a .cmd script to run the java applications, but Netlabs Netbeans and Eclipse seems to be more complex to execute.

Regards

Update: Corrected my typo.

7
Applications / Re: Java applications
« on: March 23, 2023, 04:31:14 pm »
Hi

I'm still trying to find the latest working Eclipse and Netbeans on OS/2 OpenJDK 1.6, to try to repack it and upload those to hobbes. I was unable to make run any of those old versions on a modern ArcaOS for the moment.

Help is appreciated.

Regards

8
Applications / Re: pdf plugin for Lucide missing after Poppler upgrade
« on: March 22, 2023, 08:33:37 pm »
Hi Again

By any chance do you have the "poppler-legacy-70" package installed?
Seems that  lupplr.DLL makes reference to that old poppler, that I guess was renamed as "legacy" on the rpm. With that you don't need to backlevel the main poppler package.

Regards

9
Applications / Re: pdf plugin for Lucide missing after Poppler upgrade
« on: March 22, 2023, 08:28:39 pm »
Hi

I have ArcaOS 5.0.7 and Lucide 1.5.0.1  (Hobbes has the same).
Even that I had installed Qt5 and Dooble, I don't experience your issue while opening a PDF.
Lucide 1.5.0.1 is working fine here to open and view PDFs.

The other alternative is qpdfview.  "yum install qpdfview"


Regards

10
Off Topic discussions / Re: Missed you all!
« on: March 22, 2023, 08:06:19 pm »
Hi ppgrainbow

Welcome back.  We had a horrible HDD crash on 2012 and since it took too much to recover I had to recreate the forum.

Here are you old posts, just in case: https://www.os2world.com/oldforum/index.php?action=profile;area=showposts;u=5719

Good to have you back. !!!

Regards

11
Comments, Suggestions & Questions / Re: Hobbes (Files) Reoganization
« on: March 20, 2023, 04:11:05 pm »
Hi

Maybe you noticed that I had been reorganizing the Java section (/pub/java) using the similar structure of /pub/os2/
The idea is to have Freeware/Shareware/Open/Public/Free java software that runs on our current versions of Java, and try to include some .cmd that gives the user a first hand help to run the app on OS/2. 

It is fun for the moment, and Joop's Java website had been of great use. Thanks a lot to Joop.

Regards

12
Applications / Re: Java applications
« on: March 20, 2023, 03:11:02 am »
Hi Joop
Hi Martin, did you start version 6865 more than once? Some programs look for a setup file or something similar which is written by the  program, but with first run there is nothing, so the program exits, but writes a setup file on exit. Next start it can find that file and does start.

I tried to run it several times, but it gets me the same error.

I also tried to run it directly  with "java -jar run.jar" and I got.
Code: [Select]
[C:\HOME\DESKTOP\GENJ_APP-6865]java -jar run.jar
java.lang.UnsupportedClassVersionError: launcher/Launcher : Unsupported major.mi
nor version 51.0
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:634)
        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:14
2)
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)
        at java.net.URLClassLoader.access$000(URLClassLoader.java:73)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:212)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
Could not find the main class: launcher.Launcher. Program will exit.
I think that is the usual error when the software was developed with a java version we don't have.

Regards


13
Applications / Re: Java applications
« on: March 19, 2023, 06:31:50 pm »
Hi

Testing GenealogyJ
https://joopn.home.xs4all.nl/os2ecs/ecs6e78.htm

- Version 6798 works fine.
- Version 6865 gave me an error on start.

Maybe Joop's  page can be updated to say that version 6798 works fine.

Just as personal note, I like this software and I use it like every two months for my family tree.

Regards

14
Applications / Re: Java applications
« on: March 19, 2023, 04:51:47 pm »
Thanks Lars for the link.

Regards

15
Programming / Re: Qt6 Application Testing
« on: March 19, 2023, 04:40:50 pm »
Hi Everybody

FYI: Tellie has ported BibliteQ on QT 6.4 also for testing:
- ftp://ftp.netlabs.org/pub/qtapps/biblioteq-v15022023-os2-6.4.2.7z

Please post any feedback if you like to.

Regards

Pages: [1] 2 3 ... 254