Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Greg Pringle

Pages: [1] 2 3 ... 9
1
Networking / Re: USB Modem
« on: March 04, 2022, 02:08:20 pm »
I have used TalkThru for modem use and it works well. All the normal configuration controls. I have scripts for PPP use. Also, once there is a working modem, I have used java with the added com support from IBM for modem control. That allowed me to write things like pager connections which requires being able to send any binary character. I am not sure on the license status of TalkThru but I purchased copies back in the 90's.

I used java for automated data connections. The java was able to change the default route temporarily to the modem, away from the ethernet, and then change back when the job was done.


2
Applications / Re: Apache OpenOffice no longer starts
« on: July 16, 2021, 06:27:19 pm »
I deleted the home directories and the programs directories and loaded OpenOffice 4.1.8
Now it is working again.

Thanks for the tips.

Must have been an incompatibility with the current system dll (s)

3
Applications / Re: Apache OpenOffice no longer starts
« on: July 15, 2021, 08:06:05 pm »
Thanks for the note. I used the yum list in the readme and updated all but that does not fix the problem.

4
Applications / Apache OpenOffice no longer starts
« on: July 15, 2021, 04:08:29 pm »
I had Apache OpenFoffice AOO-4160-GA running. I removed it and loaded AOO-4170-GA. Now it will not start. I deleted the directories and even re-installed the C: partition (boot) and AOO-4170-GA will not start. Then I went and re-installed again and loaded AOO-4160-GA which also will not start. It gets to the "1.Welocme"  which is the new install setup, and when "Next" is pressed the application vanishes without any errors.
Are there any suggestions?

5
Applications / Re: hard hangs
« on: June 23, 2021, 11:59:38 pm »
I notice you never answered this question from Roderick:

When the system has hung, does it respond to CTRL ALT F10 twice

I remember it as Ctrl-Alt-Num Lock twice.

It's supposed to start a system dump.

The CTRL ALT F10 x2 in Linux breaks out of the graphical shell which can be done from a VM.

The other one, CTRL ALT Num x2 is an OS/2 version.

6
So, for you "OS/2" is dead.

That reminds me of OS/2 1.0 which I used a few times. My roomate ran a BBS using it. Then 2.0 came out and I bought it. Soon I programmed for it and installed many applications at work that cound not be done with windows 3.1 As time went on I used virtually every varient of OS/2. All along it was being called "Dead". I even knew the people at IBM that were responsible for trying to kill OS/2. They all failed, most lost their jobs. Yet, OS/2 continued.

I use both an OS/2 machine and a virtual OS/2 machine. The normal machine is faster and has a better interface. I don't have to bother with multiple logins and odd screen views.

I develop for every operating system. OS/2 is still the best.

(by the way, the Colonial Pipeline hack would not have happened with OS/2)

7
General Discussion / Re: eCS 2.2 purchase
« on: May 19, 2021, 02:16:54 pm »
So, Neil, you say Arca Noaea does not have re-sellers?

8
Setup & Installation / Re: Booting with NVMe
« on: April 15, 2021, 01:43:06 pm »
I am still thinking about how to use it effectively.

I was running in Linux an application with a raid 5 setup on a AMD Epyc system. The application was so heavy on the disks it killed off the Btrfs file system. I then changed machines and went to an new Epyc system with U.2 drives only (U.2 = NVMe). The application is now running very smoothly without any disk thrashing. Speed matters. I have had to transition applications from OS/2 due to speed issues.

9
Setup & Installation / Re: Booting with NVMe
« on: April 14, 2021, 06:02:52 pm »
I had tried the USB stick method and there was a hang after leaving the config.sys editor after the end on the manual install F10. I will some variations.

10
Setup & Installation / Booting with NVMe
« on: April 14, 2021, 02:13:39 pm »
Does anyone know how to use the ArcaOs NVMe dirver for the boot device?

11
Storage / Re: eSata
« on: March 27, 2021, 12:45:42 pm »
M.2 is NMVE and so is U.2 I have been installing U.2 servers and I can say that SATA does not hold a candle to it. A 1 gig U.2 is around $350 but comes in enterprise class and is hot swapable. The one issue is how to raid these devices. Not really possible at the moment. But is it needed? I have some enterprise SATA drives online for over 14 years that are used heavily for small files 7 days a week without a single failure. The other downside is the only way to use the U.2 at present is with a rack server which has the correct backplane. I currently use linux (suse 15) for this. I have a number of instances of a java based database I wrote running on various platforms. (Win, OS/2, LInux, AS/400) I had reached a bottleneck with SATA drives with very heavy use. Now with U.2 the applications look like there is no load on them. I am eager to see NVME on OS/2.

12
Internet / Re: The new browser / QT5
« on: October 27, 2020, 04:13:52 pm »
I only checked a few YouTube videos using Falcon on Win 10 and they all worked fine.
What did not work were any of the videos on www.cnn.com or www.cbsnews.com
CBS uses some java script to have an opening commercial and then switches to the actual video.
Neither of these ran under Falcon.
CBS game me a spinning dots circle then a black screen.
CNN gave me a "Code4 | Message: Something went wrong during native playback"

13
Internet / Re: The new browser / QT5
« on: October 26, 2020, 03:50:24 pm »
Today I loaded Falkon under windows 10 and found it ran youtube fine but would not display the videos on CBS or CNN. Does anyone know why? Will this be the same for OS/2?

14
This topic is a perrinial problem for me. Small backups are easy. Zip, xcopy, cp will all work.
Some believe that incremental backups are the way.

I am lazy and have a large number of drives with large numbers of files so those methods don't work.

If there has been JFS crashes then you could really be in trouble due to pointer problems which are uncorrectable.

I came up with a java based solution which is not perfect but works.
It has 3 phases.
1. a listing of all files and directories is creaed in a file.
2. the listing is split into smaller listings based on number of files and data size.
3. the backup is performed by individually running each listing from step 2

Step 3 will either run or fail. When it failes the section of the file structure will be obvious.
The listing file can be altered to bypass bad files and then restart the backup where it left off.

Painful but will work on any drive that can be read. Even with bad JFS sections.


15
Storage / Re: JFS file corruption
« on: October 30, 2019, 01:00:42 pm »

My daily rsync of ~600GB of data on my NAS to an external drive runs in a couple of minutes.


This is definitely something to try.
In addition I have the need to make archival disk copies of complete disks which can be stored or moved to another machine.
When there is corruption of a range of files I have used my copy software to bypass the corruption. Not sure what rsync would have done.

Pages: [1] 2 3 ... 9