OS2 World Community Forum

OS/2, eCS & ArcaOS - Technical => Hardware => Topic started by: Jim Hughes on March 12, 2017, 05:35:55 pm

Title: Intel's USB3 (xchi) gotcha [w/ OT a bit of a Lenovo rant]
Post by: Jim Hughes on March 12, 2017, 05:35:55 pm
Hi to All

I recently purchased a Lenovo P310-SFF ThinkStation (with Win7 through w10 downgrade);
to use as my replacement Windows desktop and with the hope that I would also be able to eventually load some
version of os/2 on it (the hope came from Lenovo's propaganda indicating being able to use Linux, which I don't use, with

I'm still playing/tinkering with the computer, I've installed a couple of front 2.5" drive trays. Lenovo's
Rescue/re-install media (w7 or w10) disregards any current partitioning\sizing and completely wipes the
system HDD/SSD, creating a single (full disk size) GPT system partition and the associated hidden
partitions. Apparently, Lenovo's licensing won't allow their OEM w7 and w10 to coexist on the same machine.
nor, could I figure out how to change the w7 "product key" to one of my spare licenses, its not available in
the control panel system object.   

OK, as I currently use win7 and have had only a passing brush with w10, I thought why not install W7 from
scratch and then later with dfSee, to the rescue, re-size and clone/copy the Lenovo w10 installation from a
2nd drive to free space on my "working" drive.

This led to the Intel USB3 (xchi) gotcha;

Intel, in it's wisdom, on the Skylake(others?) architecture, has removed the EHCI component from their XCHI
controller which may be an initial "show stopper" for os/2 installations on mother boards with similar chip
sets, until we have USB3 support.

As an aside, the P310 does have 2 USB2 rear keyboard/mouse ports, plus I purchased a fall back of ps/2
ports. When I have time I'll cobble together a "plumber's(elect.tech's) nightmare" of cables/hub(s)/devices
and try that. Oh yea, ps/2 bits where were they last seen and in what box?

Title: Re: Intel's USB3 (xchi) gotcha [w/ OT a bit of a Lenovo rant]
Post by: Dave Yeo on March 12, 2017, 07:21:39 pm
Reading the Wiki article on Skylake, I notice that they've retired VGA, probably along with VESA, so that by itself probably breaks OS/2.
Title: Re: Intel's USB3 (xchi) gotcha [w/ OT a bit of a Lenovo rant]
Post by: Jim Hughes on March 12, 2017, 08:40:13 pm
Hi Dave

The P310 comes with some form of Intel HD graphics 530 buried in the I7 cpu. The P310 has 2 x display ports (using 1 through dp --> dvi) and 1 x VGA (-->2nd monitor), plus on the mboard there are 2 x PCI express x 16 slots (1 of them negotiable for  PCI express x4 or x1) & 2x PCI express x 1 slots.  Video will be more playing and tinkering, right now I'm just running 1080 x 1920 res on 2 monitors (one of which is  4k capable).

[Having half my major computing equip go to Hell at the same time was $$, but being in my late 60s and still working I could swing it.  I'm wishfully thinking they may last the rest of my computing life. My current w7 machine has a band aid functional opsys that I'm scared to take down until I get the P310 functional and loaded , and it will eventually be my os/2 primary.   I do have a clunker machine with os/2 installations but everything is even more flaky, too many machines, hdd changes, installations, file copy overs, etc. for all I can remember may even contain remnants going back to when warp3 red came out on floppies, but definitely at least to eCS1.O]

Title: Re: Intel's USB3 (xchi) gotcha [w/ OT a bit of a Lenovo rant]
Post by: ivan on March 12, 2017, 10:35:15 pm
Jim, you say that win 7 and win 10 will not coexist on the same hard disk which is quite understandable considering MS wanting to get everyone on to the SaaS monthly payments band wagon.

There might be a way to get round that but it does involve a second hard disk assuming the motherboard will allow that.  Use DFSee to clone the partition that holds the restore files and save to a safe place then install one of the versions and test that it works.  Again use DFSee to clone that install to the new drive, (don't forget that MS uses a small hidden boot partition and you need to clone that as well), remove the drive and then install the other win version.

You should be able to put the new drive in the unit and with a few tweaks you should see a boot menu on startup which will allow you to select which version to boot. 
Title: Re: Intel's USB3 (xchi) gotcha [w/ OT a bit of a Lenovo rant]
Post by: Jim Hughes on March 13, 2017, 12:53:58 am

Thanks Ivan
I've thought of trying that, but right now I'm "disk poor" i.e. of the right size. I've pretty well converted to using SSDs (haunted the sales) but am short of  ones that are about 200g. The Lenovo supplied w10 media won't install on 125g (too small), The P310 was bought with a 500g SSD that I want to reserve for data, not waste on empty free space.

My minimum setup is 1 disk (system(s) only and a 2nd removable disk (data/or?). I like cloning  disk --- > disk, size for size, geometry for geometry, etc, as there is far less messing around. I clone win under os2 and os2 under win. Once I've settled on the system setup, the opsys disk(s) will move to the 2 internal disk connections  leaving the 2 front loading trays free for data or whatever.

To hell with the windows world's M$ (scattered) user data filing system and the concept of "one disk is all you need, too full we will sell you another, charging $$$ to do the transfer, have fun finding that important file that got lost/misplaced ".

Title: Re: Intel's USB3 (xchi) gotcha [w/ OT a bit of a Lenovo rant]
Post by: Jim Hughes on March 13, 2017, 01:37:03 am

missed this
re: On disk Restore files they'e gone, Lenovo lets you create a USB stick or multiple progressive DVDs from the (as received) factory Restore Partition, w7 in my case, for w10 it was a ordered free download from Lenovo, There is no second kick at the can, the on disk restore is no longer accessible, nor can w10 be re downloaded. I've tried to clone the w7 stick as backup but the clones don't seem to work. Haven't tried anything with w10 other than a quick and dirty install (since blown away) to see if it works, that is how I found out that 125g was too small.

Title: Re: Intel's USB3 (xchi) gotcha [w/ OT a bit of a Lenovo rant]
Post by: ivan on March 13, 2017, 02:43:45 pm
I hate it when they do that which is why I always clone the disk of any windows box that friends bring round for me to setup - we don't touch windows at work, OS/2 or linux only.

Depending on just hoe that USB stick is setup you might be able to do a direct copy to a bootable stick.  One of my guys used a small program (win only) to make a bootable USB stick from a win 7 DVD for his parents machine, that way he always had it with him when he went to visit and fix problems.  You might be able to do something like that using the USB stick you made.

Title: Re: Intel's USB3 (xchi) gotcha [w/ OT a bit of a Lenovo rant]
Post by: Jim Hughes on March 13, 2017, 04:49:32 pm

The attempted clone I did was with dfSee using size for size usb sticks, but from different manufacturers though; the target stick was fully wiped with dfSee first. I'll have to try find an identical stick to the original, wish the manufactures/retailers looked on these things as a tool not a moving targets/fashion statements that have to be changed like normal people change socks.