OS2 World Community Forum

OS/2, eCS & ArcaOS - Technical => Hardware => Topic started by: Doug Clark on April 12, 2019, 03:58:50 pm

Title: Pen for OS/2
Post by: Doug Clark on April 12, 2019, 03:58:50 pm
I am trying to get Pen for OS/2 to install. When I run pinstall.exe (the install program) I get an error message saying "There is an active Pen for OS/2 Install program running. This is not supported."

I believe Sigurd Fastenrath has posted videos of a Samsung table running with Pen for OS/2.

Anyone know how to install Pen?
Title: Re: Pen for OS/2
Post by: Roderick Klein on April 12, 2019, 09:08:57 pm
I have noticed ArcaOS installs the deamon in the config.sys the same eCS does. Its part of minstall from Netlabs that replaces the IBM minstall versions. IBM minstall does a couple of things (I can not remember which), which you do not want running onr your system. The EXE \MMOS2\mmhelpdd.exe runs as deamon that blocks the old minstall so it does not start.

Now as it turns out Pen for OS/2 and Ultimedia installer from IBM use the same kind of minstall. That is why its blocked.
Kill the process with TOP and you should be able to install Pen for OS/2.

Roderick Klein
Title: Re: Pen for OS/2
Post by: Doug Clark on April 12, 2019, 10:00:30 pm
Thanks you Roderick,

That was exactly the problem.
Title: Re: Pen for OS/2
Post by: Martin Iturbide on April 12, 2019, 11:14:30 pm
Hi Doug.

Which "pen software" are you trying to install? and which hardware are you using?

I have tried a Wacom Bamboo Splash (https://www.youtube.com/watch?v=974z2320HxM) some time ago and worked as a mouse and used "USBECD (https://www.os2world.com/wiki/index.php/USBECD)"

Title: Re: Pen for OS/2
Post by: Martin Iturbide on April 13, 2019, 04:25:04 pm
Which "pen software" are you trying to install? and which hardware are you using?

Is this version? I just created this wiki page (https://www.os2world.com/wiki/index.php/Pen_for_OS/2).

Title: Re: Pen for OS/2
Post by: Doug Clark on April 13, 2019, 07:16:42 pm

I was trying to install the Pen for OS/2 base that came on Devcon. Then I found an updated package on Hobbes (which I think you posted) for Warp 4 or later. When I tried that I got the (same) error message. Roderick's suggestion fixed the install issue - which I see is now on the Wiki you created. Thank you. I now have Pen installed - I think. (I got a strange message from IBMLANLK about the drive not being large enough to process the locked files. I suspect that is because of the version of IBMLANLK supplied in the Pen install package - but I don't see any files that didn't get installed so....)

I am using an AceCad  AceCat III tablet. The tablet comes with a driver to use with Pen and a driver for use without Pen. I have been using it without Pen and it works great - basically replicating the functions of a mouse.  But the tablet is small - 5 inches by 5 inches - so using in the mode where the tablet represents the entire desktop is difficult with a large desktop. I wanted to install Pen to find out what other tablets Pen supported and to see how Pen worked, and perhaps upgrade to a larger tablet. But probably not a calcomp 9500 - tempting as that is.

 I have since found out there are other tablets that work with OS/2 which do not have drivers bundled with Pen - such as Wacom Bamboo - thanks for the video link. W.M.Brul (http://home.hccnet.nl/w.m.brul) has some drivers for other tablets - including USB tablets.  I thought my choices were limited to older tablets with a serial port interface, but it appears that is not the case.

The AceCat III tablet is a serial port tablet that is powered by a keyboard port. Since my motherboard (ASUS M5A78L-M USB3) has a header on the board for a serial port and a combo PS/2 keyboard/mouse port I can use the tablet.
Title: Re: Pen for OS/2
Post by: Doug Clark on April 14, 2019, 12:37:07 am
My experience with Pen for OS/2 so far:yy

The installer for Pen wants to put the old standard mouse driver (mouse.sys) toward the top of the config.sys file. I am running AOS and have AMOUSE.SYS as my mouse driver - what was installed by AOS. On boot up OS/2 loads MOUSE.SYS first, then throws a message when it gets to AMOUSE.SYS saying it can only load one mouse driver.

On my machine Pen is unstable with MOUSE.SYS. I had a couple of crashes in JFS with Pen installed and using MOUSE.SYS.

However Pen is stable when using AMOUSE.SYS, so far.

AceCad supplies two drivers for the AceCat tablet: a driver for Pen (APENOS2.SYS) and a driver for use without Pen (ACECAD.SYS). The driver for Pen does not work - when installed the computer freezes before the desktop appears on boot up, using either MOUSE.SYS or AMOUSE.SYS. I don't know if this is a problem with the AceCad driver or with Pen itself, or both.

The AceCad driver for use without Pen (ACECAD.SYS) makes the tablet appear to the system as a mouse. You can map the tip and two buttons on the pen to mouse actions, but the system cannot distinguish between a mouse pointer in a field and the pen pointer in a field with this driver.

Pen for OS/2 provides a feature for using a mouse as a pen - which in this case means using a tablet acting as a mouse as a pen. The setting appears on page 2 (added by Pen) of the Timing tab on the Mouse Driver object in System Setup.  When "Enable pause time" is checked, Pen for OS/2 will treat the pointer as a pen until the pen is pressed down (or mouse button one held down) for the amount of "pause time" without any movement.  After the pause time is reached the pointer is transformed into a regular mouse pointer. Before the pause time is reached the pointer acts as a pen - meaning you can enter "gestures" or use it for handwriting.

Title: Re: Pen for OS/2
Post by: David McKenna on April 14, 2019, 02:21:54 am
 Hi Doug,

  Haven't used PenOS/2 for a very long time, but if I remember correctly, Pen installs 2 of it's own drivers one of which (can't remember which) is not SMP safe. You might want to try it with ACPI.PSD /MAXCPU=1 (if you have a multiprocessor) and see if that helps.

Title: Re: Pen for OS/2
Post by: Martin Iturbide on April 14, 2019, 07:04:32 pm

It is also interesting to see the WPS Classes created by Pen for OS/2 once it is installed (It is the first time I install this). I will check that futher to see if something can be documented for the EDM/2 or the OS2World wiki.


Title: Re: Pen for OS/2
Post by: Doug Clark on April 15, 2019, 12:25:56 am

The two drivers are EMI.SYS and EIQOS2.SYS

I just had opening Firefox for a second time in a session crash the system - black screen, no details, rebooted on its own. Never had that happen before. I've had Firefox disappear - which almost always appears to be related to something getting messed up in the profile - but never has FF taken anything else with it. So it looks like you are correct, and I just hadn't hit the issue yet.

So I will REM out those two drivers, leave the rest of Pen installed, and see what happens for a while. The popup keyboard, for example, still works without the drivers. Then I will try each driver one by one and see how that affects different Pen functions.  I will also try the maxcpu=1 just for educational purposes.

Now that I have had Pen installed for a day or so and looked at its features, its value really is for a tablet PC, or perhaps for a convertable tablet/laptop used in tablet mode. For a digitizing tablet with its own driver hooked to a desktop or laptop that has a keyboard, not so much.
Title: Re: Pen for OS/2
Post by: Joop on November 01, 2019, 04:30:55 pm
These two drivers, EMI.SYS and EIQOS2.SYS, are for pressure. But as far as I know there are only one or two programs which do support pressure. So with the making of the drivers for the Wacom Bamboo and up it was decided not to support pressure. You can find the driver for the Wacom Bamboo on my site http://joopn.home.xs4all.nl/os2ecs/ecs2e1.htm (http://joopn.home.xs4all.nl/os2ecs/ecs2e1.htm). Wim Brul has also same driver on his site http://home.hccnet.nl/w.m.brul/usbwacom/index.html (http://home.hccnet.nl/w.m.brul/usbwacom/index.html), but with a shorter more direct manual and he made some more tablets available http://home.hccnet.nl/w.m.brul/index.html (http://home.hccnet.nl/w.m.brul/index.html). I still use the Wacom Bamboo.
Title: Re: Pen for OS/2
Post by: Doug Clark on November 02, 2019, 05:44:35 pm
I recently picked up a CalComp DrawingBoard iV and just got it hooked up and working with BlueCad on WinXP yesterday.

It is connected to an old pentium 4 3.2 ghz single core machine that dual boots XP and ECS.  So I will try next week and see if I can get it working with Pen for OS/2 on ECS. Since the board will emulate some 30 other boards/protocols and the machine is single core, I am somewhat hopeful Pen will work, if indeed the problems with Pen are related to SMP and one of the emulations available with the board match a driver supplied with Pen.

Since the board connected via RS232/serial I don't think I can use any of JOOPs drivers.
Title: Re: Pen for OS/2
Post by: Joop on November 03, 2019, 01:05:30 am
I had a Calcomp Ultraslate drawing tablet. I got a mail about a virus and I thought this was not possible in OS/2. It turned out that I had a virus  and it was IN the Calcomp driver. So I removed it and did some virus checks (back then that was still possible on an 1G memory system, today you need more memory) and my machine was clean, don't know how it is today because the only virus checker needs more memory then 1G, which I don't have. So my advice is to check the files of the Calcomp stuff. I do still have some new boards from Calcomp, but due to the included virus I don't use it and Calcomp doesn't give any answers.
Title: Re: Pen for OS/2
Post by: Sigurd Fastenrath on November 03, 2019, 11:17:01 pm
I believe Sigurd Fastenrath has posted videos of a Samsung table running with Pen for OS/2.

Just for information: I did not use PEN for OS/2 as it did not work together with the drivers I used, made by Wim Brul.
This drivers do not only work with stylus but also with touch, depending on the device you are using (i.e. Thinkpad X200 Tablet, X230 Tablet, Samsung Serie 7 Slate etc.)

I installed PEN for OS/2 to use the On Screen Keyboard Part of it, and to see if it would be usable at all. There is a Virtualkeyboard available from ecs.ru as well, wich is more modern.

For Writing I usually do use the JAVA 6 Program Jarnal. There are Painting Programs running with Java 6 as well.

I recently was able to get a Thinkpad 710T (from 1993 that should arrive this week) and I am going to try to install OS/2 2.1 and PEN for OS/2 on it as it should work with it. Looking forward to test it  ;)
Title: Re: Pen for OS/2
Post by: Doug Clark on November 18, 2019, 02:12:15 am

Wow.  I guess I won't be trying the calcomp driver that is bundled with Pen for OS/2. I don't have a virus checker or any way to check those files.  The board will emulate a Wacom output format, so I might try the watcom and your driver, if you think it would work with a USB to serial adapter.

I have been trying to buy a pen for the board and can't find out from Calcomp which cordless pens work with that board. When I tried to buy what was listed on their website, the vendor who handles their stuff said it wouldn't work, and could not tell me a part number that would. I bought the board so my wife could trace dress patterns and then modify the patterns; I thought a pen would be easier for her use while tracing than the "cursor".

I stumbled on some manuals for earlier Calcomp boards (9100 and 9500) that appear to show the formats of the output of the various Calcomp boards, and the commands you can send to the board(s) to configure them, both from the host computer and from the 16 button cursor. I can send you the links, or the files, if you would like.

Title: Re: Pen for OS/2
Post by: Wim Brul on November 19, 2019, 11:28:04 am
Hi Doug,

To try and get the GTCO CalComp DrawingBoard IV working as a mouse on eComStation start as follows:

You need to use the optional serial interface. You need to customize the tablet data format and communications parameters using the Menu Strip.

Mode: Run. Baud Rate: 38400. Data Bits: 8. Parity: None. Data Rate: 125 pps. Resolution: 2540 lpi. Output Format: 21. Emulation: Wacom Binary.

Using the above values I expect the tablet to interface the same way as the Lenovo ThinkPad (COM) models do.

Add DEVICE=O:\OS2\BOOT\PSCOM.SYS into your O:\CONFIG.SYS file assuming eComStation installed on drive O:

Reboot your system and run "COMRAW.CMD" to get raw input data. Run "DECODE.CMD" to display events.

Display from DECODE.CMD using the correct baudrate looks like:


Regards, Wim.