OS2 World Community Forum

OS/2, eCS & ArcaOS - Technical => Setup & Installation => Topic started by: Sigurd Fastenrath on September 03, 2019, 01:48:03 pm

Title: And it works! DOS and WINOS2 on Thinkpad X 250!
Post by: Sigurd Fastenrath on September 03, 2019, 01:48:03 pm
While I am playing around with the Thinkpad X250 I realizide by accident:

I am wondering, I just took a look again at Bug report 1193 in Bugtracker, and on August 20th 2019 David added a file called vio-1.0.wpi and now:

- DOS Fullscreen
- WINOS2 Fullscreen
- WINOS2 windowed

are working on the X250, even in SMP Mode!!

- DOS Windowed mode takes no input (does only show  :/ )
- DOS Windowed mode switched from DOS Fullscreen with Alt+Home starts very slow and freezes after a fiew inputs

It took some seconds more during booting, but it works!

BUT PLEASE NOTICE: It is mentioned in the readme, that it might not work on each and any Hardware!!

Wonder, why this is not mentioned elsewhere!! Great!!

And a question: is it possible to spread this file to other people or is it somehow restricted?
Title: Re: And it works! DOS and WINOS2 on Thinkpad X 250!
Post by: Mike K├Âlling on September 03, 2019, 02:51:23 pm
I can confirm that WinOS/2 and DOS full windows session is working also under eCS21.DE if the mentioned wpi is installed.
(http://WinOS201.jpg)
Greetings from Potsdam / Germany,
Mike
Title: Re: And it works! DOS and WINOS2 on Thinkpad X 250!
Post by: Sigurd Fastenrath on September 04, 2019, 08:06:43 am
Thinkpad 25 (aka Thinkpad 470):

- Fullscreen both working
- Windowed none
Title: Re: And it works! DOS and WINOS2 on Thinkpad X 250!
Post by: Eric Erickson on September 26, 2019, 09:21:48 pm
T540P Report after application of the vio-1.0.wpi referenced in Bug 1193.

WinOs2 Windows - Works fine
WinOs2 Fullscreen - Computer Hangs
Dos Window - Opens, but unable to use. No Prompt ever received. 
Dos Full screen - Computer Hangs

Since all I really want is the WinOs2 Window. I'm considering this as a win!. When I say Computer Hangs, its a hard hang requiring a Power Off to recover.
Title: Re: And it works! DOS and WINOS2 on Thinkpad X 250!
Post by: Neil Waldhauer on September 27, 2019, 04:30:35 pm
I also have a T540P, but I updated to the latest released ACPI and Panorama.

WinOS2 Window  - Works
WinOS2 Fullscreen - Works
Dos Window - Opens, but unable to use
Dos Full Screen - Works

I don't use DOS/WinOS2, so it doesn't affect my use, but I want my customers to have the best available setup.
Title: Re: And it works! DOS and WINOS2 on Thinkpad X 250!
Post by: Martin Iturbide on September 27, 2019, 06:24:44 pm
Hi

Just to complete the information, people that have access to the ArcaOS Mantis can find the "vio-1.0.wpi (2019-08-20)" file here:
https://mantis.arcanoae.com/view.php?id=1193 (https://mantis.arcanoae.com/view.php?id=1193)

Regards
Title: Re: And it works! DOS and WINOS2 on Thinkpad X 250!
Post by: David McKenna on September 29, 2019, 06:51:03 pm
 Another thing I found on 2 of my computers is that 'DOS_UMB=off' must be set, or no DOS/Win session will work...
Title: Re: And it works! DOS and WINOS2 on Thinkpad X 250!
Post by: David Graser on September 29, 2019, 08:16:42 pm
Another thing I found on 2 of my computers is that 'DOS_UMB=off' must be set, or no DOS/Win session will work...

David, what are you adding this string to?   Are you adding this string to the object's properties > environment > add or modify environmental strings or something else?
Title: Re: And it works! DOS and WINOS2 on Thinkpad X 250!
Post by: David McKenna on September 29, 2019, 08:56:20 pm
 Right click on the session icon -> Properties, click on the 'Session' tab -> Properties, choose 'All DOS settings' and scroll down to 'DOS_UMB' and click the 'Off' button. In CONFIG.SYS the default values are set on the DOS=LOW, NOUMB line. If you ever changed that for some reason (like I did) to DOS=HIGH, UMB then DOS/Win sessions will default to using DOS_UMB=On unless you go to the properties page of each session and explicitly change it there. So it's a good idea to check for that if you are having trouble with DOS/Win sessions...
Title: Re: And it works! DOS and WINOS2 on Thinkpad X 250!
Post by: David Graser on September 29, 2019, 10:40:52 pm
Right click on the session icon -> Properties, click on the 'Session' tab -> Properties, choose 'All DOS settings' and scroll down to 'DOS_UMB' and click the 'Off' button. In CONFIG.SYS the default values are set on the DOS=LOW, NOUMB line. If you ever changed that for some reason (like I did) to DOS=HIGH, UMB then DOS/Win sessions will default to using DOS_UMB=On unless you go to the properties page of each session and explicitly change it there. So it's a good idea to check for that if you are having trouble with DOS/Win sessions...

Thanks Dave.  Although the setting did not help out my DOS  Window and Win window  sessions, this info is good to know.  I still have full screen capabilities for both.
Title: Re: And it works! DOS and WINOS2 on Thinkpad X 250!
Post by: Eric Erickson on October 01, 2019, 10:32:37 pm
I also have a T540P, but I updated to the latest released ACPI and Panorama.

WinOS2 Window  - Works
WinOS2 Fullscreen - Works
Dos Window - Opens, but unable to use
Dos Full Screen - Works

I don't use DOS/WinOS2, so it doesn't affect my use, but I want my customers to have the best available setup.

I don't have an active subscription right now, so thats not an option at the moment, but I'm going to try the UMB option and see what that gives me. Mine is a V5.03 Base, have to see what updates I do have available. This is a low priority project at the moment, but will probably get more cycles as my T61p is starting to give me some issues.