OS2 World Community Forum

WebSite Information => Article Discussions => Topic started by: Martin Iturbide on October 28, 2019, 03:13:57 pm

Title: Qt 5 version 5.13.1 OS/2 Beta 1
Post by: Martin Iturbide on October 28, 2019, 03:13:57 pm
Congratulations to Bitwise works on this new milestone.

I'm looking forward to try Qt5 and I hope to get more time to play with Qt Designer.

Regards
Title: Re: Qt 5 version 5.13.1 OS/2 Beta 1
Post by: ivan on October 30, 2019, 03:16:29 pm
OK, I may be a bit thick today but what do I need to download to just run some QT5  programs?  It was simple with QT4 but I can't see what is needed for QT5 or do we have to wait for that to happen?
Title: Re: Qt 5 version 5.13.1 OS/2 Beta 1
Post by: Dave Yeo on October 30, 2019, 03:39:13 pm
The zips seem to be at http://rpm.netlabs.org/experimental/00/zip/ (http://rpm.netlabs.org/experimental/00/zip/).
Title: Re: Qt 5 version 5.13.1 OS/2 Beta 1
Post by: Martin Iturbide on October 30, 2019, 05:44:54 pm
Hi

The Qt5  5.13.1 is still on the Netlabs experimental repository. On my experience it takes some days to be on the "release/regular" RPM repository.  If you want to install the experimental repo, I wrote this some time ago (https://www.os2world.com/wiki/index.php/RPM/YUM_Tips_on_OS/2-eCS#Installing_the_Netlabs_Experimental_Repository).

Regards


Title: Re: Qt 5 version 5.13.1 OS/2 Beta 1
Post by: Pete on October 30, 2019, 09:35:26 pm
Hi ivan

You may want to look at https://github.com/bitwiseworks/qtbase-os2 for a basic readme.

Are there some qt5 apps available to try?


Regards

Pete
Title: Re: Qt 5 version 5.13.1 OS/2 Beta 1
Post by: Paul Smedley on October 31, 2019, 03:15:41 am
Hey Pete,

Are there some qt5 apps available to try?

I looked at building latest Quassel, but it failed due to needing QtScript which we don't have yet. I also looked at a newer Wireshark and that needed a different Qt5 module that we also don't have yet.

Cheers,

Paul.
Title: Re: Qt 5 version 5.13.1 OS/2 Beta 1
Post by: TeLLie on November 01, 2019, 07:56:57 am
Hi,

I have build several Qt5 progs, i will make them available

Ok, i have put some progs @ https://tellie.stackstorage.com/s/okNg928e0OdsMaGO

There are some rpm and zip files..

Please remind it are not official builds...

I will putt some more in in the next weeks

Title: Re: Qt 5 version 5.13.1 OS/2 Beta 1
Post by: David McKenna on November 04, 2019, 05:46:28 pm
 Hi Tellie,

  I get an error when I try your link... sure that is correct?

Regards,
Title: Re: Qt 5 version 5.13.1 OS/2 Beta 1
Post by: TeLLie on November 06, 2019, 08:05:48 am
Oeps,

 https://tellie.stackstorage.com/s/okNg9280OdsMaGO
This should work...
Title: Re: Qt 5 version 5.13.1 OS/2 Beta 1
Post by: Andi B. on November 06, 2019, 09:10:17 am
Elbert, I see a new luckybackup version. Thanks. I use this program very often. Have the try the newest version.

Now I wonder where the current sources are from which you build it. I searched the netlabs repos (qtapps) but it seems there is not very much content. Do you build straight from the sourceforge repository and merge your OS/2 related changes there?
Title: Re: Qt 5 version 5.13.1 OS/2 Beta 1
Post by: TeLLie on November 06, 2019, 04:59:01 pm
Andi,

look @ https://github.com/TeLLie/luckybackup-os2

And the author made some OS2 related changes...
Title: Re: Qt 5 version 5.13.1 OS/2 Beta 1
Post by: TeLLie on November 06, 2019, 11:17:48 pm
I upload a first QT5 Beebeep build to the repo.

See https://www.beebeep.net for some info about the program.


Title: Re: Qt 5 version 5.13.1 OS/2 Beta 1
Post by: Andi B. on November 09, 2019, 03:42:35 pm
Seems LuckyBackup (all QT5 programs?) do not work well with sliding focus. When I select a menu and move the cursor down into the menu listing the menu closes. Old LuckyBackup works well.
Title: Re: Qt 5 version 5.13.1 OS/2 Beta 1
Post by: roberto on November 10, 2019, 07:50:56 pm
Hello
I have been testing both the QT5 demonstration applications and the covers in this thread. The problem you comment in the menus doesn't come out to me.
But in the qphpedit.exe application, when I say *save us*, I get an error c00000005.
With pamorama when I change the colors to 256 the applications of qt5 fail and those of qt4 do not fail
Title: Re: Qt 5 version 5.13.1 OS/2 Beta 1
Post by: guzzi on November 10, 2019, 10:00:50 pm
Hello
I have been testing both the QT5 demonstration applications and the covers in this thread. The problem you comment in the menus doesn't come out to me.
But in the qphpedit.exe application, when I say *save us*, I get an error c00000005.
With pamorama when I change the colors to 256 the applications of qt5 fail and those of qt4 do not fail

If others see this as well do report this on github.

Dmitry is currently porting the webengine part of QT5. Sponsoring is still needed. Voice is sponsoring as much as possible but our funds are depleting too. We're on schedule with development and per 1-10-2019, 10-1-2019 for our American friends, only at 70% of the amount needed.

Go to https://github.com/bitwiseworks to see the current status of the different QT5 modules.
Title: Re: Qt 5 version 5.13.1 OS/2 Beta 1
Post by: TeLLie on November 15, 2019, 02:04:29 pm
Hi all,
I uploaded some new programs.
Please remember that those fprograms are hardly tested and you install them on you're own risk..
Also the Qt5 Os2 plugin don;t work fully for now, as f.e in help you try to run a url it dont work atm..

But if you like those programs please consider to donate to BWW as without them we would have this :)

http://www.bitwiseworks.com/shop/index.php?id_product=56&controller=product&id_lang=1


Title: Re: Qt 5 version 5.13.1 OS/2 Beta 1
Post by: Martin Iturbide on November 17, 2019, 04:23:22 pm
Hi Tellie

Openshot (video edition tool) uses Qt 5. Can you take a look at it and see if can be easily ported or if it requires more work?
https://github.com/OpenShot

And also VideoCut, which seems smaller.
https://sourceforge.net/projects/vidcutter/

Regards
Title: Re: Qt 5 version 5.13.1 OS/2 Beta 1
Post by: TeLLie on November 17, 2019, 10:16:34 pm
Hi Martin,
Those are files that need python, so i can not compile those...
Title: Re: Qt 5 version 5.13.1 OS/2 Beta 1
Post by: Dave Yeo on November 17, 2019, 11:06:24 pm
Looks like, amongst other things, OpenShot uses Python 3 (something we're going to need a port of with Python2 coming to end of life) and the Openshot audio library.
VideoCutter is worse, uses libmpv (hardware accelerated MPlayer fork), and OpenGL for video rendering.
Title: Re: Qt 5 version 5.13.1 OS/2 Beta 1
Post by: Martin Iturbide on November 17, 2019, 11:36:28 pm
Thanks for the info.
Title: Re: Qt 5 version 5.13.1 OS/2 Beta 1
Post by: Paul Smedley on November 18, 2019, 02:57:16 am
Hey Dave,

Looks like, amongst other things, OpenShot uses Python 3 (something we're going to need a port of with Python2 coming to end of life) and the Openshot audio library.

I keep meaning to look at Python 3 again. It's made harder now as I think it was 3.2.x was the last that included any of the old OS/2 patches.

Cheers,

Paul.