Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - R.M. Klippstein

Pages: [1] 2 3 ... 18
1
2valerius, I appologize for taking up so much of your time over the years, I will bother you no more!
Happy Birthday

klipp

2
2valerius
rc is in H:\OS2\rc.exe  (88041)
iasl  vboxtools\os2x86\bin\iasl.exe   (533548)
wrc h:ºwatcom\binp\wrc.exe   (250515)

It turns out I didn't have bison installed, I installed it and re-compiled and now iI get:

Kbuild: Linking VBoxPython2_7
weakld error: Unresolved symbol (UNDEF)  '_yydebug'.
The symbol is rferenced by-.
     H:\199-VBox\out\os2-x86\release\object\VboxDTraceCmd\src\VBox\ExtPacks\VBoxDtrace\generated\dt_lex.o

do I need sometthing else installed?
Thanks for the help.  klipp

3
Hi Dave, It I'm TOTALLY lost when it comes to anything pertaining to RC! When compiling Valery's virtualbox source code the EMXOMFLD TYPE uses WLlink . It looks like WRC is used as OPEN WATCOM is needed for the compile. I'm not smart enough to add anything that might be termed as intelligent! Sorry, But thanks for any additional suggestions.

klipp

4
@valery, It looks like the RC error is caused by encountering a negitive value while doing the final (ibelieve it's the final)  compile of virtualbox.exe I'm really dumb on this error, I've been trying to solve it since r-155 ! Its obviously something messed up in my area.
I do my compiling on AMD boxes, I guess I'll try to do it on my Intel based server next, but I bet I get the same results.
 As far as ArcaOS compiling , it can be done and gets the same results but not worth the hassel withACPI.

Good to see you back working on Virtualbox, Thanks for all the excellent work and effort.

klipp

5
Hi valery, trying to compile r-199 on ArcaOS 5.0.3 craps out on Vboxacpi. (Thats probably normal!) I'm guessing you are compiling with eCS. r-199  compiling with eCS-B2 gives the same RC error "RC: error - only interger type allowed ()." that earlier revisions gave. it then deletes the compiled virtualbox.exe. I still haven't been able to figure out a fix for this, any suggestions?

Thanks klipp

6
Hey GUYS--- THANKS Big TIME!  Al is well now.

klipp

7
I've gotten this error on two different machines with ArcaOS 5.0.3 while changing the I.P: for use on my Lan. The I.P changes correctly and all is well, but on rebooting I always get the same error. I've been unable to figure out how to get rid of this error (it actually causes no problems, except for the halt it causes during booting) which is a PITA!
Any ideas would really be appreciated.  Thanks

klipp

8
Applications / Re: Firefox 45.9 XUL.DLL error
« on: March 04, 2019, 01:06:14 am »
Hi Dave, I'm finally back, they put three more "stents" in my heart! Aagghhh!  Yesterday I got back to trying to make Firefox 45.9 once again work, no luck. I gave up went to bed. This morning I got up and went back to work and all 4 machines were waiting for me with Air-Boot waiting for my command (Lost electricity during the night!) I booted up and now Firefox 45.9 works fine?¿?¿ Can't explaine it, Guess best blame it on Mexican electricity here. The voltage here does periodically vary from 105 volts to 130 volts.
Thanks for your assistance once again.
Now I'm back to trying to make DropBox work once again, it worked a couple of years ago but now its back to the "no token found" error.

klipp

9
Applications / Re: Firefox 45.9 XUL.DLL error
« on: February 13, 2019, 03:20:34 am »
Hey Dave, It'll probably be a couple of days before I can get back to you. Gotta go to the hospital (heart Problems) for some tests!
Thanks for the help.

klipp

10
Applications / Re: Firefox 45.9 XUL.DLL error
« on: February 13, 2019, 12:21:08 am »
Hi Dave, Here are the last Firefox entries in popup.log:
02-12-2019  10:22:57  SYS3175  PID 0053  TID 0001  Slot 0079
K:\USR\BIN\FIREFOX.EXE
c0000005
11aca9cb
P1=00000001  P2=0000000c  P3=XXXXXXXX  P4=XXXXXXXX 
EAX=00000000  EBX=16e95b5c  ECX=ffffffff  EDX=00000000
ESI=16e95ae0  EDI=00000000 
DS=0053  DSACC=d0f3  DSLIM=5fffffff 
ES=0053  ESACC=d0f3  ESLIM=5fffffff 
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:164e14f5  CSACC=d0df  CSLIM=5fffffff
SS:ESP=0053:0013ff6c  SSACC=d0f3  SSLIM=5fffffff
EBP=0013ff78  FLG=00010297

PSPRINT.DRV 0001:0001a9cb

------------------------------------------------------------

02-12-2019  11:49:26  SYS3175  PID 0157  TID 0001  Slot 0079
K:\USR\BIN\FIREFOX.EXE
c0000005
11aca9cb
P1=00000001  P2=0000000c  P3=XXXXXXXX  P4=XXXXXXXX 
EAX=00000000  EBX=16d65b5c  ECX=ffffffff  EDX=00000000
ESI=16d65ae0  EDI=00000000 
DS=0053  DSACC=d0f3  DSLIM=5fffffff 
ES=0053  ESACC=d0f3  ESLIM=5fffffff 
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:164514f5  CSACC=d0df  CSLIM=5fffffff
SS:ESP=0053:0013ff64  SSACC=d0f3  SSLIM=5fffffff
EBP=0013ff70  FLG=00010297

PSPRINT.DRV 0001:0001a9cb

Safe mode gives the same error and I've added or installed no plugins. I'm really dumb on browseres,

David G Thanks for the help  I've got RPM installed and rpm'ed firefox-highmem-45.9.0-1.oc00.i686.rpm  and it looks like it installed but can't see where to go to see if it runs!  Maybe I should delete usr/bin/firefox.exe? and run it again?

11
Applications / Re: Firefox 45.9 XUL.DLL error
« on: February 12, 2019, 10:42:14 pm »
I'm still stuck without the ability to run Firefox 45.9, I cant get it working with the latest updates to ANPM installed, and I can't downgrade libc and libcx. Is there any way of getting a copy of the .RPM version? I see now that supposedly it is only available to beta testers.

Thanks klipp

12
Applications / Re: Firefox 45.9 XUL.DLL error
« on: February 08, 2019, 01:47:00 am »
Hey Pete,Good to hear from you, Its been quite a while since you last bailed me out! Turns out I didn't have Netlabs-exp installed, so I installed it,- but no cigar. It upgraded libcx to 0.4.1, Should I maybe try 0.3.1?
Dave, Looking at popuplog.os2 it shows Firefox at the bottom of the list, but I don't see anything that gives an indication of version/build. What should I be looking for?
This is a pretty old version of 45.9, and I have no idea if I can re-install a newer version over it or not.
Thanks for the help guys!
Oh, One last thought, ANPM can't upgrade heimdal-libs package, its got bad problems, could that affect Firefox 45.9 maybe?

13
Applications / Firefox 45.9 XUL.DLL error
« on: February 07, 2019, 01:41:22 am »
I just finally got around to updatng ANPM's listed necessary updates and re-booted and now Firefox 45.9 throws the error "Couldn't load XUL.DLL (OS2 error 87). Any ideas as to what is needed to make Firefox work once again?
Thanks for any responses

klipp

14
Applications / Re: VirtualBox version 176 compiling/testing
« on: November 04, 2018, 05:59:21 pm »
2valerieus, I'm using iasl.exe from OSFree and the results are the same. I'm wondering, you are using gcc-wrc-4.9.2.1-3.oc00.pentieum. I'm using gcc-wrc-4.9.2-1-3.oc00.i686  Aparently there is a difference. Yum offers a gcc-wrc-4.9.2-1.oc00-i386 but not a pentieum version. The i386 version requires replacing pretty much all of gcc. Or are i386 and Pentienm the same thing possibly? 

klipp

15
Applications / Re: VirtualBox version 176 compiling/testing
« on: November 03, 2018, 07:25:04 pm »
2valerieus, New compile using r-177 (and the correct iasl.exe (533548 size). It progresses and completes the virtualbox.exe build, links & installs it, then decides there is something else wrong and deletes virtualbox.exe with the following error!

kBuild: Installing VBoxNetDHCP => L:/177-vbox/out/os2.x86/release/bin/VBoxNetDHC
P.exe
kBuild: Installing VBoxNetLwipNAT => L:/177-vbox/out/os2.x86/release/bin/VBoxNet
NAT.exe
kBuild: Installing VMMR0 => L:/177-vbox/out/os2.x86/release/bin/VMMR0.r0
kBuild: Installing VBoxDD => L:/177-vbox/out/os2.x86/release/bin/VBoxDD.dll

Reading binary resource file L:\177-vbox\out\os2.x86\release\obj\VirtualBox\src\
platform\os2\VirtualBox.res


(0) RC: error - Only integer TYPE allowed ().
RC: 1 error detected

kmk: *** [L:/177-vbox/out/os2.x86/release/obj/VirtualBox/VirtualBox.exe] Error 1

The failing command:
@g++.exe @L:/177-vbox/out/os2.x86/release/obj/VirtualBox/VirtualBox.rsp
kmk: *** Deleting file `L:/177-vbox/out/os2.x86/release/obj/VirtualBox/VirtualBo
x.exe'
kmk: *** [L:/177-vbox/out/os2.x86/release/obj/VirtualBox/VirtualBox.exe] Deletin
g file `L:/177-vbox/out/os2.x86/release/obj/VirtualBox/VirtualBox.map'
kmk: *** [L:/177-vbox/out/os2.x86/release/obj/VirtualBox/VirtualBox.exe] Deletin
g file `L:/177-vbox/out/os2.x86/release/obj/VirtualBox/VirtualBox.rsp'
#

I've seen this before but don't remember the fix.

klipp

Pages: [1] 2 3 ... 18