Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Mike Kölling

Pages: [1] 2 3 ... 5
1
Applications / Re: Lotus 123 DOS version
« on: July 24, 2020, 03:22:25 pm »
The ideal solution would be to find working hardware. The IBM Thinkpad T43 works on eCS and probably therefore ArcaOS. The Lenovo Thinkpad X250 fails on ArcaOS.

My X250 runs DOS in full screen mode on AOS505. There has been a patch (viop-1.0.wpi) provided by Arca Noae that enables at least the full screen mode for the X250.
Greetings,
Mike

2
Applications / Re: Painting program?
« on: July 19, 2020, 12:10:17 pm »
Hello all,
Just wondering what painting programs you all recommend for ArcaOS? Something like Paint.NET on Windows would be perfect, or something as simple as Windows Paint would be OK too. Any recommendations?

For simple things I still use the drawing function of StarOffice5.1. Seems to work better for me then the drawing function of OpenOffice.

Mike

3
I have tested here 1536 and 1728. My current value is 1728, but I'm not happy with it. 2 GB is just too little for recent apps.

I totally agree that 2GB is to less. I have at least 4GB and 8GB in my laptops and set the address limit to 3072, which works well for me.

Greetings from Potsdam / Germany
Mike

4
Hi Andy,
I had similar problems in the past. Here is my solution:

Check if the IP address of your computer is listed in the "hosts" file (e.g. C:\MPTN\ETC\hosts).
Example of hosts:
127.0.0.1             localhost                 
192.168.1.46       CPName

Take also care that the name used in the hosts file is same as set in your config.sys (e.g. "SET HOSTNAME=CPName").

Otherwise you have to wait 2 minutes before your computer becomes available again.

Greetings,
Mike

5
Networking / Re: Samba Server v4.11.9
« on: June 26, 2020, 01:23:28 pm »
Glad it helped. Given you run both Samba 3.0 and now 4.11.9 I'm really interested in any comments on performance, stability, etc

Hi Paul,

The old Samba server is restarted once every week automatically to avoid problems with the Samba server. The computer by itself needs to be restarted every second month usually. We needed some time debug the script files coming with the 3.0 but now it is stable enough for us. The biggest issue we have with the older Samba server are the remains of temporary files like "~name.docx" or ".~lock.name.odt" once we open files lets say in MS-Word or OpenOffice. After closing the files the temporary files still exists. We have to clean it manually from time to time. I never saw such a problem using the 3.6 or now with your 4.11 version. Another issue with the older Samba server is the rights management. Not sure if it is better now with the newer version, because testing has taken place mainly by my person with no access from other accounts.

Greetings,
Mike

6
Networking / Re: Samba Server v4.11.9
« on: June 26, 2020, 09:21:28 am »

NTLMv1 was disabled by default a few Samba versions ago. If you want to keep Win10 compatible with Samba 3.6, you can add (I think)
ntlm auth = yes
to the global section of your smb.conf


Hi Paul,

That did the trick. I can't go up to the security level of Samba 4 by now, because we still run an old file server (with eCS2.0RC6a) with an old Samba 3.0 server - Never touch a running system :).
And the Win 10 machine must see this old file server.

Thanks for your help to solve the issue.
Wish you a nice weekend.

Greetings from Potsdam / Germany,
Mike

7
Networking / Re: Samba Server v4.11.9
« on: June 25, 2020, 04:23:53 pm »
Most useful would be a log.smbd.exe with debuglevel of 3 and an attempt to connect from win10...

Here you are.

Greetings,
Mike

8
Networking / Re: Samba Server v4.11.9
« on: June 25, 2020, 09:50:24 am »
Hi Paul,


Glad to see the servers are starting for you now.

For Win 10 - I'm going to suspect that at some time you had to 'modify' things to work with the old Samba 3.6 - something like https://centosfaq.org/centos/samba-issues-with-win-10/

This may have set security settings in Win10 that are now not allowed by Samba 4.11.x. For example - you may have forced SMB1 to be used by Win10 - this protocol is disabled by default in Samba 4.11 - but can be enabled by adding 'client min protocol=NT1' to the [global] section of smb.conf


I have the 'client min protocol=NT1' in my global section.

Please see here:

# Samba config file created using SSCC ver. 1.1.3
# from Mike@PC25_AOS
# Date: 14 Jun 2020 13:15:10
[global]
workgroup = xxx
server string = %h Samba Server
null passwords = Yes
guest account = guest
username map = C:\MPTN\ETC\samba\private\smbusermap
log file = C:\MPTN\ETC\samba\log\log.smbd.%U.%M
max protocol = SMB2
time server = Yes
load printers = No
printcap name = F:\etc\printcap
enumports command = F:\Programs\Samba\enumports.cmd
add user script = F:\Programs\Samba\usermod.cmd -a "%u"
rename user script = F:\Programs\Samba\usermod.cmd -r "%uold" "%unew"
delete user script = F:\Programs\Samba\usermod.cmd -x "%u"
add group script = F:\Programs\Samba\groupmod.cmd -a "%g"
delete group script = F:\Programs\Samba\groupmod.cmd -x "%g"
add user to group script = F:\Programs\Samba\groupmod.cmd -j "%g" "%u"
delete user from group script = F:\Programs\Samba\groupmod.cmd -l "%g" "%u"
set primary group script = F:\Programs\Samba\usermod.cmd -p "%u" "%g"
add machine script = F:\Programs\Samba\usermod.cmd -a "%u"
lm announce = Yes
wins support = Yes
add share command = F:\Programs\Samba\addshare.cmd
change share command = F:\Programs\Samba\changeshare.cmd
delete share command = F:\Programs\Samba\delshare.cmd
lock directory = C:\MPTN\ETC\samba\lock
nmbd bind explicit broadcast = No
comment = X250 mit OS/2
create mask = 0777
ea support = Yes
store dos attributes = Yes
client min protocol = NT1
name resolve order = lmhosts wins host bcast
wins server =
log level = 2

Greetings,
Mike

9
Networking / Re: Samba Server v4.11.9
« on: June 24, 2020, 01:21:50 pm »
Hi Mike,

The only 'unusual' dependency should be GTLS30.DLL from komh's GNUTLS 3.5.8 package http://hobbes.nmsu.edu/download/pub/os2/dev/unix/gnutls-3.5.8.zip

If nmbd isn't starting, is there anything in popuplog.os2 or x:\mptn\etc\samba\log\log.nmbd ?

It would also be worth checking dependency DLL's with pmdll.exe

Cheers,

Paul

Dear Paul,

I just gave it another try and placed your files again in my working environment.
pmDLL.exe showed no missing DLLs.
GNUTL is already installed with ANPM.
So I tried to start the Samba server again and now it is working, no failure message any longer. I have absolutely no clue what happened yesterday.
Accessing files on the Samba server from Win7 is working fine.
Win10 sees the Samba server but tells me that the password to access the files is wrong.
Going back to 3.6.25 =>W10 is working fine as well.

Greetings,
Mike

10
Networking / Re: Samba Server v4.11.9
« on: June 23, 2020, 02:06:39 pm »
Hi All,

I'm now at a point in Samba Server development where i'm prepared to publicly share some binaries based on Samba v4.11.9

Server executables:
http://smedley.id.au/tmp/smbd-4.11.9-20200621.zip


Hi Paul,

I tried the server today, but couldn't get it running. I replaced all the files in my working 3.6.25 samba server.
SMBD is starting as usual. NMBD fails. Error: SYS1041: The name nmbd is not recognized as an internal or external command, operable program or batch file.
Could you share which additional prerequisites might be necessary to start your build.

Replacing your server progs with the original ones brings the working Samba server 3.6.25 back.

Greetings,
Mike

11
Networking / Re: Samba Server v4.11.9
« on: June 22, 2020, 02:19:13 pm »
Hi Paul,

I am going to download it this week and give it a try. But I do need some time to do it. I will keep you updated once I have done the test.
Thanks again for your ongoing support. It is very appreciated.

Greetings from Potsdam / Germany,
Mike

12
Hardware / Re: USB 3 - ArcaOS - Hardware Reports
« on: June 13, 2020, 02:26:24 pm »
Thanks for the feedback, I had updated what I can on the wiki.

Mike K: I had included on the X250 page your report about USB 3.x. I will appreciate if you can post the pci.exe report with the USB 3x turned on inside the BIOS (like it is right now).


Hi Martin

Please find attached the requested report.

By the way. The mouse is running smooth with xHDC, when the X250 is out of the docking station

Greetings,
Mike

13
Hardware / Re: USB 3 - ArcaOS - Hardware Reports
« on: June 12, 2020, 03:01:07 pm »
Hi Martin,

the new xHCD USB3 driver is working on my TP X250. However I experienced performance issues with my mouse, when using the X250 in the docking station.

Greetings from Potsdam/Germany,
Mike

14
Multimedia / Re: Updated Uniaud32 build
« on: June 04, 2020, 11:04:05 am »

I ended up ordered a X250 Thinkpad for a fairly reasonable price ($A250), that should arrive next week. Hopefully that will allow me to reproduce your issues - and hopefully fix them too :) It's only an i3 but has 8gb ram and a 250gb SSD.

Cheers,

Paul

Hi Paul,
That sounds good. Installation of AOS shall be working from USB thumb drive without problems. You just need to set it to USB2 mode in the BIOS. And you have to disable the UEFI as well as long as we don't have it. Even installation of eCS2.2Beta2 shall be working using an external CD_ROM/DVD drive. An older eCS2.1 needs to be copied with all recent drivers to be able to boot.
Regards,
Mike

15
Multimedia / Re: Updated Uniaud32 build
« on: May 19, 2020, 10:21:15 am »
Hi Mike,
Last try (for now): http://smedley.id.au/tmp/uniaud32-linux-3.2.102-MikeK3.zip
Cheers,
Paul

Hi Paul,

I have tested the third version as well. I can only see one change in pmUnimix. There is now a control for the mic. Please see attached picture.


The sound is still not clear. Sorry for this bad test result. Attached again the debug log file.

Greetings,
Mike

Pages: [1] 2 3 ... 5