Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Digi

Pages: [1]
1
Web applications / Re: Chrome...
« on: April 02, 2018, 09:35:48 am »
What do you need from us as far as help & support goes? Is this what the FreeRDP funding request is about?

Yes, Arca Noae's message about this project:
https://www.arcanoae.com/support-freerdp-for-os2/

2
Web applications / Re: Chrome...
« on: April 01, 2018, 02:33:46 pm »
I'm working on FreeRDP port. The work is currently suspended for some time. On screenshots above you can see the programs that are running on the Application Server. For example, now I can open M$ Office documents (with MS Office programs) directly from the PMShell, File Commander or thunderbird under OS/2 with OS/4 kernel. And of course, it's possible to connect to a remote desktop.
WPS class to launch FreeRDP properties on next screenshot.

3
Web applications / Re: Chrome...
« on: March 29, 2018, 11:33:57 pm »
OS/4 kernel is used on both screenshots.

4
Web applications / Chrome...
« on: March 29, 2018, 08:29:42 am »
See attachment...

5
Web applications / Re: Oddities with Youtube.
« on: November 02, 2017, 02:58:27 pm »
Someone posted a work-around for this issue in another thread, but here is a  direct link => https://github.com/erkserkserks/h264ify-firefox.

This add-on will force youtube to stream H264 instead of the VPx stuff, works here.

Yes, I also tried it. To no avail.

6
Web applications / Oddities with Youtube.
« on: November 02, 2017, 02:15:23 pm »
I have a strange problem with youtube on the one of my systems. This is the same for FF 38.8.0 and FF 45.9.0.
On youtube I can see load bar (line) at the bottom of video frame (with loading progress), small frames on load bar whem I try move forward. But on the video frame, the "waiting ring" turns constantly and there is no image.

On page https://www.youtube.com/html5 next items available with FF 3.8.0:
  HTMLVideoElement, H.264 and WebM VP8.
with FF 45.9.0 all items available.
It's just like on my other system, where everything works fine.

All necessary components from the repository, including ffmpeg, have been updated. What could be the problem?

7
Programming / Re: memory leak: libc066, _beginthread()
« on: October 03, 2016, 07:08:16 am »
Strange... The problem disappeared after reboot.  :o

8
Programming / memory leak: libc066, _beginthread()
« on: October 03, 2016, 06:44:38 am »
Hi.

I have stable memory leak on each thread start. Can anyone confirm this problem? A small test program attached. I see an ever-increasing number of pages "stack" with Theseus:

G:\projects\test>start test.exe

C:\Programs\Theseus>getobj.cmd TEST private 1 0|find /C "stack"
15

C:\Programs\Theseus>getobj.cmd TEST private 1 0|find /C "stack"
17

C:\Programs\Theseus>getobj.cmd TEST private 1 0|find /C "stack"
19

C:\Programs\Theseus>getobj.cmd TEST private 1 0|find /C "stack"
20

C:\Programs\Theseus>getobj.cmd TEST private 1 0|find /C "stack"
23

and so on...

9
Applications / Re: Help! Need to fix yum.
« on: July 12, 2016, 03:39:47 pm »
Strange. This file has disappeared from %unixroot%\usr\lib. I copied it from another system, and now yum works.
Thank you!

10
Applications / Help! Need to fix yum.
« on: July 12, 2016, 01:26:44 am »
Please help me understand. What does that mean and how to fix it?

C:\>yum
There was a problem importing one of the Python modules
required to run yum. The error leading to this problem was:

   dlopen rc=2 extra=NSPR4K

Please install a package which provides this module, or
verify that the module is installed correctly.

It's possible that the above module doesn't match the
current version of Python, which is:
2.7.6 (default, Dec 12 2015, 04:56:50)
[GCC 4.9.2]

If you cannot solve this problem yourself, please go to
the yum faq at:
  http://yum.baseurl.org/wiki/Faq

---
By advice from http://yum.baseurl.org/wiki/Faq :

C:\>python
Python 2.7.6 (default, Dec 12 2015, 04:56:50)
[GCC 4.9.2] on os2knix
Type "help", "copyright", "credits" or "license" for more information.
>>> import yum
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "G:/unixroot/usr/lib/python2.7/site-packages/yum/__init__.py", line 23, in <module>
    import rpm
  File "G:/unixroot/usr/lib/python2.7/site-packages/rpm/__init__.py", line 9, in <module>
    from rpm._rpm import *
ImportError: dlopen rc=2 extra=NSPR4K
>>>


11
Internet / Re: Spam Filter
« on: January 24, 2016, 02:01:48 pm »
A new version 1.1 of the SpamFilter is available...

12
Internet / Spam Filter
« on: January 12, 2016, 10:13:59 am »
Hi all.

I made a spam filter to use on my mail server. It uses a variety of typical methods: on-line whitelists (RWL), on-line blacklists (URIBL, DNSBL), SPF, greylisting, analysis of the EHLO, MAIL FROM, etc. The filter works on my server with Weasel 2.01 the last few weeks and gives good results for me.
If someone is interested - I need some help. At first, of course, testing. I have no way to test how it works when all incoming mail sent from the ISP relay server. In theory, this situation should some loosen filter, because there is no possibility to check the external server's EHLO.
My english is not very good, so the second problem is the correction short texts - two readme files and comments at the configuration file. It is necessary to make them correct and clear.

Binaries and sources can be downloaded from my FTP server:

    ftp://digi.os2.snc.ru/pub/SpamFilter/

Pages: [1]