Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Pete

Pages: [1] 2 3 ... 65
1
Applications / Re: DOSBox Issue - STDCPP6?
« on: May 27, 2020, 01:53:06 pm »
Hi Rich

Thank You, that is what I had forgotten about setting up a DOSBox Command Prompt window.


Regards

Pete


2
Applications / Re: DOSBox Issue - STDCPP6?
« on: May 27, 2020, 12:33:00 am »
Hi Jochen

Yes the [autoexec] statements work fine.

The problem is the extra commands not in dosbox.conf that then happen ie mounting the selected drive or folder as C:\>


Regards

Pete

3
Applications / Re: WarpIN: Exception on Main thread
« on: May 27, 2020, 12:26:55 am »
Hi David

You are looking for this ?:\CID\SERVER\ARCAPKG\WARPIN.EXE - where ? = dvd/usb/iso drive letter.


Regards

Pete

4
Applications / Re: DOSBox Issue - STDCPP6?
« on: May 26, 2020, 07:37:32 pm »
Hi Sandra-Asja

Thanks for the update - I obviously have not had to perform this action since the "old and hard way" was the only way  :-)


Regards

Pete

5
Applications / Re: DOSBox Issue - STDCPP6?
« on: May 26, 2020, 04:22:10 pm »
Hi Dave

I think I have found a minor problem with your DOSBox build or the support files used.

AS i do not have DOS/Win16 support installed I have been using DOSBox to provide DOS window/fullscreen ~Command Prompts for very occasional use.

This worked fine until DOSBox and libstdc++ (9.2.0-4) updates.

Now DOSBox fullscreen works OK but something is adding to the dosbox,conf when using DOSBox window.

This is the end of my dosbox.conf file:-

[autoexec]
# Lines in this section will be run at startup.
mount e e:
e:


Works fine for -fullscreen, used to work fine for window as well.

When I start a DOSBox window the above mount lines happen then some more commands appear from somewhere and this happens:-

E:\>MOUNT C "H:\DESKTOP"
Drive C is mounted as local directory "H:\Desktop\"

E:\>C:

C:\>


Using -conf to point to my dosbox.conf (which should be the default to use anyway) gives the same result.

As the above MOUNT C is not part of my dosbox.conf and only happens in window mode, not -when using -fullscreen, Is it a DOSBox problem?


Just to confuse the issue: If I start a DOSBox window from the XWorkplace Configuration Folder -> ~Command Prompts -> ~DOS Window all works as it should.

The problem with the unknown lines above only occurs when I Right Mouse Button click and select Command prompts -> DOS Window in which case wherever I have selected to open a DOS Window becomes the mount directory eg RMB on folder K:\Programs and open a DOS Window results in "K:\Programs" as the directory mounted as C:\> .

Having typed the above I am now wondering if it could be XWorkplace related...

Any Ideas?


Regards

Pete

6
Applications / Re: DOSBox Issue - STDCPP6?
« on: May 25, 2020, 03:46:59 pm »
Hi Jochen

Presuming you are using ANPM - Arca Noae Package Manager from https://www.arcanoae.com/resources/downloadables/arca-noae-package-manager/ - you need to add the repo to the available repos list.

With ANPM running click Manage -> Repositories to open the Manage Respositories window.

Click Repository -> Add -> *YUM Repository and fill in the Add Repository form with these details:-

Name: Netlabs - Experimental Repo
Description: Netlabs experimental repository 00 - i386
URI: http://rpm.netlabs.org/experimental/$releasever/$basearch/

Then click Save.

You should then find netlabs-exp listed as Available, select and install.

Hopefully, if I have not forgotten a step, you should now have access to netabs-exp.


Regards

Pete




7
Applications / Re: DOSBox Issue - STDCPP6?
« on: May 24, 2020, 06:00:53 am »
Hi All

Both the problems are explained by use of yum on the command line:-

[J:\USR\BIN]yum install libstdc++6
Setting up Install Process
Package libstdc++6-4.9.2.1-3.oc00.i686 is obsoleted by libstdc++-9.2.0-4.oc00.i6
86 which is already installed
Nothing to do

The same message is displayed when trying to install libsupc++6.

Would have been helpful to see that message in ANPM...

Installed Daves dosbox-074.3 which works fine.

So, Thank you Dave for both the dosbox build and the suggestion of using yum directly.


Regards

Pete



8
Applications / Re: DOSBox Issue - STDCPP6?
« on: May 24, 2020, 03:54:17 am »
Hi All

I may have found the dosbox problem...

After updating libstdc++ to 9.2.0-4 which dragged in gcc-stdc++-shared-library 4.4.6-15 (not previously installed) I now find dosbox does not work.

I tried to "Downgrade" libstdc++ to the previous installed version which worked, 4.4.6.17-1.oc00.
This fails with this ANPM "Download Failed" message displayed:-


   An error occurred when trying to download or install packages.

   djvulibre-3.5.27-3.oc00.i686 requires stdcpp6.dll


The above error not seen prior to installing libstdc++ to 9.2.0-4 and gcc-stdc++-shared-library 4.4.6-15 just a few minutes previously.

Do other users have the above suspect files installed?

It also looks like the above installation has resulted in libstdc++6 and libsupc++6 no longer being displayed as "Installed" by ANPM which shows them as "Available".

However, trying to Install either of those libraries or "Downgrade" them results in a message that the packages are already installed, nothing to do...

How do I resolve the following problems:-

1] "Downgrade" libstdc++ to 4.4.6.17-1.oc00?

2] (Re)Install libstdc++6 and libsupc++6


Regards

Pete





9
Applications / Re: DOSBox Issue - STDCPP6?
« on: May 24, 2020, 02:46:34 am »
Hi All

I had the following release of dosbox 0.74 installed which worked fine on ArcaOS5.0.4:-

    8-07-15  9:26p     3,188,956    342 a---  dosbox.exe

Just downloaded and installed DOSBOX0.74_30.03.19.EXE to update existing installation. Works fine - even after I manually deleted all the *.dll support files previous versions used.

Not sure what libs this build requires but libc, libgcc, libstdc++6 are current.
Dropping dosbox.exe onto PMdll suggests those are the only *nixy support files needed.


Regards

Pete

10
Applications / Re: XWP v1.0.13 GA
« on: May 23, 2020, 05:23:27 am »
Hi All

When I position the mouse cursor over a Program Object and click once the
Folder Status Bar shows the filename (slightly) incorrectly by inserting a space
between the last character of the .exe extension and the surrounding quotes.

Using the Text Editor program object in Desktop -> Programs -> Utilities as
an example this has the Properties:-

  File and path name: M:\OS2\E.EXE

When I click on the Text Editor program object the Status Bar shows this:-

  "M:\OS2\E.EXE "

This is common to all Desktop program objects ie all ".exe" files but does not affect other Desktop objects  eg JPDFViewer, a java app, is displayed in the Folder Status Bar as:-

   "J:\JAVA\OPENJDK\BIN\JAVAW.EXE  -jar J:\Java\jPDFviewer\JPDFViewer.jar "


Is this a known bug/design feature?


Regards

Pete



11
Utilities / Re: MeShell commandline frontend timetable
« on: May 22, 2020, 03:01:44 pm »
Hi All

Yes, Andi, those are the settings in use for news.gmane and, like Dave, all I ever see is a response that tells me connection timed out.

Why would news.gmane work for some people but give a "connection timed out" to others?


Regards

Pete

12
Utilities / Re: MeShell commandline frontend timetable
« on: May 21, 2020, 03:01:02 pm »
Hi Andi

Re: "Adrian regularly reads the newsgroup - gmane.org.netlabs.community "

Is there a special trick to reading this newsgroup?

I ask because news gmane has not been working for a long time and pointing a browser at http://gmane.org.netlabs.community/ results in a "address not found" error.


Regards

Pete

13
Multimedia / Re: Updated Uniaud32 build
« on: May 17, 2020, 01:56:06 pm »
Hi Mike

There is a later PMunimix here https://hobbes.nmsu.edu/download/pub/os2/apps/mmedia/util/mixers/PMUniMix-bin-0_82.zip

Might also be worth checking which unimix.exe you have installed. This version works OK here with Pauls 3.2 and 3.5 uniaud builds

25-06-17  5:12p        27,585      0 a---  unimix.exe

The current "official" release has this build of unimix.exe included ftp://ftp.netlabs.org/pub/uniaud/Uniaud-20200506.exe

I suggest you place both unimix.exe and PMunimix.exe in \mmos2 rather than \mmos2\dll.


Regards

Pete

14
Setup & Installation / Re: Installing Warp 3 issues
« on: May 16, 2020, 12:33:27 pm »
Hi Dj

The photo shows the file sizes in the 3rd column. The "0" column is EA size.

Too long time since I last installed Warp3 to be of any help with the missing file problem, Sorry.


Regards

Pete



15
Multimedia / Re: Updated Uniaud32 build
« on: May 15, 2020, 03:52:37 pm »
Hi Paul

Installed the debug build from your latest uniaud32-linux-3.5.zip and can report it works as well as the previous build so far.


Regards

Pete

Pages: [1] 2 3 ... 65