Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Gabriele

Pages: [1] 2 3 4
1
Setup & Installation / Re: RAM disk and temp folders...what else?
« on: May 14, 2018, 09:54:49 pm »
... I rebooted several times and also switched off the PC, but the drive letter used by ArcaOS ramdisk is still in use! LVM sees it as:

[ CDROM 2 ]          *->T:  Compatibility                   CDFS file system


It was USBCDROM.ADD: it seems that ArcaOS/QSINIT ramdisk - I had assigned T: to it - can "steal" the drive letter to USBCDROM.ADD, while emsifs can't.

2
Setup & Installation / Re: RAM disk and temp folders...what else?
« on: May 14, 2018, 09:30:44 pm »
I'm now trying to disable ArcaOS ramdisk (as I want to test emsifs.ifs).   I removed os2ldr.cfg file and remmed hd4disk.add in config.sys. I rebooted several times and also switched off the PC, but the drive letter used by ArcaOS ramdisk is still in use! LVM sees it as:

[ CDROM 2 ]          *->T:  Compatibility                   CDFS file system

and it fact it appears in Drives folder with a CD icon. I really guess how I can definitely remove it...

3
Setup & Installation / Re: RAM disk and temp folders...what else?
« on: April 24, 2018, 12:43:47 pm »
...
Have you tried just using OS4APIC.PSD (preferrably with the /APIC switch) or are you forced to using ACPI on the system that you have ?

Hi Lars,

I have PSD=OS4APIC.PSD /APIC in CONFIG.OS4, but I just get one core instead of 4 (and of course I see the "acpi4.bpd not found or corrupted" message during bootup :-)

I should patch ACPI.PSD, I think, but I have ver. 3.23.04 installed, not 3.23.01.

4
Setup & Installation / Re: RAM disk and temp folders...what else?
« on: April 24, 2018, 12:18:17 pm »
Having just recently moved to the OS4 kernel, it is pretty straight forward unless one is using a RAM drive utilizing QSINIT.  The one thing to remember is that when updating to the latest OS4 kernel, do not replace the QSINIT loader with the latest OS4 kernel loader.

I quote David. For me, this time installing OS/4 was easy: unzipped the files - except OS2LDR - from OS/4 package, replaced ArcaOS OS2LDR with the one from QSINIT, and then everything went as expected; just ACPI is not working, but I guess I just have to study a bit more the existing threads to find the answer :-)

5
Applications / Re: Postresql backup
« on: February 14, 2018, 09:21:37 am »
Thank you Greg, I'll give psql a try. What puzzles me is that for a long time pg_dumpall worked flawlessly. Shame on me that upgraded something without realizing that I was breaking it :-)

6
Applications / Postresql backup
« on: February 07, 2018, 09:29:23 am »
Hello,

I'm trying to run the "pg_dumpall" command from the postgresql server package, but while "pg_dump" command works fine, when I run "pg_dumpall" I get the following error:

  [C:\Programs\pgsql\bin]rem pg_dump -Fc -b biblioteca | gzip -9 > dumpsql_biblioteca.tar.gz
  [C:\Programs\pgsql\bin]pg_dumpall   | gzip -9  1> dumpall.gz
  C:/usr/bin/sh.exe: 1: cannot create nul:: Directory nonexistent
  fgets failure: No such file or directory
  The program "pg_dump" is needed by pg_dumpall but was not found in the same directory as "C:/Programs/pgsql/bin/pg_dumpall".
  Check your installation.


Obviously there is something wrong with the line

"The program "pg_dump" is needed by pg_dumpall but was not found in the same directory as "C:/Programs/pgsql/bin/pg_dumpall". ":
the directory should be "C:/Programs/pgsql/bin", not "C:/Programs/pgsql/bin/pg_dumpall"... I'm sure it is something trivial related to sh, but I don't understant what it is... the environment for the command is:

  set beginlibpath=c:\programs\pgsql\bin;c:\programs\pgsql\lib;
  SET USE_HOSTS_FIRSTS=Y
  set LANG=it_IT
  set PGDATA=D:\var\postgres9\data

Thanks for any hint!



7
Networking / Re: Subnets routing?
« on: November 11, 2017, 10:33:04 am »
Thank you everybody for your replies! What is most important to me is that "Internet of things" devices on LAN2 can't access the PCs on LAN0. I read that too often such devices can easily be compromised and I don't want a hacked air conditioner accessing my wife's Windows 10 PC :-)

So, if I understand well, if I don't add a "route add" command from LAN2 to LAN0, devices on LAN2 will not be able to scan what is on LAN0. Is this correct? Ian, when you say: "Assuming your routing has been setup correctly then yes, devices on LAN2 can be hidden from LAN0 but remember this is only on the software layer", what do you mean with "this is only on the software layer"? I could connect LAN2 directly to the provider's modem, but then I would loose any control on the traffic happening on that LAN.

The best thing would be being able to access devices on LAN2 from PCs on LAN0 and forbid the other way, but I guess I need to start the IBM firewall service for that and I don't want to start playing with it... I can live accessing devices on LAN2 directly from the gateway server.


8
Networking / Subnets routing?
« on: November 07, 2017, 02:27:13 pm »
Hi all,

my home OS/2 server has three network interfaces. Currently I'm using just two of them, with Injoy in the middle acting as firewall and providing NAT for the LAN.

I would like now to use the third network interfaces to create a second LAN where I would confine the increasing number of "Internet Of Things" devices around.

Unfortunately, I know nothing about routing! With a setup.cmd file like this one:

route -fh
arp -f
ifconfig lo 127.0.0.1
ifconfig lan0 192.168.0.1 netmask 255.255.255.0 metric 1 mtu 1500   # existing LAN
dhcpstrt -i lan1 -d 0                                                                               # WAN
ifconfig lan2 192.168.2.1 netmask 255.255.255.0 metric 1 mtu 1500   # the hypothetical second LAN
inetcfg -s all
ipgate on

devices on lan0 would be effectively hidden from devices on lan2?

Thanks!
Gabriele

9
Mail-News / Re: Fetchmail stopped fetching mail
« on: October 23, 2017, 08:23:23 am »
Nothing that I can see: I still successfully fetch mail from pop.gmx.com  (POP3 SSL, port 995) while I can't download anymore from pop.tiscali.it (POP3 SSL, port 995)...  I'll try to get a more verbose output from fetchmail.

10
Mail-News / Fetchmail stopped fetching mail
« on: October 22, 2017, 07:10:36 pm »
Hi all,

on my home server running Communigate, I use fetchmail to fetch mail from a number of email addresses that I and my family have.

Months ago fetchmail stopped being able to fetch from gmail and from dreamhost. A few days ago it stopped fetching mail from an Italian provider (Tiscali). Like with gmail and dreamhost, it hangs forever while "negotiating TLS handshake".

I'm really afraid that this problem is related to some provider's mailserver upgrade, and that sooner or later I'll be unable to fetch email at all. Anybody out there using fetchmail, or it is just me?


Thanks for a reply
Gabriele

11
Thanks all for the reply! I'll then wait for the official communication :-)

12
Hi all,

I'm trying to access ArcaOS support & maintenance subscription repo, that is "arcanoae-arcaos" according to https://www.arcanoae.com/wiki/anpm/ , but I'm not lucky enough.

I added the repository through ANPM (please see attached screenshot) but I now always get a "Cannot retrieve metadata for repository: arcanoae-arcaos" error. As login credentials I used the same that I use for https://www.arcanoae.com/my-account . What I'm missing?


Thanks
Gabriele

13
Applications / Re: Icons per file extension
« on: September 01, 2015, 11:32:03 am »
Hi Andreas,

it took a reboot to change the icons, but in the end the trick worked fine, thanks!

14
Applications / Re: Icons per file extension
« on: August 25, 2015, 04:34:12 pm »
Under the TYPE section in the bigicon.txt file:
...

Thanks Greggory! So this is a feature from PNG Desktop, not feasible in a plain Warp installation.

15
Applications / Icons per file extension
« on: August 25, 2015, 03:01:21 pm »
Hi all,

it's lot of years since I started using OS/2, but this is still an open question for me. Is it possible to associate an icon to a file extension, like we do for a program? If I browse my C:\ecs\icons\BIGICONS directory, I see, for example:

file_archive_128px.png
file_archive_arj_128px.png
file_archive_rar_128px.png
file_archive_wpi_128px.png
file_archive_zip_128px.png

All the above file extensions are associated to the same program (that here is Zippy), and file_archive_128px.png is the icon for Zippy. How can I associate the other icons to *.arj/rar/wpi/zip files?

Bye
Gabriele

Pages: [1] 2 3 4