Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Julien Pierre

Pages: [1] 2 3 4
1
Hehe. As I understand it, there is exactly ONE USB ethernet card that works with OS/2. It is very old, and would be 100 Mbs, at best. No drivers for the rest.

Good to know. Which one is that ? And I can use LACP with 100 of them to get a 10 Gigabit connection ? ;)

Quote
As I recall, there is more than just the kernel that needs to be swapped. DOSCALL1.DLL too. I ran SMP on bare metal on Athlon MP for many years, with AMD Athlon MP and the old OS2APIC.PSD .

Quote
There are too many drawbacks to running in a VM, and there are a number of VMs. Some work better than others. Some cost a lot, and VBox (one of the best, from what I have heard) is free for personal use. A VM is a poor substitute for the real thing.

I disagree. In some cases, a VM is quite a bit better than bare metal. For example, I can't achieve anywhere near 4K resolution on any of my GPUs, but I can with a VM. Power management is much better also. I can suspend the VM and/or suspend the host. Suspend and resume is a vexing feature that does not work in OS/2 on bare metal.

Quote
You can't believe what MPCPUMON tells you. ACPI really confuses that program. The PULSE widget, in XCenter, is far better.

Thanks, that does provide much better data.

Quote
Well, the big one is that OS/2 doesn't have any viruses. That doesn't mean that a virus can't do bad things to programs like Firefox, which are based on windows versions. Most of them would be totally confused by the directory layout, and if they ever tried to do something like write to a system file, they would likely just cause a crash.

Seems there are a few.
https://retrocomputing.stackexchange.com/questions/8581/how-many-os-2-viruses-were-there

In any case, the very low number of viruses is mostly a byproduct of OS/2's lack of success in the marketplace, and not anything to do with its design. It's a single-user OS, and doesn't have any notion of privileges. Any process can do anything they want, including wipe the boot sector, overwrite your motherboard's BIOS flash (if somebody ported that code to OS/2 ;)), and so on. Of course, few are going to bother with this, except maybe as an academic exercise.
I don't think it's a very good reason.

Quote
OS/2 will also run ancient programs, while windows is very picky about what version of a program you try to run.

That's certainly true. But for these, I come back to VMs. For old programs, such as games, DOSbox is great. There are a lot of emulators for other machines, game consoles, etc.
The problems come when one wants to access physical devices that can't be emulated. For example, I recently restored a DDS backup tape I created with Bakupwiz for OS/2 in 1998. And a bunch of others made after that. Never got the Y2K bug fix for that program, if anyone has it. I couldn't do this restore on a VM, only bare metal, but it seems even that could be made to work with VMWare, if I had persisted a little bit more. I may still give it a try.

Quote
If it was leaked, nobody seems to know where it went. Arca Noae managed to get permission to distribute patched parts of OS/2 programs (including the kernel), but only to those who purchase ArcaOS (meaning that IBM gets a cut). They cannot (may not) distribute such things to users of older versions of OS/2.

If IBM does still have the source, it would take a large team lawyers about 3 years to sort out the licensing. Apparently, Microsoft still owns some of it, and they aren't likely to give up anything that might result in more competition. Lawyers aren't cheap, and IBM wouldn't pay a penny of it. Microsoft would probably just say "no".

OS/2 is what it is, and Arca Noae is limited in what they can do with the IBM/Microsoft code base. Others are even more limited, but they don't stand to lose the business if they get caught breaking the license terms. They may have some huge lawyer fees to pay (which could mean the end of a business), if IBM breaks tradition, and decides to go after them. So far, that hasn't happened, or it has been kept very quiet.

OS/2 is not an easy thing to work with, and those who are doing the work, are way overloaded. Hopefully, they don't burn out.

Yeah, I'm sure you are right about Microsoft lawyers ...

2
...This is not something unique to notebooks, desktops also have the same problems.
I wasn't clear enough. I usually mean self build desktop systems. There are still a lot of good compatible boards available. And compatible industrial boards will be available even a few years from now I'm sure. Of course you have to buy proper stuff. Often not the cheapest crappiest stuff the next supermarket wants to sell you. But you've a chance to get something that works in contrary to notebooks where you don't have these option anymore.

And wifi is not needed for desktop systems. Except for the few of us who do develop wlan stuff on a desktop system ;). Otherwise no wifi needed (and often not wanted) with desktop systems.

Even USB2 is available for desktops easily. Either still on the mobo or via PCI card.

So for desktop users like me (and Julien) high resolution graphic (and/or multi-head) do have much higher priority. Of course different people - different needs. We'll see how AN sets priorities.

Yes, I have 5 desktops at home, all custom built (but none with OS/2 in mind anymore). Not a single laptop. I have never bought one for myself. Only have one provided from my employer. It's connected to a docking station, KVM switch, and video adapters so it can drive my two 4K monitors. I only pop-up the screen on it because that's the only way I have found to turn it on ... Maybe I should play with the laptop's BIOS WOL options, so I don't even have to do that anymore.

3
apparently, newer computers don't have anything except WiFi any more (especially laptops).

Have yet to see a laptop without a wired ethernet port on it. But then again, I have 5 desktops, all custom built. I hate laptops of any kind.
Even such a stupid computer still likely features a USB port, to which a supported wired USB ethernet NIC could be attached.

Quote
UEFI support is a much more important project, than supporting high res monitors.

I really disagree there. I think there is no hope for a small community of closed source developers to catch up to all the new hardware out there. Making it work great in a VM is probably better. Seems most of the pieces are there, but not all together.

For example, reportedly, SCSI and SMP work in VMWare. Most other features work in Virtualbox. If you can just produce a few drivers/guest extensios that just work fine with the virtual machine emulators, it will be a far better use of limited developer resources, IMO, than trying to catch up to all the bare metal advancements.

Quote
Go to the file: C:\OS2\BOOT\OS2NOREV.$$$ and change the file name to something else. Now reboot, and watch when boot starts. It will tell you which kernel you are using. If you need to change it, don't use the "official" OS/2 way, do it manually (there is a comment in the  ArcaOS README under "Selective Install cautions"). In C:\OS2\INSTALL there are three directories (SMP, UNI, and W4). SMP contains the parts for the SMP kernel. replace the files of the same name , wherever they are in the boot drive. I expect that the SMP files are already installed, but perhaps not, if you used the default Virtual Machine Install.

As I recall, there is more than just the kernel that needs to be swapped. DOSCALL1.DLL too. I ran SMP on bare metal on Athlon MP for many years, with AMD Athlon MP and the old OS2APIC.PSD .

Quote
VBox is not friendly to OS/2 SMP. As I mentioned before, it seem that they use an implementation that mimics Hyper Threading, and that conflicts with the OS/2 threading model. The results are not good. The SMP kernel works fine, if you define a single processor in VBox.

Seems I got it to work somewhat finally, with 2 processors. 4 too, but it misbehaves (all CPUs are near full usage when idle in MPCPUPON).

Quote
As I said, both of those shared folder things are new, and both are incomplete, so far. Since it is actually transferring data directly, it should be faster.

Yes, makes sense.

Quote
OS/2 is still better than win 10, in some ways.

I have a hard time imagining what those could be.

Quote
It would help, if they had the OS/2 source code, but that is either locked away in one of IBM's dungeons, or, as some reports state "they have lost it". Priorities must be established, which means that some things, like high res video, get left behind.

Very sad. I thought the OS/2 source code had been leaked in the past, and some IBM employees got fired for it. Not that I'm condoning using that, but if it is really lost, and IBM will agree to give a license, maybe it can be resurrected.

4
no CD/DVD drive (possibly no place to put/connect one)

As long as some form of USB is supported, this should be OK. And USB is still required for keyboard and mouse, as most motherboards lack PS/2 ports, or have only a single PS/2.

Quote
no CSM support

I have not heard of motherboards without CSM yet.

Quote
and a GPT formatted disk

Which is purely a software issue, not hardware.

Quote
Even if the box comes with USB 2 connectors, there is a very good chance that they are connected to a USB 3 controller internally.

Possibly, but it would be silly to wire them that way. Most motherboards have a limited set of USB 3.0/3.1 headers, but plenty of 2.0 headers.

5
geizhals.at lists 8 pages.

Those appear to be USB 3 cards, not USB 2.0 .

6
Quote
OS/2 is older than that, but since ArcaOS is being made available nowadays, I think it's fair that it should current monitors of the day. I don't know how you get to decide what's more important. This is pretty damn important to me.

OS/2 development ceased around 1996. It would be really nice, to support "monitors of the day". In fact, it is amazing how well monitors that are not too old, are supported, considering that ONE guy does most of that, along with USB 3, WiFi, wired NIC drivers (MultiMac), AHCI, ACPI, and a lot of other things. If you are capable of writing, or modifying, video drivers, I am sure that Arca Noae would welcome the help. If not, you can wait for it, with the rest of us. We need USB3, then WiFi, UEFI, GPT disk support, and a dozen other things, before we need higher resolution screens. I hear that USB 3 is getting closer, but it doesn't exist, until it is announced.

I have never written device drivers myself, I have been more on the application side for most of my career as a developer. My current job involves writing firmware, though, but this is completely bare metal stuff from scratch, without any OS or drivers in the picture. It keeps me very busy. If I was retired, I might play around with some of this OS/2 stuff.

Yes, the things you mention would be nice. I certainly would like to see nVidia video drivers, support for 10 gig ethernet NICs, and USB 3 . Agree about GPT. Don't really care for Wifi. And you can always get around that with a Wifi bridge and wired NIC,.
As long as there is CSM in BIOSes, I'm not sure if UEFI is so important.

Quote
Show where? In the VBox settings, or in the guest ?
Both.

Quote
If in the guest, does it have the SMP kernel installed? The SMP kernel works fine, in one CPU, and *may* load if you define 2 CPUs, but it still doesn't work very well, if at all, in a VBox with more than 1 CPU defined. The UNI kernel will only run 1 CPU. The setting in VBox should be obvious.

I think my current VMs for both ECS of ArcaOS have the UNI kernel. I'm not sure how to switch to the SMP.
I got the SMP to work on bare metal on an old AMD FX-8350 8 core chip, but not in a VM.

Quote
The best sound device is SB16 (even with win XP as a guest, I use SB 16 - newer versions of windows won't support SB 16). More advanced devices will cause sound break up. That has always been the case in VBox. The startup sound is often cut off, it is best to eliminate that all together.

Well, I used to write audio software (DMP/DSMI) so I'm pretty sensitive to this stuff. I have recently restored it from backup. had mixed results with the ICH97  in Vbox. The Intel HD in Vbox is working great. Haven't tried SB16. But back in the days, the native SB16 driver that came with OS/2 and originally written by Creative Labs had lots of bugs. Maybe SB16 in Vbox with a different driver in the guest works better, I haven't tried that yet.

Quote
The most important settings are:

Use SATA with AHCI for disk access, also check the box that says SSD, AFTER you get it working with SATA and AHCI, (The default Virtual Machine installer settings do not support that, use the full ACPI setting). If converting, add the OS2AHCI driver, before deleting the DaniS506 driver, and changing the virtual controller settings. Add the parameters "/n /f" (without the quotes) to the OS2AHCI driver, AFTER you get it working (just like in a real machine).

I hadn't noticed the SSD checkbox in the VM settings. Does that actually change anything in OS/2 (like, say, TRIM support) ?

Quote
Use enough memory that it never needs to swap (1536 MB is usually adequate). It cannot be more than about 3.5 GB.

I think MEMMAN=NOSWAP will ensure it never swaps. And enough VM RAM for the guest settings, of course

Quote
Enable I/O APIC, before you install. This probably needs ACPI.

I have ACPI already. But I think the I/O APIC wasn't set during my installs, so I need to a new VM with new install.

Quote
Set Paravirtualization to Default, and enable VT-x/AMD-v and Enable Nested Paging.

Have those already.

Quote
Video has been discussed. I never enable 2D, or 3D, support. I doubt if either one actually does anything in OS/2. There are some new settings for Graphics Controller. I haven't tried them, yet.

No, I don't think the 2D / 3D support do anything.

Interesting about the new graphics options in VBox 6.0 . Might have to play with that.

Quote
USB: select USB 2.0, until we have a USB 3 driver.

Thanks.

Quote
Shared folders has been enabled (in the guest) recently, in two ways. Start without that, to prevent confusion. So far, I haven't got around to trying either one seriously, and I have heard comments that neither one actually works 100%.

I tried it, and had mixed results. The shared folder didn't work in the WPS GUI at all (drives object). However, it seemed to work in most file dialogs in PM programs.
In command shells, I had great success. I was able to map a network share from my local SSD array, and HDD array on my NAS, and got much better throughput vs accessing them via Arcamapper using SMB.
We are talking about 5 Gbps vs 400 Mbps - 12.5x faster. Massive difference. Of course, it only matters if the drives you share are fast enough, but with the arrays and 10 gbps networking in the host, it was rather amazed that the old OS/2 code could manage that throughput.

7
But OS/2 is from 1996, not 2019. Arca Noae does have the source for Panorama, and SNAP, but nobody has the time to do much with them. There are far more important things to do, than try to make 4K, or 8K, screens work. You are using VBox, use a screen resolution that is more reasonable, and it will just be another window on your monitors. I haven't tried multiple monitors, in VBox, but that may work too.

OS/2 is older than that, but since ArcaOS is being made available nowadays, I think it's fair that it should current monitors of the day. I don't know how you get to decide what's more important. This is pretty damn important to me.

Quote
Have you ever looked through all of the VBox settings, for each guest? It is there, along with many other settings that can be useful (and a lot that won't do much for you). Depending on what, and how, you did the OS/2 install, you may also need to install the SMP kernel support.

Yes, actually, I have played around with guest and with installers, and ACPI, and never had any luck getting more than 1 CPU to show.

Quote
I will mention, that the default VBox settings for OS/2 4.5 are far from ideal for ArcaOS, or eCS. They work fine with the default ArcaOS installer for Virtual Machines, but you can do many things to make ArcaOS work much better.

Any specifics as to which settings you changed that improved results ? One thing I found is that using Intel HD audio for the emulated sound device is much better. AC 97 caused sounds to break down early. Even the startup system sounds are cut off.

Quote
Thanks for that. From what I have seen, it appears that VBox is using a Hyper Threading model, and Hyper Threading is definitely not OS/2 friendly, even on real hardware. I would assume, that the host can use Hyper Threading, while running VBox, if a user allows it. I always keep it off, because I use ArcaOS on my real hardware too.

My Win10 host in this case has hyperthreading off. Hyperthreading interferes with real-time audio on my Firewire interfaces. Also, hyperthreading comes with free security vulnerabilities in the CPU. It is really best to turn it off.

8
Hardware / Re: Large mouse pointer for high resolution desktop ?
« on: January 14, 2019, 07:08:37 am »
If this were ever changed, make the default icon bigger to say 64x64 or 48x48. 

I would say, change it to 128x128 at least, since 8K monitors are already for sale.
64x64 would be good enough for 4K, but not for 8K .

9
Delete AUXPRINT.PAK first. Then, I think you need to run "ppd . psprint.drv". Finally, you then need to select that driver on creating the printer so that the whole set of files eventually end up in directory \os2\dll\psprint.

Thanks. I got it to work finally !

10

Quote
3840x2160x16bpp seems to work, though, with Panorama. I don't know if I dare to try again with SNAP or GENGRADD now that I have it working.

I have no idea why you would want a resolution like that, but if it works, use it.

Simple - I have a triple monitor setup. The left and center monitors are 32" and Ultra HD 4K, which means 3840x2160 is the native resolution. The third one on the right is 23" and HD, but I have it setup in portrait mode, at 1080x1920 . I want the guest to have 1:1 pixel mapping, to avoid scaling, which creates artifacts.

Quote
Quote
On bare metal, I have only nVidia video cards

NVIDIA is well known to be a very bad choice for OS/2 users, but that has nothing to do with VBox, which emulates it's own video.


Well, it is related for me, since the lack of nVidia driver for OS/2 prevents me from running on bare metal. Virtualbox is the only way for me to get a decent resolution.


Quote
Does it work with a reasonable resolution (you say that it does)? Why do you want to use something like that?  It is obviously exceeding the capabilities of the OS/2 drivers. OS/2 was designed to use screen resolutions of 1280x1024x32, and the drivers have probably never been used with very large resolutions (do screens of that resolution even exist?).

It is 2019, not 1992 . Many monitors have higher resolution. My two 4K monitors are LG 32UD59-B, which were only about $400 each last year. Some monitors exist that are even higher resolution. There are 5K displays at 5120x2800, and 8K displays at 7680x4320. Those are currently out of my price range, but I have no doubt I will move on to higher resolution at some point when they become affordable.

Quote
What I would really like to get to work is SMP in the guest.

I tried that a few years ago, with an eCS guest. It sort of worked, for a few minutes, then froze. I should try it again, they may have fixed something (but I doubt it). I suspect that they are using logic that mimics Hyper Threading, and that is not, at all, compatible with the OS/2 threading model. FWIW, I have tried SMP with a windows guest. The difference in performance is not that great, so I usually use single processor mode in VBox, for all guests.
[/quote]

I am curious how you got eCS to see more than one processor. I have not succeeded so far. Probably should be its own thread.

11
8.) in the screen object in the guest, select your new resolution

Thanks. I followed your instructions. My problem is that at step 8, the only resolution shown is now 3840x2160x65536 . This is the last video mode I had chosen under Panorama. There is no "choice" of resolution that I can make. Something is messed up with the Screen object with ArcaOS with GENGRADD once Panorama has been installed previously. This bug only happens on ArcaOS. On ECS, I get a whole list of video modes to choose from, from 320x200x256 all the way to 3840x2160x16877216 .

Quote
The fact that the screen object looks different is due to the fact that SNAP and Panorama add additional functionality via the SET GREEXT keyword in config.sys. But this is completely irrelevant to what you are trying to achieve (to add and use your own resolution). That can be achieved with naked GENGRADD (which does not require the SET GREEXT config.sys setting).

I have removed SET GREEXT from my CONFIG.SYS as you instructed, yet I still have this problem.

Quote
If you insist on using PANORAMA, then make sure that you disable "shadow buffer" in the screen object. It is possible that this negatively interferes with what the host system needs to do.

Thanks, will keep that in mind.

12
On large files (multi GB), I got 34MB/s average from the NAS to VM. And 54MB/s from a share on the Win10 host to ArcaOS guest. Those are only about 272 and 432 Mbps respectively. I should be able to at least get Gigabit speed on the LAN and local share, and hopefully more, but it seems the networking in Virtualbox is just too slow. I might get faster results with iperf and/or netio as it would take the SMB out of the picture.

So, I broke the Gigabit limit on my LAN in my OS/2 VM.

Here is how I did it :
1) upgraded to Virtualbox 6.0
2) noticed there were new additions with a VBOXFS.IFS for shared folders
3) shared my X: drive from my Win10 host to ArcaOS guest as X: also .
X: is a share mounted from my Ubuntu NAS to the Win10 host.
4) ran my file benchmark again, on a 4.5GB ISO movie file
I averaged 243,677 KB/s , which is 1949 Mbps , or about 2 Gbps. This is consistent with what I was seeing in the Win10 host task manager - network bandwidth at 2 Gbps .
Subsequent runs are even faster, because the Win10 host is caching the remote file : 608,601 KB/s . This is about 5 Gbps . In this case there as 0 network bandwidth usage, though, due to caching.

That means I have to try with files that don't fit in the host's RAM (32GB), or just try with different (uncached) files each time.

I didn't try yet sharing a local drive to the VM yet. I have a striped array of SSDs which does 2600MBps sequential (about 21Gbps) in Crystaldiskmark 6 for sequential test. My guess is that I will hit a bottleneck much lower than that in the VM.

Just tried it, since adding shared folders don't require a VM restart.
I was able to read a 35GB file, uncached, at 656,854 KB/s from the local SSD array. I tried again with a 2GB file, twice to make sure it was cached, and got similar speed. So, 5 Gbps appears to be the upper limit for the shared folders in Virtualbox.



13
Hi Julien,

Attached is a cleaned and prepared for import by the PIN.EXE from my library of Brother PPDs (I prepared them while I was deciding which printers to get).

Thank you ! Let me give that a try .

I did the following .
1) ran cleanppd.cmd on your PPD

2) copied the files from c:\sys\install\prndrv\pmdd_6 to c:\bro

{0}[c:\bro] dir

 Volume in drive C is ARCAOS         Serial number is A627:05B8
 Directory of  C:\bro\*

 1-10-19  14:42           2,507      0   ___A_  AUXPRINT.PAK
 8-11-13  13:43           3,181  5,031   ___A_  cleanppd.cmd
 1-12-19  18:40          26,027      0   ___A_  mfc-l8850cdw.ppd
 2-13-17  21:51         141,978     61   ___A_  pin.exe
 2-13-17  21:51          10,100      0   ___A_  pin.sym
 2-13-17  21:51          58,799     61   ___A_  ppdenc.exe
 2-13-17  21:51           5,300      0   ___A_  ppdenc.sym
 2-13-17  21:51       4,041,475      0   ___A_  printer1.pak
 2-13-17  21:51         851,194 20,524   ___A_  psprint.drv
 2-13-17  21:51          20,511      0   ___A_  psprint.ea
 3-18-16  20:16          34,683      0   ___A_  psprint.hlp
 2-13-17  21:51          23,726      0   ___A_  psprint.lst
 2-13-17  21:51          38,164      0   ___A_  psprint.sym
 4-10-16  22:32          33,969      0   ___A_  readme
       5,291,614 bytes in 14 files and 0 dirs
       5,320,704 bytes allocated
 271,993,995,264 bytes (253GB) free

3) ran pin PPD :

{0}[c:\bro] pin ppd . .
PostScript resource packaging utility version 1.21
Copyright (c) IBM Corp. 2000,2001. All rights reserved.
Copyright (c) netlabs.org 2007,2010. All rights reserved.
Copyright (c) Arca Noae, LLC 2015,2016. All rights reserved.

Producing Printer Device PAK
reading driver extended attributes
  fail
SYS0005: Access is denied.

fail

{1}[c:\bro]

I tried different combinations of arguments, but always got the same issue. I had PSPRINT.DRV loaded from an existing printer object, but that shouldn't have been a problem since it was another copy in c:\bro . Anyway, I deleted all the printer objects referencing this driver, and still get this permission issue. Maybe one process still has it loaded somehow. But still, this shouldn't be an issue with the copied file.

14
When you use OS/2, you need to be careful what you buy.

I ran OS/2 primarily from 1992 to 2007, so I'm well aware of that. I had only touched it a little bit again a few years ago with ECS, mostly in VMs. And now with ArcaOS.
My hardware choices are not dictated by OS/2 anymore. I think I'm fine with having 1 printer supported, the Brother one. The other 2 are mainly photo printers, and I am not sure there would be good drivers for them other than the proprietary ones Canon and Epson offer for Windows and Mac.

Quote
I wonder why the installer in ArcaOS does not offer an option to install this driver.

If it isn't offered, it probably means that there is a licensing problem, or it doesn't work very well. You would need to ask Arca Noae.
[/quote]

Considering this other driver is located on the ArcaOS CD, I doubt it's a licensing issue. Seems like a bug to me to only show the non-enhanced driver by default in the list, unless someone knows where to look for it. I will add this to my long list of tickets :)

15
I still think a native code benchmark would be preferable to one written in Python.

For testing LAN performance, there is iperf3 on other platforms, but I have not found an OS/2 port.

There is https://88watts.net/download/netio-1.33.zip for testing LAN performance. http://hobbes.nmsu.edu/download/pub/os2/util/network/netio132.zip has binaries for most other systems.

Thanks, I'll take a look. I now have a 10 Gigabit ethernet LAN. With iperf3, I can get 9.9 Gbps with 2 streams using jumbo frames between my Ubuntu NAS and my Win10 desktop on a Netgear GS110MX switch. With real file transfers, I get about 3 to 5 Gbps to and from a 50TB RAIDZ2 array. I will check first if netio is up to the 10 Gbps challenge between Linux and Win10 first, before I try it on ArcaOS.

I used a quick file system benchmark for OS/2 that I wrote 25 years ago. Ran it in my ArcaOS VM . I mounted shares from my Win10 host (local) and Ubuntu AS (remote). With ArcaMapper.

On large files (multi GB), I got 34MB/s average from the NAS to VM. And 54MB/s from a share on the Win10 host to ArcaOS guest. Those are only about 272 and 432 Mbps respectively. I should be able to at least get Gigabit speed on the LAN and local share, and hopefully more, but it seems the networking in Virtualbox is just too slow. I might get faster results with iperf and/or netio as it would take the SMB out of the picture.

Pages: [1] 2 3 4