Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Per E. Johannessen

Pages: [1] 2 3 ... 11
1
Programming / VX-Rexx container - get values
« on: October 08, 2020, 07:39:37 pm »
Hi,

I have a VX-Rexx project with a container filled with values from a query named "QRY_AVR".
The container has 4 columns and 4 records:

----------------------
|AAAA|BBBB|CCCC|DDDD |
----------------------
|   1|2004|  10|35490|
|   1|2004|  12|  732|
|   1|2004|  50|-8150|
|   1|2004|  99|-7320|
----------------------


The code below returns the sum of column "DDDD" (20752):

sum = 0

ok = VRMethod( "QRY_AVR", "MoveFirst" )
do while( ok = 1 )
    call VRMethod "QRY_AVR", "RowData", "data."
    str = ""
    sum = sum + data.4
    do i = 1 to data.0
    str = str data.i
    end
        ok = VRMethod( "QRY_AVR", "MoveNext" ) 
end

However, sometimes I need to get a specific value from the container.
Let's say I need the value in "DDDD" which corresponds to to the value "12" in "CCCC",
anyone knows how to do that?

(I can get the needed values using several queries, but prefer some rexx-code to do the job.)

2
Mail-News / Re: Mail disappeared SeaMonkey
« on: August 19, 2020, 09:04:59 pm »
Have to investigate about SMART, but chkdsk, with or without /f, does not report any issues.
(The SSD drive was new in january this year.)

3
Mail-News / Re: Mail disappeared SeaMonkey
« on: August 19, 2020, 07:30:41 pm »
I've already used DFSee but only to check for errors and it did not find any.
Looks like I have to read the manual before using any of DFSee's recovery tools......

4
Mail-News / Re: Mail disappeared SeaMonkey
« on: August 19, 2020, 06:54:31 pm »
Yes I have checked the profiles folder and now I noticed that more folders/files are missing:
in \profiles\fakename.xyz\ there is only one folder named MAIL which contains 3 subfolders, one for each mail account, and each of them only contains the files I mentioned before, (the empty files created today; Inbox, Inbox.msf, Trash and Trash.mfs).

Just discovered another thing; tried to start OpenOffice Calc and it now starts with presenting the "Welcome to OpenOffice" like it does after a fresh installation. The OO package is installed on the same partition as the SeaMonkey mail stuff. I was using OO Calc a lot yesterday and at one point I had to restart it due to some calculation functions stopped working and after restarting it all worked again. As far as I can see all OO directories/files are where they should be. Other programs on this partition work fine.

5
Mail-News / Mail disappeared SeaMonkey
« on: August 19, 2020, 05:00:12 pm »
When booting AOS today I got the message "The program pointed to by the SET RUNWORKPLACE= line in config.sys could not be started".
I then replaced os2.ini and os2sys.ini with recent backed up versions and the system boots fine and all seems intact except e-mail folders which I have on a JFS partition.

Started SeaMonkey mail and it showed only 3 of 7 mail accounts, but there are no mails in any of them, also the subfolders are not displayed. In each accounts folder there are only four files; Inbox, Inbox.msf, Trash, and Trash.mfs, and they all seem to have been recreated today by SeaMonkey.
All other folders and files on this JFS partition are OK.

Before restoring mail from a back up I'd like to try to recover the files. (The back up is unfortunately a couple of weeks old.)

So far I've only tried JUne and it does not find the missing files. JRescuer seems to be for JFS volumes which are "unavailable" so I have not tried it.

Ideas anyone?

6
Networking / Re: VNC/FTP Asus RT-AC1750U
« on: February 16, 2020, 01:07:03 pm »
Turned out to be simpler than I feared, both vnc and ftp works after filling in correct values in the settings for "port forwarding".

7
Networking / Re: VNC/FTP Asus RT-AC1750U
« on: February 15, 2020, 10:28:43 pm »
Thanks for info, don't have the manual here, but found this https://www.asus.com/support/FAQ/114093/ so I'll give it a try.

Good to know about the "OS/2 Voice option", I'll go that route if I can't get it to work.


8
Networking / VNC/FTP Asus RT-AC1750U
« on: February 15, 2020, 05:24:08 pm »
Need to set up a new Asus RT-AC1750U for accepting incoming VNC and FTP connections. This router has lots of options and I have no experience with this stuff. The router is at a remote site and I can connect and configure it remotely. Basically I need to connect to a pc running VNC server at the remote site, and probably a ftp-server. (The pc I want to connect to is running eCS.)
Appreciate if someone can help with this.

9
Setup & Installation / Re: Airboot & GPT
« on: January 25, 2020, 11:58:07 pm »
I'm going to have a "shared" partiiton on the Win10 disk and I would not be able to access it from ArcaOS if it was not converted to MBR.

10
Setup & Installation / Re: Airboot & GPT
« on: January 25, 2020, 07:24:30 pm »
Thanks for advises.
However, I used EaseUS Partition Master, Pro-version, and it did convert from GPT to MBR without any issues
and all partitions and data are intact.
Added LVM info to the Win10 partition and Airboot works fine.

11
Setup & Installation / Airboot & GPT
« on: January 24, 2020, 08:53:29 pm »
On a system I have two hdd's, one MBR with ArcaOS and one GPT with Win10. Airboot skips GPT disks so it can't boot Win10.
AFAIK the GPT disk has to be converted to MBR for Airboot to see it. Has anyone tried EaseUS Partition Master which claim to keep all data/partitioning on the GPT disk intact, or does anyone have another solution?

12
Setup & Installation / Re: Trap 0008 installing ArcaOS 504
« on: January 11, 2020, 05:18:03 pm »
Solution, for now, is to boot from DVD after phase 2 is finished, copy pcibus.snp from ramdrive (z:) to \os2\boot.
Got this info from AN and they are working on a fix.

13
Setup & Installation / Re: Trap 0008 installing ArcaOS 504
« on: January 10, 2020, 02:29:17 am »
Does it crash the same way if you choose manage system when it first boots?

Yes, it displays the Arco-logo for a couple of seconds and then I get the trap 0008.

14
Setup & Installation / Re: Trap 0008 installing ArcaOS 504
« on: January 05, 2020, 10:51:41 pm »
Have not tried the manage system option since I already did a new install "Modern hardware, no ACPI" and that works fine.
Did attach a log to the ticket I placed at AN and hopefully that will help in enabling ACPI on this system.

15
Setup & Installation / Re: Trap 0008 installing ArcaOS 504
« on: January 05, 2020, 12:38:53 am »
Thanks, Dave, lots of interesting info there. Still I've not been able to boot the system, so no testlog yet.
Tried limiting CPU count to 1 but that did not make a difference.
Anyone familiar with the BIOS on newer Lenovo systems and knows if there is some settings, in addition to "compatible" and disabling hyperthreading, that should be changed?

Pages: [1] 2 3 ... 11