Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Fahrvenugen

Pages: [1] 2 3 ... 5
1
Setup & Installation / Re: Warp 3 with WINOS2
« on: September 10, 2019, 11:44:33 pm »
Hi,

If you have Windows 3.1 disks (or the install disks on a CD) it is not all that difficult to make it work after an OS/2 Warp3 red spine install.

First get Warp 3 running on (preferably) an HPFS partition. Install with a standard VGA video driver, do NOT install any video beyond standard VGA or you will have issues (don't worry - you can install a better driver later once you get it up and running)

Second, grab the wsetup utility from Hobbes:

http://hobbes.nmsu.edu/download/pub/windows/wsetup14.zip

Wsetup will essentially extract all the needed Windows 3.1 files into the appropriate folders on your hard disk.  It runs in a DOS box.  You'll need to tell it where your Windows 3.1 source files are and I think it asks where you want to have it installed on your hard disk (although I admit that it has been a while since I have run this).

Once it has extracted the needed Windows 3.1 source files to your hard disk, exit your dos box and run Selective Install.  You should then have the option to install the WinOS/2 stuff.  Select that option and let Selective Install do its thing - you'll probably need your Windows 3.1 install disks again as it'll probably ask for them.

Next reboot - after reboot you should be able to get into a full screen WinOS/2 session.  Once there in Program Manager (you won't initially see any icons) create the icons - from Program Manager chose File --> Run --> type SETUP /p

That should create your icons in program manager, go ahead and start something up and see if it works.

Exit out of your WinOS/2 session and now you should be able to run the "migrate programs" (or whatever that app is called that searches for stuff and creates icons on your desktop), this should create seamless WinOS/2 icons on your desktop.  Also go ahead and try a seamless session.  It should work.

At this point you'll want to install some updates - Fixpak 40 for Warp 3, after Fixpak 40 you should be able to get SNAP (or another video driver) working (and it'll probably work with WinOS/2), you can also install Win32s version 1.25, plus the Video for Windows update.  Note that Win32s does require a later fixpak.  Be sure to reboot after a fixpak install and / or video driver install.  Also if I recall correctly if you install Win32s 1.25 it won't work properly until after you reboot - it relies on a driver that gets loaded upon boot.






2
Events / Re: Do not forget: Spock (Leonard Nimoy) introduced OS/2 Warp
« on: August 30, 2019, 04:35:05 pm »
Why didn't IBM ship OS/2 with its own computer models? 

As has been pointed out by a few people here, IBM most definitely did ship its own computer models with OS/2.  I can recall press releases from when Warp 3 came out talking about how there was a policy at IBM to offer OS/2 pre-loaded on any of its PC's that it sold.  There was also the selection system where OS/2 along with DOS - Windows was on IBM systems and you could pick the one you wanted upon boot/setup (and if you'd picked one you could later switch, but that option was not always clear in the documentation - many people thought that once they'd picked Dos-Windows they could not then go to OS/2).

For those who bought a desktop or laptop directly from IBM the sales representative would ask if you wanted OS/2 or Dos-Windows.

I think it is also worth pointing out that IBM did initially have some success marketing Warp 3 - even after Windows 95 had been released.  There was the TV campaign (the commercial with the Nuns is the one most people remember), but even more successful then that and often overlooked was the Just Add Warp campaign.  It came out just shortly after the release of Windows 95 and was promoted heavily.  If you called IBM they'd mail you the disks, or for those who were online you could download it (via FTP if on the internet or it was also available through the various services such as Compuserve and all the BBSes that were around in those days).

Just Add Warp was actually a decent campaign and won several awards.  It contained a Windows 3.1 app (which also ran under Win95) which would check your system's hardware and tell you if your system could run Warp.  Checking hard drive space, memory, CPU, graphics, sound, etc.  It had a OS/2 Warp demo showing the benefits of Warp.  It also had a number of help files which walked you through some of the benefits of OS/2 over running Windows, how to install OS/2 on the system containing Windows 95, how to remove Win95 from your system if you chose to do so, OS/2 tips and tricks, and more.

It also had a dual-boot app that - if you had Windows 95 and OS/2 installed on the same FAT partition it would put on each desktop the dual-boot app to allow you to boot to the other.  For those running OS/2 along side Windows 95 it also had a "long file name conversion utility" which would map Win95's long file names to OS/2 EA's - so that when you looked at a file's object in WPS you'd see the long file name.

For a brief time IBM claimed that the Just Add OS/2 Warp kit was its most requested and most downloaded software from IBM.  In January of 1996 IBM claimed that for the month of December OS/2 Warp 3 was the best selling software on the market - outselling boxed Windows 95 (not counting OEM installs) according to one of the organizations that monitored software sales.

Unfortunately it was not to last.  Microsoft had a huge foothold through the OEM installs.  At IBM with the failure of the PPC and PPC version of OS/2 IBM made significant cuts to their PSP division.  Upper management at IBM decided to focus OS/2 more on the business market and mostly abandoned the consumer market. 

3
Applications / Re: WordPerfect for Windows 6.1 OS/2 tools
« on: August 27, 2019, 04:18:45 pm »
These days I don't use FTP all that much, but I recall when I used Warp 3 there was one I had installed which once connected to a site it presented everything as if it was a folder / object.  You could just drag and drop the files you wanted or an entire folder to your system and it would grab everything in the background.  It worked great, especially if you wanted to create a mirror of entire FTP sites and such.

I agree that it is impressive that Corel has kept this content online and all in one place - especially when a pile of this stuff predates Corel owning the software (some of this stuff is Novell and some SSI).

4
Applications / Re: WordPerfect for Windows 6.1 OS/2 tools
« on: August 27, 2019, 05:59:46 am »
I just found the "official" location for the tools, direct from Corel.

ftp://ftp.corel.com/pub/WordPerfect/wpwin/61/os261.exe

That's for the US English version and WordPerfect 6.0a or 6.1.  They also have a copy of the patch for other language versions of WordPerfect for Windows 3.1, along with a variety of other patches and utilities at

ftp://ftp.corel.com/pub/WordPerfect/wpwin/61/




5
Applications / Re: WordPerfect for Windows 6.1 OS/2 tools
« on: August 26, 2019, 11:28:29 pm »
Hi,

The patch / OS/2 tools for Wordperfect 6.1 works fine on JFS or HPFS, the only issue is that it needs to use the 8.3 file names.  Of course this is no different from any Win3.x application.

Otherwise I recently installed it on ArcaOS and had no difficulty.

I agree that the quick launch app isn't needed any more and I would not bother with it.   Back in the day - when machines didn't have gigs of memory and it would take some time for Win3.1 apps to start up it was helpful.  But today for most systems starting a Win3.x app is extremely quick, so there isn't really a benefit to running quicklaunch.

Otherwise I quite appreciate the efforts that Novel put into making sure that WordPerfect 6.1 ran well under OS/2 and had a few extra enhancements that were otherwise not available.


6
Utilities / Re: Where do I find SciTech Display Doctor?
« on: August 17, 2019, 04:36:09 pm »
Hi,

I'd agree with other posts that you are better with either the version of SNAP that is on Hobbes or the version in ArcaOS.  I have to say that while there are reports of SNAP 3.1.8 not working well with SMP, I have run that version with multiple processor machines and not run into the issues reported.

If you do want the older Scitech Display Doctor, IBM did license a "special edition" of SDD version 7  which is still available at:

ftp://service.boulder.ibm.com/ps/products/os2/os2ddpak_cur/sddse704.exe


7
Hi,

As mentioned, check to make sure that hyperthreading is turned off in the BIOS.

Also, since you've mentioned a graphic lockup, which graphic driver are you using?  If you're using either Panaroma or SNAP, try the other one and see if the problem persists?  I've found on a lot of older hardware (and some newer hardware) I have better luck with SNAP

8
Multimedia / Re: Warp with 2 sound cards?
« on: June 06, 2019, 05:44:45 pm »
Lars,

Unfortunately I don't have much programming experience with MMOS2, but I agree that Timur is probably the most knowledgeable.  Most of what he did when he worked for IBM was centered around MMOS2

He's got an email on his website:

http://timur.tabi.org/timur/


9
Multimedia / Re: Warp with 2 sound cards?
« on: June 05, 2019, 09:53:12 pm »
Lars,

With the current state of MMOS2, the fact that IBM essentially abandoned it around the time of Warp 3, I am not surprised that there are bugs.  I certainly would not put any fault in your driver or applet, in fact I applaud your efforts - I'm really impressed with how well your USB audio driver works.

The sad part - there was a time when MMOS2 was near the top of the game - I can recall when the only system that had better multimedia capabilities was the Amiga.  Unfortunately today it can be a challenge just to get a sound card to work.  But I can't say that I'm all that surprised.

Anyways, thanks for your efforts.  I still have an old Warp 3 machine here, it isn't the one that I had from way back when with 2 audio cards, but I might just see if I can get the Warp 3 box I do have going with 2 cards to see if it works the way I remember.  I do recall that when I did have 2 cards working it was on an old machine with all ISA ports (it took quite a bit of fiddling with the jumpers and IRQ's to get it to work... that's how I recall it was an ISA based machine).  Unfortunately I don't remember specific details of any configurations that might have been needed.  1996 was a long time ago!

Cheers!


10
Multimedia / Re: Warp with 2 sound cards?
« on: June 02, 2019, 07:19:10 pm »
Thanks for the replies, I'll have to try again.

Lars, I did recently install your USB drivers, but had not paid close attention to the applet for changing the default.  I'll have a look at that, it may be partly what I need.

I'll also have to try out PlayRec, it looks like it may do what I want. 

Thanks!

11
Multimedia / Warp with 2 sound cards?
« on: June 02, 2019, 06:49:39 am »
Hi,

I remember back in the Warp 3 days I had at one point managed to find a way to get Warp to recognize and be able to use 2 sound cards at the same time, each able to do different things - either playing different audio out each card, or having one doing a record the other a playback, or both recording different things at the same time.

Does anyone know if this is still possible with current drivers?  I know that MMOS2 is still pretty much the same as it was in the Warp 3 days so I imagine it can still  handle it, but drivers -  particularly UniAud and some of the CMI and SBLive drivers don't seem to be able to handle this, at least I have not had much luck.

Anyone know if this is still possible?

12
Multimedia / Re: SYBA USB Stereo Sound Adapter: Good or bad?
« on: June 02, 2019, 05:27:04 am »
Lars,

I do want to thank you for all your work on OS/2 over the years.  I've got a bunch of cheap USB-Audio adapters that I picked up for around $1 each, based on the CM108 chipset.  I was happy to find that it works well with your USB driver.

My only complaint about it is that its record channel is only mono, but that's a limitation of the hardware and has nothing to do with your driver.  I actually found that - when recording from it in mono I got better results then when I tried similar tests under Windows (which gives the occasional choppiness).  Playback to the USB dongle works well, overall I'm very impressed.

Best!

13
Utilities / Re: best process killer application
« on: January 17, 2019, 10:03:47 pm »
I know it is quite old by the standards of others that have come out since, but I still like WatchCat


14
Applications / Re: The Java drama and the OS/2 Community.
« on: November 10, 2018, 08:45:39 pm »
The dissapointing part of all of this is how far Java has diverged from its original promise.

Originally it was "write once, run anywhere".  Part of this  implied that your apps would run on all future versions of Java on all future platforms.  The idea that all versions of the Java runtime were (in theory) going to be backwards compatible with previously released versions. 

Unfortunately this got abandoned quickly.  Java apps that require a specific version of the Java runtime, and in some cases I've even seen Java stuff that requires both a specific version of Java on a specific OS.

15
Setup & Installation / Re: OS2 Warp Version 3 wont boot from Hard Drive
« on: October 19, 2018, 10:19:30 pm »
This could be two things.  Just re-reading your original post it sounds like it'll boot with a CD drive installed, but once you disconnect the CD drive it won't boot.

First double check the jumpers on your hard disk.  There will either be a jumper setting for "single" *or* if there is no setting for "single" try pulling the jumper out entirely.  Some of those old drives would default to single if no jumper was installed.  Some BIOSes -  especially older ones, if they see a "master" drive on the IDE bus they'll then look for a "Slave" on that bus too.  If they don't find it they'd come to a grinding halt.

The second thing it could be, if it is starting to initially boot but then stopping, the original release of Warp 3 had a very buggy IDE driver (ibm1s506 and others).  Back in the day I had a 386 which would boot Warp 3 when the CD drive was *not* plugged in but as soon as it was plugged in it would crash.  IBM released a fix for the buggy drivers on the install disks at:

ftp://service.boulder.ibm.com/ps/products/os2/fixes/v3.0warp/english-us/warpinst/

If it is a driver issue that might fix it.


Pages: [1] 2 3 ... 5